Real time network require a solution

Hi All, 

I am currently providing professional services for a Service Provider organization.

My manager has asked me to implement the below solution in of our customer's [i.e. a Service Provider] network :

 

  • Any user who is trying to access internet service during off peak hours, should get entire available bandwidth
  • Any user who is trying to access internet service during peak hours, they should get their subscribed bandwidth [i.e 10 Mbps] as per their plan with the service provider company
  • Both the conditions mentioned above should be customizable according to the content/protocol i.e. HTTP, HTTP Adaptive Streaming Protocol or Real Time Streaming protocol etc. The main objective is "to dynamically control user's internet speed depending on available bandwidth and type of content being accessed" 

 

The main objective of the Service provider is to utilise their network to the maximum with best QOE. 

I am trying to test this solution first on GNS3. I think with QOS I will be able to rate limit user traffic based on available bandwidth and specific content. Please find my network below with attached running config of each router:

image

 

 

R1#sh run

Building configuration...

 

Current configuration : 1586 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname R1

!

boot-start-marker

boot-end-marker

!

logging buffered 4096 informational

!

no aaa new-model

!

resource policy

!

memory-size iomem 5

no ip icmp rate-limit unreachable

ip cef

ip tcp synwait-time 5

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

interface FastEthernet0/0

 ip address 192.168.137.2 255.255.255.0

 ip nat outside

 ip virtual-reassembly

 duplex auto

 speed auto

!

interface FastEthernet0/1

 no ip address

 shutdown

 duplex auto

 speed auto

!

interface Serial1/0

 ip address 1.0.0.1 255.0.0.0

 ip nbar protocol-discovery

 ip nat inside

 ip virtual-reassembly

 serial restart-delay 0

 clock rate 64000

!

interface Serial1/1

 ip address 2.0.0.1 255.0.0.0

 ip nbar protocol-discovery

 ip nat inside

 ip virtual-reassembly

 serial restart-delay 0

 clock rate 64000

!

interface Serial1/2

 no ip address

 shutdown

 serial restart-delay 0

!

interface Serial1/3

 no ip address

 shutdown

 serial restart-delay 0

!

router eigrp 100

 network 0.0.0.0

 no auto-summary

!

ip route 0.0.0.0 0.0.0.0 192.168.137.1

!

!

no ip http server

no ip http secure-server

ip nat pool GLOBAL-IP 192.168.137.10 192.168.137.50 netmask 255.255.255.0

ip nat inside source list 1 pool GLOBAL-IP

!

access-list 1 permit 10.0.0.0 0.255.255.255

!

!

!

!

!

!

control-plane

!

!

!

!

!

!

!

!

!

!

!

line con 0

 exec-timeout 0 0

 privilege level 15

 logging synchronous

line aux 0

 exec-timeout 0 0

 privilege level 15

 logging synchronous

line vty 0 4

 login

!

!

end

 

R1#$

+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++



Connected to Dynamips VM "R5" (ID 0, type c3725) - Console port

Press ENTER to get the prompt.


R5#sh run

Building configuration...


Current configuration : 1250 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname R5

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

!

resource policy

!

memory-size iomem 5

no ip icmp rate-limit unreachable

ip cef

ip tcp synwait-time 5

!

!

!

!

no ip domain lookup

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

interface FastEthernet0/0

 no ip address

 shutdown

 duplex auto

 speed auto

!

interface FastEthernet0/1

 no ip address

 shutdown

 duplex auto

 speed auto

!

interface Serial1/0

 ip address 1.0.0.2 255.0.0.0

 serial restart-delay 0

 clock rate 64000

!

interface Serial1/1

 no ip address

 shutdown

 serial restart-delay 0

!

interface Serial1/2

 no ip address

 shutdown

 serial restart-delay 0

!

interface Serial1/3

 ip address 4.0.0.1 255.0.0.0

 serial restart-delay 0

 clock rate 64000

!

router eigrp 100

 network 0.0.0.0

 no auto-summary

!

ip route 0.0.0.0 0.0.0.0 1.0.0.1

ip route 0.0.0.0 0.0.0.0 2.0.0.1

!

!

no ip http server

no ip http secure-server

!

!

!

!

!

!

!

control-plane

!

!

!

!

!

!

!

!

!

!

!

line con 0

 exec-timeout 0 0

 privilege level 15

 logging synchronous

line aux 0

 exec-timeout 0 0

 privilege level 15

 logging synchronous

line vty 0 4

 login

!

!

end


R5#

+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++




R6#sh run

Building configuration...


Current configuration : 1250 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname R6

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

!

resource policy

!

memory-size iomem 5

no ip icmp rate-limit unreachable

ip cef

ip tcp synwait-time 5

!

!

!

!

no ip domain lookup

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

interface FastEthernet0/0

 no ip address

 shutdown

 duplex auto

 speed auto

!

interface FastEthernet0/1

 no ip address

 shutdown

 duplex auto

 speed auto

!

interface Serial1/0

 no ip address

 shutdown

 serial restart-delay 0

!

interface Serial1/1

 ip address 2.0.0.2 255.0.0.0

 serial restart-delay 0

 clock rate 64000

!

interface Serial1/2

 ip address 3.0.0.1 255.0.0.0

 serial restart-delay 0

 clock rate 64000

!

interface Serial1/3

 no ip address

 shutdown

 serial restart-delay 0

!

router eigrp 100

 network 0.0.0.0

 no auto-summary

!

ip route 0.0.0.0 0.0.0.0 1.0.0.1

ip route 0.0.0.0 0.0.0.0 2.0.0.1

!

!

no ip http server

no ip http secure-server

!

!

!

!

!

!

!

control-plane

!

!

!

!

!

!

!

!

!

!

!

line con 0

 exec-timeout 0 0

 privilege level 15

 logging synchronous

line aux 0

 exec-timeout 0 0

 privilege level 15

 logging synchronous

line vty 0 4

 login

!

!

end


R6#

+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++





R7#sh run

Building configuration...


Current configuration : 1256 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname R7

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

!

resource policy

!

memory-size iomem 5

no ip icmp rate-limit unreachable

ip cef

ip tcp synwait-time 5

!

!

!

!

no ip domain lookup

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

interface FastEthernet0/0

 ip address 10.0.0.1 255.0.0.0

 duplex auto

 speed auto

!

interface FastEthernet0/1

 no ip address

 shutdown

 duplex auto

 speed auto

!

interface Serial1/0

 no ip address

 shutdown

 serial restart-delay 0

!

interface Serial1/1

 no ip address

 shutdown

 serial restart-delay 0

!

interface Serial1/2

 ip address 3.0.0.2 255.0.0.0

 serial restart-delay 0

 clock rate 64000

!

interface Serial1/3

 ip address 4.0.0.2 255.0.0.0

 serial restart-delay 0

 clock rate 64000

!

router eigrp 100

 network 0.0.0.0

 no auto-summary

!

ip route 0.0.0.0 0.0.0.0 1.0.0.1

ip route 0.0.0.0 0.0.0.0 2.0.0.1

!

!

no ip http server

no ip http secure-server

!

!

!

!

!

!

!

control-plane

!

!

!

!

!

!

!

!

!

!

!

line con 0

 exec-timeout 0 0

 privilege level 15

 logging synchronous

line aux 0

 exec-timeout 0 0

 privilege level 15

 logging synchronous

line vty 0 4

 login

!

!

end


R7#

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++



I am looking for a solution which can encompass all the requirements with existing configuration.
 Please note C2 and C3 are my hosts and C1 is internet

Comments

  • peetypeety ✭✭✭ ✭✭✭

    I am currently providing professional services for a Service Provider organization.

    My manager has asked me to implement the below solution in of our customer's [i.e. a Service Provider] network :

     

    • Any user who is trying to access internet service during off peak hours, should get entire available bandwidth
    • Any user who is trying to access internet service during peak hours, they should get their subscribed bandwidth [i.e 10 Mbps] as per their plan with the service provider company
    • Both the conditions mentioned above should be customizable according to the content/protocol i.e. HTTP, HTTP Adaptive Streaming Protocol or Real Time Streaming protocol etc. The main objective is "to dynamically control user's internet speed depending on available bandwidth and type of content being accessed" 

     

    The main objective of the Service provider is to utilise their network to the maximum with best QOE. 

    ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++




    I am looking for a solution which can encompass all the requirements with existing configuration.
     Please note C2 and C3 are my hosts and C1 is internet

    I have some simple questions for you: what have you tried, what results have you seen, what troubleshooting have you done to identify why your initial attempted solution isn't doing what you hoped?

     

  • Help vampirism aside, I wonder what the best way to handle something like this would be w/o specialized hardware.  I know there's an entire industry built around selling this sort of solution and accounting as well.  Seems like most of them revolve around PPP and firewalling/caching.

  • The interesting point here is to change the qos during peak and non-peak hours.

    Quick and dirty solution without using special qos hardware. Configure 2 policy-maps on the router, one for peak hours, and one for non-peak hours. Use any method to change the required qos policy-map on the WAN interface at specified times. For example, you can use Cisco Event Manager, TCL, automated script telnetting to the router from a PC, SNMP set commands from a PC, etc...

    Or, it might be possible using one policy map, by running a time-dependant access-list on the incoming LAN Interface on the router, to mark customer traffic with certain DSCP/IP PREC value during peak hours, and to mark a different DSCP/PREC value during non-peak hours. The policy map will give each DSCP different bandwidth. You might need to use artificial bandwidth statement on the WAN Interface to allow you to configure 2xActual Bandwidth in the policy-map.

  • Time based ACL's that will put traffic onto different classes depending on time of day as part of your parent policy.  That parent policy will rate limit during peak hours and run wide open during off-peak.  Then nest a service policy that give tags/classifies/queues/whatever to the different classes fo traffic you mentioned.

    Really not that difficult if you think about it...right?

  • His scenario seemed to require a lot more flexibility than TBACLs and policing would provide.

  • Both the conditions mentioned above should be customizable according to the content/protocol i.e. HTTP, HTTP Adaptive Streaming Protocol or Real Time Streaming protocol etc. The main objective is "to dynamically control user's internet speed depending on available bandwidth and type of content being accessed"

    I think the third requirement is way too vague to warrant serious consideration from implementation perspective.

  • This entire thread is basically "GIV3 M3 T3H FR33 CONS$ULITNGZ PLZ!"  It was cross-posted to boot.  It's still an interesting scenario to consider, though.

  • HA !!  yep.  That about sums it up...

  • This smells of homework. 

     

    My job would be so freaking easy if everytime my boss came to me with something, the deliverables were that specific. They never are. Usually its customer A is having an issue or Bob in accounting can't watch Cat videos on Youtube, fix it by next tuesday. 

  • Unfortunately, often the specific tasks include the unsaid assumption that there will be no additional cost associated with them.  The tasks themselves are usually driven by "big picture" folks with no concept of what's technically possible *at all* let alone with decade old equipment.  Imagine if it were "Bob in accounting needs to watch cat videos, but under no circumstance should he be allowed to watch dog videos.  Kathy in sales, however should only be able to access dog videos.  Neither of them should be able to watch parakeet videos and only farmville is OK on facespace, not candy crush."  Nice and specific, but undoable with the 1721 and 2950 in the wiring closet.

Sign In or Register to comment.