Task 2.1 OSPF

since hub to hub/spoke frame maps are already in the initial configuraiton. All three are using default ospf non-broadcast network type. There is really no need to use ip ospf network point-to-multipoint non-broadcast on each se0/0/0. But still ip ospf priority 0 is needed on both spokes s0/0/0 since hub has the neighbor command and has to be DR.  

Comments

  • Got this now.

     

    neighbor cost has to be in point-to-multipoint nonbroadcast.

  • Hi,

      And there is no DR on point-to-something OSPF network types.

    Regards

  • Hi,

    can anyone explain how the neighbor costs were derived? I expected a 1:2 ratio, but the SG specifically says 97:195. Which is almost 1:2, but not quite. Is there a reason for this?

    Thanks

  • Hi,

      In the task requirements you are given the rates for each circuit: 512Kbps and 1024Kbps. If you calculate the OSPF cost its formula of 100000000/512000 and 100000000/1024000 you will get thse values; so OSPF uses, by default a refernce badwidth of 100Mbps for cost calculation. To find out the link cost, divide this reference bandwidth by the interface bandwitdth.

    Hope it helps,

  • Many thanks for your answer Cristian, that was very helpful! 

    Marcel

     

  • Hi,

    I have a question on the initial configuration, whcih is network 0.0.0.0 0.0.0.0 area 0 configured on all routers. 

    Can we apply two OSPF areas on the same interface?

    When i applied OSPF areea 38 (R3 and SW2), the following message appers on R3:

    %OSPF-4-ERRRCV: Received invalid packet: mismatch area ID, from backbone area must be virtual-link but not found from 154.1.38.8, FastEthernet0/0

  • jchanjchan ✭✭ ✭✭

    since hub to hub/spoke frame maps are already in the initial configuraiton. All three are using default ospf non-broadcast network type. There is really no need to use ip ospf network point-to-multipoint non-broadcast on each se0/0/0. But still ip ospf priority 0 is needed on both spokes s0/0/0 since hub has the neighbor command and has to be DR.  

    The way I completed this task just as you mentioned on above, plus addedd the bandwidth statement on R3,R4, R5 frame-relay interfaces and broadcast keyword on the frame-relay map statements.  I think I met the task requirement by doing do.  Comment?

    Never mind, SG is correct.  R3 s1/0 is a main interface and configured with dlci 304 and 305, so the BW statement won't work, it needs the neighbor command and set cost for each neighbor.  Thanks!  Good one.

  • jchanjchan ✭✭ ✭✭

    SG screen outputs on R3 shows the learned routes cost = 195 for 150.1.5.5 and cost = 97 for 150.1.4.4,  I think below outputs is more correct.(defined cost + 1 for loopback0).  Comment?

    Rack1R3#sh ip route | i 150.1
         150.1.0.0/16 is variably subnetted, 8 subnets, 2 masks
    C       150.1.3.0/24 is directly connected, Loopback0
    O       150.1.8.8/32 [110/2] via 154.1.38.8, 00:06:49, FastEthernet0/0
    O       150.1.7.7/32 [110/99] via 154.1.0.4, 00:02:18, Serial1/0
    O       150.1.6.6/32 [110/846] via 154.1.23.2, 00:06:49, Serial1/3
    O       150.1.5.5/32 [110/196] via 154.1.0.5, 00:02:18, Serial1/0
    O       150.1.4.4/32 [110/98] via 154.1.0.4, 00:02:18, Serial1/0

    O       150.1.2.2/32 [110/782] via 154.1.23.2, 00:06:49, Serial1/3
    O       150.1.1.1/32 [110/782] via 154.1.13.1, 00:06:49, Serial1/2

  • SG screen outputs on R3 shows the learned routes cost = 195 for 150.1.5.5 and cost = 97 for 150.1.4.4,  I think below outputs is more correct.(defined cost + 1 for loopback0).  Comment?

    Yes, you are correct:

    Rack1R4#show ip ospf int loop0 | i Cost
      Process ID 1, Router ID 150.1.4.4, Network Type POINT_TO_POINT, Cost: 1

    Method to calculate ospf cost by dividing 100Mbit/bandwidth is best and proper way, but may be also slow and prone to human errors.

    Dirty hack on this is to temporarily set bandwidth to desired value on any interface (note original bandwidth parameter!) and do sh ip ospf int brief to see what is the cost. It may be faster and eliminate possibility of mistake during calculations. Just let the router do it's job and tell you value.

    Second thing, Network 154.1.5.0/24 on R5's Fa0/0 would be still in Area0, and there will be no connectivity to this network unless we do virtual-link or change area on this interface.

     

  • soulsoul

    Hi - task is clear to me. I also used  JDR method having the router give the correct cost.

    However I've been unable to setup this task with graded labs gear:

    Rack1R3#sh run int s1/0
    Building configuration...

    Current configuration : 440 bytes
    !
    interface Serial1/0
     ip address 154.1.0.3 255.255.255.0
     ip pim sparse-mode
     encapsulation frame-relay
     ip ospf network point-to-multipoint non-broadcast
     ip ospf 1 area 3457
    [snip]

    Rack1R3#conf t
    Enter configuration commands, one per line.  End with CNTL/Z.
    Rack1R3(config)#router ospf 1
    Rack1R3(config-router)#neighbor 154.1.0.4
    OSPF: Neighbor command is allowed only on NBMA and point-to-multipoint networks

    Rack1R3(config-router)#
    Rack1R3(config-router)#do sh ip ospf int s1/0
    Serial1/0 is up, line protocol is up
      Internet Address 154.1.0.3/24, Area 3457
      Process ID 1, Router ID 150.1.3.3, Network Type POINT_TO_MULTIPOINT, Cost: 781
    [snip]

     

    Rack1R3(config-router)#int s1/0
    Rack1R3(config-if)#ip ospf net
    Rack1R3(config-if)#ip ospf network non
    Rack1R3(config-if)#ip ospf network non-broadcast
    Rack1R3(config-if)#do sh ip ospf int s1/0 | i Network Type
      Process ID 1, Router ID 150.1.3.3, Network Type NON_BROADCAST, Cost: 781
    Rack1R3(config-if)#router ospf 1
    Rack1R3(config-router)#neighbo
    Rack1R3(config-router)#neighbor 154.1.0.4
    OSPF: Neighbor command is allowed only on NBMA and point-to-multipoint networks

    Whatever network type I set it gives back this error...

    There is a BUG related to this bug it kicks in with vlinks (but no VL on this lab)

    It can be either one of this: a bug - or my brain is melting after so many rack hours and I'm missing something BIG here. I tried with two different racks...

     

    Thanks

     

  • soulsoul

    As a test I've just removed tunnel34 and tunnel 35 and now it works:

     

    Rack1R3(config)#no int tun34
    Rack1R3(config)#no int tun35
    Rack1R3(config)#
    Jun  5 01:44:22.044: %PIM-5-NBRCHG: neighbor 154.1.0.4 DOWN on interface Tunnel34 non DR
    Rack1R3(config)#
    Jun  5 01:44:23.594: %PIM-5-NBRCHG: neighbor 154.1.0.5 DOWN on interface Tunnel35 non DR
    Rack1R3(config)#end
    Rack1R3#conf t
    Enter configuration commands, one per line.  End with CNTL/Z.
    Rack1R3(config)#router ospf 1
    Rack1R3(config-router)#neighbor 154.1.0.4
    Rack1R3(config-router)#end

    after I add again the tunnel interfaces again the issue come back although the neighbor are not reached via those tunnels and are OSPF passive interfaces:

     

    Rack1R3(config)#interface Tunnel34
    Rack1R3(config-if)# ip unnumbered Serial1/0
    Rack1R3(config-if)# ip pim sparse-mode
    Rack1R3(config-if)# tunnel source Serial1/0
    Rack1R3(config-if)# tunnel destination 154.1.0.4
    Rack1R3(config-if)#interface Tunnel35
    Rack1R3(config-if)# ip unnumbered Serial1/0
    Rack1R3(config-if)# ip pim sparse-mode
    Rack1R3(config-if)# tunnel source Serial1/0
    Rack1R3(config-if)# tunnel destination 154.1.0.5

    Rack1R3(config)#router ospf 1
    Rack1R3(config-router)#passive-interface tun34
    Rack1R3(config-router)#passive-interface tun35

    Rack1R3(config-router)#do sh ip route 154.1.0.5
    Routing entry for 154.1.0.0/24
      Known via "connected", distance 0, metric 0 (connected, via interface)
      Routing Descriptor Blocks:
      * directly connected, via Serial1/0
          Route metric is 0, traffic share count is 1

    Rack1R3(config-router)#neigh 154.1.0.5
    OSPF: Neighbor command is allowed only on NBMA and point-to-multipoint networks

    Rack1R3(config-router)#end
    Rack1R3#

    Anyone?

     

  • Hey there Soul!

     

     

    I'm experiencing the same bug on my rack and this kinda disapointing !

    Rack1R3#sh ip ospf int s1/0 | inc Type
      Process ID 1, Router ID 150.1.3.3, Network Type POINT_TO_MULTIPOINT, Cost: 781
    Rack1R3#
    Rack1R3#config t
    Enter configuration commands, one per line.  End with CNTL/Z.
    Rack1R3(config)#router ospf 1
    Rack1R3(config-router)#neigh 154.1.0.5 cost 1024
    OSPF: Neighbor command is allowed only on NBMA and point-to-multipoint networks

    Rack1R3(config-router)#
    Rack1R3(config-router)#
    Rack1R3(config-router)#
    Rack1R3(config-router)#do sh run int tunnel 34
    Building configuration...

    Current configuration : 126 bytes
    !
    interface Tunnel34
     ip unnumbered Serial1/0
     ip pim sparse-mode
     tunnel source Serial1/0
     tunnel destination 154.1.0.4
    end

    Rack1R3(config-router)#do sh run int tunnel 35
    Building configuration...

    Current configuration : 126 bytes
    !
    interface Tunnel35
     ip unnumbered Serial1/0
     ip pim sparse-mode
     tunnel source Serial1/0
     tunnel destination 154.1.0.5
    end

    Rack1R3(config-router)#no int tunnel 34
    Rack1R3(config)#no int tunnel 3
    *Mar  1 00:02:33.399: %PIM-5-NBRCHG: neighbor 154.1.0.4 DOWN on interface Tunnel34 non DR
    Rack1R3(config)#no int tunnel 35
    Rack1R3(config)#
    *Mar  1 00:02:35.250: %PIM-5-NBRCHG: neighbor 154.1.0.5 DOWN on interface Tunnel35 non DR
    Rack1R3(config)#
    Rack1R3(config)#router ospf 1
    Rack1R3(config-router)#neigh 154.1.0.5 cost 1024
    Rack1R3(config-router)#neigh 154.1.0.4 cost 512
    Rack1R3(config-router)#
    *Mar  1 00:03:06.950: %OSPF-5-ADJCHG: Process 1, Nbr 150.1.4.4 on Serial1/0 from LOADING to FULL, Loading Done
    *Mar  1 00:03:06.954: %OSPF-5-ADJCHG: Process 1, Nbr 150.1.5.5 on Serial1/0 from LOADING to FULL, Loading Done
    Rack1R3(config-router)#interface Tunnel34
    Rack1R3(config-if)# ip unnumbered Serial1/0
    Rack1R3(config-if)# ip pim sparse-mode
    Rack1R3(config-if)# tunnel source Serial1/0
    Rack1R3(config-if)# tunnel destination 154.1.0.4
    Rack1R3(config-if)#
    *Mar  1 00:03:16.145: %PIM-5-NBRCHG: neighbor 154.1.0.4 UP on interface Tunnel34
    Rack1R3(config-if)#interface Tunnel35
    Rack1R3(config-if)# ip unnumbered Serial1/0
    Rack1R3(config-if)# ip pim sparse-mode
    Rack1R3(config-if)# tunnel source Serial1/0
    Rack1R3(config-if)# tunnel destination 154.1.0.5
    Rack1R3(config-if)#

     

     

    One trick if you dont want to calculate the cost is that you just invert both bandwith and you ll use the same ratio as it should be :) No matter what the cost is you still can you it that way...

     

    But if the cost must reflect the real bandwith then JDR way to configure it is the best one !

  • soulsoul

    Happy to see I'm not alone :)

    Hey - I see you and I are following more or less the same topics/thread. When is your lab date scheduled?

  • I still dont understand why the none-broad cast mode does not work , can you explain ?

  • I'm not currently looking to initial configs, but check if frame-relay from initial configs allows multicast/broadcast, which might point to use point-to-multipoint broadcast or non-boradcast. Otherwise you could technically use any of these 2 network types: on PTM broadcast "neighbor" command is optional, but if you use it you need to specify a cost for that neighbor while on PTM non-broadcast "neighbor" command is mandatory but assigning a cost for that neighbor is optional.

    As you can see the task forces you to use a "neighbor cost" command.

    Good luck with your studies!

  • Got the same problem with the other folks here:

    Rack3R3(config-router)#router ospf 1
    Rack3R3(config-router)# neighbor 154.3.0.4 cost 97
    OSPF: Neighbor command is allowed only on NBMA and point-to-multipoint networks
    Rack3R3(config-router)# neighbor 154.3.0.5 cost 195
    OSPF: Neighbor command is allowed only on NBMA and point-to-multipoint networks

     

    Christian,

    The initial configs for FR doesn't have broadcast so Point-To-Multipoint Broadcast is out of the question.

    Rack3R3(config-router)#do sh frame map
    Serial1/0 (up): ip 154.3.0.4 dlci 304(0x130,0x4C00), static,
                  CISCO, status defined, active
    Serial1/0 (up): ip 154.3.0.5 dlci 305(0x131,0x4C10), static,
                  CISCO, status defined, active

  • Hi,

      Yes, those messages are pretty self explanatory,l and as i remember do not even show up in config if your network type is not correct. If FR initial configuration does not allow for broadcast/multicast, in this case 100% sure you should use PTM non-broadcast, cause modifying initial configs should not be allowed unless explicitly specified in a task or required in order to meet task requirements. In here you have an 100% valid solution without modifying initial configs and there is nothing int the lab looking for PTM broadcast.

    Good luck with your studies!

  • Hello benizepam,

    Can you post the current IOS version and Series of Router you are using? Some ppls already talked about the same issue.

    Visit Here:
    http://ieoc.com/forums/t/6363.aspx

    and
    Cisco Site:
    https://supportforums.cisco.com/thread/191336

    The guy from Cisco suggested to reload the router (your router might not recognized your NBMA interface).

    and this as well
    http://ieoc.com/forums/p/16430/136340.aspx#136340

    It might be the bug on IOS.

    HAPPY STUDY

  • nnn,

    The lab I was using when I encountered the issue was just a rack rental from Graded Labs. I'll be doing the same lab in about 12 hours from now, so I'll be posting the IOS image information if I encounter the same issue again.

  • I encounter the same issue even after the reload. Looks like I'll have to do a "workaround" for this task.

    Rack3R3(config)#router ospf 1
    Rack3R3(config-router)# neighbor 154.3.0.4 cost 97
    OSPF: Neighbor command is allowed only on NBMA and point-to-multipoint networks
    Rack3R3(config-router)# neighbor 154.3.0.5 cost 195
    OSPF: Neighbor command is allowed only on NBMA and point-to-multipoint networks
    Rack3R3(config-router)# network 150.3.3.3 0.0.0.0 area 3457
    Rack3R3(config-router)# network 154.3.0.3 0.0.0.0 area 3457
    Rack3R3(config-router)#do sh ver
    Cisco IOS Software, C2600 Software (C2600-ADVENTERPRISEK9-M), Version 12.4(10), RELEASE SOFTWARE (fc1)

  • Did you try to completely remove FR configuration on the interface (enable PPP, enable FR), add it again?

    Good luck with your studies!

  • I haven't tried that one yet but will do it after I repeat Lab 16 again. Even then, having the problem in the first place doesn't make any sense. :)

  •  

    - Bring the interface on default configuration (default interface intname)

    - Shutdown the interface

    - Apply the configuration and use no shutdown command

    This might help you!

    [:D]

    I haven't tried that one yet but will do it after I repeat Lab 16 again. Even then, having the problem in the first place doesn't make any sense. :)

     

  • I've had exactly the same issue and scrathed my head for a long time......

    on the OSPF process there was a command  for all networks....

    "netw 0.0.0.0 255.255.255.255 area 0"

     

    after this was removed...the neigh "154.x.0.5|4 cost x " could be inserted......

     

    Try it out it worked for me, but I did waste a lot of time on this!

     

    also...remember to activate the netw  or interface ospf commands for are 0...to get the adj up again!

     

     

     

  • also....if you want to do it on the cli..... and not use the math..... configure one of your serial/fastethernet interfaces with the specified BW..... then apply the ip ospf 1 area 0,,..... or any relevant ospf interface command to get the interface to join the ospf process..... then do the ..."ip ospf int " command to check the ospf cost......

     

    works like a charm!

    sounds like a lot of work but can do it quick!

  • Also just to point this out...since R4 has a least cost path to R5's 154.1.0.5; R3 will not show the 195 cost route to reach it.  To see the results you can disable R4's Fa0/1 interface. 

    Before


    Rack1R3#show ip route ospf    

         154.1.0.0/16 is variably subnetted, 12 subnets, 2 masks

    O       154.1.0.5/32 [110/98] via 154.1.0.4, 00:05:48, Serial1/0

    O       154.1.0.4/32 [110/97] via 154.1.0.4, 00:05:48, Serial1/0

    After

    Rack1R3#show ip route ospf

         154.1.0.0/16 is variably subnetted, 12 subnets, 2 masks

    O       154.1.0.5/32 [110/195] via 154.1.0.5, 00:00:02, Serial1/0

    O       154.1.0.4/32 [110/97] via 154.1.0.4, 00:05:51, Serial1/0

     

  • It didn't work with me till i deleted the tunnel interfaces Tu34, Tu35 from R3

    Then i recreated the tunnels again and it's still working even after reloading R3

    Any ideas?

    Best regards,

    Amr

  • Hi all together,

    what about the Vlan 5 Interface of R5?? I cannot find anything stated about it in the tasks wording and also not on the SG ...

    That interface remains in OSPF area 0 (as the initial config is "network 0.0.0.0 255.255.255.255 area 0"). This splits up the area 0 and the network is not in the routing table of R3 anymore. (well it is via BGP, but it's not in the ospf database)

    There are 2 possible solutions:

    1. create a virtual link

    2. move this network to area 3457 too

    But what's the correct answer?? Let me guess: Ask the proctor ...

    Kind regards

    Falk

Sign In or Register to comment.