Frame Switch 4.0 Topology

Just curious as to what everyone is using for their frame switch in their home lab for the 4.0 topology? Is the NM-8A/S module still a valid option or is there something newer that I should be using? I checked the topology thread here and it says they're still using a 2522 but I'm just concerned if that is really still the best option. thanks

Comments

  • I have an NM-8A/S at home, acting as the frame switch. It works perfectly fine.  It doesn't look like they changed anything in regards to the Frame switch in V4.

    This router is an old 2620 and acts as BB1 as well.  If you would like the running config of it, I'd be more than happy to provide it to you.

  • Thanks for the info. I just wanted to be sure before I bought the module that something hadn't changed drastically. Yeah if you could paste it that would be great. I'm going to put it in an old 2610 I have..I had initially thought of just keeping the switch separate from the BB but perhaps it would be a bit more budget friendly to use it for both. THanks again!!

  • Sure thing.  It's basically the same config in the workbook section.  Here you are:

     


     

    BB1#

    BB1#

    BB1#term len 0

    BB1#sh ver

    Cisco Internetwork Operating System Software 

    IOS (tm) C2600 Software (C2600-I-M), Version 12.1(7), RELEASE SOFTWARE (fc1)

    Copyright (c) 1986-2001 by cisco Systems, Inc.

    Compiled Thu 22-Feb-01 12:50 by kellythw

    Image text-base: 0x80008088, data-base: 0x808023C4

     

    ROM: System Bootstrap, Version 11.3(2)XA4, RELEASE SOFTWARE (fc1)

     

    BB1 uptime is 4 weeks, 6 days, 1 hour, 36 minutes

    System returned to ROM by power-on

    System restarted at 16:00:01 PST Sun Feb 28 1993

    System image file is "flash:c2600-i-mz_121-7.bin"

     

    cisco 2620 (MPC860) processor (revision 0x102) with 53248K/12288K bytes of memory.

    Processor board ID JAD04490AUJ (3628618217)

    M860 processor: part number 0, mask 49

    Bridging software.

    X.25 software, Version 3.0.0.

    1 FastEthernet/IEEE 802.3 interface(s)

    1 Serial network interface(s)

    2 Serial(sync/async) network interface(s)

    8 Low-speed serial(sync/async) network interface(s)

    32K bytes of non-volatile configuration memory.

    16384K bytes of processor board System flash (Read/Write)

     

    Configuration register is 0x2102

     

    BB1#

    BB1#

    BB1#

    BB1#

    BB1#

    BB1#

    BB1#

    BB1#

    BB1#

    BB1#sh run

    Building configuration...

     

    Current configuration : 9774 bytes

    !

    ! Last configuration change at 17:36:41 PST Sat Apr 3 1993

    !

    version 12.1

    service timestamps debug uptime

    service timestamps log uptime

    no service password-encryption

    !

    hostname BB1

    !

    enable password cisco

    !

    username ROUTER6 password 0 CISCO

    !

    !

    !

    !

    clock timezone PST -8

    clock summer-time PDT recurring

    ip subnet-zero

    no ip finger

    no ip domain-lookup

    !

    frame-relay switching

    !

    key chain EIGRP

     key 1

      key-string CISCO

    bridge irb

    !

    !

    !

    interface Loopback112

     ip address 112.0.0.1 255.0.0.0

    !

    interface Loopback113

     ip address 113.0.0.1 255.0.0.0

    !

    interface Loopback114

     ip address 114.0.0.1 255.0.0.0

    !

    interface Loopback115

     ip address 115.0.0.1 255.0.0.0

    !

    interface Loopback116

     ip address 116.0.0.1 255.0.0.0

    !

    interface Loopback117

     ip address 117.0.0.1 255.0.0.0

    !

    interface Loopback118

     ip address 118.0.0.1 255.0.0.0

    !

    interface Loopback119

     ip address 119.0.0.1 255.0.0.0

    !

    interface Loopback51001

     ip address 51.0.0.1 255.255.0.0

    !

    interface Loopback51101

     ip address 51.1.0.1 255.255.0.0

    !

    interface Loopback51201

     ip address 51.2.0.1 255.255.0.0

    !

    interface Loopback51301

     ip address 51.3.0.1 255.255.0.0

    !

    interface Loopback51401

     ip address 51.4.0.1 255.255.0.0

    !

    interface Loopback51501

     ip address 51.5.0.1 255.255.0.0

    !

    interface Loopback51601

     ip address 51.6.0.1 255.255.0.0

    !

    interface Loopback51701

     ip address 51.7.0.1 255.255.0.0

    !

    interface Loopback200000

     ip address 200.0.0.1 255.255.255.0

    !

    interface Loopback200010

     ip address 200.0.1.1 255.255.255.0

    !

    interface Loopback200020

     ip address 200.0.2.1 255.255.255.0

    !

    interface Loopback200030

     ip address 200.0.3.1 255.255.255.0

    !

    interface Loopback2121801

     ip address 212.18.0.1 255.255.255.0

    !

    interface Loopback2121811

     ip address 212.18.1.1 255.255.255.0

    !

    interface Loopback2121821

     ip address 212.18.2.1 255.255.255.0

    !

    interface Loopback2121831

     ip address 212.18.3.1 255.255.255.0

    !

    interface FastEthernet0/0

     no ip address

     shutdown

     duplex auto

     speed auto

    !

    interface Serial0/0

     no ip address

     encapsulation lapb multi

    !

    interface Serial0/1

     no ip address

     shutdown

    !

    interface Serial0/2

     no ip address

     shutdown

    !

    interface Serial1/0

     description Connected to R1

     no ip address

     encapsulation frame-relay

     clockrate 64000

     frame-relay intf-type dce

     frame-relay route 103 interface Serial1/2 301

     frame-relay route 104 interface Serial1/4 401

     frame-relay route 105 interface Serial1/5 501

     frame-relay route 113 interface Serial1/3 311

    !

    interface Serial1/1

     description Connected to R2

     no ip address

     encapsulation frame-relay

     clockrate 64000

     frame-relay intf-type dce

     frame-relay route 201 interface Serial1/0 102

     frame-relay route 203 interface Serial1/2 302

     frame-relay route 204 interface Serial1/4 402

     frame-relay route 205 interface Serial1/5 502

     frame-relay route 213 interface Serial1/3 312

    !

    interface Serial1/2

     description Connected to R3 S1/0

     no ip address

     encapsulation frame-relay

     clockrate 64000

     frame-relay intf-type dce

     frame-relay route 301 interface Serial1/0 103

     frame-relay route 302 interface Serial1/1 203

     frame-relay route 304 interface Serial1/4 403

     frame-relay route 305 interface Serial1/5 503

    !

    interface Serial1/3

     description Connected to R3 S1/1

     no ip address

     encapsulation frame-relay

     clockrate 64000

     frame-relay intf-type dce

     frame-relay route 311 interface Serial1/0 113

     frame-relay route 312 interface Serial1/1 213

     frame-relay route 314 interface Serial1/4 413

     frame-relay route 315 interface Serial1/5 513

    !

    interface Serial1/4

     description Connected to R4

     no ip address

     encapsulation frame-relay

     clockrate 64000

     frame-relay intf-type dce

     frame-relay route 401 interface Serial1/0 104

     frame-relay route 402 interface Serial1/1 204

     frame-relay route 403 interface Serial1/2 304

     frame-relay route 405 interface Serial1/5 504

     frame-relay route 413 interface Serial1/3 314

    !

    interface Serial1/5

     description Connected to R5

     no ip address

     encapsulation frame-relay

     clockrate 64000

     frame-relay intf-type dce

     frame-relay route 501 interface Serial1/0 105

     frame-relay route 502 interface Serial1/1 205

     frame-relay route 503 interface Serial1/2 305

     frame-relay route 504 interface Serial1/4 405

     frame-relay route 513 interface Serial1/3 315

    !

    interface Serial1/6

     description Connected to R6

     bandwidth 1544

     no ip address

     encapsulation frame-relay

     clockrate 64000

     frame-relay intf-type dce

    !

    interface Serial1/6.51 point-to-point

     description PVC 51 to R6

     ip address 54.1.3.254 255.255.255.0

     frame-relay interface-dlci 51   

    !

    interface Serial1/6.100 point-to-point

     description PVC 100 to R6

     ip address 54.1.2.254 255.255.255.0

     frame-relay interface-dlci 100   

    !

    interface Serial1/6.101 point-to-point

     description PVC 101 to R6

     ip address 54.1.1.254 255.255.255.0

     ip authentication mode eigrp 10 md5

     ip authentication key-chain eigrp 10 EIGRP

     frame-relay interface-dlci 101   

    !

    interface Serial1/6.201 point-to-point

     description PPP over PVC 201 to R6

     frame-relay interface-dlci 201 ppp Virtual-Template1

    !

    interface Serial1/6.301 point-to-point

     description PPP over PVC 301 to R6

     frame-relay interface-dlci 301 ppp Virtual-Template11

    !

    interface Serial1/6.401 point-to-point

     description Bridging over PVC 401 to R6

     frame-relay interface-dlci 401   

     bridge-group 1

    !

    interface Serial1/7

     description Connected to BB3

     ip address 172.16.4.1 255.255.255.0

     clockrate 64000

    !

    interface Virtual-Template1

     ip address 54.1.7.254 255.255.255.0

     ppp authentication chap

    !

    interface Virtual-Template11

     ip address 54.1.8.254 255.255.255.0

     ppp authentication pap

     ppp pap sent-username BB1 password 7 032772382520

    !

    interface BVI1

     ip address 54.1.10.254 255.255.255.0

    !

    router eigrp 10

     network 54.0.0.0

     network 200.0.0.0 0.0.3.255

     distribute-list EIGRP out

     distribute-list prefix DENY_DEFAULT in

     no auto-summary

     no eigrp log-neighbor-changes

     no eigrp log-neighbor-warnings

    !

    router rip

     version 2

     network 54.0.0.0

     network 212.18.0.0

     network 212.18.1.0

     network 212.18.2.0

     network 212.18.3.0

     distribute-list RIP out

     no auto-summary

    !

    router bgp 54

     no synchronization

     bgp log-neighbor-changes

     network 112.0.0.0

     network 113.0.0.0

     network 114.0.0.0 route-map SET_COMMUNITY_54

     network 115.0.0.0 route-map SET_COMMUNITY_54

     network 116.0.0.0

     network 117.0.0.0

     network 118.0.0.0

     network 119.0.0.0

     neighbor RACKS peer-group

     neighbor RACKS remote-as 100

     neighbor RACKS send-community

     neighbor RACKS route-map BGP_IN in

     neighbor RACKS route-map BGP_OUT out

     neighbor 54.1.1.6 peer-group RACKS

     neighbor 54.1.2.6 peer-group RACKS

     neighbor 54.1.3.6 peer-group RACKS

     neighbor 54.1.4.6 peer-group RACKS

     neighbor 54.1.5.6 peer-group RACKS

     neighbor 54.1.6.6 peer-group RACKS

     neighbor 54.1.7.6 peer-group RACKS

     neighbor 54.1.8.6 peer-group RACKS

     neighbor 54.1.10.6 peer-group RACKS

     neighbor 54.1.10.100 peer-group RACKS

     neighbor 172.16.4.3 remote-as 54

     neighbor 172.16.4.3 next-hop-self

     neighbor 172.16.4.3 send-community

     no auto-summary

    !

    ip classless

    ip route 204.12.0.0 255.255.0.0 172.16.4.3

    no ip http server

    ip as-path access-list 1 permit ^$

    !

    !

    ip prefix-list BGP_PREPEND_1 seq 5 permit 112.0.0.0/8

    ip prefix-list BGP_PREPEND_1 seq 10 permit 113.0.0.0/8

    !

    ip prefix-list DEFAULT seq 5 permit 0.0.0.0/0

    !

    ip prefix-list DENY_DEFAULT seq 5 deny 0.0.0.0/0

    ip prefix-list DENY_DEFAULT seq 10 permit 0.0.0.0/0 le 32

    !

    ip access-list standard EIGRP

     permit 200.0.0.0 0.0.3.255

    ip access-list standard RIP

     permit 212.18.0.0 0.0.3.0

    route-map BGP_IN deny 10

     match ip address prefix-list DEFAULT

    !

    route-map BGP_IN permit 10000

    !

    route-map SET_COMMUNITY_54 permit 10

     set community 54

    !

    route-map BGP_OUT permit 10

     match ip address prefix-list BGP_PREPEND_1

     set as-path prepend 50 60

    !

    route-map BGP_OUT permit 10000

     match as-path 1

    !

    bridge 1 protocol ieee

     bridge 1 route ip

    banner exec ^C

     

    +-------------------------------------------------------------------------------+

    |                                                                               |

    | Welcome to BB1!  The following commands are available for use at privilege 0  |

    |                                                                               |

    | ping                                                                          |

    | telnet                                                                        |

    | traceroute                                                                    |

    | show ip route                                                                 |

    | show ip bgp                                                                   |

    | show ip bgp neighbors                                                         |

    | show ip bgp summary                                                           |

    | show ip protocols                                                             |

    | show ip interface brief                                                       |

    |                                                                               |

    | The reference configuration for this device is available at:                  |

    | http://www.internetworkexpert.com/downloads/bb1.txt                           |

    |                                                                               |

    +-------------------------------------------------------------------------------+

    ^C

    alias exec en exit

    alias exec ena exit

    alias exec enab exit

    alias exec enabl exit

    privilege exec level 0 telnet 

    privilege exec level 0 traceroute 

    privilege exec level 0 ping 

    privilege exec level 1 terminal 

    privilege exec level 1 enable 

    privilege exec level 0 show 

    !

    line con 0

     exec-timeout 5 0

     transport input none

    line aux 0

     transport input all

    line vty 0 4

     exec-timeout 5 0

     privilege level 0

     no login

    !

    ntp authentication-key 1 md5 047822352C0E 7

    ntp trusted-key 1

    ntp master 4

    end

     

    BB1#

    BB1#

    BB1#

    BB1#

    BB1#term len 24

    BB1#

    BB1#

    BB1#exit

     

Sign In or Register to comment.