Lab 1 / Task 6.X : MOH multicast issue

Hello,








NB : For my studies, I use 4 CIPC softphones (HQ/BR1/BR2/PSTN) running on my laptop (using virtual machines and Cisco VPN client to connect to the rack from laptop).


I have an issue with MOH multicast in Lab 1 / Task 6.X : everything is OK with unicast MOH but when I want to use multicast I can't hear any MOH. Please note that CUCM shows that it sends MOH as multicast stream :



admin:show perf query class "Cisco MOH Device"
==>query class :

 - Perf class (Cisco MOH Device) has instances and values:
    MOH_2           -> MOHHighestActiveResources      = 1
    MOH_2           -> MOHMulticastResourceActive     = 0
    MOH_2           -> MOHMulticastResourceAvailable  = 250000
    MOH_2           -> MOHOutOfResources              = 0
    MOH_2           -> MOHTotalMulticastResources     = 250000
    MOH_2           -> MOHTotalUnicastResources       = 250
    MOH_2           -> MOHUnicastResourceActive       = 0
    MOH_2           -> MOHUnicastResourceAvailable    = 250
    MOH_3           -> MOHHighestActiveResources      = 1
    MOH_3           -> MOHMulticastResourceActive     = 1
    MOH_3           -> MOHMulticastResourceAvailable  = 249999
    MOH_3           -> MOHOutOfResources              = 0
    MOH_3           -> MOHTotalMulticastResources     = 250000
    MOH_3           -> MOHTotalUnicastResources       = 250
    MOH_3           -> MOHUnicastResourceActive       = 0
    MOH_3           -> MOHUnicastResourceAvailable    = 250
admin:



I did apply multicast confs on HQ/BR1/BR2 routers ("ip multicast-routing" in global conf mode and "ip pim dense-mode" on interfaces with voice stream, etc.).



How can I troubleshoot my issue (I didn't find any troobleshooting example in workbooks for MOH...) ?





Best regards,

SB.

Comments

  • When BR1-IP-Phone places on hold HQ-IP-Phone :

    - I still can't hear MOH at HQ-IP-Phone (multicast MOH issue) ;

    - I have very few multicast traces at HQ router and a lot at BR1 router.

    Why do I have such traces as HQ-IP-Phone which should receive MOH is not behind BR1 router ???

    --

    "debug ip mpacket" at HQ : very few traces (with correct TTL=126, as I fixed it at the maximum - 127)

    VORack06R1#
    Dec 28 13:20:33.321: IP(0): MAC sa=000c.299c.19cb (FastEthernet0/0.10), IP last-hop=177.1.10.10
    Dec 28 13:20:33.321: IP(0): IP tos=0xB8, len=60, id=0, ttl=126, prot=17
    Dec 28 13:20:33.321: IP(0): s=177.1.10.10 (FastEthernet0/0.10) d=239.1.1.3 (Serial0/0/1:0.1) id=0, ttl=126, prot=17, len=60(60), mforward
    Dec 28 13:20:33.325: IP(0): s=177.1.10.10 (FastEthernet0/0.10) d=239.1.1.3 (Serial0/0/1:0.2) id=0, ttl=126, prot=17, len=60(60), mforward
    Dec 28 13:20:33.325: IP(0): MAC sa=000c.299c.19cb (FastEthernet0/0.10), IP last-hop=177.1.10.10
    Dec 28 13:20:33.325: IP(0): IP tos=0xB8, len=200, id=0, ttl=126, prot=17
    Dec 28 13:20:33.325: IP(0): s=177.1.10.10 (FastEthernet0/0.10)
    VORack06R1# d=239.1.1.1 (Serial0/0/1:0.1) id=0, ttl=126, prot=17, len=200(200), mforward
    Dec 28 13:20:33.325: IP(0): s=177.1.10.10 (FastEthernet0/0.10) d=239.1.1.1 (Serial0/0/1:0.2) id=0, ttl=126, prot=17, len=200(200), mforward
    VORack06R1#
    Dec 28 13:20:43.333: IP(0): MAC sa=000c.2910.4b09 (FastEthernet0/0.10), IP last-hop=177.1.10.20
    Dec 28 13:20:43.333: IP(0): IP tos=0xB8, len=60, id=0, ttl=126, prot=17
    Dec 28 13:20:43.333: IP(0): s=177.1.10.20 (FastEthernet0/0.10) d=239.1.1.7 (Serial0/0/1:0.1) id=0, ttl=126, prot=17, len=60(60), mforward
    Dec 28 13:20:43.333: IP(0): s=177.1.10.20 (FastEthernet0/0.10) d=239.1.1.7 (Serial0/0/1:0.2) id=0, ttl=126, prot=17, len=60(60), mforward
    Dec 28 13:20:43.333: IP(0): MAC sa=000c.2910.4b09 (FastEthernet0/0.10), IP last-hop=177.1.10.20
    Dec 28 13:20:43.333: IP(0): IP tos=0xB8, len=200, id=0, ttl=126, prot=17
    Dec 28 13:20:43.333: IP(0): s=177.1.10.20 (FastEthernet0/0.10)
    VORack06R1# d=239.1.1.5 (Serial0/0/1:0.1) id=0, ttl=126, prot=17, len=200(200), mforward
    Dec 28 13:20:43.337: IP(0): s=177.1.10.20 (FastEthernet0/0.10) d=239.1.1.5 (Serial0/0/1:0.2) id=0, ttl=126, prot=17, len=200(200), mforward
    VORack06R1#

    --

    "debug ip mpacket" at BR1 : a lot of traces (with correct TTL=125, as I fixed it at the maximum - 127)

    Dec 28 13:25:43.653: IP(0): MAC sa=DLCI 101 (Serial0/0/1:0.1)
    Dec 28 13:25:43.653: IP(0): IP tos=0xB8, len=60, id=0, ttl=125, prot=17
    Dec 28 13:25:43.653: IP(0): s=177.1.10.10 (Serial0/0/1:0.1) d=239.1.1.3 id=0, ttl=125, prot=17, len=64(60), mroute olist null
    Dec 28 13:26:01.469: %SYS-3-MSGLOST: 1145 messages lost because of queue overflow
    Dec 28 13:25:44.497: IP(0): s=177.1.10.20 (Serial0/0/1:0.1) d=239.1.1.5 id=0, ttl=125, prot=17, len=204(200), mroute olist null
    Dec 28 13:25:45.145: IP(0): MAC sa=DLCI 101 (Serial0/0/1:0.1)
    Dec 28 13:25:45.145: IP(0): IP tos=0xB8, len=60, id=0, ttl=125, prot=17
    Dec 28 13:25:45.145: IP(0): s=177.1.10.10 (Serial0/0/1:0.1) d=239.1.1.3 id=0, ttl=125, prot=17, len=64(60), mroute olist null
    Dec 28 13:25:45.149: IP(0): MAC sa=DLCI 101 (Serial0/0/1:0.1)
    Dec 28 13:25:45.149: IP(0): IP tos=0xB8, len=200, id=0, ttl=125, prot=17
    Dec 28 13:25:45.149: IP(0): s=177.1.10.10 (Serial0/0/1:0.1) d=239.1.1.1 id=0, ttl=125, prot=17, len=204(200), mroute olist null
    Dec 28 13:26:02.469: %SYS-3-MSGLOST: 720 messages lost because of queue overflow
    Dec 28 13:25:45.185: IP(0): MAC sa=DLCI 101 (Serial0/0/1:0.1)
    Dec 28 13:25:45.185: IP(0): IP tos=0xB8, len=60, id=0, ttl=125, prot=17
    Dec 28 13:25:45.185: IP(0): s=177.1.10.10 (Serial0/0/1:0.1) d=239.1.1.3 id=0, ttl=125, prot=17, len=64(60), mroute olist null
    Dec 28 13:25:45.189: IP(0): MAC sa=DLCI 101 (Serial0/0/1:0.1)
    Dec 28 13:25:45.189: IP(0): IP tos=0xB8, len=200, id=0, ttl=125, prot=17
    Dec 28 13:25:45.189: IP(0): s=177.1.10.10 (Serial0/0/1:0.1) d=239.1.1.1 id=0, ttl=125, prot=17, len=204(200), mroute olist null
    Dec 28 13:25:45.953: IP(0): MAC sa=DLCI 101 (Serial0/0/1:0.1)
    Dec 28 13:25:45.953: IP(0): IP tos=0xB8, len=60, id=0, ttl=125, prot=17
    Dec 28 13:26:03.469: %SYS-3-MSGLOST: 745 messages lost because of queue overflow
    Dec 28 13:25:45.997: IP(0): MAC sa=DLCI 101 (Serial0/0/1:0.1)
    Dec 28 13:25:45.997: IP(0): IP tos=0xB8, len=60, id=0, ttl=125, prot=17
    Dec 28 13:25:45.997: IP(0): s=177.1.10.20 (Serial0/0/1:0.1) d=239.1.1.7 id=0, ttl=125, prot=17, len=64(60), mroute olist null
    Dec 28 13:25:45.997: IP(0): MAC sa=DLCI 101 (Serial0/0/1:0.1)
    Dec 28 13:25:45.997: IP(0): IP tos=0xB8, len=200, id=0, ttl=125, prot=17
    Dec 28 13:25:45.997: IP(0): s=177.1.10.20 (Serial0/0/1:0.1) d=239.1.1.5 id=0, ttl=125, prot=17, len=204(200), mroute olist null
    Dec 28 13:25:46.649: IP(0): MAC sa=DLCI 101 (Serial0/0/1:0.1)
    Dec 28 13:25:46.649: IP(0): IP tos=0xB8, len=60, id=0, ttl=125, prot=17
    Dec 28 13:26:03.469: %SYS-3-MSGLOST: 745 messages lost because of queue overflow
    Dec 28 13:25:46.693: IP(0): MAC sa=DLCI 101 (Serial0/0/1:0.1)
    Dec 28 13:25:46.693: IP(0): IP tos=0xB8, len=60, id=0, ttl=125, prot=17
    Dec 28 13:25:46.693: IP(0): s=177.1.10.20 (Serial0/0/1:0.1) d=239.1.1.7 id=0, ttl=125, prot=17, len=64(60), mroute olist null
    Dec 28 13:25:46.693: IP(0): MAC sa=DLCI 101 (Serial0/0/1:0.1)
    Dec 28 13:25:46.693: IP(0): IP tos=0xB8, len=200, id=0, ttl=125, prot=17
    Dec 28 13:25:46.693: IP(0): s=177.1.10.20 (Serial0/0/1:0.1) d=239.1.1.5 id=0, ttl=125, prot=17, len=204(200), mroute olist null
    Dec 28 13:25:47.465: IP(0): MAC sa=DLCI 101 (Serial0/0/1:0.1)
    Dec 28 13:25:47.465: IP(0): IP tos=0xB8, len=60, id=0, ttl=125, prot=17
    Dec 28 13:26:04.469: %SYS-3-MSGLOST: 745 messages lost because of queue overflow
    Dec 28 13:25:47.509: IP(0): MAC sa=DLCI 101 (Serial0/0/1:0.1)
    Dec 28 13:25:47.509: IP(0): IP tos=0xB8, len=200, id=0, ttl=125, prot=17
    Dec 28 13:25:47.509: IP(0): s=177.1.10.10 (Serial0/0/1:0.1) d=239.1.1.1 id=0, ttl=125, prot=17, len=204(200), mroute olist null
    Dec 28 13:25:48.209: IP(0): MAC sa=DLCI 101 (Serial0/0/1:0.1)
    Dec 28 13:25:48.209: IP(0): IP tos=0xB8, len=60, id=0, ttl=125, prot=17
    Dec 28 13:25:48.209: IP(0): s=177.1.10.20 (Serial0/0/1:0.1) d=239.1.1.7 id=0, ttl=125, prot=17, len=64(60), mroute olist null
    VORack06R2#

    --

    Best regards,

    SB.

  • What's your max hops set to?

  • also are you hearing dead silience or do you at least get the tone-on-hold?

  • Hello Aquabrown,





    Thank you for your answer.


    I set the TTL to the maximum (that is 127 in CUCM, that's why it becomes 126 at HQ and 125 at BR1 - see previous post). I can't hear anything.





    Best regards,

    SB.

  • IPSec (without having a GRE encapsulation inside of it) does not support multicast IP traffic. INE uses EzVPN to connect our remote clients back to our racks - which is IPSec only and itself does not support GRE. Therefore the only way you will be able to test MMoH in this sort of lab environment is if you place a call in from your PSTN phone into a BR1 phone (or HQ phone) and have the BR1 (or HQ) phone place the PSTN phone on hold. What you are really doing here is placing the BR1 gateway on hold, and then the BR1 gw is receiving MMoH and it is converted to speech and sent PCM via the PRI to the PSTN, which is then sent Unicast RTP to the PSTN IP phone at your place of study. This is all verified via the means you already have performed.

     

    HTH!

  • Hi Mark,

    Thank you for your answer. I will follow your instructions next time I study.

    Best regards,

    SB.

  • Hi Mark,


    According to your answer I wanted to check this and tried to hear multicast MoH music from PSTN as you explained (that is by placing a call between PSTN phone and HQ/BR1 phone, and placing the PSTN phone on hold from HQ/BR1 phone). I couldn't ;-! So I tried to hear it using unicast MOH : no more success.
    How can I troubleshoot my issue for both multicast and unicast MoH ?

    What is funny is that I could hear unicast MoH between HQ an BR1 phones while in AAR conditions, that is using PSTN router... any explanation ?


    Thank you for your help,

    Best regards,

    SB.

  • Hi Mark,



    Any help possible for my case ? Thanks !



    Best
    regards,

    SB.

  • Hi INE experts,

    It would be very nice to help me troubleshooting my case I have for all other labs with MoH...



    Best regards,

    SB.

  • Hey SB,

     

    A change was recently made on the PSTN router base config.

    Can you try again with the MMoH by calling from PSTN Phone into a BR1 Phone, and pushing Hold on the BR1 Phone (to put the PSTN caller on hold) and then send us the output of BR1 R2 IOS show cmd "sh ip mroute"?

     

    Cheers,

    Mark Snow

  • Hello Mark,


    Thank you for your reply. I will try again next sunday and the results and output will be posted here.


    Best regards,

    SB.

  • Hi Mark,


    I did as you wrote : call from PSTN to BR1 Phone, push "Hold" on the BR1 Phone (CIPC softphone).
    Please find below the outputs for HQ router and BR1 router.
    I did a "debug ip mpacket detail" and "sh ip mroute" on both routers.

    At the bottom, I show the output of the "show perf query class "Cisco MOH Device"" command on
    the Subscriber, which shows that MoH server MOH_3 (Subscriber MOH server) is currenly in use.


    As usual :
    - I can't here any MoH music at PSTN, when I use multicast MoH ;
    - but everything is working well when I use unicast MoH...


    Best regards,
    SB.


    --------------------------------------------------------------------------------


    VORack02R1#sh ip mroute
    IP Multicast Routing Table
    Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
    L - Local, P - Pruned, R - RP-bit set, F - Register flag,
    T - SPT-bit set, J - Join SPT, M - MSDP created entry,
    X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
    U - URD, I - Received Source Specific Host Report,
    Z - Multicast Tunnel, z - MDT-data group sender,
    Y - Joined MDT-data group, y - Sending to MDT-data group,
    V - RD & Vector, v - Vector
    Outgoing interface flags: H - Hardware switched, A - Assert winner
    Timers: Uptime/Expires
    Interface state: Interface, Next-Hop or VCD, State/Mode

    (*, 239.1.1.1), 03:41:36/stopped, RP 0.0.0.0, flags: D
    Incoming interface: Null, RPF nbr 0.0.0.0
    Outgoing interface list:
    Serial0/0/1:0.1, Forward/Dense, 03:40:28/00:00:00

    (177.1.10.10, 239.1.1.1), 00:02:23/00:00:36, flags: PT
    Incoming interface: FastEthernet0/0.10, RPF nbr 0.0.0.0
    Outgoing interface list:
    Serial0/0/1:0.1, Prune/Dense, 00:02:20/00:00:41

    (*, 239.1.1.3), 03:01:07/stopped, RP 0.0.0.0, flags: D
    Incoming interface: Null, RPF nbr 0.0.0.0
    Outgoing interface list:
    Serial0/0/1:0.1, Forward/Dense, 03:01:07/00:00:00

    (177.1.10.10, 239.1.1.3), 00:02:24/00:00:35, flags: PT
    Incoming interface: FastEthernet0/0.10, RPF nbr 0.0.0.0
    Outgoing interface list:
    Serial0/0/1:0.1, Prune/Dense, 00:02:20/00:00:41

    (*, 239.1.1.5), 03:00:38/stopped, RP 0.0.0.0, flags: D
    Incoming interface: Null, RPF nbr 0.0.0.0
    Outgoing interface list:
    Serial0/0/1:0.1, Forward/Dense, 03:00:38/00:00:00

    (177.1.10.20, 239.1.1.5), 00:02:04/00:00:55, flags: PT
    Incoming interface: FastEthernet0/0.10, RPF nbr 0.0.0.0
    Outgoing interface list:
    Serial0/0/1:0.1, Prune/Dense, 00:01:58/00:01:11

    (*, 239.1.1.7), 03:00:38/stopped, RP 0.0.0.0, flags: D
    Incoming interface: Null, RPF nbr 0.0.0.0
    Outgoing interface list:
    Serial0/0/1:0.1, Forward/Dense, 03:00:38/00:00:00

    (177.1.254.2, 239.1.1.7), 00:01:01/00:01:57, flags: PT
    Incoming interface: Serial0/0/1:0.1, RPF nbr 177.0.101.2
    Outgoing interface list: Null

    (177.1.10.20, 239.1.1.7), 00:02:05/00:00:54, flags: PT
    Incoming interface: FastEthernet0/0.10, RPF nbr 0.0.0.0
    Outgoing interface list:
    Serial0/0/1:0.1, Prune/Dense, 00:01:59/00:01:09

    (*, 224.0.1.40), 03:41:47/00:02:12, RP 0.0.0.0, flags: DCL
    Incoming interface: Null, RPF nbr 0.0.0.0
    Outgoing interface list:
    Serial0/0/1:0.1, Forward/Dense, 03:40:30/00:00:00
    FastEthernet0/0.11, Forward/Dense, 03:41:47/00:00:00

    (*, 224.0.1.41), 03:41:46/00:02:19, RP 0.0.0.0, flags: DCL
    Incoming interface: Null, RPF nbr 0.0.0.0
    Outgoing interface list:
    FastEthernet0/0.10, Forward/Dense, 03:41:26/00:00:00
    Serial0/0/1:0.1, Forward/Dense, 03:41:37/00:00:00
    FastEthernet0/0.11, Forward/Dense, 03:41:46/00:00:00

    VORack02R1#
    Mar 28 14:05:57.887: IP(0): MAC sa=000c.29b7.424c (FastEthernet0/0.10), IP last-hop=177.1.10.10
    Mar 28 14:05:57.887: IP(0): IP tos=0xB8, len=60, id=0, ttl=126, prot=17
    Mar 28 14:05:57.891: IP(0): s=177.1.10.10 (FastEthernet0/0.10) d=239.1.1.3 (Serial0/0/1:0.1) id=0, ttl=126, prot=17, len=60(60), mforward
    Mar 28 14:05:57.891: IP(0): MAC sa=000c.29b7.424c (FastEthernet0/0.10), IP last-hop=177.1.10.10
    Mar 28 14:05:57.891: IP(0): IP tos=0xB8, len=200, id=0, ttl=126, prot=17
    Mar 28 14:05:57.891: IP(0): s=177.1.10.10 (FastEthernet0/0.10) d=239.1.1.1 (Serial0/0/1:0.1) id=0, ttl=126, prot=17, len=200(200), mforward
    VORack02R1#
    Mar 28 14:06:18.391: IP(0): MAC sa=000c.295f.9a9f (FastEthernet0/0.10), IP last-hop=177.1.10.20
    Mar 28 14:06:18.391: IP(0): IP tos=0xB8, len=60, id=0, ttl=126, prot=17
    Mar 28 14:06:18.391: IP(0): s=177.1.10.20 (FastEthernet0/0.10) d=239.1.1.7 (Serial0/0/1:0.1) id=0, ttl=126, prot=17, len=60(60), mforward
    Mar 28 14:06:18.395: IP(0): MAC sa=000c.295f.9a9f (FastEthernet0/0.10), IP last-hop=177.1.10.20
    Mar 28 14:06:18.395: IP(0): IP tos=0xB8, len=200, id=0, ttl=126, prot=17
    Mar 28 14:06:18.395: IP(0): s=177.1.10.20 (FastEthernet0/0.10) d=239.1.1.5 (Serial0/0/1:0.1) id=0, ttl=126, prot=17, len=200(200), mforward
    VORack02R1#


    --------------------------------------------------------------------------------


    VORack02R2#sh ip mroute
    IP Multicast Routing Table
    Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
    L - Local, P - Pruned, R - RP-bit set, F - Register flag,
    T - SPT-bit set, J - Join SPT, M - MSDP created entry,
    X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
    U - URD, I - Received Source Specific Host Report,
    Z - Multicast Tunnel, z - MDT-data group sender,
    Y - Joined MDT-data group, y - Sending to MDT-data group,
    V - RD & Vector, v - Vector
    Outgoing interface flags: H - Hardware switched, A - Assert winner
    Timers: Uptime/Expires
    Interface state: Interface, Next-Hop or VCD, State/Mode

    (*, 239.1.1.1), 00:27:52/stopped, RP 0.0.0.0, flags: D
    Incoming interface: Null, RPF nbr 0.0.0.0
    Outgoing interface list:
    Serial0/0/1:0.1, Forward/Dense, 00:27:52/00:00:00

    (177.1.10.10, 239.1.1.1), 00:00:51/00:02:08, flags: PT
    Incoming interface: Serial0/0/1:0.1, RPF nbr 177.0.101.1
    Outgoing interface list: Null

    (*, 239.1.1.3), 00:27:53/stopped, RP 0.0.0.0, flags: D
    Incoming interface: Null, RPF nbr 0.0.0.0
    Outgoing interface list:
    Serial0/0/1:0.1, Forward/Dense, 00:27:53/00:00:00

    (177.1.10.10, 239.1.1.3), 00:00:53/00:02:06, flags: PT
    Incoming interface: Serial0/0/1:0.1, RPF nbr 177.0.101.1
    Outgoing interface list: Null

    (*, 239.1.1.5), 00:27:31/stopped, RP 0.0.0.0, flags: D
    Incoming interface: Null, RPF nbr 0.0.0.0
    Outgoing interface list:
    Serial0/0/1:0.1, Forward/Dense, 00:27:31/00:00:00

    (177.1.10.20, 239.1.1.5), 00:00:31/00:02:28, flags: PT
    Incoming interface: Serial0/0/1:0.1, RPF nbr 177.0.101.1
    Outgoing interface list: Null

    (*, 239.1.1.7), 00:46:31/stopped, RP 0.0.0.0, flags: D
    Incoming interface: Null, RPF nbr 0.0.0.0
    Outgoing interface list:
    Serial0/0/1:0.1, Forward/Dense, 00:46:31/00:00:00

    (177.1.10.20, 239.1.1.7), 00:00:31/00:02:28, flags: PT
    Incoming interface: Serial0/0/1:0.1, RPF nbr 177.0.101.1
    Outgoing interface list: Null

    (177.1.254.2, 239.1.1.7), 00:02:35/00:02:54, flags: PT
    Incoming interface: Loopback0, RPF nbr 0.0.0.0
    Outgoing interface list:
    Serial0/0/1:0.1, Prune/Dense, 00:02:34/00:00:30

    (*, 224.0.1.40), 03:39:26/00:02:24, RP 0.0.0.0, flags: DCL
    Incoming interface: Null, RPF nbr 0.0.0.0
    Outgoing interface list:
    Serial0/0/1:0.1, Forward/Dense, 03:39:03/00:00:00
    Vlan11, Forward/Dense, 03:39:26/00:00:00

    VORack02R2#
    VORack02R2#
    Mar 28 14:03:57.239: IP(0): MAC sa=**Unknown SNPA type** (Loopback0)
    Mar 28 14:03:57.239: IP(0): IP tos=0x68, len=116, id=3, ttl=254, prot=17
    Mar 28 14:03:57.239: IP(0): s=177.1.254.2 (Loopback0) d=239.1.1.7 id=3, ttl=254, prot=17, len=116(116), mroute olist null
    VORack02R2#
    Mar 28 14:04:01.911: IP(0): MAC sa=**Unknown SNPA type** (Loopback0)
    Mar 28 14:04:01.911: IP(0): IP tos=0x68, len=116, id=4, ttl=254, prot=17
    Mar 28 14:04:01.911: IP(0): s=177.1.254.2 (Loopback0) d=239.1.1.7 id=4, ttl=254, prot=17, len=116(116), mroute olist null
    VORack02R2#
    Mar 28 14:04:08.139: IP(0): MAC sa=**Unknown SNPA type** (Loopback0)
    Mar 28 14:04:08.139: IP(0): IP tos=0x68, len=116, id=5, ttl=254, prot=17
    Mar 28 14:04:08.139: IP(0): s=177.1.254.2 (Loopback0) d=239.1.1.7 id=5, ttl=254, prot=17, len=116(116), mroute olist null
    VORack02R2#
    Mar 28 14:04:11.471: IP(0): MAC sa=**Unknown SNPA type** (Loopback0)
    Mar 28 14:04:11.471: IP(0): IP tos=0x68, len=116, id=6, ttl=254, prot=17
    Mar 28 14:04:11.471: IP(0): s=177.1.254.2 (Loopback0) d=239.1.1.7 id=6, ttl=254, prot=17, len=116(116), mroute olist null
    VORack02R2#
    Mar 28 14:04:15.283: IP(0): MAC sa=**Unknown SNPA type** (Loopback0)
    Mar 28 14:04:15.283: IP(0): IP tos=0x68, len=116, id=7, ttl=254, prot=17
    Mar 28 14:04:15.283: IP(0): s=177.1.254.2 (Loopback0) d=239.1.1.7 id=7, ttl=254, prot=17, len=116(116), mroute olist null
    VORack02R2#
    Mar 28 14:04:21.778: IP(0): MAC sa=**Unknown SNPA type** (Loopback0)
    Mar 28 14:04:21.778: IP(0): IP tos=0x68, len=116, id=8, ttl=254, prot=17
    Mar 28 14:04:21.778: IP(0): s=177.1.254.2 (Loopback0) d=239.1.1.7 id=8, ttl=254, prot=17, len=116(116), mroute olist null
    VORack02R2#
    Mar 28 14:04:26.550: IP(0): MAC sa=**Unknown SNPA type** (Loopback0)
    Mar 28 14:04:26.550: IP(0): IP tos=0x68, len=116, id=9, ttl=254, prot=17
    Mar 28 14:04:26.550: IP(0): s=177.1.254.2 (Loopback0) d=239.1.1.7 id=9, ttl=254, prot=17, len=116(116), mroute olist null
    VORack02R2#
    Mar 28 14:04:29.510: IP(0): MAC sa=**Unknown SNPA type** (Loopback0)
    Mar 28 14:04:29.510: IP(0): IP tos=0x68, len=116, id=10, ttl=254, prot=17
    Mar 28 14:04:29.510: IP(0): s=177.1.254.2 (Loopback0) d=239.1.1.7 id=10, ttl=254, prot=17, len=116(116), mroute olist null
    VORack02R2#
    Mar 28 14:04:33.126: IP(0): MAC sa=**Unknown SNPA type** (Loopback0)
    Mar 28 14:04:33.126: IP(0): IP tos=0x68, len=116, id=11, ttl=254, prot=17
    Mar 28 14:04:33.130: IP(0): s=177.1.254.2 (Loopback0) d=239.1.1.7 id=11, ttl=254, prot=17, len=116(116), mroute olist null
    VORack02R2#
    Mar 28 14:04:36.650: IP(0): MAC sa=**Unknown SNPA type** (Loopback0)
    Mar 28 14:04:36.650: IP(0): IP tos=0x68, len=116, id=12, ttl=254, prot=17
    Mar 28 14:04:36.650: IP(0): s=177.1.254.2 (Loopback0) d=239.1.1.7 id=12, ttl=254, prot=17, len=116(116), mroute olist null
    VORack02R2#
    Mar 28 14:04:39.206: IP(0): MAC sa=**Unknown SNPA type** (Loopback0)
    Mar 28 14:04:39.210: IP(0): IP tos=0x68, len=116, id=13, ttl=254, prot=17
    Mar 28 14:04:39.210: IP(0): s=177.1.254.2 (Loopback0) d=239.1.1.7 id=13, ttl=254, prot=17, len=116(116), mroute olist null
    VORack02R2#
    Mar 28 14:04:42.470: IP(0): MAC sa=**Unknown SNPA type** (Loopback0)
    Mar 28 14:04:42.470: IP(0): IP tos=0x68, len=116, id=14, ttl=254, prot=17
    Mar 28 14:04:42.470: IP(0): s=177.1.254.2 (Loopback0) d=239.1.1.7 id=14, ttl=254, prot=17, len=116(116), mroute olist null
    VORack02R2#
    Mar 28 14:04:46.410: IP(0): MAC sa=**Unknown SNPA type** (Loopback0)
    Mar 28 14:04:46.410: IP(0): IP tos=0x68, len=116, id=15, ttl=254, prot=17
    Mar 28 14:04:46.410: IP(0): s=177.1.254.2 (Loopback0) d=239.1.1.7 id=15, ttl=254, prot=17, len=116(116), mroute olist null
    VORack02R2#


    --------------------------------------------------------------------------------


    admin:show perf query class "Cisco MOH Device"
    ==>query class :

    - Perf class (Cisco MOH Device) has instances and values:
    MOH_2 -> MOHHighestActiveResources = 0
    MOH_2 -> MOHMulticastResourceActive = 0
    MOH_2 -> MOHMulticastResourceAvailable = 250000
    MOH_2 -> MOHOutOfResources = 0
    MOH_2 -> MOHTotalMulticastResources = 250000
    MOH_2 -> MOHTotalUnicastResources = 250
    MOH_2 -> MOHUnicastResourceActive = 0
    MOH_2 -> MOHUnicastResourceAvailable = 250
    MOH_3 -> MOHHighestActiveResources = 1
    MOH_3 -> MOHMulticastResourceActive = 1
    MOH_3 -> MOHMulticastResourceAvailable = 249999
    MOH_3 -> MOHOutOfResources = 0
    MOH_3 -> MOHTotalMulticastResources = 250000
    MOH_3 -> MOHTotalUnicastResources = 250
    MOH_3 -> MOHUnicastResourceActive = 0
    MOH_3 -> MOHUnicastResourceAvailable = 250


    admin:


    --------------------------------------------------------------------------------
  • Hi SB,

     

    Can you send us the R1 and R2 (complete) configs, and also confirm what "Base IP Address" you are using for both CUCM Pub MoH and CUCM Sub MoH servers?

     

    Cheers,

  • Hi Mark,






    No more success today for MoH multicasting !!! Once gain, everything is fine with Unicast but I can't hear the music from PSTN phone when I use Multicast.



    I proceeded again as you wrote me : I placed call from PSTN to BR1 and I pushed BR1 "On hold" button in order to receive listen MoH music at PSTN phone.





    Concerning "Base IP address" :

    - Publisher (MOH_2) uses 239.1.1.1 (127 hops max) ;

    - Subscriber (MOH_3) uses 239.1.1.2 (127 hops max) .





    Please find below :

    - my R1 and R2 complete configs,

    - "sh ip mroute" outputs for R1 and R2,

    - "show perf query class "Cisco MOH Device" " output on Subscriber CLI .




    PS : Please remember I use CICP phones running in virtual machines and I
    connect to the rack through IPSec (see earlier posts).






    Best regards,
    SB.







    -------------------------------------------------------------------





    VORack01R1#sh runn
    Building configuration...

    Current configuration : 4205 bytes
    !
    ! Last configuration change at 02:14:15 PST Sun Apr 11 2010
    ! NVRAM config last updated at 02:14:16 PST Sun Apr 11 2010
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname VORack01R1
    !
    boot-start-marker
    boot-end-marker
    !
    logging message-counter syslog
    enable secret 5 $1$d96D$8trTHcL10zc12/p.rh7BM.
    !
    no aaa new-model
    clock timezone PST -8
    network-clock-participate wic 0
    no network-clock-participate wic 3
    !
    dot11 syslog
    ip source-route
    !
    !
    ip cef
    ip dhcp excluded-address 177.1.11.1 177.1.11.39
    ip dhcp excluded-address 177.1.11.91 177.1.11.254
    !
    ip dhcp pool PHONES
       network 177.1.11.0 255.255.255.0
       option 150 ip 177.1.10.10
       default-router 177.1.11.1
       lease 0 2
    !
    !
    no ip domain lookup
    ip multicast-routing
    no ipv6 cef
    !
    multilink bundle-name authenticated
    !
    !
    !
    !
    isdn switch-type primary-ni
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    voice-card 0
     dsp services dspfarm
    !
    !
    !
    !
    !
    archive
     log config
      hidekeys
    !
    !
    !
    !
    !
    controller T1 0/0/0
     cablelength short 133
     pri-group timeslots 1-3,24 service mgcp
    !
    controller T1 0/0/1
     cablelength short 133
     channel-group 0 timeslots 1-24
    !
    controller T1 0/3/0
    !
    ip tcp synwait-time 5
    !
    !
    !
    !
    interface Loopback0
     ip address 177.1.254.1 255.255.255.255
    !
    interface FastEthernet0/0
     description == To SW1
     no ip address
     duplex auto
     speed auto
    !
    interface FastEthernet0/0.10
     description == Server VLAN
     encapsulation dot1Q 10
     ip address 177.1.10.1 255.255.255.0
     ip pim dense-mode
    !
    interface FastEthernet0/0.11
     description == Voice VLAN
     encapsulation dot1Q 11
     ip address 177.1.11.1 255.255.255.0
     ip pim dense-mode
    !
    interface FastEthernet0/0.12
     description == Data VLAN
     encapsulation dot1Q 12
     ip address 177.1.12.1 255.255.255.0
    !
    interface FastEthernet0/1
     description === To PSTN
     ip address 177.1.19.254 255.255.255.0
     duplex auto
     speed auto
    !
    interface Serial0/0/0:23
     no ip address
     encapsulation hdlc
     isdn switch-type primary-ni
     isdn incoming-voice voice
     isdn bind-l3 ccm-manager
     no cdp enable
    !
    interface Serial0/0/1:0
     description == Frame Relay
     no ip address
     encapsulation frame-relay
    !
    interface Serial0/0/1:0.1 point-to-point
     description == FR To BR1
     ip address 177.0.101.1 255.255.255.0
     ip pim dense-mode
     snmp trap link-status
     frame-relay interface-dlci 101
    !
    interface Serial0/0/1:0.2 point-to-point
     description == FR To BR2
     ip address 177.0.201.1 255.255.255.0
     ip pim dense-mode
     snmp trap link-status
     frame-relay interface-dlci 201
    !
    router ospf 1
     log-adjacency-changes
     network 0.0.0.0 255.255.255.255 area 0
    !
    ip forward-protocol nd
    ip http server
    no ip http secure-server
    !
    !
    !
    nls resp-timeout 1
    cpd cr-id 1
    cdp timer 6
    !
    !
    !
    !
    !
    !
    !
    control-plane
    !
    !
    !
    voice-port 0/0/0:23
    !
    ccm-manager switchback immediate
    ccm-manager redundant-host 177.1.10.10
    ccm-manager mgcp
    ccm-manager fax protocol cisco
    !
    mgcp
    mgcp call-agent 177.1.10.20 service-type mgcp version 0.1
    mgcp dtmf-relay voip codec all mode out-of-band
    mgcp fax t38 ecm
    mgcp bind control source-interface Loopback0
    mgcp bind media source-interface Loopback0
    !
    mgcp profile default
    !
    sccp local FastEthernet0/0.11
    sccp ccm 177.1.10.20 identifier 2 version 7.0
    sccp ccm 177.1.10.10 identifier 1 version 7.0
    sccp ip precedence 3
    sccp
    !
    sccp ccm group 1
     associate ccm 2 priority 1
     associate ccm 1 priority 2
     associate profile 1 register CFB_R1
    !
    dspfarm profile 1 conference
     codec g711ulaw
     codec g711alaw
     codec g729ar8
     codec g729abr8
     codec g729r8
     codec g729br8
     maximum sessions 2
     associate application SCCP
    !
    !
    !
    !
    !
    gatekeeper
     zone local ZONE_01 cisco.com 177.1.254.1
     zone prefix ZONE_01 1* gw-priority 9 HQ_GK_TRUNK_2
     zone prefix ZONE_01 1* gw-priority 8 HQ_GK_TRUNK_1
     zone prefix ZONE_01 1* gw-priority 0 BR2_GW
     zone prefix ZONE_01 44* gw-priority 9 BR2_GW
     zone prefix ZONE_01 44* gw-priority 0 HQ_GK_TRUNK_2 HQ_GK_TRUNK_1
     gw-type-prefix 1#*
      arq reject-unknown-prefix
     no shutdown
    !
    !
    line con 0
     exec-timeout 0 0
     privilege level 15
     logging synchronous level 0 limit 20
    line aux 0
    line vty 0 4
     password cisco
     login
    !
    scheduler allocate 20000 1000
    ntp authentication-key 1 md5 032772382520 7
    ntp source Loopback0
    ntp master 2
    end

    VORack01R1#





    -------------------------------------------------------------------





    VORack01R2#sh runn
    Building configuration...

    Current configuration : 5138 bytes
    !
    ! Last configuration change at 04:13:21 CST Sun Apr 11 2010
    ! NVRAM config last updated at 04:14:20 CST Sun Apr 11 2010
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname VORack01R2
    !
    boot-start-marker
    boot-end-marker
    !
    logging message-counter syslog
    enable secret 5 $1$frs.$PC9fag6cKuUdzoNMnCGv0/
    !
    no aaa new-model
    clock timezone CST -6
    network-clock-participate wic 0
    !
    dot11 syslog
    ip source-route
    !
    !
    ip cef
    ip dhcp excluded-address 177.2.11.1 177.2.11.99
    ip dhcp excluded-address 177.2.11.110 177.2.11.254
    !
    ip dhcp pool PHONES
       network 177.2.11.0 255.255.255.0
       option 150 ip 177.1.10.10
       default-router 177.2.11.1
    !
    !
    no ip domain lookup
    ip multicast-routing
    no ipv6 cef
    !
    multilink bundle-name authenticated
    !
    !
    !
    !
    isdn switch-type primary-ni
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    voice translation-rule 1
     rule 1 /312301(2...)/ /1/
    !
    !
    voice translation-profile DID
     translate called 1
    !
    !
    voice-card 0
     dsp services dspfarm
    !
    !
    application
     global
      service alternate default
     !
    !
    !
    !
    !
    !
    archive
     log config
      hidekeys
    !
    !
    !
    !
    !
    controller T1 0/0/0
     cablelength short 133
     pri-group timeslots 1-3,24
    !
    controller T1 0/0/1
     cablelength short 133
     channel-group 0 timeslots 1-24
    !
    ip tcp synwait-time 5
    !
    !
    !
    !
    interface Loopback0
     ip address 177.1.254.2 255.255.255.255
     ip pim dense-mode
     h323-gateway voip interface
     h323-gateway voip bind srcaddr 177.1.254.2
    !
    interface FastEthernet0/0
     no ip address
     shutdown
     duplex auto
     speed auto
    !
    interface FastEthernet0/1
     no ip address
     shutdown
     duplex auto
     speed auto
    !
    interface FastEthernet0/1/0
     description == BR1 IP Phone
     switchport trunk native vlan 12
     switchport trunk allowed vlan 1,11,12,1002-1005
     switchport mode trunk
     switchport voice vlan 11
    !
    interface FastEthernet0/1/1
     switchport trunk native vlan 12
     switchport trunk allowed vlan 1,11,12,1002-1005
     switchport mode trunk
     switchport voice vlan 11
     shutdown
    !
    interface FastEthernet0/1/2
    !
    interface FastEthernet0/1/3
     description == unknown
    !
    interface Serial0/0/0:23
     no ip address
     encapsulation hdlc
     isdn switch-type primary-ni
     isdn incoming-voice voice
     isdn outgoing display-ie
     no cdp enable
    !
    interface Serial0/0/1:0
     description == Frame Relay
     no ip address
     encapsulation frame-relay
    !
    interface Serial0/0/1:0.1 point-to-point
     description == FR To HQ
     ip address 177.0.101.2 255.255.255.0
     ip pim dense-mode
     snmp trap link-status
     frame-relay interface-dlci 101
    !
    interface Vlan1
     no ip address
    !
    interface Vlan11
     description == Voice VLAN
     ip address 177.2.11.1 255.255.255.0
     ip pim dense-mode
    !
    interface Vlan12
     description == Data VLAN
     ip address 177.2.12.1 255.255.255.0
    !
    router ospf 1
     log-adjacency-changes
     network 0.0.0.0 255.255.255.255 area 0
    !
    ip forward-protocol nd
    no ip http server
    no ip http secure-server
    !
    !
    !
    cdp timer 6
    !
    !
    !
    !
    !
    !
    !
    control-plane
    !
    !
    !
    voice-port 0/0/0:23
    !
    ccm-manager fallback-mgcp
    ccm-manager fax protocol cisco
    !
    mgcp fax t38 ecm
    !
    sccp local Vlan11
    sccp ccm 177.1.10.10 identifier 1 version 7.0
    sccp ccm 177.1.10.20 identifier 2 version 7.0
    sccp ip precedence 3
    sccp
    !
    sccp ccm group 1
     associate ccm 2 priority 1
     associate ccm 1 priority 2
     associate profile 1 register XCR_R2
    !
    dspfarm profile 1 transcode
     codec g711ulaw
     codec g711alaw
     codec g729ar8
     codec g729abr8
     maximum sessions 2
     associate application SCCP
    !
    !
    dial-peer voice 1 pots
     incoming called-number .
     direct-inward-dial
    !
    dial-peer voice 3120 voip
     destination-pattern 312301....$
     session target ipv4:177.1.10.20
    !
    dial-peer voice 3121 voip
     destination-pattern 312301....$
     session target ipv4:177.1.10.10
    !
    dial-peer voice 911 pots
     description == 911 ==
     destination-pattern 911
     port 0/0/0:23
     forward-digits 3
    !
    dial-peer voice 9911 pots
     description == 9911 ==
     destination-pattern 9911
     port 0/0/0:23
     forward-digits 3
    !
    dial-peer voice 900 pots
     description == Local
     destination-pattern 9[2-9]......$
     port 0/0/0:23
    !
    dial-peer voice 901 pots
     description == LD
     destination-pattern 91[2-9]..[2-9]......$
     port 0/0/0:23
     prefix 1
    !
    dial-peer voice 902 pots
     description == International ==
     destination-pattern 9011T
     port 0/0/0:23
     prefix 011
    !
    dial-peer voice 1000 pots
     description == SRST HQ Abreviated ==
     destination-pattern 1...$
     port 0/0/0:23
     prefix 17752011
    !
    dial-peer voice 3000 pots
     description == SRST BR2 Abreviated ==
     destination-pattern 3...$
     port 0/0/0:23
     prefix 011442321313
    !
    !
    !
    !
    gatekeeper
     shutdown
    !
    !
    call-manager-fallback
     secondary-dialtone 9
     max-conferences 8 gain -6
     transfer-system full-consult
     ip source-address 177.2.11.1 port 2000
     max-ephones 2
     max-dn 4
     system message primary !!! SRST at BR1 !!!
     transfer-pattern .T
     moh music-on-hold.au
     multicast moh 239.1.1.1 port 16384 route 177.3.11.1 177.1.254.2
    !
    !
    line con 0
     exec-timeout 0 0
     privilege level 15
     logging synchronous level 0 limit 20
    line aux 0
    line vty 0 4
     password cisco
     login
    !
    scheduler allocate 20000 1000
    ntp authentication-key 1 md5 112A3036343D 7
    ntp authenticate
    ntp trusted-key 1
    ntp source Loopback0
    ntp server 177.1.254.1 key 1
    end

    VORack01R2#




    -------------------------------------------------------------------





    VORack01R1#sh ip mroute
    IP Multicast Routing Table
    Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
           L - Local, P - Pruned, R - RP-bit set, F - Register flag,
           T - SPT-bit set, J - Join SPT, M - MSDP created entry,
           X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
           U - URD, I - Received Source Specific Host Report,
           Z - Multicast Tunnel, z - MDT-data group sender,
           Y - Joined MDT-data group, y - Sending to MDT-data group,
           V - RD & Vector, v - Vector
    Outgoing interface flags: H - Hardware switched, A - Assert winner
     Timers: Uptime/Expires
     Interface state: Interface, Next-Hop or VCD, State/Mode

    (*, 239.1.1.1), 00:48:55/stopped, RP 0.0.0.0, flags: D
      Incoming interface: Null, RPF nbr 0.0.0.0
      Outgoing interface list:
        Serial0/0/1:0.2, Forward/Dense, 00:46:00/00:00:00
        Serial0/0/1:0.1, Forward/Dense, 00:47:30/00:00:00

    (177.1.10.10, 239.1.1.1), 00:01:43/00:01:16, flags: PT
      Incoming interface: FastEthernet0/0.10, RPF nbr 0.0.0.0
      Outgoing interface list:
        Serial0/0/1:0.1, Prune/Dense, 00:01:36/00:01:29
        Serial0/0/1:0.2, Prune/Dense, 00:01:40/00:01:28

    (177.2.11.1, 239.1.1.1), 00:01:58/00:01:01, flags: PT
      Incoming interface: Serial0/0/1:0.1, RPF nbr 177.0.101.2
      Outgoing interface list:
        Serial0/0/1:0.2, Prune/Dense, 00:01:58/00:01:08

    (*, 239.1.1.5), 00:36:02/stopped, RP 0.0.0.0, flags: D
      Incoming interface: Null, RPF nbr 0.0.0.0
      Outgoing interface list:
        Serial0/0/1:0.2, Forward/Dense, 00:36:02/00:00:00
        Serial0/0/1:0.1, Forward/Dense, 00:36:02/00:00:00

    (177.1.254.2, 239.1.1.5), 00:00:45/00:02:14, flags: PT
      Incoming interface: Serial0/0/1:0.1, RPF nbr 177.0.101.2
      Outgoing interface list:
        Serial0/0/1:0.2, Prune/Dense, 00:00:45/00:02:18

    (177.1.10.20, 239.1.1.5), 00:01:15/00:01:44, flags: PT
      Incoming interface: FastEthernet0/0.10, RPF nbr 0.0.0.0
      Outgoing interface list:
        Serial0/0/1:0.1, Prune/Dense, 00:01:12/00:01:49
        Serial0/0/1:0.2, Prune/Dense, 00:01:16/00:01:47

    (*, 224.0.1.40), 00:48:57/00:02:28, RP 0.0.0.0, flags: DCL
      Incoming interface: Null, RPF nbr 0.0.0.0
      Outgoing interface list:
        Serial0/0/1:0.2, Forward/Dense, 00:46:03/00:00:00
        Serial0/0/1:0.1, Forward/Dense, 00:47:32/00:00:00
        FastEthernet0/0.10, Forward/Dense, 00:48:57/00:00:00

    (*, 224.0.1.41), 00:48:56/00:02:29, RP 0.0.0.0, flags: DCL
      Incoming interface: Null, RPF nbr 0.0.0.0
      Outgoing interface list:
        Serial0/0/1:0.2, Forward/Dense, 00:48:03/00:00:00
        Serial0/0/1:0.1, Forward/Dense, 00:48:10/00:00:00
        FastEthernet0/0.11, Forward/Dense, 00:48:50/00:00:00
        FastEthernet0/0.10, Forward/Dense, 00:48:56/00:00:00

    VORack01R1#




    -------------------------------------------------------------------







    VORack01R2#sh ip mroute
    IP Multicast Routing Table
    Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
           L - Local, P - Pruned, R - RP-bit set, F - Register flag,
           T - SPT-bit set, J - Join SPT, M - MSDP created entry,
           X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
           U - URD, I - Received Source Specific Host Report,
           Z - Multicast Tunnel, z - MDT-data group sender,
           Y - Joined MDT-data group, y - Sending to MDT-data group,
           V - RD & Vector, v - Vector
    Outgoing interface flags: H - Hardware switched, A - Assert winner
     Timers: Uptime/Expires
     Interface state: Interface, Next-Hop or VCD, State/Mode

    (*, 239.1.1.1), 00:18:20/stopped, RP 0.0.0.0, flags: D
      Incoming interface: Null, RPF nbr 0.0.0.0
      Outgoing interface list:
        Serial0/0/1:0.1, Forward/Dense, 00:18:20/00:00:00

    (177.1.10.10, 239.1.1.1), 00:00:15/00:02:44, flags: PT
      Incoming interface: Serial0/0/1:0.1, RPF nbr 177.0.101.1
      Outgoing interface list: Null

    (*, 239.1.1.5), 00:17:57/stopped, RP 0.0.0.0, flags: D
      Incoming interface: Null, RPF nbr 0.0.0.0
      Outgoing interface list:
        Serial0/0/1:0.1, Forward/Dense, 00:17:57/00:00:00

    (177.1.254.2, 239.1.1.5), 00:02:22/00:02:58, flags: PT
      Incoming interface: Loopback0, RPF nbr 0.0.0.0
      Outgoing interface list:
        Serial0/0/1:0.1, Prune/Dense, 00:02:15/00:00:44

    (177.1.10.20, 239.1.1.5), 00:02:52/00:00:07, flags: PT
      Incoming interface: Serial0/0/1:0.1, RPF nbr 177.0.101.1
      Outgoing interface list: Null

    (*, 224.0.1.40), 00:49:11/stopped, RP 0.0.0.0, flags: DCL
      Incoming interface: Null, RPF nbr 0.0.0.0
      Outgoing interface list:
        Serial0/0/1:0.1, Forward/Dense, 00:49:11/00:00:00

    VORack01R2#






    -------------------------------------------------------------------





    admin:show perf query class "Cisco MOH Device"
    ==>query class :

     - Perf class (Cisco MOH Device) has instances and values:
        MOH_2           -> MOHHighestActiveResources      = 0
        MOH_2           -> MOHMulticastResourceActive     = 0
        MOH_2           -> MOHMulticastResourceAvailable  = 250000
        MOH_2           -> MOHOutOfResources              = 0
        MOH_2           -> MOHTotalMulticastResources     = 250000
        MOH_2           -> MOHTotalUnicastResources       = 250
        MOH_2           -> MOHUnicastResourceActive       = 0
        MOH_2           -> MOHUnicastResourceAvailable    = 250
        MOH_3           -> MOHHighestActiveResources      = 1
        MOH_3           -> MOHMulticastResourceActive     = 1
        MOH_3           -> MOHMulticastResourceAvailable  = 249999
        MOH_3           -> MOHOutOfResources              = 0
        MOH_3           -> MOHTotalMulticastResources     = 250000
        MOH_3           -> MOHTotalUnicastResources       = 250
        MOH_3           -> MOHUnicastResourceActive       = 0
        MOH_3           -> MOHUnicastResourceAvailable    = 250


    admin:

     

     

  • Hi SB,

    Try adding this command:

    no ip igmp snooping

    There has been a long time problem with IGMP Snooping on IOS Routers that also have 4-ESW modules in them. Turn that off and things should begin to work properly as I see the multicast streams in your show commands.

     

    Also I might recommend using a different octet to differentiate between Pub and Sub MMoH Server Base IP Addressing (e.g. Pub 239.1.1.1 and Sub 239.2.1.1).

     

    Cheers,

  • Hi Mark,





    Thank you for your answer (and I did notice your recommandation for using a different octet to differentiate between Pub/Sub MMoH Server
    Base IP Addressing).



    Concerning the "no ip igmp snooping" command, I noticed (too late :) that some lab solution guides give this command for BR1 router, some others not... I will try at next time I study.



    But I have one another question concerning this case : I did try too to hear multicast MoH with PSTN Phone placed on hold by HQ Phone, and I proceeded as you told me -> placing a call between PSTN and HQ phones, pushing "On Hold" button on HQ phone, and trying to listen the music at PSTN phone... I didn't succeed with HQ phone !



    As there isn't any HWIC-4ESW at HQ router, what could explain that the issue is the same with HQ phone/gateway ? Should I issue this "no ip igmp snooping" command at HQ router too, even if it hasn't any HWIC-4ESW module ?







    Best regards,

    SB.

  • SB,

     

    No - the IGMP snooping command wouldn't effect the HQ router. However having ip pim dense-mode on the Loopback interface would effect your ability to hear the MMoH via the PSTN. Put that command on the interface Loopback 0 and try to hear it again!

     

    Cheers,

Sign In or Register to comment.