Task 5.2 AutoRP Listener

Would it be safe to say as a rule of thumb to place the "ip pim autorp listener" command on when you have configured "ip pim sparse-mode" on your interfaces and your using AutoRP vs Using "ip pim sparse-dense-mode" on the interfaces and statically configuring the RP on the routers/switch without using the "ip pim autorp listener?

I guess I'm trying to distinguish when to use this command. Any input would be greatly appreciated.

Comments

  • Ip pim autorp listener command allows you to join to multicast groups 224.0.1.39 and 224.0.1.40 in dense mode ( RP-announce and RP-discovery). If all interfaces are in sparse mode u need somehow to listen for this group. that's why this command is needed to join this groups in dense.
  • I got some chance to lab this part and found I was able to see the groups announced by the RP on the router R4,

    Rack25R4#sh ip pim rp mapp
    PIM Group-to-RP Mappings

    Group(s) 225.0.0.0/8
    RP 150.25.2.2 (?), v2v1
    Info source: 150.25.8.8 (?), elected via Auto-RP
    Uptime: 00:00:48, expires: 00:02:12
    Group(s) 239.0.0.0/8
    RP 150.25.5.5 (?), v2v1
    Info source: 150.25.8.8 (?), elected via Auto-RP
    Uptime: 00:01:00, expires: 00:02:07
    Rack25R4#
    Rack25R4#


    My question is why this happened since I did not add the ip pim autorp command and all the interfaces were configured with ip pim sparse-mode
  • I've noticed the same strange behavior:

     Code:

    Rack1R4#sh ip pim rp map
    PIM Group-to-RP Mappings

    Group(s) 225.0.0.0/8
    RP 150.1.2.2 (?), v2v1
    Info source: [b]141.1.0.8[/b] (?), elected via Auto-RP
    Uptime: 1d00h, expires: 00:02:18
    Group(s) 239.0.0.0/8
    RP 150.1.5.5 (?), v2v1
    Info source: [b]141.1.0.8[/b] (?), elected via Auto-RP
    Uptime: 1d00h, expires: 00:02:17


    where 141.1.0.8 is SW2's IP on ethernet segment between R2 and R5.
  • I have another question:

    why SG says that 'ip pim autorp listner' should be configured on all mcast-aware devices ? for me it works fine - to simply enable it on R2 to provide R3 with RP-to-group mapping, R4 knows via somehow way as I mentioned earlier.
  • I have found the same behaviour, configuring ip pim autorp listener on R2, R5 and SW2 is enough to get full multicast reachability. Anyone know why this is happening, is it a feature of later versions of IOS?
Sign In or Register to comment.