TASK 1.7 Point-to-Point Addressing


1.7    Point-to-Point Addressing


 

Configure R4 and R5’s
Serial interfaces
to use the IP addresses

167.X.45.4/32 and 167.X.45.5/32 respectively.

Ensure that R4 and R5 can ping each other’s
Serial
interfaces.


 


 

The creation of additional
logical interfaces is permitted for this
task. Do not use static routing to accomplish this.

 

FROM DO AND DONTS:

 

Do not change any interface encapsulations unless otherwise specified 

 

 

Solution: 


interface Loopback45

ip
address 167.1.45.4 255.255.255.255

!

Interface
Multilink 1

Ip
unnumbered Loopback45

 

interface Serial0/1/0 encap ppp

ppp multilink

ppp
multilink group
1

encapsulation
ppp

 

why to use ppp and multilink groups??  I let it in hdlc and change the wrong frame-relay config from R5. 

 

Is correct the solution from SG?

 

 

 

Comments

  • hfarias,

    Since the task specifically permits the use of a logical interface, ppp multilink will install the peer neighbor route automatically, facilitating traffic between the /32 ip addresses. Otherwise a static route would be required for traffic over the link where no common subnet encompasses the ip addresses of the end-points.

    Since the task did not specifically permit changing from HDLC to PPP, a question to the proctor would be in order.

    How did you get routing from 167.1.45.4/32 to 167.1.45.5/32 without ppp/peer neighbor route?

    1.7    Point-to-Point Addressing

    Configure R4 and R5’s Serial interfaces to use the IP addresses

    167.X.45.4/32 and 167.X.45.5/32 respectively.

    Ensure that R4 and R5 can ping each other’s Serial interfaces.



     

    The creation of additional logical interfaces is permitted for this task. Do not use static routing to accomplish this.

    FROM DO AND DONTS:

    Do not change any interface encapsulations unless otherwise specified 

     Solution: 

     interface Loopback45

    ip address 167.1.45.4 255.255.255.255

    Interface Multilink 1

    Ip unnumbered Loopback45

     interface Serial0/1/0 encap ppp

    ppp multilink

    ppp multilink group 1

    encapsulation ppp

     why to use ppp and multilink groups??  I let it in hdlc and change the wrong frame-relay config from R5. 

     Is correct the solution from SG?

     

     

  • Hi Darrel,   In my lab, EIGRP did it for me:

    Serial0/2/1:1 is up, line protocol is up
      Hardware is GT96K Serial
      Interface is unnumbered. Using address of Loopback1 (167.1.45.5)
      MTU 1500 bytes, BW 1984 Kbit/sec, DLY 20000 usec,
         reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation HDLC, loopback not set

    Routing entry for 167.1.45.4/32
      Known via "eigrp 10", distance 90, metric 1930240, type internal
      Redistributing via eigrp 10
      Last update from 167.1.45.4 on Serial0/2/1:1, 17:58:34 ago
      Routing Descriptor Blocks:
      * 167.1.45.4, from 167.1.45.4, 17:58:34 ago, via Serial0/2/1:1
          Route metric is 1930240, traffic share count is 1
          Total delay is 25000 microseconds, minimum bandwidth is 1984 Kbit
          Reliability 255/255, minimum MTU 1500 bytes
          Loading 1/255, Hops 1

    interface Loopback1
     ip address 167.1.45.5 255.255.255.255

     

  • hfarias,

    If you get a similar task in the actual Lab Exam, it would be good to clarify whether R4 and R5 should be able to ping each other without having a dynamic routing protocol configured - ppp and the peer neighbor route would enable connectivity before EIGRP is configured.

         167.1.0.0/32 is subnetted, 2 subnets
    C       167.1.45.5 is directly connected, Multilink1
    C       167.1.45.4 is directly connected, Loopback45
    c3640a#p 167.1.45.5

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 167.1.45.5, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 28/30/32 ms
    c3640a#p 167.1.45.4

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 167.1.45.4, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
    c3640a#

  • ok, thanks very much for the help.

     

  • I am still confused why we should use multilink? Isn't using encap ppp enough in order to make the router use peer default route? Please enlighten me.

  • 4rchange1,

    I aggree with you; automatic insertion of the connected neighbor happens right after you configure encapsulation ppp on the ser0/1 of R4 & R5 - via "peer neighbor-route", which kick in by default  I don't see the need of using the multilink.

    =================

    Rack1R4(config-if)#do sh ip route | inc 167.1.45.5
    C       167.1.45.5/32 is directly connected, Serial0/1
    Rack1R4(config-if)#do sh run int ser0/1
    Building configuration...

    Current configuration : 112 bytes
    !
    interface Serial0/1
     ip unnumbered Loopback45
     ip pim sparse-mode
     encapsulation ppp
     clock rate 2000000
    end

    -----------------------------------------

    Rack1R5(config-if)#do sh ip route | inc 167.1.45.4
    C       167.1.45.4/32 is directly connected, Serial0/1
    Rack1R5(config-if)#do sh run int ser0/1
    Building configuration...

    Current configuration : 112 bytes
    !
    interface Serial0/1
     ip unnumbered Loopback45
     ip pim sparse-mode
     encapsulation ppp
     clock rate 2000000
    end

    =================

     

    Before anyone ask, I did disable EIGRP for this test.

     

     

  • I configured ip unnumbered loopback directly on ther serial interfaces. This seemed to meet the tasks requirements. Why did the SG use Multilink?

  • I just did this without multilink (in Dynamips).

  • Hi all,

       In such a case (i speak for the lab here), when you are specifically asked to configure the task in a certain way, you should DO IT as it asks. I quote from the lab "The creation of additional logical interfaces is permitted for this task". It's critical you understand when you are allowed to configure a task in which ever way you want and when you are required to do it in a certain way only. This is, unfortunately, one of the differences between passing the lab or failing it, even thouth technically you are prepared.

    Good luck with your studies!

  • Hi Cristian,

    By creating a logical interface as a Loopback and then configuring ip unnumbered Lo1 on the Serial interfaces, that would satisfy the task requirements of using logical interfaces. Is there a reason why an additional logical interface as Multilink Group is needed here?

    KR,

    Bas

  • basvd76,

    If you noticed some additional task related to multilink, you should create the multilink otherwise create Loopbackinterface and configure unnumbered on serial interface is enough.

    [:D]

  • DarrellEscola,


    To install peer neighbor route, you don't need multilink. When you configure multilink or just encap ppp with static ip or ip unnumbered command, it automatically install the peer neighbor route (until n unless you use no peer neighbor route command).

    See here:

    R4(config-if)#do show run int s0/0
    Building configuration...

    Current configuration : 95 bytes
    !
    interface Serial0/0
     ip unnumbered Loopback0
     encapsulation ppp
     serial restart-delay 0
    end
    !

    R3#show running-config interface s1/0
    Building configuration...

    Current configuration : 95 bytes
    !
    interface Serial1/0
     ip unnumbered Loopback0
     encapsulation ppp
     serial restart-delay 0
    end

    !

    R4#show ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2
           i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
           ia - IS-IS inter area, * - candidate default, U - per-user static route
           o - ODR, P - periodic downloaded static route

    Gateway of last resort is not set

         3.0.0.0/32 is subnetted, 1 subnets
    C       3.3.3.3 is directly connected, Serial0/0 see here this is peer neighbor route(IP of R3)
         4.0.0.0/32 is subnetted, 1 subnets
    C       4.4.4.4 is directly connected, Loopback0
    [:D]

  • nnn.

    It is true that either ppp or multilink will install a peer-neighbor route - however the task referred to a logical interface, which would be the multilink interface.

    DarrellEscola,


    To install peer neighbor route, you don't need multilink. When you configure multilink or just encap ppp with static ip or ip unnumbered command, it automatically install the peer neighbor route (until n unless you use no peer neighbor route command).

     

  • Hi Darrell,

    The Loopback interfaces we are using are already logical interfaces to get the result, so satisfies the task's requirement, doesn't it? I still don't see the need for the Multilink group.

    Another solution could be the use of Multilink group and don't bother with the Loopback interfaces. That would satisfy the task as well in my opinion. Wouldn't you agree?

    KR,

    Bas

  • If you know that there are multiple ways of accomplishing the task, take those alternatives to the proctor. If you tell the proctor "I can do it this way or that way, which way would you prefer?" you have a better chance of getting an answer than if you can't show that you understand the alternative methods.

    Also, look at the subsequent tasks - is there any future task that would work better (or only) with one alternative?

    Hi Darrell,

    The Loopback interfaces we are using are already logical interfaces to get the result, so satisfies the task's requirement, doesn't it? I still don't see the need for the Multilink group.

    Another solution could be the use of Multilink group and don't bother with the Loopback interfaces. That would satisfy the task as well in my opinion. Wouldn't you agree?

    KR,

    Bas

     

  • That would be the best way forward indeed, thanks for your take on this, much appreciated! :-)

  • Hi basvd76,

       If i would read the task for the first time i would still think on multilink and not on loopbacks, however it may e subjective. But, if you search the documentatio you would see that loopback is an virtual interaface with no special meaning, while multilink, GRE tunnel interfaces and other tunneling techniques are logical interfaces as there is some sort of logic/behavior behind it.

      Of course, asking the proctor does not hurt, but in such i case i would expect a negative answer from him (something like do as you think best), cause responding will give you the answer. Proctor is not allowed to give you a task answer, can give guidance on a task if something is "missing" or wording is a bit convoluted.

    Good luck with your studies!

  • Some cisco Languages:

    You can specify a software-only interface called a
    loopback interface to emulate an interface. Loopback interfaces are
    supported on all platforms. A loopback interface is a virtual interface
    that is always up and allows Border Gateway Protocol (BGP) and remote
    source-route bridging (RSRB) sessions to stay up even if the outbound
    interface is down.



    Logical Interface Configuration Examples



    This section includes the following examples to illustrate configuration tasks described in this chapter:



    imageIP Tunneling: Example



    imageConfiguring GRE/IPv4 Tunnels: Examples




    IP Tunneling: Example



    The following example shows an IP tunneling configuration with commented (!) explanations:


    ! Creates the interface.


    interface tunnel 0 


     ! Enables IPX on the interface.


     novell network 1e


     ! Enables AppleTalk.


     appletalk cable-range 4001-4001 128 


     ! Enables IP.


     ip address 10.1.2.3. 255.255.255.0


     ! Enables DECnet.


     DECnet cost 4


     ! Sets the source address, or interface, for packets.


      tunnel source ethernet 0


    ! Determines where the encapsulated packets are to go.


     tunnel destination 131.108.14.12


     ! Sets the protocol.


     tunnel mode gre


     ! Computes a checksum on passenger packets if protocol does not already have reliable 
     ! checksum


     tunnel checksum needed


     ! Sets the ID key.


     tunnel key 42


     ! Sets dropping of out-of-order packets.


     tunnel sequence-datagrams





    Configuring GRE/IPv4 Tunnels: Examples



    The following example shows a simple configuration of GRE tunneling.
    Note that Ethernet interface 0/1 is the tunnel source for Router A and
    the tunnel destination for Router B. Fast Ethernet interface 0/1 is the
    tunnel source for Router B and the tunnel destination for Router A.

     

    Make some sense!!!!

     

     

  • I am happy with the explanations here, I think a comment in the SG stating why multilink (logical) vs loopback (virtual) can save some time to future candidates.

  • Agree on the solution without the multipoint interfaces.

    R4

     

    interface Serial0/1/0

     ip unnumbered Loopback10

     encapsulation ppp

     clock rate 2000000

     

    interface Loopback10

     ip address 167.1.45.4 255.255.255.255

      

    R5

     

    interface Serial0/1/0

     ip unnumbered Loopback10

     encapsulation ppp

     

    interface Loopback10

     ip address 167.1.45.5 255.255.255.255

     

    Rack1R4#ping 167.1.45.5

     

    Type escape sequence to abort.

    Sending 5, 100-byte ICMP Echos to 167.1.45.5, timeout is 2 seconds:

    !!!!!

    Success ra

      

    Rack1R4#sh ip route connected  | inc 167.1.45

    C       167.1.45.5/32 is directly connected, Serial0/1/0

    C       167.1.45.4/32 is directly connected, Loopback10

     

     

    Rack1R5#sh ip route connected  | inc 167.1.45

    C       167.1.45.5/32 is directly connected, Loopback10

    C       167.1.45.4/32 is directly connected, Serial0/1/0


     

  • Hi basvd76,

       If i would read the task for the first time i would still think on multilink and not on loopbacks, however it may e subjective. But, if you search the documentatio you would see that loopback is an virtual interaface with no special meaning, while multilink, GRE tunnel interfaces and other tunneling techniques are logical interfaces as there is some sort of logic/behavior behind it.

      Of course, asking the proctor does not hurt, but in such i case i would expect a negative answer from him (something like do as you think best), cause responding will give you the answer. Proctor is not allowed to give you a task answer, can give guidance on a task if something is "missing" or wording is a bit convoluted.

    Good luck with your studies!

    Like for me, Your answer dosen't make a sense. There's not specified in the task what exactly interfaces they want from us. Logical is logical dosen't matter Lo or Mu. Don't try to defend the not well defined task. When I would read the task for the first time, I would still think of Lo not Mu. Because it's much simpler and configuration is optimized. I can for example blame You for Your config just because it's not optimal. To much lines!

    And I hear that if Proctor says this sentence to You, You can't be more lucky, because he already know that You know all possible solutions.

  • I believe that for Cisco "virtual interface" and "logical interface" have the same meaning. For example, in interface config guide for 12.2, configuring Loopback interface is under "Configuring Logical Interfaces" section. More importantly, if you check 12.4T Interface & HW config guide, you will find section called "Configuring Virtual interfaces" and the very first paragraph states (I have bolded interesting part):

    "Virtual interfaces are software-based interfaces that you create in the memory of the networking device using Cisco IOS commands. Virtual interfaces do not have a hardware component such as the RJ-45 female port on a 100BASE-T Fast Ethernet network interface card. This module describes the four common types of virtual, or logical, interfaces that can be configured using Cisco IOS software:".

    Then it goes to list loopback, null, subinterface and tunnel interface.

    Maybe the task should have said "You have to use both common and uncommon logical interfaces to solve this task". [:)]

  • Guys,

    How about "Dialer Interfaces"? As per Cisco...

    • Dialer interfaces—Logical entities that use a per-destination dialer profile. Any number of dialer interfaces can be created in a router. All configuration settings specific to the destination go in the dialer interface configuration. Each dialer interface uses a dialer pool, which is a pool of physical interfaces (ISDN BRI and PRI, asynchronous-modem, and synchronous serial). 

    Rack14R4:


    interface Dialer0

     ip address 145.14.45.4 255.255.255.0

     encapsulation ppp

     dialer pool 1

     dialer idle-timeout 0

     dialer persistent

    end

    !


    interface Serial0/1/0

     no ip address

     encapsulation ppp

     dialer in-band

     dialer pool-member 1

     clock rate 2000000

     pulse-time 1

    end





    Rack14R5:

    !


    interface Dialer0

     ip address 145.14.45.5 255.255.255.0

     encapsulation ppp

     dialer pool 1

     dialer idle-timeout 0

     dialer persistent

    end







    interface Serial0/1/0

     no ip address

     encapsulation ppp

     dialer in-band

     dialer pool-member 1

     pulse-time 1

    end







    Rack14R4(config-if)#do sh ip ro conn | i 145.14.45

    C       145.14.45.0/24 is directly connected, Dialer0

    C       145.14.45.5/32 is directly connected, Dialer0





    Rack14R4(config-if)#do ping 145.14.45.5



    Type escape sequence to abort.

    Sending 5, 100-byte ICMP Echos to 145.14.45.5, timeout is 2 seconds:

    !!!!!

    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms







    Rack14R5(config-if)#do sh ip ro conn | i 145.14.45

    C       145.14.45.0/24 is directly connected, Dialer0

    C       145.14.45.4/32 is directly connected, Dialer0





    Rack14R5(config-if)#do ping 145.14.45.4



    Type escape sequence to abort.

    Sending 5, 100-byte ICMP Echos to 145.14.45.4, timeout is 2 seconds:

    !!!!!

    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms





  • As the encapsulation on R5's S0/1/0 is set to frame-relay in the initial config and we are not allowed to change the encapsulations, I went with yet another solution - configuring frame-relay on R4 and using PPPoFR, then unnumbering the virtual-templates to the new loopbacks.

    I know I am still changing the encapsulation R4, but I figured it'd be better to do it where nothing is specifically configured instead of changing R5 which is implicitly frame-relay.

  • I actually configured back-to-back frame-relay between R4 and R5. Worked like a charm.

    R4:

    interface Loopback45
     ip address 167.1.45.4 255.255.255.255

    interface Serial0/1
     ip unnumbered Loopback45
     encapsulation frame-relay
     no keepalive
     frame-relay map ip 167.1.45.5 45 broadcast

    R5:

    interface Loopback45
     ip address 167.1.45.5 255.255.255.255

    interface Serial0/1
     ip unnumbered Loopback45
     encapsulation frame-relay
     no keepalive
     frame-relay map ip 167.1.45.4 45 broadcast

    Is there any reason why this is not a valid configuration for this task?

    Thanks.

  • One other point, the task states "The creation of additional logical interfaces is permitted for this task" not required.  Therefore, I would use a logical interface as needed, but it is not necessarily a requirement of the task.

    One last point, if Logical doesn't equal Virtual, by that definition you technically would not be allowed to create a Loopback interface if the strict defining of the word Virtual only equated to Loopback and Logical equated only to Tunnel/Multilink/Virtual-Templates etc.

    Logic tells us that Virtual/Logical are synonymous. 

    If the task was worded as "logical interfaces should only be used, only encapsulation configuration permited on the physical interface", then the SG would make sense.

    Just my two cents.

Sign In or Register to comment.