confused about MQC solution for 5.4

In the walk through video they said you could apply an MQC solution to the task. What would this solution look like? Is my syntax correct?

class-map match-all MUTLI
class-map match-all MULTI
match access-group 2
!
!
policy-map MULTICAST
class MUTLI
police 1000000 8000 exceed-action drop

access-list 2 permit 224.0.0.0 15.255.255.255


When I do run the command below I get this...


Rack1SW1(config-if)#service-pol out MULTICAST
police command is not supported for this interface
Configuration failed!
Warning: Assigning a policy map to the output side of an interface not supported

Comments

  • Actually Dane, this was the first approach I tried. If I read it all right from the DocCD, you can't police outbound on a physical interface and you can't police at the VLAN level of a heirarchical policy map for VLAN-based QoS, so I was at a loss. Since you have to limit outbound mcast on a certain port, but more than one other port could potentially source mcast towards this one certain port, it doesn't seem like you can police inbound on a physical.

    Didn't spend too much time on it and just switched over to the SG approach. I'm definitely reading Odom's QoS book again, and I'll be on the lookout for this sort of thing on the next read. Unfortunately, he doesn't cover Catalyst QoS very deeply and I think he used some old 2900 for all of the examples, so probably VLAN-based QoS isn't even covered, come to think of it...
  • Thanks alot for the Rely scott

    Btw I had the same question too why the "tty"?
  • That tty must just be an artifact from some earlier revision of the lab or something...
  • Although i don't know the exact question, i believe that "access-list 2 permit 224.0.0.0 15.255.255.255" isn't correct because standard access-lists match on the source address. Since multicast addresses are used as destination addresses, you have to use an extended acl.

    Also, for hierarchical policing you could use something like

    class-map VLAN-CLASS
    match vlan X

    policy-map VLAN-POLICY
    class default
    police 32000

    policy-map INTERFACE-POLICY
    class VLAN-CLASS
    service-policy VLAN-POLICY

Sign In or Register to comment.