b-acd config at BR2 =no audio=

Hi,

I configured b-acd on BR2, i called the pilot from Pstn and the call was connected but i couldnt hear anything. i used debug voice application script to watch it.

Pls assist me

this is my config.


Dec  8 23:11:15.471: //9//TCL :/tcl_PutsObjCmd: TCL B-ACD:  >>> B-ACD Service Running <<<
VORack02R3#
Dec  8 23:12:15.469: //9//TCL :/tcl_PutsObjCmd: TCL B-ACD:  >>> B-ACD Service Running <<<
VORack02R3#
Dec  8 23:13:15.467: //9//TCL :/tcl_PutsObjCmd: TCL B-ACD:  >>> B-ACD Service Running <<<
VORack02R3#sh run
Building configuration...

Current configuration : 8719 bytes
!
! Last configuration change at 22:51:45 UTC Tue Dec 8 2009
! NVRAM config last updated at 20:53:54 UTC Tue Dec 8 2009
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname VORack02R3
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
enable secret 5 $1$crUT$TETahCZyVJ7.kaMMVn21y1
!
no aaa new-model
network-clock-participate slot 1
!
voice-card 0
 dsp services dspfarm
!        
voice-card 1
 dspfarm 
!        
dot11 syslog
ip source-route
!        
!        
ip cef   
ip dhcp excluded-address 177.3.11.1 177.3.11.99
ip dhcp excluded-address 177.3.11.111 177.3.11.254
!        
ip dhcp pool VOICE
   network 177.3.11.0 255.255.255.0
   default-router 177.3.11.1
   option 150 ip 177.3.11.1
!        
!        
no ip domain lookup
no ipv6 cef
!        
multilink bundle-name authenticated
!        
!        
!        
!        
isdn switch-type primary-net5
!        
!        
!        
voice service voip
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 sip     
  registrar server expires max 600 min 60
!        
!        
!        
!        
!        
!        
!        
!        
!        
!        
!        
!        
!        
!        
!        
!        
voice register global
 mode cme
 source-address 177.3.11.1 port 5060
 max-dn 10
 max-pool 5
 load 7960-7940 P0S3-08-8-00
 authenticate register
 tftp-path flash:
 create profile sync 000433437225642A
!        
voice register dn  1
 number 3002
 name BR2Ph2
 label 3002
!        
voice register pool  1
 id mac 0005.9A3C.7A00
 type 7960
 number 1 dn 1
 dtmf-relay sip-notify
 username br2ph2 password cisco
 codec g711ulaw
 after-hour exempt
!        
!        
!        
!        
application
 service aa flash:app-b-acd-aa-2.1.2.2.tcl
  paramspace english index 1
  param number-of-hunt-grps 3
  param handoff-string aa
  param dial-by-extension-option 3
  paramspace english language en
  param max-time-vm-retry 2
  param aa-pilot 21313000
  paramspace english location flash:
  param second-greeting-time 30
  param call-retry-timer 20
  param max-time-call-retry 300
  param voice-mail 3008
  param service-name queue
 !       
 service queue flash:app-b-acd-2.1.2.2.tcl
  param queue-len 10
  param aa-hunt0 3008
  param aa-hunt1 3100
  param queue-manager-debugs 1
  param number-of-hunt-grps 2
  param aa-hunt2 3200
 !       
!        
!        
!        
!        
!        
archive  
 log config
  hidekeys
!        
!        
!        
!        
!        
controller E1 1/0/0
 pri-group timeslots 1-3,16
!        
controller E1 1/0/1
 channel-group 0 timeslots 1-31
!        
ip tcp synwait-time 5
!        
!        
!        
!        
interface Loopback0
 ip address 177.1.254.3 255.255.255.255
!        
interface FastEthernet0/0
 description == To SW2
 no ip address
 duplex auto
 speed auto
!        
interface FastEthernet0/0.11
 description == Voice VLAN
 encapsulation dot1Q 11
 ip address 177.3.11.1 255.255.255.0
!        
interface FastEthernet0/0.12
 description == Data VLAN
 encapsulation dot1Q 12
 ip address 177.3.12.1 255.255.255.0
!        
interface Service-Engine0/0
 no ip address
 shutdown
!        
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!        
interface Serial1/0/0:15
 no ip address
 encapsulation hdlc
 isdn switch-type primary-net5
 isdn incoming-voice voice
 isdn outgoing display-ie
 no cdp enable
!        
interface Serial1/0/1:0
 description == Frame Relay
 no ip address
 encapsulation frame-relay
!        
interface Serial1/0/1:0.1 point-to-point
 description == To HQ
 ip address 177.0.201.2 255.255.255.0
 snmp trap link-status
 frame-relay interface-dlci 201  
!        
router ospf 1
 log-adjacency-changes
 network 0.0.0.0 255.255.255.255 area 0
!        
ip forward-protocol nd
no ip http server
no ip http secure-server
!        
!        
!        
cdp timer 6
!        
!        
!        
!        
!        
!        
tftp-server flash:P003-08-8-00.sbn
tftp-server flash:P003-08-8-00.bin
tftp-server flash:P0S3-08-8-00.loads
tftp-server flash:P0S3-08-8-00.sb2
!        
control-plane
!        
!        
!        
voice-port 1/0/0:15
!        
ccm-manager fax protocol cisco
!        
mgcp fax t38 ecm
!        
sccp local FastEthernet0/0.11
sccp ccm 177.3.11.1 identifier 1 priority 1 version 7.0
sccp     
!        
sccp ccm group 1
 associate ccm 1 priority 1
 associate profile 1 register mtp0013c454ec08
 keepalive retries 5
 switchover method immediate
 switchback interval 5
!        
dspfarm profile 1 transcode 
 codec g711ulaw
 codec g711alaw
 codec g729ar8
 codec g729abr8
 codec g729r8
 codec g729br8
 maximum sessions 6
 associate application SCCP
!        
dial-peer cor custom
 name DEFAULT
 name PREMIUM
!        
!        
dial-peer cor list PT
!        
dial-peer cor list PT-DEFAULT
 member DEFAULT
!        
dial-peer cor list PT-PREMIUM
 member PREMIUM
!        
dial-peer cor list CSS-DEFAULT
 member DEFAULT
!        
dial-peer cor list CSS-PREMIUM
 member PREMIUM
!        
!        
dial-peer voice 1 pots
 incoming called-number .
 direct-inward-dial
 port 1/0/0:15
!        
dial-peer voice 999 pots
 corlist outgoing PT-DEFAULT
 destination-pattern 999
 port 1/0/0:15
 forward-digits 3
!        
dial-peer voice 900 pots
 corlist outgoing PT-DEFAULT
 destination-pattern 9[1-9].......$
 port 1/0/0:15
!        
dial-peer voice 901 pots
 corlist outgoing PT-DEFAULT
 destination-pattern 90[1-9].........$
 port 1/0/0:15
 prefix 0
!        
dial-peer voice 902 pots
 corlist outgoing PT-PREMIUM
 destination-pattern 900T
 port 1/0/0:15
 prefix 00
!        
dial-peer voice 123 pots
 translation-profile outgoing 123-999
 destination-pattern 123
 port 1/0/0:15
!        
dial-peer voice 4567 pots
 translation-profile outgoing REJECT
 destination-pattern 4567
 port 1/0/0:15
!        
dial-peer voice 7 pots
 translation-profile outgoing TO_PSTN
 destination-pattern 7...T
 port 1/0/0:15
!        
dial-peer voice 3000 pots
 service aa
 incoming called-number 21313000
 port 1/0/0:15
!        
!        
!        
!        
gatekeeper
 shutdown
!        
!        
telephony-service
 sdspfarm units 1
 sdspfarm transcode sessions 40
 sdspfarm tag 1 mtp0013c454ec08
 em logout 0:0 0:0 0:0
 max-ephones 4
 max-dn 32
 ip source-address 177.3.11.1 port 2000
 auto assign 1 to 4
 load 7960-7940 P003-08-8-00
 time-zone 5
 time-format 24
 date-format dd-mm-yy
 max-conferences 8 gain -6
 call-forward pattern .T
 moh flash:/music-on-hold.au
 web admin system name admin password cisco
 dn-webedit
 time-webedit
 transfer-system full-consult
 transfer-pattern .T
 secondary-dialtone 9
 login timeout 15
 after-hours block pattern 1 900
 after-hours day Sun 18:30 09:00
 after-hours day Mon 18:30 09:00
 after-hours day Tue 18:30 09:00
 after-hours day Wed 18:30 09:00
 after-hours day Thu 18:30 09:00
 after-hours day Fri 18:30 09:00
 after-hours day Sat 18:30 09:00
 after-hours pstn-prefix 4 45
 night-service code *12345
 night-service day Sun 18:00 09:00
 night-service day Mon 18:00 09:00
 night-service day Tue 18:00 09:00
 night-service day Wed 18:00 09:00
 night-service day Thu 18:00 09:00
 night-service day Fri 18:00 09:00
 night-service day Sat 00:00 23:59
 server-security-mode non-secure
 create cnf-files version-stamp 7960 Dec 08 2009 22:47:04
!        
!        
ephone-template  1
 softkeys idle  Newcall Pickup Redial Mobility Login HLog
 softkeys seized  Callback Cfwdall Endcall Gpickup
 softkeys connected  Endcall Hold Mobility Trnsfer HLog
!        
!        
ephone-dn  1  dual-line
 number 3001
 label 3001
 description 21313001
 name BR2Ph1
 mobility
 corlist incoming CSS-DEFAULT
 night-service bell
!        
!        
ephone-dn  2  dual-line
 number 3005 secondary 21313005
 label 3005
 name BR2Ph1
!        
!        
ephone-dn  3  dual-line
 number 3003
!        
!        
ephone-dn  4  dual-line
 number 3004
!        
!        
ephone-dn  5  dual-line
 number 3008 secondary 21313008
 description 21313008
 name BR2Ph3
!        
!        
ephone-dn  7  octo-line
 number 3020
 label 3020
!        
!        
ephone-dn  10  dual-line
 number 3010
 label Shared Line
!        
!        
ephone-dn  11
 number 3011
 --More--
Dec  8 23:14:15.465: //9//TCL :/tcl_PutsObjCmd: TCL B-ACD:  >>> B-ACD Service Running <<<
 label 3011
!        
!        
ephone-dn  12
 number 3012
 label 3012
!        
!        
ephone  1
 no phone-ui speeddial-fastdial
 no phone-ui snr
 no multicast-moh
 device-security-mode none
 mac-address 000C.F1FB.DEDB
 ephone-template 1
 keepalive 30 auxiliary 0
 max-calls-per-button 7
 busy-trigger-per-button 5
 username "br2ph1" password cisco
 type 7960
 button  1:1 2:2 3:7 4:11
 button  6:10
 pin 12345
!        
!        
!        
ephone  2
 no phone-ui speeddial-fastdial
 no phone-ui snr
 no multicast-moh
 device-security-mode none
 mac-address 0200.4C4F.4F51
 keepalive 30 auxiliary 0
 username "br2ph3" password cisco
 button  1:5 2:12 3:7 6:10
 pin 12345
 night-service bell
!        
!        
!        
ephone  3
 no phone-ui speeddial-fastdial
 no phone-ui snr
 no multicast-moh
 device-security-mode none
 keepalive 30 auxiliary 0
!        
!        
!        
ephone  4
 no phone-ui speeddial-fastdial
 no phone-ui snr
 no multicast-moh
 device-security-mode none
 keepalive 30 auxiliary 0
!        
!        
ephone-hunt 1 longest-idle
 pilot 3100
 list 3001, 3011
 timeout 3, 3
!        
!        
ephone-hunt 2 longest-idle
 pilot 3200
 list 3008, 3012
 timeout 3, 3
!        
!        
!        
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous level 0 limit 20
 --More--

 

Thanks

Comments


  • Hi Redninja,


    Two config errors I see and they are both in the "queue" application portion. 



    First change

        param number-of-hunt-grps 2

    to match how many hunt groups you actually have - 3. This param is represented properly in the "aa" application config. 


    Secondly, change this

       param aa-hunt0 3008

    to this

       param aa-hunt10 3008

    I assume you wanted this dn (3008) as an operator. If so aa-hunt10 is the proper syntax. aa-hunt0 is not a valid parameter. 



    After that, please run these two commands from exec mode:


    call application voice load aa

    call application voice load queue


    Then test it again and please let us know your results.



    Cheers,





    Mark Snow

    CCIE #14073 (Voice, Security)

    Instructor

    Internetwork Expert





    On Dec 9, 2009, at 2:23, redninja <[email protected]> wrote:


    Hi,

    I configured b-acd on BR2, i called the pilot from Pstn and the call was connected but i couldnt hear anything. i used debug voice application script to watch it.

    Pls assist me

    this is my config.


    Dec  8 23:11:15.471: //9//TCL :/tcl_PutsObjCmd: TCL B-ACD:  >>> B-ACD Service Running <<<
    VORack02R3#
    Dec  8 23:12:15.469: //9//TCL :/tcl_PutsObjCmd: TCL B-ACD:  >>> B-ACD Service Running <<<
    VORack02R3#
    Dec  8 23:13:15.467: //9//TCL :/tcl_PutsObjCmd: TCL B-ACD:  >>> B-ACD Service Running <<<
    VORack02R3#sh run
    Building configuration...

    Current configuration : 8719 bytes
    !
    ! Last configuration change at 22:51:45 UTC Tue Dec 8 2009
    ! NVRAM config last updated at 20:53:54 UTC Tue Dec 8 2009
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname VORack02R3
    !
    boot-start-marker
    boot-end-marker
    !
    logging message-counter syslog
    enable secret 5 $1$crUT$TETahCZyVJ7.kaMMVn21y1
    !
    no aaa new-model
    network-clock-participate slot 1
    !
    voice-card 0
     dsp services dspfarm
    !        
    voice-card 1
     dspfarm 
    !        
    dot11 syslog
    ip source-route
    !        
    !        
    ip cef   
    ip dhcp excluded-address 177.3.11.1 177.3.11.99
    ip dhcp excluded-address 177.3.11.111 177.3.11.254
    !        
    ip dhcp pool VOICE
       network 177.3.11.0 255.255.255.0
       default-router 177.3.11.1
       option 150 ip 177.3.11.1
    !        
    !        
    no ip domain lookup
    no ipv6 cef
    !        
    multilink bundle-name authenticated
    !        
    !        
    !        
    !        
    isdn switch-type primary-net5
    !        
    !        
    !        
    voice service voip
     allow-connections h323 to h323
     allow-connections h323 to sip
     allow-connections sip to h323
     allow-connections sip to sip
     sip     
      registrar server expires max 600 min 60
    !        
    !        
    !        
    !        
    !        
    !        
    !        
    !        
    !        
    !        
    !        
    !        
    !        
    !        
    !        
    !        
    voice register global
     mode cme
     source-address 177.3.11.1 port 5060
     max-dn 10
     max-pool 5
     load 7960-7940 P0S3-08-8-00
     authenticate register
     tftp-path flash:
     create profile sync 000433437225642A
    !        
    voice register dn  1
     number 3002
     name BR2Ph2
     label 3002
    !        
    voice register pool  1
     id mac 0005.9A3C.7A00
     type 7960
     number 1 dn 1
     dtmf-relay sip-notify
     username br2ph2 password cisco
     codec g711ulaw
     after-hour exempt
    !        
    !        
    !        
    !        
    application
     service aa flash:app-b-acd-aa-2.1.2.2.tcl
      paramspace english index 1
      param number-of-hunt-grps 3
      param handoff-string aa
      param dial-by-extension-option 3
      paramspace english language en
      param max-time-vm-retry 2
      param aa-pilot 21313000
      paramspace english location flash:
      param second-greeting-time 30
      param call-retry-timer 20
      param max-time-call-retry 300
      param voice-mail 3008
      param service-name queue
     !       
     service queue flash:app-b-acd-2.1.2.2.tcl
      param queue-len 10
      param aa-hunt0 3008
      param aa-hunt1 3100
      param queue-manager-debugs 1
      param number-of-hunt-grps 2
      param aa-hunt2 3200
     !       
    !        
    !        
    !        
    !        
    !        
    archive  
     log config
      hidekeys
    !        
    !        
    !        
    !        
    !        
    controller E1 1/0/0
     pri-group timeslots 1-3,16
    !        
    controller E1 1/0/1
     channel-group 0 timeslots 1-31
    !        
    ip tcp synwait-time 5
    !        
    !        
    !        
    !        
    interface Loopback0
     ip address 177.1.254.3 255.255.255.255
    !        
    interface FastEthernet0/0
     description == To SW2
     no ip address
     duplex auto
     speed auto
    !        
    interface FastEthernet0/0.11
     description == Voice VLAN
     encapsulation dot1Q 11
     ip address 177.3.11.1 255.255.255.0
    !        
    interface FastEthernet0/0.12
     description == Data VLAN
     encapsulation dot1Q 12
     ip address 177.3.12.1 255.255.255.0
    !        
    interface Service-Engine0/0
     no ip address
     shutdown
    !        
    interface FastEthernet0/1
     no ip address
     shutdown
     duplex auto
     speed auto
    !        
    interface Serial1/0/0:15
     no ip address
     encapsulation hdlc
     isdn switch-type primary-net5
     isdn incoming-voice voice
     isdn outgoing display-ie
     no cdp enable
    !        
    interface Serial1/0/1:0
     description == Frame Relay
     no ip address
     encapsulation frame-relay
    !        
    interface Serial1/0/1:0.1 point-to-point
     description == To HQ
     ip address 177.0.201.2 255.255.255.0
     snmp trap link-status
     frame-relay interface-dlci 201  
    !        
    router ospf 1
     log-adjacency-changes
     network 0.0.0.0 255.255.255.255 area 0
    !        
    ip forward-protocol nd
    no ip http server
    no ip http secure-server
    !        
    !        
    !        
    cdp timer 6
    !        
    !        
    !        
    !        
    !        
    !        
    tftp-server flash:P003-08-8-00.sbn
    tftp-server flash:P003-08-8-00.bin
    tftp-server flash:P0S3-08-8-00.loads
    tftp-server flash:P0S3-08-8-00.sb2
    !        
    control-plane
    !        
    !        
    !        
    voice-port 1/0/0:15
    !        
    ccm-manager fax protocol cisco
    !        
    mgcp fax t38 ecm
    !        
    sccp local FastEthernet0/0.11
    sccp ccm 177.3.11.1 identifier 1 priority 1 version 7.0
    sccp     
    !        
    sccp ccm group 1
     associate ccm 1 priority 1
     associate profile 1 register mtp0013c454ec08
     keepalive retries 5
     switchover method immediate
     switchback interval 5
    !        
    dspfarm profile 1 transcode 
     codec g711ulaw
     codec g711alaw
     codec g729ar8
     codec g729abr8
     codec g729r8
     codec g729br8
     maximum sessions 6
     associate application SCCP
    !        
    dial-peer cor custom
     name DEFAULT
     name PREMIUM
    !        
    !        
    dial-peer cor list PT
    !        
    dial-peer cor list PT-DEFAULT
     member DEFAULT
    !        
    dial-peer cor list PT-PREMIUM
     member PREMIUM
    !        
    dial-peer cor list CSS-DEFAULT
     member DEFAULT
    !        
    dial-peer cor list CSS-PREMIUM
     member PREMIUM
    !        
    !        
    dial-peer voice 1 pots
     incoming called-number .
     direct-inward-dial
     port 1/0/0:15
    !        
    dial-peer voice 999 pots
     corlist outgoing PT-DEFAULT
     destination-pattern 999
     port 1/0/0:15
     forward-digits 3
    !        
    dial-peer voice 900 pots
     corlist outgoing PT-DEFAULT
     destination-pattern 9[1-9].......$
     port 1/0/0:15
    !        
    dial-peer voice 901 pots
     corlist outgoing PT-DEFAULT
     destination-pattern 90[1-9].........$
     port 1/0/0:15
     prefix 0
    !        
    dial-peer voice 902 pots
     corlist outgoing PT-PREMIUM
     destination-pattern 900T
     port 1/0/0:15
     prefix 00
    !        
    dial-peer voice 123 pots
     translation-profile outgoing 123-999
     destination-pattern 123
     port 1/0/0:15
    !        
    dial-peer voice 4567 pots
     translation-profile outgoing REJECT
     destination-pattern 4567
     port 1/0/0:15
    !        
    dial-peer voice 7 pots
     translation-profile outgoing TO_PSTN
     destination-pattern 7...T
     port 1/0/0:15
    !        
    dial-peer voice 3000 pots
     service aa
     incoming called-number 21313000
     port 1/0/0:15
    !        
    !        
    !        
    !        
    gatekeeper
     shutdown
    !        
    !        
    telephony-service
     sdspfarm units 1
     sdspfarm transcode sessions 40
     sdspfarm tag 1 mtp0013c454ec08
     em logout 0:0 0:0 0:0
     max-ephones 4
     max-dn 32
     ip source-address 177.3.11.1 port 2000
     auto assign 1 to 4
     load 7960-7940 P003-08-8-00
     time-zone 5
     time-format 24
     date-format dd-mm-yy
     max-conferences 8 gain -6
     call-forward pattern .T
     moh flash:/music-on-hold.au
     web admin system name admin password cisco
     dn-webedit
     time-webedit
     transfer-system full-consult
     transfer-pattern .T
     secondary-dialtone 9
     login timeout 15
     after-hours block pattern 1 900
     after-hours day Sun 18:30 09:00
     after-hours day Mon 18:30 09:00
     after-hours day Tue 18:30 09:00
     after-hours day Wed 18:30 09:00
     after-hours day Thu 18:30 09:00
     after-hours day Fri 18:30 09:00
     after-hours day Sat 18:30 09:00
     after-hours pstn-prefix 4 45
     night-service code *12345
     night-service day Sun 18:00 09:00
     night-service day Mon 18:00 09:00
     night-service day Tue 18:00 09:00
     night-service day Wed 18:00 09:00
     night-service day Thu 18:00 09:00
     night-service day Fri 18:00 09:00
     night-service day Sat 00:00 23:59
     server-security-mode non-secure
     create cnf-files version-stamp 7960 Dec 08 2009 22:47:04
    !        
    !        
    ephone-template  1
     softkeys idle  Newcall Pickup Redial Mobility Login HLog
     softkeys seized  Callback Cfwdall Endcall Gpickup
     softkeys connected  Endcall Hold Mobility Trnsfer HLog
    !        
    !        
    ephone-dn  1  dual-line
     number 3001
     label 3001
     description 21313001
     name BR2Ph1
     mobility
     corlist incoming CSS-DEFAULT
     night-service bell
    !        
    !        
    ephone-dn  2  dual-line
     number 3005 secondary 21313005
     label 3005
     name BR2Ph1
    !        
    !        
    ephone-dn  3  dual-line
     number 3003
    !        
    !        
    ephone-dn  4  dual-line
     number 3004
    !        
    !        
    ephone-dn  5  dual-line
     number 3008 secondary 21313008
     description 21313008
     name BR2Ph3
    !        
    !        
    ephone-dn  7  octo-line
     number 3020
     label 3020
    !        
    !        
    ephone-dn  10  dual-line
     number 3010
     label Shared Line
    !        
    !        
    ephone-dn  11
     number 3011
     --More--
    Dec  8 23:14:15.465: //9//TCL :/tcl_PutsObjCmd: TCL B-ACD:  >>> B-ACD Service Running <<<
     label 3011
    !        
    !        
    ephone-dn  12
     number 3012
     label 3012
    !        
    !        
    ephone  1
     no phone-ui speeddial-fastdial
     no phone-ui snr
     no multicast-moh
     device-security-mode none
     mac-address 000C.F1FB.DEDB
     ephone-template 1
     keepalive 30 auxiliary 0
     max-calls-per-button 7
     busy-trigger-per-button 5
     username "br2ph1" password cisco
     type 7960
     button  1:1 2:2 3:7 4:11
     button  6:10
     pin 12345
    !        
    !        
    !        
    ephone  2
     no phone-ui speeddial-fastdial
     no phone-ui snr
     no multicast-moh
     device-security-mode none
     mac-address 0200.4C4F.4F51
     keepalive 30 auxiliary 0
     username "br2ph3" password cisco
     button  1:5 2:12 3:7 6:10
     pin 12345
     night-service bell
    !        
    !        
    !        
    ephone  3
     no phone-ui speeddial-fastdial
     no phone-ui snr
     no multicast-moh
     device-security-mode none
     keepalive 30 auxiliary 0
    !        
    !        
    !        
    ephone  4
     no phone-ui speeddial-fastdial
     no phone-ui snr
     no multicast-moh
     device-security-mode none
     keepalive 30 auxiliary 0
    !        
    !        
    ephone-hunt 1 longest-idle
     pilot 3100
     list 3001, 3011
     timeout 3, 3
    !        
    !        
    ephone-hunt 2 longest-idle
     pilot 3200
     list 3008, 3012
     timeout 3, 3
    !        
    !        
    !        
    line con 0
     exec-timeout 0 0
     privilege level 15
     logging synchronous level 0 limit 20
     --More--

     

    Thanks





    Internetwork Expert - The Industry Leader in CCIE Preparation

    http://www.internetworkexpert.com



    Subscription information may be found at:

    http://www.ieoc.com/forums/ForumSubscriptions.aspx

  • Thanks alot for pointing me to that. After making the changes, i still cant hear anything when i call 3000 from PSTN, i can only see the connection.

     

     

  • Sorry I revised my post but hadn't seen that you had already responded.

    Can you try these two commands from exec mode (non config t mode)


    call application voice load aa

    call application voice load queue


    Then let us know?


    If it is still a problem, I will put your config into my rack and test it out to see what I can find.


    Cheers,

  • Thanks alot Mark. Tried again, but still no audio

  • Dear Mark,

    I have the same problem , so please if you find a solution please tell me.

    Thanks in advance;

    Abo 3mr

  • Please provide your complete BR2 router config here.

     

    Cheers,

  • Dear Cheers;

    Kindly find below my configuration taking into your consideratio the call is already stablished from the callmanager to callmanager express

     

    BR2CME#sh run
    Building configuration...

    Current configuration : 3325 bytes
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname BR2CME
    !
    boot-start-marker
    boot-end-marker
    !
    enable password cisco
    !
    no aaa new-model
    memory-size iomem 5
    clock timezone cst -6
    ip cef
    !
    !
    no ip dhcp use vrf connected
    ip dhcp excluded-address 192.168.1.1 192.168.1.100
    !        
    ip dhcp pool BR2
       network 192.168.1.0 255.255.255.0
       option 150 ip 192.168.1.1
       default-router 172.30.160.3
    !
    !
    no ip domain lookup
    ip multicast-routing
    !
    multilink bundle-name authenticated
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !        
    !
    !
    !
    voice translation-rule 1
     rule 1 /2131(....)/ /1/
    !
    !
    voice translation-profile 1
     translate called 1
    !
    !
    !
    application
      service callq flash:app-b-acd-2.1.2.2.tcl
      param queue-len 10
      param aa-hunt10 3002
      param aa-hunt1 3001
      param number-of-hunt-grps 3
      param aa-hunt2 3002
      param queue-manager-debugs 1
      !
      service acdaa flash:app-b-acd-aa-2.1.2.2.tcl
      paramspace english index 0
      param number-of-hunt-grps 3
      param handoff-string acdaa
      paramspace english language en
      param call-retry-timer 30
      param service-name callq
      paramspace english location flash:
      param second-greeting-time 60
      param drop-through-prompt _bacd_welcome.au
      param max-time-vm-retry 2
      param max-time-call-retry 600
      param voice-mail 73002
      param aa-pilot 3000
      !
    !
    !
    !
    !
    !
    username cisco password 0 cisco
    archive
     log config
      hidekeys
    !        
    !
    !
    !
    !
    !
    !
    !
    interface Loopback0
     ip address 13.13.13.1 255.255.255.0
     ip pim dense-mode
    !
    interface FastEthernet0/0
     ip address 192.168.1.1 255.255.255.0
     ip pim dense-mode
     duplex auto
     speed auto
    !
    interface Serial0/0
     no ip address
     encapsulation frame-relay
     clock rate 2000000
    !
    interface Serial0/0.1 point-to-point
     ip address 172.30.160.3 255.255.255.0
     ip pim dense-mode
     snmp trap link-status
     frame-relay interface-dlci 203  
    !
    interface FastEthernet0/1
     no ip address
     shutdown
     duplex auto
     speed auto
    !
    interface Serial0/1
     no ip address
     shutdown
     clock rate 2000000
    !
    router eigrp 100
     network 13.13.13.0 0.0.0.255
     network 172.30.160.3 0.0.0.0
     network 192.168.1.0
     no auto-summary
    !
    ip forward-protocol nd
    ip route 10.1.200.0 255.255.255.0 172.30.160.4
    !
    !
    ip http server
    no ip http secure-server
    !
    !
    !
    !
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    dial-peer voice 20 voip
     service acdaa
     destination-pattern 3000
     session target ipv4:192.168.1.1
     incoming called-number 3000
    !
    !
    !
    !
    gatekeeper
     shutdown
    !
    !
    telephony-service
     max-ephones 2
     max-dn 10
     ip source-address 192.168.1.1 port 2000
     auto assign 1 to 2
     max-conferences 8 gain -6
     transfer-system full-consult
     create cnf-files version-stamp Jan 01 2002 00:00:00
    !
    !
    ephone-dn  1  dual-line
     number 3001
     name BR2 IP PH 1
    !
    !
    ephone-dn  2  dual-line
     number 3002
     name BR2 IP PH 2
    !
    !
    ephone-dn  3
     number 4000
    !
    !
    ephone-dn  10
     number 73... no-reg primary
     call-forward all 3555
    !
    !
    ephone  1
     no multicast-moh
     device-security-mode none
     mac-address 001D.7D96.DFA1
     button  1:1 2:3
    !
    !        
    !
    ephone  2
     no multicast-moh
     device-security-mode none
     mac-address 0200.4C4F.4F51
     type 7960
     button  1:2

  • Can you place the call in from CUCM to CUCME BACD and also provide the output from "debug voice application script" and also "debug voip dialpeer". 

    Thanks,

    Mark Snow



    On Feb 8, 2010, at 16:55, "abo 3mr" <[email protected]> wrote:

    Dear Cheers;

    Kindly find below my configuration taking into your consideratio the call is already stablished from the callmanager to callmanager express

     

    BR2CME#sh run
    Building configuration...

    Current configuration : 3325 bytes
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname BR2CME
    !
    boot-start-marker
    boot-end-marker
    !
    enable password cisco
    !
    no aaa new-model
    memory-size iomem 5
    clock timezone cst -6
    ip cef
    !
    !
    no ip dhcp use vrf connected
    ip dhcp excluded-address 192.168.1.1 192.168.1.100
    !        
    ip dhcp pool BR2
       network 192.168.1.0 255.255.255.0
       option 150 ip 192.168.1.1
       default-router 172.30.160.3
    !
    !
    no ip domain lookup
    ip multicast-routing
    !
    multilink bundle-name authenticated
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !        
    !
    !
    !
    voice translation-rule 1
     rule 1 /2131(....)/ /1/
    !
    !
    voice translation-profile 1
     translate called 1
    !
    !
    !
    application
      service callq flash:app-b-acd-2.1.2.2.tcl
      param queue-len 10
      param aa-hunt10 3002
      param aa-hunt1 3001
      param number-of-hunt-grps 3
      param aa-hunt2 3002
      param queue-manager-debugs 1
      !
      service acdaa flash:app-b-acd-aa-2.1.2.2.tcl
      paramspace english index 0
      param number-of-hunt-grps 3
      param handoff-string acdaa
      paramspace english language en
      param call-retry-timer 30
      param service-name callq
      paramspace english location flash:
      param second-greeting-time 60
      param drop-through-prompt _bacd_welcome.au
      param max-time-vm-retry 2
      param max-time-call-retry 600
      param voice-mail 73002
      param aa-pilot 3000
      !
    !
    !
    !
    !
    !
    username cisco password 0 cisco
    archive
     log config
      hidekeys
    !        
    !
    !
    !
    !
    !
    !
    !
    interface Loopback0
     ip address 13.13.13.1 255.255.255.0
     ip pim dense-mode
    !
    interface FastEthernet0/0
     ip address 192.168.1.1 255.255.255.0
     ip pim dense-mode
     duplex auto
     speed auto
    !
    interface Serial0/0
     no ip address
     encapsulation frame-relay
     clock rate 2000000
    !
    interface Serial0/0.1 point-to-point
     ip address 172.30.160.3 255.255.255.0
     ip pim dense-mode
     snmp trap link-status
     frame-relay interface-dlci 203  
    !
    interface FastEthernet0/1
     no ip address
     shutdown
     duplex auto
     speed auto
    !
    interface Serial0/1
     no ip address
     shutdown
     clock rate 2000000
    !
    router eigrp 100
     network 13.13.13.0 0.0.0.255
     network 172.30.160.3 0.0.0.0
     network 192.168.1.0
     no auto-summary
    !
    ip forward-protocol nd
    ip route 10.1.200.0 255.255.255.0 172.30.160.4
    !
    !
    ip http server
    no ip http secure-server
    !
    !
    !
    !
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    dial-peer voice 20 voip
     service acdaa
     destination-pattern 3000
     session target ipv4:192.168.1.1
     incoming called-number 3000
    !
    !
    !
    !
    gatekeeper
     shutdown
    !
    !
    telephony-service
     max-ephones 2
     max-dn 10
     ip source-address 192.168.1.1 port 2000
     auto assign 1 to 2
     max-conferences 8 gain -6
     transfer-system full-consult
     create cnf-files version-stamp Jan 01 2002 00:00:00
    !
    !
    ephone-dn  1  dual-line
     number 3001
     name BR2 IP PH 1
    !
    !
    ephone-dn  2  dual-line
     number 3002
     name BR2 IP PH 2
    !
    !
    ephone-dn  3
     number 4000
    !
    !
    ephone-dn  10
     number 73... no-reg primary
     call-forward all 3555
    !
    !
    ephone  1
     no multicast-moh
     device-security-mode none
     mac-address 001D.7D96.DFA1
     button  1:1 2:3
    !
    !        
    !
    ephone  2
     no multicast-moh
     device-security-mode none
     mac-address 0200.4C4F.4F51
     type 7960
     button  1:2




    Internetwork Expert - The Industry Leader in CCIE Preparation

    http://www.internetworkexpert.com



    Subscription information may be found at:

    http://www.ieoc.com/forums/ForumSubscriptions.aspx
  • Dear Mark Snow ;

    Kindly find below the debug output, after I called the script I didn't hear any voice but after some seconds I pressed on 2 the call already connected to direcory number 3002 but also without any voice.

    BR;

    Hany

    BR2CME#
    *Mar  1 06:43:07.395: //4//TCL :/tcl_PutsObjCmd:
    proc init_perCallvars
    *Mar  1 06:43:07.399:
    *Mar  1 06:43:07.439: //4//TCL :/tcl_PutsObjCmd: TCL AA: ++ Playing Welcome Prompt and options menu ++
    *Mar  1 06:43:21.415: //1//TCL :/tcl_PutsObjCmd: TCL B-ACD: +++ New incoming call to queue 3001 +++
    *Mar  1 06:43:21.459: //1//TCL :/tcl_PutsObjCmd: TCL B-ACD:  >>> THE QUEUE IS {TclModule_67402410_0_24187212 {CALL_NEW} {1014965001}} <<<
    *Mar  1 06:43:21.487: //1//TCL :/tcl_PutsObjCmd: TCL B-ACD: +++ 3001 Queue Length = 1 +++
    *Mar  1 06:43:21.591: //4//TCL :/tcl_PutsObjCmd: TCL AA: >>> Destination Huntgroup = 3001 <<<
    *Mar  1 06:43:21.691: //1//TCL :/tcl_PutsObjCmd: TCL B-ACD:  >>> THE QUEUE IS {TclModule_67402410_0_24187212 {CALL_PROGRESS} {1014965001}} <<<
    *Mar  1 06:43:21.759: //4//TCL :/tcl_PutsObjCmd:
     proc act_CallSetupDone
    *Mar  1 06:43:21.763:
    *Mar  1 06:43:21.763: //4//TCL :/tcl_PutsObjCmd:
     IP IVR Leg Setup Status = ls_007
    *Mar  1 06:43:21.767:
    *Mar  1 06:43:21.783: //4//TCL :/tcl_PutsObjCmd: TCL AA: >> Agent Busy <<
    *Mar  1 06:43:21.807: //1//TCL :/tcl_PutsObjCmd: TCL B-ACD:  >>> THE QUEUE IS {TclModule_67402410_0_24187212 {CALL_BUSY} {1014965001}} <<<
    *Mar  1 06:43:31.455: //1//TCL :/tcl_PutsObjCmd: TCL B-ACD:  >>> THE QUEUE IS {TclModule_67402410_0_24187212 {CALL_BUSY} {1014965011}} <<<
    *Mar  1 06:43:31.467: //1//TCL :/tcl_PutsObjCmd: TCL B-ACD: >>> Received HELLO from TclModule_67402410_0_24187212 <<<
    *Mar  1 06:43:32.075: //1//TCL :/tcl_PutsObjCmd: TCL B-ACD:  >>> B-ACD Service Running <<<
    *Mar  1 06:43:32.099: //1//TCL :/tcl_PutsObjCmd: TCL B-ACD: >>> {TclModule_67402410_0_24187212 {CALL_BUSY} {1014965011}} <<<
    *Mar  1 06:43:41.443: //1//TCL :/tcl_PutsObjCmd: TCL B-ACD:  >>> THE QUEUE IS {TclModule_67402410_0_24187212 {CALL_BUSY} {1014965021}} <<<
    *Mar  1 06:43:41.447: //1//TCL :/tcl_PutsObjCmd: TCL B-ACD: >>> Received HELLO from TclModule_67402410_0_24187212 <<<
    *Mar  1 06:43:51.479: //1//TCL :/tcl_PutsObjCmd: TCL B-ACD:  >>> THE QUEUE IS {TclModule_67402410_0_24187212 {CALL_BUSY} {1014965031}} <<<
    *Mar  1 06:43:51.507: //1//TCL :/tcl_PutsObjCmd: TCL B-ACD: >>> Received HELLO from TclModule_67402410_0_24187212 <<<
    *Mar  1 06:43:51.791: //1//TCL :/tcl_PutsObjCmd: TCL B-ACD:  >>> THE QUEUE IS {TclModule_67402410_0_24187212 {CALL_RETRY} {1014965031}} <<<
    *Mar  1 06:43:51.859: //4//TCL :/tcl_PutsObjCmd:
     proc act_CallSetupDone
    *Mar  1 06:43:51.863:
    *Mar  1 06:43:51.863: //4//TCL :/tcl_PutsObjCmd:
     IP IVR Leg Setup Status = ls_007
    *Mar  1 06:43:51.867:
    *Mar  1 06:43:51.867: //4//TCL :/tcl_PutsObjCmd: TCL AA: >> Agent Busy <<
    *Mar  1 06:43:51.971: //1//TCL :/tcl_PutsObjCmd: TCL B-ACD:  >>> THE QUEUE IS {TclModule_67402410_0_24187212 {CALL_RETRY_PROGRESS} {1014965031}} <<<
    *Mar  1 06:43:52.063: //1//TCL :/tcl_PutsObjCmd: TCL B-ACD:  >>> THE QUEUE IS {TclModule_67402410_0_24187212 {CALL_BUSY} {1014965031}} <<<
    *Mar  1 06:44:01.503: //1//TCL :/tcl_PutsObjCmd: TCL B-ACD:  >>> THE QUEUE IS {TclModule_67402410_0_24187212 {CALL_BUSY} {1014965041}} <<<
    *Mar  1 06:44:01.511: //1//TCL :/tcl_PutsObjCmd: TCL B-ACD: >>> Received HELLO from TclModule_67402410_0_24187212 <<<
    *Mar  1 06:44:11.520: //1//TCL :/tcl_PutsObjCmd: TCL B-ACD:  >>> THE QUEUE IS {TclModule_67402410_0_24187212 {CALL_BUSY} {1014965051}} <<<
    *Mar  1 06:44:11.548: //1//TCL :/tcl_PutsObjCmd: TCL B-ACD: >>> Received HELLO from TclModule_67402410_0_24187212 <<<
    *Mar  1 06:44:15.816: //1//TCL :/tcl_PutsObjCmd: TCL B-ACD:  >>> Call Abandoned Time = 54 Seconds<<<
    *Mar  1 06:44:15.864: //1//TCL :/tcl_PutsObjCmd: TCL B-ACD ++ Service Counter = 2 ++
    *Mar  1 06:44:15.888: //1//TCL :/tcl_PutsObjCmd: TCL B-ACD: +++ 3001 Queue Length = 0 +++
    *Mar  1 06:44:15.976: //1//TCL :/tcl_PutsObjCmd: TCL B-ACD:  >>> 3001 Queue Length = 0 <<<
    *Mar  1 06:44:15.988: //1//TCL :/tcl_PutsObjCmd: TCL B-ACD:  >>> Queue 3001 is Empty <<<
    *Mar  1 06:44:17.312: //8//TCL :/tcl_PutsObjCmd:
    proc init_perCallvars
    *Mar  1 06:44:17.316:
    *Mar  1 06:44:17.356: //8//TCL :/tcl_PutsObjCmd: TCL AA: ++ Playing Welcome Prompt and options menu ++
    *Mar  1 06:44:25.112: //1//TCL :/tcl_PutsObjCmd: TCL B-ACD: +++ New incoming call to queue 3002 +++
    *Mar  1 06:44:25.124: //1//TCL :/tcl_PutsObjCmd: TCL B-ACD:  >>> THE QUEUE IS {TclModule_67402580_0_24257144 {CALL_NEW} {1014965065}} <<<
    *Mar  1 06:44:25.160: //1//TCL :/tcl_PutsObjCmd: TCL B-ACD: +++ 3002 Queue Length = 1 +++
    *Mar  1 06:44:25.304: //8//TCL :/tcl_PutsObjCmd: TCL AA: >>> Destination Huntgroup = 3002 <<<
    *Mar  1 06:44:25.436: //1//TCL :/tcl_PutsObjCmd: TCL B-ACD:  >>> THE QUEUE IS {TclModule_67402580_0_24257144 {CALL_PROGRESS} {1014965065}} <<<
    *Mar  1 06:44:32.084: //1//TCL :/tcl_PutsObjCmd: TCL B-ACD:  >>> B-ACD Service Running <<<
    *Mar  1 06:44:32.104: //1//TCL :/tcl_PutsObjCmd: TCL B-ACD: >>> {TclModule_67402580_0_24257144 {CALL_PROGRESS} {1014965065}} <<<
    *Mar  1 06:44:32.124: //1//TCL :/tcl_PutsObjCmd: TCL B-ACD: >>> {TclModule_67402580_0_24257144 {CALL_PROGRESS} {1014965065}} <<<
    *Mar  1 06:44:35.112: //1//TCL :/tcl_PutsObjCmd: TCL B-ACD:  >>> THE QUEUE IS {TclModule_67402580_0_24257144 {CALL_PROGRESS} {1014965075}} <<<
    *Mar  1 06:44:35.116: //1//TCL :/tcl_PutsObjCmd: TCL B-ACD: >>> Received HELLO from TclModule_67402580_0_24257144 <<<
    *Mar  1 06:44:45.144: //1//TCL :/tcl_PutsObjCmd: TCL B-ACD:  >>> THE QUEUE IS {TclModule_67402580_0_24257144 {CALL_PROGRESS} {1014965085}} <<<
    *Mar  1 06:44:45.148: //1//TCL :/tcl_PutsObjCmd: TCL B-ACD: >>> Received HELLO from TclModule_67402580_0_24257144 <<<
    *Mar  1 06:44:47.172: //8//TCL :/tcl_PutsObjCmd:
     proc act_CallSetupDone
    *Mar  1 06:44:47.172:
    *Mar  1 06:44:47.176: //8//TCL :/tcl_PutsObjCmd:
     IP IVR Leg Setup Status = ls_000
    *Mar  1 06:44:47.176:
    *Mar  1 06:44:47.188: //8//TCL :/tcl_PutsObjCmd: TCL AA: >> Call answered by the agent; Call Connected <<
    *Mar  1 06:44:47.380: //8//TCL :/tcl_PutsObjCmd: TCL AA: >>> Incoming LEG ID = 8; Outgoing LEG ID = 12 <<<
    *Mar  1 06:44:47.584: //1//TCL :/tcl_PutsObjCmd: TCL B-ACD:  >>> Time to Answer = 22 Seconds<<<
    *Mar  1 06:44:47.704: //1//TCL :/tcl_PutsObjCmd: TCL B-ACD:  >>> THE QUEUE IS {TclModule_67402580_0_24257144 {CALL_HANDOFF} {1014965087}} <<<
    *Mar  1 06:44:47.748: //1//TCL :/tcl_PutsObjCmd: TCL B-ACD ++ Service Counter = 3 ++
    *Mar  1 06:44:47.772: //1//TCL :/tcl_PutsObjCmd: TCL B-ACD: +++ 3002 Queue Length = 0 +++
    *Mar  1 06:44:47.796: //1//TCL :/tcl_PutsObjCmd: TCL B-ACD:  >>> 3002 Queue Length = 0 <<<
    *Mar  1 06:44:47.808: //1//TCL :/tcl_PutsObjCmd: TCL B-ACD:  >>> Queue 3002 is Empty <<<
    *Mar  1 06:45:32.092: //1//TCL :/tcl_PutsObjCmd: TCL B-ACD:  >>> B-ACD Service Running <<<
    *Mar  1 06:46:32.100: //1//TCL :/tcl_PutsObjCmd: TCL B-ACD:  >>> B-ACD Service Running <<<
    *Mar  1 06:47:32.109: //1//TCL :/tcl_PutsObjCmd: TCL B-ACD:  >>> B-ACD Service Running <<<

  • try to add this command to your dial-peer

     

    dial-peer voice 20 voip

    codec g711ulaw

     

  • Ok I will try and give you the result

  • We'll be waiting!

    Do you have a rack session tonight?

Sign In or Register to comment.