configure vlans on router - not as simple as I thought

Router R1 is connected to router R2 via their fa0/0.  The question asks "R1 and R2’s F0/0 interface should be configured in VLAN 12" (I quote here from the question)

I thought this was a simple step but...

I tried:

1. using sub-interface

interface FastEthernet0/0.12
 encapsulation dot1q 12
 ip add x.x.x.x 255.255.255.0

using subinterface seemed fine for vlan and eirgp protocol. However, in the next steps of the question, it asks using leak-map option in "ip summary-addrress eirgp ..." command. The leak-map option only works on physical interface NOT sub-interface. So there is a conflict here.

Then

2. I tried to use "switchport" command on fa0/0

After entering fa0/0 interface mode, I found out that I could NOT enter "switchport" command. There was no such command available!!

Switchport command makes the interface into a layer 2 interface. However the question clearly asks to configure IP address on the fa0/0 interface

I use GNS3 with 3600 Software (C3640-IK9O3S-M), Version 12.4(13b)

 What did I miss? I am confused. What is the appropriate way to finish this task?

 

 

 

Comments


  • Are R1 , R2 connected back to back or are both of them connected to a switch? If they are connected to a switch then can't you put the switch ports where R1 and R2 are connected in vlan 12? Wouldn't that still satisfy the first requirement i.e.  "R1 and R2’s F0/0 interface should be configured in VLAN 12" ?


  • yes, R1 and R2 are back to back connected via fastethernet. No switch in between. 

     

    You have a good point I didn't think of. Many thanks 

     

    Did you imply that if two back-to-back connected router (via ethernet), there is no need to configure the vlan on their ethernet interfaces, so I can ignore the words of "R1 and R2’s F0/0 interface should be configured in VLAN 12"?

  • It sounds as though they are trying to get you to do something like IRB bridging with a bridge group. You can use the command vlan-id dot1q # on the physical interface to set the vlan and not negate your ip address.

  • Thanks rroark. Per your suggestion. Here are what I did

    bridge irb

    bridge irb

    bridge 12

    inter fa0/0

    vlan-id dot1q 12

    bridge-group 12

    end

    show bridge group

    Now I can see the interface fa0/0 is in bridge group 12.

    It seems bridge group configuration is local router effective only. Because all the protocols between r1 and r2 can work fine with only r1 being configured with the setting above.

     

Sign In or Register to comment.