Task 5.5, Task 5.6

Hi

I seem to be stuck in the seeming easy Task 5.5 , 5.6. I don't seem to be having end-to-end connectivity between VPN_A endpoints.

Rack1R1#sh ip bgp vpn vrf VPN_A
BGP table version is 9, local router ID is 131.2.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 131.2.1.1:1234 (default for vrf VPN_A)
*> 172.16.1.0/24    0.0.0.0                  0         32768 ?
*> 172.16.5.0/24    131.2.5.5                0             0 5 i

Rack1R5#sh ip bgp vpn vrf VPN_A
BGP table version is 5, local router ID is 131.2.5.5
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 131.2.5.5:5 (default for vrf VPN_A)
*> 172.16.1.0/24    131.2.1.1                0             0 1234 ?
*> 172.16.5.0/24    0.0.0.0                  0         32768 i

Rack1R1#sh ip route vrf VPN_A

     172.16.0.0/24 is subnetted, 2 subnets
B       172.16.5.0 [20/0] via 131.2.5.5, 00:30:39
C       172.16.1.0 is directly connected, FastEthernet0/0

Rack1R5#sh ip route vrf VPN_A

     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.5.0 is directly connected, Ethernet0/0

###note- vrf RIB missing the route to other end-point

Rack1R1#sh mpls forw vrf VPN_A
Local  Outgoing      Prefix            Bytes Label   Outgoing   Next Hop
Label  Label or VC   or Tunnel Id      Switched      interface
20     Aggregate     172.16.1.0/24[V]  0             VPN_A

Rack1R5#sh mpls forw vrf VPN_A
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
tag    tag or VC   or Tunnel Id      switched   interface
17     Aggregate   172.16.5.0/24[V]  0

##Note - Outgoing interface on R5 does not show the VPN_A

I am sure, I am missing something and no matter how many times I have looked at it, I have made no progress!! Please help out in finding what is going wrong.

For sake of simplicity, I have made the setup with only R1, R3,R4,R5 and R7 and focussing solely on Task 5.5, 5.6

Configs -





R1

Conf t

ip vrf VPN_A

rd 131.2.1.1:1234

route-target export
131.2.1.1:1234

route-target import
131.2.5.5:5

!

int f0/0

ip vrf forward VPN_A

ip add 172.16.1.1
255.255.255.0

!

router bgp 1234

address-family ipv4
vrf VPN_A

redistribute
connected

end

 

R5

Conf t

ip vrf VPN_A

rd 131.2.5.5:5

route-target export
131.2.5.5:5

route-target import
131.2.1.1:1234

!

int e0/0

ip vrf forwarding
VPN_A

ip add 172.16.5.5
255.255.255.0

!

router bgp 5

address-family ipv4
vrf VPN_A

net 172.16.5.0 mask
255.255.255.0

!

ip route 131.2.1.1
255.255.255.255 131.2.4.4

##Label will be
created with static route

!

int s1/1

mpls label proto ldp

mpls ip

end


 





R4

conf t

ip prefix-list R5_LB
seq 5 permit 131.2.5.5/32

!

route-map
CONNECTED_TO_ISIS permit 10

match ip address
prefix-list R5_LB

!

router isis

redistribute
connected route-map CONNECTED_TO_ISIS level-1

!

int s1/1

mpls ip

end

 

Comments

Sign In or Register to comment.