Filtering Multicast on common ethernet segment

Hello everyone.  I'm working on the IP Multicast lab in Workbook Volume 1.  Everything is set up properly to run Multicast in PIM Sparse Mode, however the routers are sharing a common switch, and the multicast is being flooded to all switches, and looping back to all routers. This is causing the RPF check to fail. (See output below)

Sep 13 05:28:37.712: PIM(0): Received RRP-Reachable on FastEthernet0/0 from 150.1.2.2
Sep 13 05:28:44.479:      for group 224.0.1.40
Sep 13 05:28:44.479: PIM(0): Not RPF interface, group 224.0.1.40
Sep 13 05:28:44.483: PIM(0): Received RP-Reachable on FastEthernet0/0 from 150.1.2.2
Sep 13 05:28:44.483: PIM(0): Received RP-Reachable on FastEthernet0/0 from 150.1.2.2
Sep 13 05:28:44.487:      for group 224.0.1.40
Sep 13 05:28:44.487: PIM(0): Not RPF interface, group 224.0.1.40P-Reachable on FastEthernet0/0 from 150.1.2.2

I've tried filtering the multicast traffic in two ways:

1. access-list 1 permit x.x.x.x (address of PIM neighbor in same subnet on ethernet segment)

When i tried this, routing broke, as the only traffic permitted on the ethernet segment was traffic from x.x.x.x

2. access-list 100 permit pim host x.x.x.x any (address of PIM neighbor in same subnet on ethernet segment)
    access-list 100 deny   pim any any
    access-list 100 permit ip any any

This fixed my routing issue, however now multicast traffic will not be sent past the 2 connected ethernet neighbors.

As soon as I disable the access list, all devices on the common ethernet segment are seen again, and the loop reoccurs.

I'm completely stumped.  If anyone can offer advice I would greatly appreciate it.

Thanks,

Jim

Sign In or Register to comment.