Migrating CIPC Phones from SCCP to SIP : impossible to place calls after migration ?

Hi,

 

I tried to convert two CIPC phones from SCCP to SIP using CUCM and following procedure provided in new workbook (V3.0).

I can convert them without any problem from SCCP to SIP, but when they are in SIP mode after migration, it is no more possible to place any call between them.

When I convert them back to SCCP, I can place calls again.

 

Does anybody know what could cause this issue ? Did I miss something ?

 

Thanks,

SB.

Comments

  • Hello,

    Once you have converted the phones to SIP, have you ensured that they register again? If you are using auto-registration, you must change the auto-register protocol, and restart all relevant devices from the Enterprise Parameters page.

  • Hi Josh,

     

    Concerning, your questions :

    - yes, all CIPC phones do register again correctly, getting their DNs without any problems,

    - the auto-register protocol is set to SIP in Enterprise Parameters page before the migration, as it is required following the procedure in workbooks,

    - when I delete them, they do register again using SIP, and they are listed as SIP phones in CUCM devices.

     

    Any idea ?

     

    Thank for your help,

    SB.

  • Hello,

     

    Thank you for the further information. Are you receiving dial-tone at all? I have tested the config with CIPC and it does work, however there may be an issue with CIPC and registering properly, even though it shows as registered. Try deleting the phone, and letting it reregister.

    Let us know if this helps.

     

     

  • OK, I will try again during my next session at the end of the week and I will post my results after.

     

    Thank you for your answers,

    SB.

  • Hi Josh,

     

    Concerning this issue, I tried again yesterday. Before to go on, you have to know that I used three CIPC phones : one was running directly on my OS (XP) and others were running in two separates XP virtual machines, using Sun VirtualBox with NAT configured for those virtual hosts.

     

    It seems that there was no problem concerning the migration from SCCP to SIP, but only the first CIPC phone (running on my "physical" OS) was able to place calls.

    Both phones running in virtual machines were not able to place or receive SIP calls, as they are able to do it with SCCP...

     

    Any idea ? Why can't I place or receive SIP calls from a virtual machine ? Does it has something to do with NAT ? Is it a CIPC limitation ?

     

    Thank for your help,

    SB.

  • Hello SB,

     

    You should not have an issue with the phones on VMware, I personally have used CIPC in Vmware and it works fine, including working with placing calls. The one issue I have seen that may be affecting your phones is CIPC issues with auto-registration after a firmware conversion. Althought the phone will show as registered, the actual functionality will not work. Delete the phone, then manually add it using the mac-address, and this should resolve your problem.

Sign In or Register to comment.