Task 3.2 PPP

I'm lost on this one. I can't get the up/up with or without the ip address. The SG doesn't give any helpful insight either. Would love to hear the solution to getting this circuit to work.



R5 config

username ROUTER4 password 0 CISCO

interface Serial0/1
ip address 132.2.45.5 255.255.255.0
encapsulation ppp
ppp chap hostname ROUTER5

Serial0/1 132.2.45.5 YES manual up dow

R4 config

username ROUTER5 password 0 CISCO

interface Serial0/1
ip address 132.2.45.4 255.255.255.0
encapsulation ppp
ppp authentication chap
ppp chap hostname ROUTER4

Serial0/1 132.2.45.4 YES manual up dow

R5 Debug

Mar 25 17:55:25.731: Se0/1 PPP: Using default call direction
Mar 25 17:55:25.731: Se0/1 PPP: Treating connection as a dedicated line
Mar 25 17:55:25.731: Se0/1 PPP: Session handle[75000006] Session id[5]
Mar 25 17:55:25.731: Se0/1 PPP: Authorization required
r5(config-if)#

Comments

  • gwood83,

    You have told each router what username and password to expect, but you have not told either router what password to send.

    Try: "ppp chap password CISCO" under the interface configuration on both routers.

    Darrell
  • Greatly appreciated. I got a hour and half left to get it right. Thanks Darrell.
  • I placed the command "ppp chap password CISCO" on both interfaces no joy. Tried just on R4 no joy, tried just on R5 no joy. Same configuration as above just with the "ppp chap password 0 CISCO" command. I'm still getting the exact same debug as well.
  • gwood83,

    Check to make sure there is no space after the CISCO for any of the username or password entries - retype the lines with a return immediately after the CISCO. Leaving a space, the router will expect a password of 'CISCO '.

    Darrell
  • Here is the full config on R4 and R5. It still doesn't work and I made sure there wasn't an extra space and I even added both usernames no joy with or without the extra username.

    r4#sh run
    Building configuration...

    Current configuration : 1959 bytes
    !
    ! Last configuration change at 21:14:57 UTC Tue Mar 25 2008
    ! NVRAM config last updated at 21:15:02 UTC Tue Mar 25 2008
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname r4
    !
    boot-start-marker
    boot-end-marker
    !
    logging buffered 4096 debugging
    logging console notifications
    !
    no aaa new-model
    memory-size iomem 10
    !
    !
    ip cef
    no ip domain lookup
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    username ROUTER5 password 0 CISCO
    username ROUTER4 password 0 CISCO
    !
    !
    !
    !
    !
    !
    interface Loopback0
    ip address 150.1.4.4 255.255.255.0
    !
    interface Ethernet0/0
    no ip address
    shutdown
    half-duplex
    !
    interface Serial0/0
    ip address 132.2.0.4 255.255.255.0
    encapsulation frame-relay
    ip ospf network point-to-multipoint
    no frame-relay inverse-arp IP 405
    no frame-relay inverse-arp IP 413
    !
    interface Ethernet0/1
    ip address 132.2.255.4 255.255.255.0
    half-duplex
    !
    interface Serial0/1
    ip address 132.2.45.4 255.255.255.0
    encapsulation ppp
    ppp authentication chap
    ppp chap hostname ROUTER4
    ppp chap password 0 CISCO
    !
    router eigrp 10
    redistribute ospf 200 metric 1544 1 255 1 1500
    network 132.2.45.4 0.0.0.0
    no auto-summary
    eigrp router-id 150.1.4.4
    !
    router ospf 200
    router-id 150.1.4.4
    log-adjacency-changes
    redistribute eigrp 10 metric 40 subnets
    network 132.2.0.4 0.0.0.0 area 0
    network 132.2.255.0 0.0.0.255 area 255
    network 150.1.4.4 0.0.0.0 area 0
    !
    router bgp 300
    no synchronization
    bgp router-id 150.1.4.4
    bgp log-neighbor-changes
    neighbor 132.2.0.1 remote-as 300
    neighbor 132.2.0.1 route-reflector-client
    neighbor 132.2.0.2 remote-as 300
    neighbor 132.2.0.2 route-reflector-client
    neighbor 132.2.0.3 remote-as 300
    neighbor 132.2.0.3 route-reflector-client
    neighbor 132.2.45.5 remote-as 200
    no auto-summary
    !
    ip http server
    no ip http secure-server
    !
    !
    !
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    line con 0
    logging synchronous
    line aux 0
    line vty 0 4
    !
    !
    end
    ************************************************************

    r5#sh run
    Building configuration...

    Current configuration : 2079 bytes
    !
    ! Last configuration change at 21:14:02 UTC Tue Mar 25 2008
    ! NVRAM config last updated at 21:14:06 UTC Tue Mar 25 2008
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname r5
    !
    boot-start-marker
    boot-end-marker
    !
    logging buffered 4096 debugging
    logging console notifications
    !
    no aaa new-model
    memory-size iomem 10
    !
    !
    ip cef
    no ip domain lookup
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    username ROUTER5 password 0 CISCO
    username ROUTER4 password 0 CISCO
    !
    !
    !
    !
    !
    !
    interface Loopback0
    ip address 150.1.5.5 255.255.255.0
    !
    interface Ethernet0/0
    ip address 132.2.5.5 255.255.255.0
    half-duplex
    !
    interface Serial0/0
    no ip address
    encapsulation frame-relay
    !
    interface Serial0/0.1 point-to-point
    ip address 132.2.35.5 255.255.255.0
    frame-relay interface-dlci 513
    !
    interface Ethernet0/1
    ip address 192.10.2.5 255.255.255.0
    half-duplex
    !
    interface Serial0/1
    ip address 132.2.45.5 255.255.255.0
    encapsulation ppp
    ppp chap hostname ROUTER5
    ppp chap password 0 CISCO
    !
    router eigrp 10
    redistribute connected route-map CONNECTED->EIGRP
    network 132.2.35.5 0.0.0.0
    network 132.2.45.5 0.0.0.0
    network 150.1.5.5 0.0.0.0
    no auto-summary
    eigrp router-id 150.1.5.5
    !
    router bgp 200
    no synchronization
    bgp router-id 150.1.5.5
    bgp log-neighbor-changes
    aggregate-address 132.2.0.0 255.255.0.0 summary-only
    neighbor 132.2.35.3 remote-as 300
    neighbor 132.2.35.3 route-map AS_254_SUMMARY_DENY out
    neighbor 132.2.45.4 remote-as 300
    neighbor 132.2.45.4 route-map AS_254_SUMMARY_DENY out
    neighbor 192.10.2.254 remote-as 254
    neighbor 192.10.2.254 password CISCO
    no auto-summary
    !
    ip http server
    no ip http secure-server
    !
    !
    !
    !
    ip prefix-list DENY_SUMMARY seq 5 permit 132.2.0.0/16
    !
    route-map CONNECTED->EIGRP permit 10
    match interface Ethernet0/0 Ethernet0/1
    !
    route-map AS_254_SUMMARY_DENY deny 10
    match ip address prefix-list DENY_SUMMARY
    !
    route-map AS_254_SUMMARY_DENY permit 100
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    line con 0
    logging synchronous
    line aux 0
    line vty 0 4
    !
    !
    end

    r5#

    Debugs on r5

    Mar 25 21:12:20.258: %SYS-5-CONFIG_I: Configured from console by console
    Mar 25 21:12:21.126: %LINK-3-UPDOWN: Interface Serial0/1, changed state to up
    Mar 25 21:12:21.126: Se0/1 PPP: Using default call direction
    Mar 25 21:12:21.126: Se0/1 PPP: Treating connection as a dedicated line
    Mar 25 21:12:21.126: Se0/1 PPP: Session handle[CC00000F] Session id[15]
    Mar 25 21:12:21.126: Se0/1 PPP: Authorization required
    Mar 25 21:13:11.282: Se0/1 PPP: Authorization required
    Mar 25 21:14:01.458: Se0/1 PPP: Authorization required
  • I'm going to have to do some reading on this tonight has anyone noticed that the Documentation page or the univercd is all screwed up on cisco's website. I was trying to search for this topic and I kept getting redirected to blank pages basically for 12.2 - 4 IOS.
  • I needed to configure the clockrate for one of the interfaces.
  • I am totally lost...

    Why do you need to configure "clockrate" and why only just one interface? Thanks for any help!
  • Is it because on ppp serial link, one end is DTE and the other end is DCE?

    Is it the same as Task3.1, hdlc serial link requires one DTE on one end and one DCE on the other end? Is that why "clockrate 64000" shown in SolnGuide on 3.1?


    Thanks for any clarification!
    Dennis
  • Lojo,

    You are correct - the clockrate xxxxx command is only required on DCE interfaces. Some versions of IOS will give you an error message when you try to configure clockrate on a DTE interface, but others will let you put the command on the wrong interface. The show controllers serial x/x command will show the type of cable connected, and will show clockrate if a DCE cable is present and the clockrate has been configured.

    Darrell
Sign In or Register to comment.