busy signal

for the past three days i have been getting a busy signal when i try to dail from the PSTN to BR2... this is the ouput from debug q931

 


VORack02PSTN#

Jun 17 17:34:25.303: ISDN Se0/1/0:15 Q931: Applying typeplan for sw-type 0x12 is 0x0 0x1, Calling num 911

Jun 17 17:34:25.307: ISDN Se0/1/0:15 Q931: Applying typeplan for sw-type 0x12 is 0x0 0x1, Called num 22323001

Jun 17 17:34:25.307: ISDN Se0/1/0:15 Q931: TX -> SETUP pd = 8  callref = 0x008B

        Bearer Capability i = 0x8090A3

                Standard = CCITT

                Transfer Capability = Speech

                Transfer Mode = Circuit

                Transfer Rate = 64 kbit/s

        Channel ID i = 0xA98381

                Exclusive, Channel 1

        Progress Ind i = 0x8183 - Origination address is non-ISDN

VORack02PSTN#

        Calling Party Number i = 0x0180, '911'

                Plan:ISDN, Type:Unknown

        Called Party Number i = 0x81, '22323001'

                Plan:ISDN, Type:Unknown

Jun 17 17:34:25.327: ISDN Se0/1/0:15 Q931: RX <- RELEASE_COMP pd = 8  callref = 0x808B

        Cause i = 0x80AF - Resource unavailable, unspecified

 

this is the number i am dailing 442322323001

 

this my configs


 



max-ephones 4

max-dn 32

max-conferences 8 gain -6

dspfarm units 0

dspfarm transcode sessions 0

conference software

privacy

no privacy-on-hold

hunt-group report delay 1 hours

hunt-group logout DND

max-redirect 5

dialplan-pattern 1 22323... extension-length 4

cnf-file location: system:

cnf-file option: PER-PHONE-TYPE

network-locale[0] US   (This is the default network locale for this box)

network-locale[1] US

 

so where i am going wrong. Thanks



Comments

  • Hi,

    Is that the complete debugging output? There is just one SETUP message
    here, and there should be at least one or two other returned by the
    destination stattion (e.g. at least RELEASE)

    Regards,
    Petr

    ----- Original Message -----
    From: "cagiva24"
    Sent: Thu, June 18, 2009 4:41
    Subject:[CCIE Voice] busy signal


    for the past three days i have been getting a busy signal when i try to
    dail from
    the PSTN to BR2... this is the ouput from debug q931





    VORack02PSTN#

    Jun 17 17:34:25.303: ISDN Se0/1/0:15 Q931: Applying typeplan for sw-type
    0x12 is 0x0
    0x1, Calling num 911

    Jun 17 17:34:25.307: ISDN Se0/1/0:15 Q931: Applying typeplan for sw-type
    0x12 is 0x0
    0x1, Called num 22323001

    Jun 17 17:34:25.307: ISDN Se0/1/0:15 Q931: TX -> SETUP pd = 8 callref =
    0x008B

    Bearer Capability i = 0x8090A3

    Standard = CCITT

    Transfer Capability = Speech

    Transfer Mode = Circuit

    Transfer Rate = 64 kbit/s

    Channel ID i = 0xA98381

    Exclusive, Channel 1

    Progress Ind i = 0x8183 - Origination address is non-ISDN

    VORack02PSTN#

    Calling Party Number i = 0x0180, '911'

    Plan:ISDN, Type:Unknown

    Called Party Number i = 0x81, '22323001'

    Plan:ISDN, Type:Unknown

    Jun 17 17:34:25.327: ISDN Se0/1/0:15 Q931: RX

    ----- End of original message --
  • That is the message that I got. I tried to follow the configurations step for atleast 3-4 days.. 

     

     


    telephony-services

    max-dn 32

    max-ephone 4

    ip source-address 177.3.21.1

    dial-pattern 1 22323... exten 4<------ could that be wrong?

     

    ---------------

    what number should i be calling and under what ext. on the pstn?

    ----------------

    when i type this:

     

    controller e1 1/0/0

    pri-group time-slots 1-3

     

    Its gives me and error message bout the bytes.however it does come up MULTIPLE_FRAME_ESTABLISHED

     


  •  

    that is the complete output. 

    -------------------------------------------------------

     

    Jun 19 10:35:24.176: ISDN Se0/1/0:15 Q931: Applying typeplan for sw-type 0x12 is 0x0 0x1, Calling num 911

    Jun 19 10:35:24.180: ISDN Se0/1/0:15 Q931: Applying typeplan for sw-type 0x12 is 0x0 0x1, Called num 23333001

    Jun 19 10:35:24.180: ISDN Se0/1/0:15 Q931: TX -> SETUP pd = 8  callref = 0x0085

            Bearer Capability i = 0x8090A3

                    Standard = CCITT

                    Transfer Capability = Speech

                    Transfer Mode = Circuit

                    Transfer Rate = 64 kbit/s

            Channel ID i = 0xA98381

                    Exclusive, Channel 1

            Progress Ind i = 0x8183 - Origination address is non-ISDN

    VORack03PSTN#

            Calling Party Number i = 0x0180, '911'

                    Plan:ISDN, Type:Unknown

            Called Party Number i = 0x81, '23333001'

                    Plan:ISDN, Type:Unknown

    Jun 19 10:35:24.200: ISDN Se0/1/0:15 Q931: RX <- RELEASE_COMP pd = 8  callref = 0x8085

            Cause i = 0x80AF - Resource unavailable, unspecified

    VORack03PSTN#

    Jun 19 10:35:31.236: ISDN Se0/0/0:23 Q931: Ux_DLRelInd: DL_REL_IND received from L2

    VORack03PSTN#


  • OK, well does not help much; try collecting more information at the called
    router (R2 in your case). In addition to this, please provide the
    configurations for R2

    Petr Lapukhov

    ----- Original Message -----
    From: "cagiva24"
    Sent: Fri, June 19, 2009 21:42
    Subject:Re: [CCIE Voice] busy signal


    that is the complete output.

    -------------------------------------------------------



    Jun 19 10:35:24.176: ISDN Se0/1/0:15 Q931: Applying typeplan for sw-type
    0x12 is 0x0
    0x1, Calling num 911

    Jun 19 10:35:24.180: ISDN Se0/1/0:15 Q931: Applying typeplan for sw-type
    0x12 is 0x0
    0x1, Called num 23333001

    Jun 19 10:35:24.180: ISDN Se0/1/0:15 Q931: TX -> SETUP pd = 8 callref =
    0x0085

    Bearer Capability i = 0x8090A3

    Standard = CCITT

    Transfer Capability = Speech

    Transfer Mode = Circuit

    Transfer Rate = 64 kbit/s

    Channel ID i = 0xA98381

    Exclusive, Channel 1

    Progress Ind i = 0x8183 - Origination address is non-ISDN

    VORack03PSTN#

    Calling Party Number i = 0x0180, '911'

    Plan:ISDN, Type:Unknown

    Called Party Number i = 0x81, '23333001'

    Plan:ISDN, Type:Unknown

    Jun 19 10:35:24.200: ISDN Se0/1/0:15 Q931: RX

    ----- End of original message --

  • I am working the new Voice Workbook 

    R3

    logging message-counter syslog

    enable secret 5 $1$OLJ.$wMwpAsR7QbQmZMrxlilcU.

    !

    no aaa new-model

    no network-clock-participate slot 1

    !

    voice-card 0

    !

    voice-card 1

     dspfarm

    !

    dot11 syslog

    ip source-route

    !

    !

    ip cef

    ip dhcp excluded-address 177.3.31.1 177.3.31.99

    ip dhcp excluded-address 177.3.31.111 177.3.31.254

    !

    ip dhcp pool Rack3_Voice

       network 177.3.31.0 255.255.255.0

       default-router 177.3.31.1

       option 150 ip 177.3.31.1

    !

    !

    no ip domain lookup

    no ipv6 cef

    !

    multilink bundle-name authenticated

    !

    !

    !

    !

    isdn switch-type primary-net5

    !

    !

    !

    voice service voip

     allow-connections sip to sip

     sip

      registrar server expires max 1200 min 300

    !

    !

    !

    !

    !

    !

    !

    !

    !

    !

    !

    !

    !

    !

    !

    !

    voice register global

     mode cme

     source-address 177.3.31.1 port 5060

     max-dn 10

     max-pool 5

     load 7960-7940 term60.default

     authenticate register

     tftp-path flash:

     create profile sync 0049084562744308

    !

    voice register dn  1

     number 3002

     name Br2ph2

     label 3002

    !

    voice register pool  1

     id mac 0000.0000.0000

     number 1 dn 1

     dtmf-relay sip-notify

     username br2ph2 password cisco

     codec g711ulaw

    !

    !

    !

    !

    !

    !

    !

    archive

     log config

      hidekeys

    !

    !

    !

    !

    !

    controller E1 1/0/0

     pri-group timeslots 1-3,16

    !

    controller E1 1/0/1

     channel-group 0 timeslots 1-31

    !

    ip tcp synwait-time 5

    !

    !

    !

    !

    interface Loopback0

     ip address 177.3.254.3 255.255.255.255

    !

    interface FastEthernet0/0

     description == To SW2

     no ip address

     duplex auto

     speed auto

    !

    interface FastEthernet0/0.31

     description == Voice VLAN

     encapsulation dot1Q 31

     ip address 177.3.31.1 255.255.255.0

    !

    interface FastEthernet0/0.32

     description == Data VLAN

     encapsulation dot1Q 32

     ip address 177.3.32.1 255.255.255.0

    !

    interface Service-Engine0/0

     no ip address

     shutdown

    !

    interface FastEthernet0/1

     no ip address

     shutdown

     duplex auto

     speed auto

    !

    interface Serial1/0/0:15

     no ip address

     encapsulation hdlc

     isdn switch-type primary-net5

     isdn incoming-voice voice

     isdn outgoing display-ie

     no cdp enable

    !

    interface Serial1/0/1:0

     description == Frame Relay

     no ip address

     encapsulation frame-relay

    !

    interface Serial1/0/1:0.1 point-to-point

     description == To HQ

     ip address 177.0.203.2 255.255.255.0

     snmp trap link-status

     frame-relay interface-dlci 203

    !

    router ospf 1

     log-adjacency-changes

     network 0.0.0.0 255.255.255.255 area 0

    !

    ip forward-protocol nd

    no ip http server

    no ip http secure-server

    !

    !

    !

    cdp timer 6

    !

    !

    !

    !

    !

    !

    tftp-server flash:P003-08-8-00.bin

    tftp-server flash:P003-08-8-00.sbn

    tftp-server flash:P0S3-08-8-00.loads

    tftp-server flash:P0S3-08-8-00.sb2

    !

    control-plane

    !

    !

    !

    voice-port 1/0/0:15

     shutdown

    !

    ccm-manager fax protocol cisco

    !

    mgcp fax t38 ecm

    !

    !

    !

    dial-peer voice 1 pots

     incoming called-number .

     direct-inward-dial

     port 1/0/0:15

    !

    !

    !

    !

    gatekeeper

     shutdown

    !

    !

    telephony-service

     em logout 0:0 0:0 0:0

     max-ephones 4

     max-dn 32

     ip source-address 177.3.31.1 port 2000

     system message CUCME at BR2

     time-zone 5

     time-format 24

     date-format dd-mm-yy

     dialplan-pattern 1 23333... extension-length 4

     max-conferences 8 gain -6

     call-forward pattern .T

     dn-webedit

     time-webedit

     transfer-system full-consult

     transfer-pattern .T

     secondary-dialtone 9

     create cnf-files version-stamp 7960 Jun 19 2009 10:31:38

    !

    !

    ephone-dn  1  dual-line

     number 3001

     label 3001

     description 442323333001

     name Br2ph1

    !

    !

    ephone-dn  2

     number 3005

     label 3005

     description 442323333001

     name Br2ph1

    !

    !

    ephone  1

     device-security-mode none

     mac-address 0019.D1E8.41D7

     username "br2ph1" password cisco

     button  1:1 2:2

     pin 12345

    !

    !

    !

    line con 0

     exec-timeout 0 0

     privilege level 15

     logging synchronous level 0 limit 20

    line aux 0

    line 194

     no activation-character

     no exec

     transport preferred none

     transport input all

     transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh

    line vty 0 4

     password cisco

     login

    !

    scheduler allocate 20000 1000

    ntp master

    end

     

    VORack03R3#debug isdn q931

     


    VORack03R3#

    Jun 19 12:06:31.556: ISDN Se1/0/0:15 Q931: RX <- SETUP pd = 8  callref = 0x008A

            Bearer Capability i = 0x8090A3

                    Standard = CCITT

                    Transfer Capability = Speech

                    Transfer Mode = Circuit

                    Transfer Rate = 64 kbit/s

            Channel ID i = 0xA98381

                    Exclusive, Channel 1

            Progress Ind i = 0x8183 - Origination address is non-ISDN

            Calling Party Number i = 0x0180, '911'

                    Plan:ISDN, Type:Unknown

            Called Party Number i = 0x81, '23333001'

                    Plan:ISDN, Type:Unknown

    Jun 19 12:06:31.560: ISDN Se1/0/0:15 Q931: Received SETUP  callref = 0x808A callID = 0x000B switch = primary-net5 interface = User

    VORack03R3#

    Jun 19 12:06:31.564: ISDN Se1/0/0:15 Q931: TX -> RELEASE_COMP pd = 8  callref = 0x808A

            Cause i = 0x80AF - Resource unavailable, unspecified

     

    ---------------

    pstn debug info:

     


    VORack03PSTN#

    Jun 19 12:08:13.260: ISDN Se0/0/0:23 Q931: Ux_DLRelInd: DL_REL_IND received from L2

    Jun 19 12:08:14.356: ISDN Se0/1/0:15 Q931: Applying typeplan for sw-type 0x12 is 0x0 0x1, Calling num 911

    Jun 19 12:08:14.360: ISDN Se0/1/0:15 Q931: Applying typeplan for sw-type 0x12 is 0x0 0x1, Called num 23333001

    Jun 19 12:08:14.360: ISDN Se0/1/0:15 Q931: TX -> SETUP pd = 8  callref = 0x008B

            Bearer Capability i = 0x8090A3

                    Standard = CCITT

                    Transfer Capability = Speech

                    Transfer Mode = Circuit

                    Transfer Rate = 64 kbit/s

            Channel ID i = 0xA98381

                    Exclusive, Channel 1

            Progress Ind i = 0x8183 - Origination address is non-ISDN

    VORack03PSTN#

            Calling Party Number i = 0x0180, '911'

                    Plan:ISDN, Type:Unknown

            Called Party Number i = 0x81, '23333001'

                    Plan:ISDN, Type:Unknown

    Jun 19 12:08:14.380: ISDN Se0/1/0:15 Q931: RX <- RELEASE_COMP pd = 8  callref = 0x808B

            Cause i = 0x80AF - Resource unavailable, unspecified






  • Hi, 

    voice-port 1/0/0:15 is in shutdown state? Is it part of testing or what?

    dialplan-pattern seems to be ok, so from this perspective everything should be fine

    Have you tried alternative solutions with translation rules/profiles or secondary number under ephone-dn? Dialplan-pattern needs to be removed from telephony-service configurations for alternative solutions.

    Cheers,

    Seba

  • No, its not apart of the testing state. I tried the alterrnative and still no go.When I get to the last digit that is when I hear the busy signal.

  • show isdn status on R3. It appears your voice port is admin down. This
    might be the reason that the remote side never returns any ISDN Q.931
    message in response.



    ----- Original Message -----
    From: "cagiva24"
    Sent: Fri, June 19, 2009 23:12
    Subject:Re: [CCIE Voice] busy signal


    I am working the new Voice Workbook

    R3

    logging message-counter syslog

    enable secret 5 $1$OLJ.$wMwpAsR7QbQmZMrxlilcU.

    !

    no aaa new-model

    no network-clock-participate slot 1

    !

    voice-card 0

    !

    voice-card 1

    dspfarm

    !

    dot11 syslog

    ip source-route

    !

    !

    ip cef

    ip dhcp excluded-address 177.3.31.1 177.3.31.99

    ip dhcp excluded-address 177.3.31.111 177.3.31.254

    !

    ip dhcp pool Rack3_Voice

    network 177.3.31.0 255.255.255.0

    default-router 177.3.31.1

    option 150 ip 177.3.31.1

    !

    !

    no ip domain lookup

    no ipv6 cef

    !

    multilink bundle-name authenticated

    !

    !

    !

    !

    isdn switch-type primary-net5

    !

    !

    !

    voice service voip

    allow-connections sip to sip

    sip

    registrar server expires max 1200 min 300

    !

    !

    !

    !

    !

    !

    !

    !

    !

    !

    !

    !

    !

    !

    !

    !

    voice register global

    mode cme

    source-address 177.3.31.1 port 5060

    max-dn 10

    max-pool 5

    load 7960-7940 term60.default

    authenticate register

    tftp-path flash:

    create profile sync 0049084562744308

    !

    voice register dn 1

    number 3002

    name Br2ph2

    label 3002

    !

    voice register pool 1

    id mac 0000.0000.0000

    number 1 dn 1

    dtmf-relay sip-notify

    username br2ph2 password cisco

    codec g711ulaw

    !

    !

    !

    !

    !

    !

    !

    archive

    log config

    hidekeys

    !

    !

    !

    !

    !

    controller E1 1/0/0

    pri-group timeslots 1-3,16

    !

    controller E1 1/0/1

    channel-group 0 timeslots 1-31

    !

    ip tcp synwait-time 5

    !

    !

    !

    !

    interface Loopback0

    ip address 177.3.254.3 255.255.255.255

    !

    interface FastEthernet0/0

    description == To SW2

    no ip address

    duplex auto

    speed auto

    !

    interface FastEthernet0/0.31

    description == Voice VLAN

    encapsulation dot1Q 31

    ip address 177.3.31.1 255.255.255.0

    !

    interface FastEthernet0/0.32

    description == Data VLAN

    encapsulation dot1Q 32

    ip address 177.3.32.1 255.255.255.0

    !

    interface Service-Engine0/0

    no ip address

    shutdown

    !

    interface FastEthernet0/1

    no ip address

    shutdown

    duplex auto

    speed auto

    !

    interface Serial1/0/0:15

    no ip address

    encapsulation hdlc

    isdn switch-type primary-net5

    isdn incoming-voice voice

    isdn outgoing display-ie

    no cdp enable

    !

    interface Serial1/0/1:0

    description == Frame Relay

    no ip address

    encapsulation frame-relay

    !

    interface Serial1/0/1:0.1 point-to-point

    description == To HQ

    ip address 177.0.203.2 255.255.255.0

    snmp trap link-status

    frame-relay interface-dlci 203

    !

    router ospf 1

    log-adjacency-changes

    network 0.0.0.0 255.255.255.255 area 0

    !

    ip forward-protocol nd

    no ip http server

    no ip http secure-server

    !

    !

    !

    cdp timer 6

    !

    !

    !

    !

    !

    !

    tftp-server flash:P003-08-8-00.bin

    tftp-server flash:P003-08-8-00.sbn

    tftp-server flash:P0S3-08-8-00.loads

    tftp-server flash:P0S3-08-8-00.sb2

    !

    control-plane

    !

    !

    !

    voice-port 1/0/0:15

    shutdown

    !

    ccm-manager fax protocol cisco

    !

    mgcp fax t38 ecm

    !

    !

    !

    dial-peer voice 1 pots

    incoming called-number .

    direct-inward-dial

    port 1/0/0:15

    !

    !

    !

    !

    gatekeeper

    shutdown

    !

    !

    telephony-service

    em logout 0:0 0:0 0:0

    max-ephones 4

    max-dn 32

    ip source-address 177.3.31.1 port 2000

    system message CUCME at BR2

    time-zone 5

    time-format 24

    date-format dd-mm-yy

    dialplan-pattern 1 23333... extension-length 4

    max-conferences 8 gain -6

    call-forward pattern .T

    dn-webedit

    time-webedit

    transfer-system full-consult

    transfer-pattern .T

    secondary-dialtone 9

    create cnf-files version-stamp 7960 Jun 19 2009 10:31:38

    !

    !

    ephone-dn 1 dual-line

    number 3001

    label 3001

    description 442323333001

    name Br2ph1

    !

    !

    ephone-dn 2

    number 3005

    label 3005

    description 442323333001

    name Br2ph1

    !

    !

    ephone 1

    device-security-mode none

    mac-address 0019.D1E8.41D7

    username &quot;br2ph1&quot; password cisco

    button 1:1 2:2

    pin 12345

    !

    !

    !

    line con 0

    exec-timeout 0 0

    privilege level 15

    logging synchronous level 0 limit 20

    line aux 0

    line 194

    no activation-character

    no exec

    transport preferred none

    transport input all

    transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh

    line vty 0 4

    password cisco

    login

    !

    scheduler allocate 20000 1000

    ntp master

    end



    VORack03R3#debug isdn q931





    VORack03R3#

    Jun 19 12:06:31.556: ISDN Se1/0/0:15 Q931: RX RELEASE_COMP pd = 8
    callref = 0x808A

    Cause i = 0x80AF - Resource unavailable, unspecified



    ---------------

    pstn debug info:





    VORack03PSTN#

    Jun 19 12:08:13.260: ISDN Se0/0/0:23 Q931: Ux_DLRelInd: DL_REL_IND
    received from L2

    Jun 19 12:08:14.356: ISDN Se0/1/0:15 Q931: Applying typeplan for sw-type
    0x12 is 0x0
    0x1, Calling num 911

    Jun 19 12:08:14.360: ISDN Se0/1/0:15 Q931: Applying typeplan for sw-type
    0x12 is 0x0
    0x1, Called num 23333001

    Jun 19 12:08:14.360: ISDN Se0/1/0:15 Q931: TX -> SETUP pd = 8 callref =
    0x008B

    Bearer Capability i = 0x8090A3

    Standard = CCITT

    Transfer Capability = Speech

    Transfer Mode = Circuit

    Transfer Rate = 64 kbit/s

    Channel ID i = 0xA98381

    Exclusive, Channel 1

    Progress Ind i = 0x8183 - Origination address is non-ISDN

    VORack03PSTN#

    Calling Party Number i = 0x0180, '911'

    Plan:ISDN, Type:Unknown

    Called Party Number i = 0x81, '23333001'

    Plan:ISDN, Type:Unknown

    Jun 19 12:08:14.380: ISDN Se0/1/0:15 Q931: RX

    ----- End of original message --
  • Thank You So Much. That DId It!!!!

Sign In or Register to comment.