Am I running into a bug ? (3+ hours still no go on a 1 pt task)

I run into this problem that I suspect a bug.  I'm doing a task in Vol3 Lab9 which requires filtering out a default route generated by an OSPF router (R1) from redis into RIP on boundary routers (R4 & R5).

First I put a route-map to set the tag on R1 so when it generates the default route, it will be tagged.  Then I went to R4 and R5, config route-map to do deny 10 for the matching of this tag and permit 20 for everything else.  Applied this config under RIP process using redis statement on both R4 and R5.  The result is no filtering at all.  It permits the default route as well as all other OSPF routes into RIP.  I did sh ip route 0.0.0.0 on R4 and confirmed I see a tag as expected.  R5 initially learned about the default route from OSPF, then it changed to learn from RIP in a while and stays there.  Definitely, the default route is leaked into RIP on R4 then passed on to R5 via RIP.

After some troubleshooting to no avail, I opened the SG.  SG uses prefix list to catch the default route with route-map to block it with the redis statement.  So, I thought, ok, I'll try it.  I changed the config like the SG, and clear the routes and ospf process etc.  Same thing !  The default route still leaks into RIP.  I did show route-map and show ip prefix-list and the output shows no matching.

So, puzzling still, I inserted a route-map statement deny 15 on both R4 and R5 to see if my route-map is not working.  Well, I was surprised to watch the default route still allowed while everything else was denied by line 15.  So, this is strange.  Tried two different matching methods (tag and prefix-list) still can't catch the default route.

IOS is 12.4-16a.  Am I missing something simple ?

Sign In or Register to comment.