Task 4.10 Even Second Octet Filtering

OK, so my very first thought was an offset list to poison the even second octet routes. However, the task speficially states that this should apply to routes coming from BB3. Since the offset list can only be applied generically to the VLAN 783 interface, this would also impact routes coming from SW2. Thus, were you on an even rack, wouldn't you lose the VLAN 8 and lo0 networks also?

I searched high and low for a better answer to this prior to looking at the Solutions Guide. This is the sort of thing that would tear me up in the real lab. Thoughts?

Comments

  • "Since the offset list can only be applied generically to the VLAN 783 interface, this would also impact routes coming from SW2. Thus, were you on an even rack, wouldn't you lose the VLAN 8 and lo0 networks also?"

    Good point.

    VLAN8 (132.1.8.0/24) is on sw2 and advertised via RIP. If we change that interface's second octect to 2 will it be filtered?

    sw2#sh ip int br | i Vlan8
    Vlan8 132.1.8.8 YES NVRAM up up

    sw2#conf t
    Enter configuration commands, one per line. End with CNTL/Z.
    sw2(config)#int vlan8
    sw2(config-if)#ip add 132.2.8.8 255.255.255.0

    sw2#sh ip int br | i Vlan8
    Vlan8 132.2.8.8 YES manual up up
    sw2(config)#router rip
    sw2(config-router)#no network 132.1.0.0
    sw2(config-router)#network 132.2.0.0

    sw1 (before filtering even-numbered second octet routes):
    router rip
    version 2
    network 150.1.0.0
    network 204.12.1.0
    no auto-summary


    sw1#sh ip route rip
    132.2.0.0/24 is subnetted, 1 subnets
    R 132.2.8.0 [120/1] via 204.12.1.8, 00:00:19, Vlan783 <-vlan8<br /> 31.0.0.0/16 is subnetted, 4 subnets
    R 31.3.0.0 [120/1] via 204.12.1.254, 00:00:08, Vlan783
    R 31.2.0.0 [120/1] via 204.12.1.254, 00:00:08, Vlan783
    R 31.1.0.0 [120/1] via 204.12.1.254, 00:00:08, Vlan783
    R 31.0.0.0 [120/1] via 204.12.1.254, 00:00:08, Vlan783
    150.1.0.0/24 is subnetted, 2 subnets
    R 150.1.8.0 [120/1] via 204.12.1.8, 00:00:19, Vlan783
    30.0.0.0/16 is subnetted, 4 subnets
    R 30.2.0.0 [120/1] via 204.12.1.254, 00:00:09, Vlan783
    R 30.3.0.0 [120/1] via 204.12.1.254, 00:00:09, Vlan783
    R 30.0.0.0 [120/1] via 204.12.1.254, 00:00:09, Vlan783
    R 30.1.0.0 [120/1] via 204.12.1.254, 00:00:09, Vlan783


    After filtering:

    router rip
    version 2
    offset-list FILTER_EVEN_ROUTES in 16 Vlan783
    network 150.1.0.0
    network 204.12.1.0
    no auto-summary
    !
    ip access-list standard FILTER_EVEN_ROUTES
    permit 0.0.0.0 255.254.255.255

    sw1#clear ip route *
    sw1#sh ip route rip
    31.0.0.0/16 is subnetted, 2 subnets
    R 31.3.0.0 [120/1] via 204.12.1.254, 00:00:11, Vlan783
    R 31.1.0.0 [120/1] via 204.12.1.254, 00:00:11, Vlan783
    150.1.0.0/24 is subnetted, 2 subnets
    R 150.1.8.0 [120/1] via 204.12.1.8, 00:00:09, Vlan783
    30.0.0.0/16 is subnetted, 2 subnets
    R 30.3.0.0 [120/1] via 204.12.1.254, 00:00:11, Vlan783
    R 30.1.0.0 [120/1] via 204.12.1.254, 00:00:11, Vlan783

    132.2.0.0/24 is gone. Sucks to be on an even rack. :-)
  • Thanks nullroute! I figured that was the case but took so long in getting through this lab the way it was, I didn't stop to put in the extra mile that you did...
Sign In or Register to comment.