Task 4.10

Hi all

This task askes BB3 to receive all the networks without redistributing EIGRP to RIP.The solution is redistributing E0/1 into eigrp.

So what?! what is the result of doing that?then will BB3 receive the networks?!!

Thanks

Comments

  • I think something is missing...the route map is not applied anywhere.....

  • Hi Guys, I think that the task 4.10 : "Without redistributing EIGRP into RIP ensure that BB3 can reach any of
    the IP addresses within the network."  the solution to the inside networks was made in the task  4.3 because of the summarization in RIP.

    The solution in redistributing E0/1 into eigrp  is because RIP doesnt pass the network in inside Eth 0/1 to eigrp because it network is connected and is not in the routing table for RIP. And it is necessary to reach inside networks from the outside of 204.1.12.0/24 network.

    I dont know if I am Right.

    Regards.

    Horacio.

     

     

     

  • I'm a bit confused

    How dooes the BB3 router knwo the routes to R4/R6 Loopbacks etc  if its only running RIP  with no EIGRP redistribution ?

    Are we to assume there is a default static on BB3 ?

  • R3 is announcing the summaries (via auto-summary) for 150.x.0.0/16 and 144.x.0.0/16 networks so it knows all the internal prefixes. The only thing missing for BB3 to reach networks is that inside routers knows of the link between R3 and BB3.

  • Yes, should make use of the RIPv2's default auto-summary feature to summarize 150.1.0.0/16 and 144.1.0.0/16, and the BB3 router will the all it needs to reach back to the internal network.

    To make RIP to the advertise the internal networks, i can either use, with the enabling of the Auto-summary feature.

    router rip
     auto
     network 150.1.0.0
     network 144.1.0.0

    OR:

    router rip

     auto
     redistribute connected metric 5

  • Yes , I agree, did it exaclty the same !

     

  • And it is necessary to reach inside networks from the outside of 204.1.12.0/24 network.

    For example BB3 should be able to reach 192.10.X.0/24, however it has no means to do so with the current solution.

    My initial thought was add a default-information originate under the RIP process - however BB3 would not install this default - as it is prevented via configuration on BB3!  The only other option would be the following -

    ip route 192.10.X.0 255.255.255.0 null0

    router rip
    redistribute static

    But both of these solutions break the "Do's and Don'ts" - "Do not use any static routes, default routes, default networks, or policy routing unless otherwise specified"

  • Hi welshydragon,

    Yes that is correct, the use of static routes breaks the lab do's and don'ts

  • Yes that is correct, the use of static routes breaks the lab do's and don'ts

    So therefore you can't solve the problem unless of course you redistribute EIGRP into RIP - which again isn't allowed.

    Based on the IGP diagram - BB3 must be able to reach 192.10.X.0/24 and the networks advertised by BB2 - except we can't implement an allowed solution to achieve full reachability!

  • In task 4.4, creating two different ospf processes ion sw2 and perform redistribution between can also achieve the same result. Ihis is done because in section 4.5 tunnel and virtual links are not allowed on sw2 and R1.

    In task 4.10, we can simply add connected interface f0/1 and lo0 into eigrp while redistributing rip into eigrp. By doing this way BB3 had all routes including 192.10.x.0/24 to have full reachability of the network from bb3.

  • In task 4.4, creating two different ospf processes ion sw2 and perform redistribution between can also achieve the same result. Ihis is done because in section 4.5 tunnel and virtual links are not allowed on sw2 and R1.

    Agreed :-)

    In task 4.10, we can simply add connected interface f0/1 and lo0 into eigrp while redistributing rip into eigrp. By doing this way BB3 had all routes including 192.10.x.0/24 to have full reachability of the network from bb3.

    I don't agree with this - please can you elaborate how "Without redistributing EIGRP into RIP  ensure that BB3 can reach any of the IP addresses within the network" can be solved by the above solution?

    BB2 would be able to reach BB3 by virtue of "Perform redistribution of RIP into EIGRP on R3", but BB3 would not be able to return the traffic back to BB2.

    As stated in an earlier post the only way this would work if BB3 would accept a default route form R3 - however look at the following config on BB3 -

    router rip
    ...
    distribute-list prefix DENY_DEFAULT in
    ...
    !
    ip prefix-list DENY_DEFAULT seq 5 deny 0.0.0.0/0
    ip prefix-list DENY_DEFAULT seq 10 permit 0.0.0.0/0 le 32
    !

    I know it's not good form to look at backbone router configurations - but I wanted to know why my default route from R3 was not being accepted!

    So the only solution is to redistribute EIGRP into RIP - except this is not allowed as per the two task requirements!

Sign In or Register to comment.