ATT in ISIS

Hello,

 

Normally ISIS L1/L2 will set att bit and due to that L1 router will have default route installed in routing tabel. now how we can avoid advertising ATT bit?

 

It means in which case L1/L2 will not set ATT bit in update?

 

thanks,

Dev

Comments

  • Hi,

    create an "clns filter-set" rule to deny the L2 network "YY.XXX", then create a route-map matching this and under the ISIS process config apply the route-map to set-attached-bit. For example:

    clns filter-set 1 deny XX.YY

    route-map ISISMAP perm 10

    match clns address 1

    set-attached-bit route-map ISISMAP

    You will have to leak the L2 network into L1 or else you will lose reachablity to it.

    HTH,

    mpls-te

  • MPLS-TE,

     

    Thanks for your reply, I will try it in my LAB.

     

    thanks,

    Dev

  • hello

    Does this YY.XXXX has to be in database or clns routing table?

    I am trying to set ATT bit when my 47.0002 area is reachable. But router clears ATT bit though 47.0002 is present on database

    Without  route-map

    R2#sh isis data

    IS-IS Level-1 Link State Database:
    LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
    R2.00-00            * 0x0000001D   0x98EB        946               1/0/0
    R3.00-00              0x0000000C   0x2419        921               0/0/0
    R5.00-00              0x0000000F   0xE93C        909               0/0/0
    IS-IS Level-2 Link State Database:
    LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
    R1.00-00              0x0000000D   0x9ABB        938               0/0/0
    R2.00-00            * 0x0000001C   0xB67E        1114              0/0/0
    R4.00-00              0x0000000F   0xF734        1128              0/0/0
    R2#

    after following configuration

    clns filter-set deffil permit 47.0002

    router isis
     net 47.0001.0000.0000.0002.00
     set-attached-bit route-map def-map
    route-map def-map permit 10
     match clns address deffil

    R2#sh isis data

    IS-IS Level-1 Link State Database:
    LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
    R2.00-00            * 0x0000001E   0x8EFC        1191              0/0/0
    R3.00-00              0x0000000C   0x2419        876               0/0/0
    R5.00-00              0x0000000F   0xE93C        864               0/0/0
    IS-IS Level-2 Link State Database:
    LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
    R1.00-00              0x0000000D   0x9ABB        893               0/0/0
    R2.00-00            * 0x0000001C   0xB67E        1069              0/0/0
    R4.00-00              0x0000000F   0xF734        1083              0/0/0
    R2#sh isis data det R1.00-00


    IS-IS Level-2 LSP R1.00-00
    LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
    R1.00-00              0x0000000D   0x9ABB        883               0/0/0
      Area Address: 47.0002
      NLPID:        0xCC
      Hostname: R1
      IP Address:   1.1.1.1
      Metric: 10         IS R2.00
      Metric: 10         IP 1.1.1.0 255.255.255.0
      Metric: 10         IP 1.1.12.0 255.255.255.0
    R2#sh clns route
    Codes: C - connected, S - static, d - DecnetIV
           I - ISO-IGRP,  i - IS-IS,  e - ES-IS

    C  47.0001.0000.0000.0002.00 [1/0], Local IS-IS NET
    C  47.0001 [2/0], Local IS-IS Area

    R2#

    thank you

  • <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">








    Enable "clns routing" and try again.

     
    <!>

    Regards,

    Antonio Soares,
    CCIE #18473 (R&S)
    [email protected]

    Antonio Soares, CCIE #18473 (RS/SP/DC)
    [email protected]
    http://www.ccie18473.net

  • Hello

    In fact I have tried with 'clns routing' globally and 'clns enable' on interface. But no luck. This is 12.2(25)S9 and dynamips.

    thank you

  • <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">








    Try to add "clns router isis" under the interfaces. And
    show us the "show clns route" output.

     
    <!>

    Regards,

    Antonio Soares,
    CCIE #18473 (R&S)
    [email protected]

    Antonio Soares, CCIE #18473 (RS/SP/DC)
    [email protected]
    http://www.ccie18473.net

  • Seems like YY.XXXX has to be on clns routing table. After I configured 'clns router isis' on interface I got yy.xxxx entry on clns routing table and router set/clear ATT bit as expected.

    R2#sh clns route
    Codes: C - connected, S - static, d - DecnetIV
           I - ISO-IGRP,  i - IS-IS,  e - ES-IS
           B - BGP,       b - eBGP-neighbor

    C  47.0001.0000.0000.0002.00 [1/0], Local IS-IS NET
    C  47.0001 [2/0], Local IS-IS Area

    i  47.0002 [110/10]
          via R1, Serial1/0
    R2#sh isis data 

    IS-IS Level-1 Link State Database:
    LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
    R2.00-00            * 0x0000000A   0x374D        1096              1/0/0
    R3.00-00              0x00000005   0x3212        579               0/0/0

    without clns routing table entry ATT bit not set

    R2#sh isis data     

    IS-IS Level-1 Link State Database:
    LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
    R2.00-00            * 0x0000000C   0xB27D        1193              0/0/0
    R3.00-00              0x00000005   0x3212        555               0/0/0
    IS-IS Level-2 Link State Database:
    LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
    R1.00-00              0x00000008   0x8157        1070              0/0/0
    R2.00-00            * 0x00000009   0x0FA3        1187              0/0/0
    R2#sh clns route
    Codes: C - connected, S - static, d - DecnetIV
           I - ISO-IGRP,  i - IS-IS,  e - ES-IS
           B - BGP,       b - eBGP-neighbor

    C  47.0001.0000.0000.0002.00 [1/0], Local IS-IS NET
    C  47.0001 [2/0], Local IS-IS Area

    R2#

Sign In or Register to comment.