ATM Problem

Hi all;

i configure the  ATM switch LS as in the initial configuration but I cannot reach any point over the ATM cloud .

if any one can help i will be greatful below the configuration for the ATM swith and one of the routers as example:

ATM SWITCH:

ATM-SWITCH#sh ip int br
Interface                  IP-Address      OK? Method Status                Protocol
ATM0/0/0                   150.1.101.254   YES NVRAM  up                    up     
ATM0/0/1                   150.1.102.254   YES NVRAM  up                    up     
ATM0/0/2                   150.1.109.254   YES NVRAM  up                    up     
ATM0/0/3                   unassigned      YES NVRAM  down                  down   
ATM0                       unassigned      YES NVRAM  up                    up     
Ethernet0                  unassigned      YES NVRAM  up                    down   
Loopback0                  150.100.100.254 YES NVRAM  up                    up     
ATM-SWITCH#
ATM-SWITCH#
ATM-SWITCH#sh ver
Cisco Internetwork Operating System Software
IOS (tm) LS1010 WA4-5 Software (LS1010-WPK2-M), Version 12.1(27b)E3, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2007 by cisco Systems, Inc.
Compiled Mon 06-Aug-07 21:12 by hqluong
Image text-base: 0x60010F98, data-base: 0x61032000

ROM: System Bootstrap, Version 11.2(1.4.WA3.0) [integ 1.4.WA3.0], RELEASE SOFTWARE
ROM: LS1010 WA4-5 Software (LS1010-WPK2-M), Version 12.1(27b)E3, RELEASE SOFTWARE (fc1)

ATM-SWITCH uptime is 50 minutes
System returned to ROM by reload at 10:46:15 UTC Fri Mar 27 2009
System image file is "bootflash:ls1010-wpk2-mz.121-27b.E3.bin"



This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
[email protected].

cisco LS1010 (R4600) processor with 65536K bytes of memory.
R4700 CPU at 100Mhz, Implementation 33, Rev 1.0
Last reset from power-on
1 Ethernet/IEEE 802.3 interface(s)
5 ATM network interface(s)
123K bytes of non-volatile configuration memory.

47040K bytes of ATA PCMCIA card at slot 0 (Sector size 512 bytes).
Configuration register is 0x2102

ATM-SWITCH#
ATM-SWITCH#
ATM-SWITCH#
ATM-SWITCH#sh urn
               ^
% Invalid input detected at '^' marker.

ATM-SWITCH#sh run
Building configuration...

Current configuration : 1625 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname ATM-SWITCH
!
!
sdm ipqos zero
sdm policy 0
ip subnet-zero
no ip domain-lookup
!
ip ssh time-out 120
ip ssh authentication-retries 3
!
atm address 47.0091.8100.0000.00e0.1e65.2101.00e0.1e65.2101.00
atm address 47.0091.8100.0000.0060.705c.d601.0060.705c.d601.00
atm router pnni
 no aesa embedded-number left-justified
 node 1 level 56 lowest
  redistribute atm-static
!
clns routing
!
!
!
interface Loopback0
 ip address 150.100.100.254 255.255.255.255
 ip router isis
!
interface ATM0/0/0
 description Rack1R1
 ip address 150.1.101.254 255.255.255.0
 ip router isis
 logging event subif-link-status
 no atm ilmi-keepalive
 tag-switching atm control-vc 1 64
 tag-switching ip
!
interface ATM0/0/1
 description Rack1R2
 ip address 150.1.102.254 255.255.255.0
 ip router isis
 logging event subif-link-status
 no atm ilmi-keepalive
 atm pvc 0 201  interface  ATM0/0/0 0 102
 tag-switching ip
!
interface ATM0/0/2
 description Rack1R9
 ip address 150.1.109.254 255.255.255.0
 ip router isis
 logging event subif-link-status
 no atm ilmi-keepalive
 atm pvc 0 901  interface  ATM0/0/0 0 109
 atm pvc 0 902  interface  ATM0/0/1 0 209
 tag-switching ip
!
interface ATM0/0/3
 no ip address
!
interface ATM0
 no ip address
!
interface Ethernet0
 no ip address
!
router ospf 1
 log-adjacency-changes
 network 0.0.0.0 255.255.255.255 area 0
!
router isis
 net 49.9999.9999.9999.9999.00
!
ip classless
no ip http server
!
!
!
line con 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end
         
ATM-SWITCH#ping 150.1.101.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 150.1.101.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
ATM-SWITCH#ping 150.1.102.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 150.1.102.2, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
ATM-SWITCH#ping 150.1.109.9

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 150.1.109.9, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

 

 

 

R1:

R1#
R1#sh ip int br
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        10.1.17.1       YES manual up                    up     
FastEthernet0/1        unassigned      YES TFTP   administratively down down   
ATM1/0                 unassigned      YES manual up                    up     
ATM1/0.1               150.1.101.1     YES manual up                    up     
Serial3/0              unassigned      YES TFTP   administratively down down   
Serial3/1              unassigned      YES TFTP   administratively down down   
Serial3/2              unassigned      YES TFTP   administratively down down   
Serial3/3              unassigned      YES TFTP   administratively down down   
Serial3/4              unassigned      YES TFTP   administratively down down   
Serial3/5              unassigned      YES TFTP   administratively down down   
Serial3/6              unassigned      YES TFTP   administratively down down   
Serial3/7              unassigned      YES TFTP   administratively down down   
Loopback0              150.1.1.1       YES manual up                    up     
R1#
R1#
R1#sh ver
Cisco IOS Software, 7200 Software (C7200-K91P-M), Version 12.2(25)S9, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2006 by Cisco Systems, Inc.
Compiled Tue 28-Mar-06 23:12 by alnguyen

ROM: System Bootstrap, Version 12.2(4r)B2, RELEASE SOFTWARE (fc2)
BOOTLDR: 7200 Software (C7200-KBOOT-M), Version 12.1(8a)E, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)

 R1 uptime is 23 hours, 30 minutes
System returned to ROM by reload at 07:38:09 UTC Wed Mar 25 2009
System image file is "disk0:c7200-k91p-mz.122-25.S9.bin"


This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.
         
A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
[email protected].

Cisco 7206VXR (NPE400) processor (revision A) with 491520K/32768K bytes of memory.
Processor board ID 29814676
R7000 CPU at 350Mhz, Implementation 39, Rev 3.3, 256KB L2 Cache
6 slot VXR midplane, Version 2.7

Last reset from power-on

PCI bus mb0_mb1 (Slots 0, 1, 3 and 5) has a capacity of 600 bandwidth points.
Current configuration on bus mb0_mb1 has a total of 700 bandwidth points.
The set of PA-2FE, PA-POS-2OC3, and I/O-2FE qualify for "half
bandwidth points" consideration, when full bandwidth point counting
results in oversubscription, under the condition that only one of the
two ports is used. With this adjustment, current configuration on bus
mb0_mb1 has a total of 500 bandwidth points.
This configuration is within the PCI bus capacity and is supported
under the above condition.

PCI bus mb2 (Slots 2, 4, 6) has a capacity of 600 bandwidth points.
Current configuration on bus mb2 has a total of 0 bandwidth points
This configuration is within the PCI bus capacity and is supported.

Please refer to the following document "Cisco 7200 Series Port
Adaptor Hardware Configuration Guidelines" on CCO <www.cisco.com>,
for c7200 bandwidth points oversubscription/usage guidelines.


2 FastEthernet interfaces
8 Serial interfaces
1 ATM interface
125K bytes of NVRAM.

47040K bytes of ATA PCMCIA card at slot 0 (Sector size 512 bytes).
8192K bytes of Flash internal SIMM (Sector size 256K).
Configuration register is 0x2102

R1#
R1#
R1#
R1#sh run
Building configuration...

Current configuration : 1836 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
ip subnet-zero
ip cef
!
!
no ip domain-lookup
!
clns routing
no mpls traffic-eng auto-bw timers frequency 0
call rsvp-sync
!        
!
!
!
!
!
!
!
interface Loopback0
 ip address 150.1.1.1 255.255.255.255
 ip router isis
!
interface FastEthernet0/0
 ip address 10.1.17.1 255.255.255.0
 duplex full
 speed 100
 no clns route-cache
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
 no clns route-cache
!
interface ATM1/0
 mtu 1500
 no ip address
 no atm enable-ilmi-trap
 clns enable
!
interface ATM1/0.1 mpls
 ip address 150.1.101.1 255.255.255.0
 ip router isis
 no atm enable-ilmi-trap
 mpls atm control-vc 1 64
!
interface Serial3/0
 no ip address
 encapsulation frame-relay
 shutdown
 no fair-queue
 serial restart-delay 0
 no clns route-cache
!
interface Serial3/1
 no ip address
 shutdown
 serial restart-delay 0
 no clns route-cache
!
interface Serial3/2
 no ip address
 shutdown
 serial restart-delay 0
 no clns route-cache
!
interface Serial3/3
 no ip address
 shutdown
 serial restart-delay 0
 no clns route-cache
!
interface Serial3/4
 no ip address
 shutdown
 serial restart-delay 0
 no clns route-cache
!
interface Serial3/5
 no ip address
 shutdown
 serial restart-delay 0
 no clns route-cache
!
interface Serial3/6
 no ip address
 shutdown
 serial restart-delay 0
 no clns route-cache
!
interface Serial3/7
 no ip address
 shutdown
 serial restart-delay 0
 no clns route-cache
!
router isis
 net 49.0001.0000.0000.0001.00
 is-type level-2-only
!
ip classless
!        
no ip http server
!
!
!
!
!
!
control-plane
!
!
dial-peer cor custom
!
!
!
!
line con 0
 privilege level 15
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 no login
!        
!
end

R1#                                         
R1#ping 150.1.101.254

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 150.1.101.254, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
R1#
R1#
R1#
R1#sh ip rou
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 1 subnets
C       10.1.17.0 is directly connected, FastEthernet0/0
     150.1.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       150.1.1.1/32 is directly connected, Loopback0
C       150.1.101.0/24 is directly connected, ATM1/0.1
R1#

 

Comments

  • hi

    maybe MPLS isn't running correctly under R1 - try adding "mpls ip" under "conf t" and under the specific interface (ATM1/0.1).

    also try adding "mpls label protocol tdp" or "mpls label protocol ldp" on both routers and then issue this command and post its output here - "show mpls forwarding-table" - on both R1 and the ATM router

     

    HTH

  • hi it worked perfictly!!!!!!!

    thanksss alot man

  • Can someone explain why we need to enable 'mpls ip' to ping the ATM switch interface (i.e 150.1.101.254) from R1

     

     

     

  • Can someone explain why we need to enable 'mpls ip' to ping the ATM switch interface (i.e 150.1.101.254) from R1

     

     

     

    coz you configured R1 as cell mode mpls, if you use pvc, then you don't have to

  • OK..got it,thanks.You mean if i configure as point-to-point subinterface then i dont have to.

    Can you suggest some tutorial/books to understand ATM MPLS

  • OK..got it,thanks.You mean if i configure as point-to-point subinterface then i dont have to.

    Can you suggest some tutorial/books to understand ATM MPLS

    Yeah, when you use cell mode MPLS for your MPLS ATM subinterface, the data plane would expect forward the packets based on the LFIB, but if you don't have labels for the prefixes, the LFIB won't work.

    <<MPLS Configuration on Cisco IOS software>> chapter 2 is pretty good.

    Bo

Sign In or Register to comment.