Multicast VPN GRE tunnel not selecting lo0 - HELP!!

Hi,

Going through Lab 8 on RackRentals real hardware and noticed something I've never seen before and suspect IOS bug/hardware.

When I enter the 'mdt default x.x.x.x' command under the VRF on R2 (7200) I get the following message:

 


SPRack2R2(config)#ip vrf AS200

SPRack2R2(config-vrf)#mdt default 232.200.200.200

%MDT-4-LBSRC: VRF AS200: MDT Serial2/0.12 uses source address 158.2.12.2 from a non-loopback interface

 

PIM sparse mode is enabled on all relevant interfaces and on lo0 (interestingly PIM is NOT enabled on the interface the tunnel uses for MDT source!)

I cannot make R2 select the lo0 interface as the source for love nor money - rebooted, taken off commands, re-added etc. Each and every time R2 insists on picking a random serial interface to address the MDT tunnel. This of course screws the rest of the multicast section as nobody can peer with R2 via PIM for the VRF multicast traffic across the backbone.

All BGP (IPv4 and VPNv4) are sourced from R2 lo0 and everything else in lab is working fine - verified config with solutions guide etc.

Any one else ever had this problem - did you ever fix it or assume it was a bug and moved on?

 

Code level:

Cisco IOS Software, 7200 Software (C7200-K91P-M), Version 12.2(25)S9

 

Thanks

 

Comments



  • Re: [CCIE SP] Multicast VPN GRE tunnel not selecting lo0 - HELP!!


    Try changing it to 239.x.x.x and see what it does. I am perhaps wondering if there is an issue because of SSM as IOS SSM Multicast uses the 232.0.0.0/8 range and you are running PIM sparse.













    On 3/11/09 4:50 PM, "pkg" <[email protected]> wrote:



    Hi,



    Going through Lab 8 on RackRentals real hardware and noticed something I've never seen before and suspect IOS bug/hardware.



    When I enter the 'mdt default x.x.x.x' command under the VRF on R2 (7200) I get the following message:



     



    SPRack2R2(config)#ip vrf AS200



    SPRack2R2(config-vrf)#mdt default 232.200.200.200



    %MDT-4-LBSRC: VRF AS200: MDT Serial2/0.12 uses source address 158.2.12.2 from a non-loopback interface



     



    PIM sparse mode is enabled on all relevant interfaces and on lo0 (interestingly PIM is NOT enabled on the interface the tunnel uses for MDT source!)



    I cannot make R2 select the lo0 interface as the source for love nor money - rebooted, taken off commands, re-added etc. Each and every time R2 insists on picking a random serial interface to address the MDT tunnel. This of course screws the rest of the multicast section as nobody can peer with R2 via PIM for the VRF multicast traffic across the backbone.



    All BGP (IPv4 and VPNv4) are sourced from R2 lo0 and everything else in lab is working fine - verified config with solutions guide etc.



    Any one else ever had this problem - did you ever fix it or assume it was a bug and moved on?



     



    Code level:



    Cisco IOS Software, 7200 Software (C7200-K91P-M), Version 12.2(25)S9



     



    Thanks



     









    Internetwork Expert - The Industry Leader in CCIE Preparation

    http://www.internetworkexpert.com



    Subscription information may be found at:

    http://www.ieoc.com/forums/ForumSubscriptions.aspx



  • Hi,

    All routers have 'ip pim ssm default' configured.

    I tried using 239.2.2.2 instead to see if the tunnel would at least use the lo0 but no joy - same problem of it selecting a serial interface that isnt running PIM.

    I'm convinced this is a bug on the 7200 platform as I've done this many many times and never seen this message.






  • Did you try setting the "nei x.x.x.x update-source loopback0" under router bgp of the vpnv4 neighbors.    Also the very first neighbor in address-family vpnv4 needs to have the correct loopback.   Otherwise this will mess up the tunnels. 
     



    From: [email protected]
    To: [email protected]
    Date: Wed, 11 Mar 2009 07:50:42 -0700
    Subject: [CCIE SP] Multicast VPN GRE tunnel not selecting lo0 - HELP!!




    Hi,

    Going through Lab 8 on RackRentals real hardware and noticed something I've never seen before and suspect IOS bug/hardware.

    When I enter the 'mdt default x.x.x.x' command under the VRF on R2 (7200) I get the following message:

     

    SPRack2R2(config)#ip vrf AS200

    SPRack2R2(config-vrf)#mdt default 232.200.200.200

    %MDT-4-LBSRC: VRF AS200: MDT Serial2/0.12 uses source address 158.2.12.2 from a non-loopback interface

     



    PIM sparse mode is enabled on all relevant interfaces and on lo0 (interestingly PIM is NOT enabled on the interface the tunnel uses for MDT source!)

    I cannot make R2 select the lo0 interface as the source for love nor money - rebooted, taken off commands, re-added etc. Each and every time R2 insists on picking a random serial interface to address the MDT tunnel. This of course screws the rest of the multicast section as nobody can peer with R2 via PIM for the VRF multicast traffic across the backbone.

    All BGP (IPv4 and VPNv4) are sourced from R2 lo0 and everything else in lab is working fine - verified config with solutions guide etc.

    Any one else ever had this problem - did you ever fix it or assume it was a bug and moved on?

     

    Code level:

    Cisco IOS Software, 7200 Software (C7200-K91P-M), Version 12.2(25)S9

     

    Thanks

     




    Internetwork Expert - The Industry Leader in CCIE Preparation
    http://www.internetworkexpert.com

    Subscription information may be found at:
    http://www.ieoc.com/forums/ForumSubscriptions.aspx


    Hotmail® is up to 70% faster. Now good news travels really fast. Find out more.
  • Hi,

    you can use the command "bgp next-hop LopbackX" under the "ip vrf"
    configuration
    to enforce the use of LoopbackX for MDT interface source (one of the
    side-effect of this command).

    Petr

    ----- Original Message -----
    From: "pkg"
    Sent: Wed, March 11, 2009 18:50
    Subject:[CCIE SP] Multicast VPN GRE tunnel not selecting lo0 - HELP!!


    Hi,

    Going through Lab 8 on RackRentals real hardware and noticed something
    I've never
    seen before and suspect IOS bug/hardware.

    When I enter the 'mdt default x.x.x.x' command under the VRF on R2 (7200)
    I get the
    following message:





    SPRack2R2(config)#ip vrf AS200

    SPRack2R2(config-vrf)#mdt default 232.200.200.200

    %MDT-4-LBSRC: VRF AS200: MDT Serial2/0.12 uses source address 158.2.12.2
    from a
    non-loopback interface




    PIM sparse mode is enabled on all relevant interfaces and on lo0
    (interestingly PIM
    is NOT enabled on the interface the tunnel uses for MDT source!)

    I cannot make R2 select the lo0 interface as the source for love nor money -
    rebooted, taken off commands, re-added etc. Each and every time R2 insists on
    picking a random serial interface to address the MDT tunnel. This of
    course screws
    the rest of the multicast section as nobody can peer with R2 via PIM for
    the VRF
    multicast traffic across the backbone.

    All BGP (IPv4 and VPNv4) are sourced from R2 lo0 and everything else in
    lab is
    working fine - verified config with solutions guide etc.

    Any one else ever had this problem - did you ever fix it or assume it was
    a bug and
    moved on?



    Code level:

    Cisco IOS Software, 7200 Software (C7200-K91P-M), Version 12.2(25)S9



    Thanks



    --
    View this message online at: http://ieoc.com/forums/p/5543/18808.aspx#18808
    --
    Internetwork Expert - The Industry Leader in CCIE Preparation
    http://www.internetworkexpert.com

    Subscription information may be found at:
    http://www.ieoc.com/forums/ForumSubscriptions.aspx

    ----- End of original message --
  • Thanks

     

    I'll try and recreate when next rental is due and try the 'bgp next-hop' under the VRF to see if that can override this strange behaviour.

    All neighbors had the correct update-source (response to earlier question) for VPNv4 peerings but it was via a peer group rather than directly (possible conflict maybe?) applied to each neighbor as per the Lab question.

  • Hi

    Have same problem on some routers in SP network configured with PIM SM and MDT.

     

    If IOS permits: try to enable

    router bgp xxx

    address-family ipv4 mdt

    nei....

    Had same problem on couple of 7609 running SRA, adding 'address-family ipv4 mdt' now seems to have solved problem

     Before adding this Tunnel0 selected another loopback

     

    Also observed another problem: Sometimes tunnel does not come up until reboot.

     

    Jon

     

Sign In or Register to comment.