PPPoE if PPPoE enable not supported ???

Have someone configured PPPoE client over FastE interface where "pppoe enable" or any other "ppp..." command is not supported ???

whenever I go in interface configuration mode, and try "(config-if)# ppp? " I get "...unrecognized command... " ???

 

is there a way to configure PPPoE Client without configuring "pppoe enable " under interface ? maybe some legacy cnfig (on 2600 platform) ?

 

Thanks

Comments

  • Did you try "

    pppoe-client dial-pool-number"?

    thanks,
    Dev
  • Would this be configured under the FE interface ?

     

    Thanks

  • Yes that will be under interface configuration mode!

    Please let me know if works! if it doesnt work then please post IOS version you are running!

     

    thanks,

    Dev

  • Thanks Dev,

    any time I put "ppp?" under interface, it was saying "unrecognized command".... no command with PPPxxxxx exists under interface...

    2600 with 12.2(xx)Tyy if I remember well ...

     

     

  • Hi,

    This is a good question!

    did you enabled vpdn:

    something like:

    !
    vpdn enable
    !
    vpdn-group PPPoE
     accecpt-dialin
      protocol pppoe
    !

    If you have the specific IOS somewhere  I could try out a setup.  On cisco.com I cannot download an c2600 12.2.t anyting IOS.

     

    HTH
     Ueli

     

  • <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2//EN">


    AW: Re: [CCIE SP] PPPoE if PPPoE enable not supported ???


    I have done that on the server side (VPDN & Virt-Templ),..

    .... and then created Dialer on the Client...



    Finally when I try to put that dialer on the client's FE  .... ppp/pppoe it's unrecognised command...



    I don't know if there are some dialer-pool or dialer-group tweaks here, in global config... (Note: dialerxxxxx... is also NOT recognised coomand under interface ...)



    Just driving me crazy...







    Cisco GmbH

    Stefan Arsovski

    [email protected];

    +49 173 38 10 994;



     -----Original Message-----

    From:   Ueli [mailto:[email protected]]

    Sent:   Wednesday, March 11, 2009 10:05 AM GMT Standard Time

    To:     Stefan Arsovski (sarsovsk)

    Subject:        Re: [CCIE SP] PPPoE if PPPoE enable not supported ???



    Hi,



    This is a good question!



    did you enabled vpdn:



    something like:



    !

    vpdn enable

    !

    vpdn-group PPPoE

     accecpt-dialin

      protocol pppoe

    !



    If you have the specific IOS somewhere  I could try out a setup.  On cisco.com I cannot download an c2600 12.2.t anyting IOS.







    HTH

     Ueli













    Internetwork Expert - The Industry Leader in CCIE Preparation

    http://www.internetworkexpert.com



    Subscription information may be found at:

    http://www.ieoc.com/forums/ForumSubscriptions.aspx





  • W: Re: [CCIE SP] PPPoE if PPPoE enable not supported ???

    I have done that on the server side (VPDN & Virt-Templ),..

    .... and then created Dialer on the Client...



    Finally when I try to put that dialer on the client's FE  .... ppp/pppoe it's unrecognised command...



    I don't know if there are some dialer-pool or dialer-group tweaks here, in global config... (Note: dialerxxxxx... is also NOT recognised coomand under interface ...)



    Just driving me crazy...

     

    I'll just could get an old  12.2.T image for a c2600.

    IOS (tm) C2600 Software (C2600-IK9O3S3-M), Version 12.2(15)T17, RELEASE SOFTWARE (fc1)


    And it's crazy, the pppoe-commands are available:
    Rack1R0(config)#int f0/0
    Rack1R0(config-if)#pppoe?
    pppoe  pppoe-client 
    !

    I'know, some days ago I did have the same problem, pppoe doesn't show up under the ethernet interface. And it was a 2600-cisco with a 12.2.T image installed.

    Ueli

  • I think I had the same issue with 12.2(11)T11. I can't seem to find the code anymore...

  • vpdn enable
    !
    vpdn-group 1
     accept-dialin
      protocol pppoe

     

    interface FastEthernet0/0
     no ip address
     pppoe enable
     pppoe-client dial-pool-number 1
    !

    interface Dialer1
     mtu 1492
     ip address dhcp
     encapsulation ppp
     dialer pool 1
     dialer idle-timeout 0
     dialer persistent
     dialer-group 1

     

  • Here you are the sollution.

     

    Kind regards,

    Dani

Sign In or Register to comment.