FIBipv4-packet-proc: packet routing failed.. Why this message ..

I am setting up ldp in a  scenario between 2 routers both  routers are generating error messages mentioned below":

00:57:18: IP: s=10.139.63.251 (local), d=224.0.0.5 (FastEthernet3/0), len 80, sending broad/multicast, proto=89
00:57:18: IP: s=10.139.63.251 (local), d=224.0.0.5 (FastEthernet3/0), len 80, sending full packet, proto=89
00:57:18: IP: s=10.139.63.250 (FastEthernet3/0), d=224.0.0.2, len 62, rcvd 0
00:57:18:     UDP src=646, dst=646
00:57:18: FIBipv4-packet-proc: route packet from FastEthernet3/0 src 10.139.63.250 dst 224.0.0.2
00:57:18: FIBfwd-proc: Default:224.0.0.0/24 receive entry
00:57:18: FIBipv4-packet-proc: packet routing failed
00:57:19: IP: s=10.139.63.251 (local), d=224.0.0.2 (FastEthernet3/0), len 62, sending broad/multicast
00:57:19:     UDP src=646, dst=646
00:57:19: IP: s=10.139.63.251 (local), d=224.0.0.2 (FastEthernet3/0), len 62, sending full packet
00:57:19:     UDP src=646, dst=646
ASBR-ISP1#
00:57:22: IP: s=10.139.63.250 (FastEthernet3/0), d=224.0.0.2, len 62, rcvd 0
00:57:22:     UDP src=646, dst=646
00:57:22: FIBipv4-packet-proc: route packet from FastEthernet3/0 src 10.139.63.250 dst 224.0.0.2

#sh version
Cisco IOS Software, 7200 Software (C7200-K91P-M), Version 12.2(31)SB13, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2008 by Cisco Systems, Inc.
Compiled Thu 21-Aug-08 12:06 by pwade

ROM: ROMMON Emulation Microcode
BOOTLDR: 7200 Software (C7200-K91P-M), Version 12.2(31)SB13, RELEASE SOFTWARE (fc1)

ASBR-ISP1#sh run
Building configuration...

Current configuration : 1621 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname ASBR-ISP1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
ip cef
!
call rsvp-sync
!
interface Loopback0
 ip address 10.139.63.228 255.255.255.240
 ip ospf network point-to-point
!
interface FastEthernet3/0
 ip address 10.139.63.251 255.255.255.254
 speed auto
 duplex auto
 mpls ip

router ospf 1
 router-id 10.139.63.228
 log-adjacency-changes
 network 10.139.63.224 0.0.0.15 area 0
 network 10.139.63.250 0.0.0.1 area 0
!
ip classless

 

Comments

  • i think i saw this once - maybe its the /31 subnet ?

    try a X.X.X.252 subnet (/30) and if its not that please post both router's configs here ...

    Shai L.

    I am setting up ldp in a  scenario between 2 routers both  routers are generating error messages mentioned below":

    00:57:18: IP: s=10.139.63.251 (local), d=224.0.0.5 (FastEthernet3/0), len 80, sending broad/multicast, proto=89
    00:57:18: IP: s=10.139.63.251 (local), d=224.0.0.5 (FastEthernet3/0), len 80, sending full packet, proto=89
    00:57:18: IP: s=10.139.63.250 (FastEthernet3/0), d=224.0.0.2, len 62, rcvd 0
    00:57:18:     UDP src=646, dst=646
    00:57:18: FIBipv4-packet-proc: route packet from FastEthernet3/0 src 10.139.63.250 dst 224.0.0.2
    00:57:18: FIBfwd-proc: Default:224.0.0.0/24 receive entry
    00:57:18: FIBipv4-packet-proc: packet routing failed
    00:57:19: IP: s=10.139.63.251 (local), d=224.0.0.2 (FastEthernet3/0), len 62, sending broad/multicast
    00:57:19:     UDP src=646, dst=646
    00:57:19: IP: s=10.139.63.251 (local), d=224.0.0.2 (FastEthernet3/0), len 62, sending full packet
    00:57:19:     UDP src=646, dst=646
    ASBR-ISP1#
    00:57:22: IP: s=10.139.63.250 (FastEthernet3/0), d=224.0.0.2, len 62, rcvd 0
    00:57:22:     UDP src=646, dst=646
    00:57:22: FIBipv4-packet-proc: route packet from FastEthernet3/0 src 10.139.63.250 dst 224.0.0.2

    #sh version
    Cisco IOS Software, 7200 Software (C7200-K91P-M), Version 12.2(31)SB13, RELEASE SOFTWARE (fc1)
    Technical Support: http://www.cisco.com/techsupport
    Copyright (c) 1986-2008 by Cisco Systems, Inc.
    Compiled Thu 21-Aug-08 12:06 by pwade

    ROM: ROMMON Emulation Microcode
    BOOTLDR: 7200 Software (C7200-K91P-M), Version 12.2(31)SB13, RELEASE SOFTWARE (fc1)

    ASBR-ISP1#sh run
    Building configuration...

    Current configuration : 1621 bytes
    !
    version 12.2
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname ASBR-ISP1
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    ip subnet-zero
    ip cef
    !
    call rsvp-sync
    !
    interface Loopback0
     ip address 10.139.63.228 255.255.255.240
     ip ospf network point-to-point
    !
    interface FastEthernet3/0
     ip address 10.139.63.251 255.255.255.254
     speed auto
     duplex auto
     mpls ip

    router ospf 1
     router-id 10.139.63.228
     log-adjacency-changes
     network 10.139.63.224 0.0.0.15 area 0
     network 10.139.63.250 0.0.0.1 area 0
    !
    ip classless

     




  • Re: [CCIE SP] FIBipv4-packet-proc: packet routing failed.. Why this message ..


    I think the problem is that the /31 is not supported in that version.



    or



    You can try changing network mask to a /32 0.0.0.0 area 0 plus add ip ospf network point-to-point under the interface to change it’s behavior on both sides of the link as a 31-bit prefix assumes a point to point link



    Let me know as I cannot test at the moment



    Thanks



    James







    On 1/28/09 8:29 PM, "kgupta2006" <[email protected]> wrote:



    network 10.139.63.250 0.0.0.1 area 0

  • I just solved the issue .... :) 

    closely looked and saw that i was using a subnet 10.139.63.224/28 and had allocated ip addresses from it using the same subnet mask for the 2 routers ... so PE1-ISP1 had 10.139.63.225/28 in lo0 and ASBR-ISP1 had 10.139.63.228/28.. and as you have noticed i used ip ospf net point-to-point under the loopbacks , that was the issue .  so once i removed the ip ospf net point-to-point under the loopbacks then the address were treated differently as /32

    so  ldp sessions were successfully forming now .. bad ip addressing selection for loopbacks ...

  • ignore my reply ..false lead .... the problem still exists .. trying your suggestion .. will let you know

  • It's a FIB (Label Table) failure for the AllRouters 224.0.0.2, which makes sense....  But it should have received it and processed it just fine!  :)  Just can't label switch it!  I don't recall ever seeing this in a debug, but I'm not sure I did packet-level debugs without an ACL either, so that may explain why! 

    You're receiving LDP informaiton, right?

    Scott







    ----- Original Message -----
    From: "kgupta2006" <[email protected]>
    Sent: Wed, January 28, 2009 11:29
    Subject: [CCIE SP] FIBipv4-packet-proc: packet routing failed.. Why this message ..


    I am setting up ldp in a  scenario between 2 routers both  routers are generating error messages mentioned below":

    00:57:18: IP: s=10.139.63.251 (local), d=224.0.0.5 (FastEthernet3/0), len 80, sending broad/multicast, proto=89
    00:57:18: IP: s=10.139.63.251 (local), d=224.0.0.5 (FastEthernet3/0), len 80, sending full packet, proto=89
    00:57:18: IP: s=10.139.63.250 (FastEthernet3/0), d=224.0.0.2, len 62, rcvd 0
    00:57:18:     UDP src=646, dst=646
    00:57:18: FIBipv4-packet-proc: route packet from FastEthernet3/0 src 10.139.63.250 dst 224.0.0.2
    00:57:18: FIBfwd-proc: Default:224.0.0.0/24 receive entry
    00:57:18: FIBipv4-packet-proc: packet routing failed
    00:57:19: IP: s=10.139.63.251 (local), d=224.0.0.2 (FastEthernet3/0), len 62, sending broad/multicast
    00:57:19:     UDP src=646, dst=646
    00:57:19: IP: s=10.139.63.251 (local), d=224.0.0.2 (FastEthernet3/0), len 62, sending full packet
    00:57:19:     UDP src=646, dst=646
    ASBR-ISP1#
    00:57:22: IP: s=10.139.63.250 (FastEthernet3/0), d=224.0.0.2, len 62, rcvd 0
    00:57:22:     UDP src=646, dst=646
    00:57:22: FIBipv4-packet-proc: route packet from FastEthernet3/0 src 10.139.63.250 dst 224.0.0.2

    #sh version
    Cisco IOS Software, 7200 Software (C7200-K91P-M), Version 12.2(31)SB13, RELEASE SOFTWARE (fc1)
    Technical Support: http://www.cisco.com/techsupport
    Copyright (c) 1986-2008 by Cisco Systems, Inc.
    Compiled Thu 21-Aug-08 12:06 by pwade

    ROM: ROMMON Emulation Microcode
    BOOTLDR: 7200 Software (C7200-K91P-M), Version 12.2(31)SB13, RELEASE SOFTWARE (fc1)

    ASBR-ISP1#sh run
    Building configuration...

    Current configuration : 1621 bytes
    !
    version 12.2
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname ASBR-ISP1
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    ip subnet-zero
    ip cef
    !
    call rsvp-sync
    !
    interface Loopback0
     ip address 10.139.63.228 255.255.255.240
     ip ospf network point-to-point
    !
    interface FastEthernet3/0
     ip address 10.139.63.251 255.255.255.254
     speed auto
     duplex auto
     mpls ip

    router ospf 1
     router-id 10.139.63.228
     log-adjacency-changes
     network 10.139.63.224 0.0.0.15 area 0
     network 10.139.63.250 0.0.0.1 area 0
    !
    ip classless

     



    --
    View this message online at: http://ieoc.com/forums/p/4966/16257.aspx#16257
    --
    Internetwork Expert - The Industry Leader in CCIE Preparation

    http://www.internetworkexpert.com



    Subscription information may be found at:

    http://www.ieoc.com/forums/ForumSubscriptions.aspx
    <!>

  • yes.. Ldp neighborship is all right after removing the ip ospf network point-to-point under the lo0 of all routers as because the subnet was showing same in the routers route table ..and ldp was not forming

    Under what conditions can we have a FIB failure and does it affect operation of MPLS core network later ...

     

  • FIB Label table failure ....happens why ? Can I have the fundamentals behind that

     

    :)

     

  • I am facing the same issue , any idea  the reason for the FIB failure. I am getting the same error while trying to establsih the a BGP session. The IPs on the same subnets and I can ping and establish a tcp connection !!!

  • I feel it is the configuration problem.

    In my secnario, I have configured 3 routers in the below manner with serial interfaces.

    image

    Below are the configs:

    R1 Configuration:

    interface Serial2/0
     ip address 192.168.1.1 255.255.255.252
     serial restart-delay 0
     clock rate 64000
     service-policy output Network_Policy
    end

    R1#sh class-map
     Class Map match-any class-default (id 0)
       Match any

     Class Map match-any Network_Ctrl (id 1)
      Description: Network_Control_Protocol
       Match protocol icmp
       Match protocol telnet
    R1#sh policy-map
      Policy Map Network_Policy
        Class Network_Ctrl
          set dscp cs6

    R1#sh runn | s ip route
    ip route 172.16.1.0 255.255.255.252 Serial2/0

    ---------------------------------------------------------

    R2 Configuration:

    R2#sh run int ser 2/0
    interface Serial2/0
     ip address 192.168.1.2 255.255.255.252
     ip access-group 100 in
     auto discovery qos
     serial restart-delay 0
     clock rate 64000
     service-policy input Test_Input

    R2#sh run int ser 2/1
    interface Serial2/1
     ip address 172.16.1.1 255.255.255.252
     serial restart-delay 0
     clock rate 64000

    R2#sh class-map
     Class Map match-any class-default (id 0)
       Match any

     Class Map match-all Network_Ctrl (id 1)
       Match   dscp cs6 (48)

    R2#sh policy-map
      Policy Map Test_Input
        Class Network_Ctrl
          set mpls experimental imposition dscp

    R2#sh access-lists 100
    Extended IP access list 100
        10 permit icmp any any dscp cs6 log

    ip route 172.16.1.0 255.255.255.252 Serial2/1
    ip route 192.168.1.0 255.255.255.252 Serial2/0

    ----------------------------------------------------

    R3 Configuration:

    ---------------------

    interface Serial1/0
     ip address 172.16.1.2 255.255.255.252
     serial restart-delay 0
     clock rate 64000

    ip route 192.168.1.0 255.255.255.252 172.16.1.1

    and Finally I have got this output from debug ip packet

    IP: s=192.168.1.1 (Serial1/0), d=172.16.1.2, len 100, input feature
        ICMP type=8, code=0, MCI Check(64), rtype 0, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
    FIBipv4-packet-proc: route packet from Serial1/0 src 192.168.1.1 dst 172.16.1.2
    FIBfwd-proc: Default:172.16.1.2/32 receive entry
    FIBipv4-packet-proc: packet routing failed
    IP: tableid=0, s=192.168.1.1 (Serial1/0), d=172.16.1.2 (Serial1/0), routed via RIB
    IP: s=192.168.1.1 (Serial1/0), d=172.16.1.2 (Serial1/0), len 100, rcvd 3
        ICMP type=8, code=0
    IP: s=192.168.1.1 (Serial1/0), d=172.16.1.2, len 100, stop process pak for forus packet
        ICMP type=8, code=0
    FIBipv4-packet-proc: route packet from (local) src 172.16.1.2 dst 192.168.1.1
    FIBipv4-packet-proc: packet routing succeeded
    IP: s=172.16.1.2 (local), d=192.168.1.1 (Serial1/0), len 100, sending
        ICMP type=0, code=0
    IP: s=172.16.1.2 (local), d=192.168.1.1 (Serial1/0), len 100, sending full packet
        ICMP type=0, code=0

    Reply with your inputs

  • Ip route pointing to interface instead of ip

    Sent from my iPad 2

    On 12 Dec 2012, at 17:59, vsdendukuri <[email protected]> wrote:

    I feel it is the configuration problem.

    In my secnario, I have configured 3 routers in the below manner with serial interfaces.

    Below are the configs:

    R1 Configuration:

    interface Serial2/0
     ip address 192.168.1.1 255.255.255.252
     serial restart-delay 0
     clock rate 64000
     service-policy output Network_Policy
    end

    R1#sh class-map
     Class Map match-any class-default (id 0)
       Match any

     Class Map match-any Network_Ctrl (id 1)
      Description: Network_Control_Protocol
       Match protocol icmp
       Match protocol telnet
    R1#sh policy-map
      Policy Map Network_Policy
        Class Network_Ctrl
          set dscp cs6

    R1#sh runn | s ip route
    ip route 172.16.1.0 255.255.255.252 Serial2/0

    ---------------------------------------------------------

    R2 Configuration:

    R2#sh run int ser 2/0
    interface Serial2/0
     ip address 192.168.1.2 255.255.255.252
     ip access-group 100 in
     auto discovery qos
     serial restart-delay 0
     clock rate 64000
     service-policy input Test_Input

    R2#sh run int ser 2/1
    interface Serial2/1
     ip address 172.16.1.1 255.255.255.252
     serial restart-delay 0
     clock rate 64000

    R2#sh class-map
     Class Map match-any class-default (id 0)
       Match any

     Class Map match-all Network_Ctrl (id 1)
       Match   dscp cs6 (48)

    R2#sh policy-map
      Policy Map Test_Input
        Class Network_Ctrl
          set mpls experimental imposition dscp

    R2#sh access-lists 100
    Extended IP access list 100
        10 permit icmp any any dscp cs6 log

    ip route 172.16.1.0 255.255.255.252 Serial2/1
    ip route 192.168.1.0 255.255.255.252 Serial2/0

    ----------------------------------------------------

    R3 Configuration:

    ---------------------

    interface Serial1/0
     ip address 172.16.1.2 255.255.255.252
     serial restart-delay 0
     clock rate 64000

    ip route 192.168.1.0 255.255.255.252 172.16.1.1

    and Finally I have got this output from debug ip packet

    IP: s=192.168.1.1 (Serial1/0), d=172.16.1.2, len 100, input feature
        ICMP type=8, code=0, MCI Check(64), rtype 0, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
    FIBipv4-packet-proc: route packet from Serial1/0 src 192.168.1.1 dst 172.16.1.2
    FIBfwd-proc: Default:172.16.1.2/32 receive entry
    FIBipv4-packet-proc: packet routing failed
    IP: tableid=0, s=192.168.1.1 (Serial1/0), d=172.16.1.2 (Serial1/0), routed via RIB
    IP: s=192.168.1.1 (Serial1/0), d=172.16.1.2 (Serial1/0), len 100, rcvd 3
        ICMP type=8, code=0
    IP: s=192.168.1.1 (Serial1/0), d=172.16.1.2, len 100, stop process pak for forus packet
        ICMP type=8, code=0
    FIBipv4-packet-proc: route packet from (local) src 172.16.1.2 dst 192.168.1.1
    FIBipv4-packet-proc: packet routing succeeded
    IP: s=172.16.1.2 (local), d=192.168.1.1 (Serial1/0), len 100, sending
        ICMP type=0, code=0
    IP: s=172.16.1.2 (local), d=192.168.1.1 (Serial1/0), len 100, sending full packet
        ICMP type=0, code=0

    Reply with your inputs




    INE - The Industry Leader in CCIE Preparation

    http://www.INE.com



    Subscription information may be found at:

    http://www.ieoc.com/forums/ForumSubscriptions.aspx
  • Didn't work, I am getting same error on all three devices.

  • Looking at your configurations, under your policy-maps you're missing a class-default for non interesting traffic - If your ICMP traffic isn't being matched in your class-map


    Also do you have CEF enabled globally, since you're classifing on the ICMP protocol using NBAR?

    For pure testing I would remove my ACL's and Policy Maps, verify IP connectivty, - have you tested this?


  • I am sending 1 packet of ping/icmp packet, So i dont feel there is non-interesting traffic.

    I have enabled CEF, I am not using NBAR (enabled auto discovery qos), with basic ip connectivity is also same problem(i removed acl, qos.

     

  • What has the MPLS imposition got to do with scenario as I do not see and MPLS commands on the serial interfaces. Go back to basics and ping. Then add nbar to match protocol

    Cheers

    J

    Sent from my iPhone 4

    On 12 Dec 2012, at 17:59, vsdendukuri <[email protected]> wrote:

    I feel it is the configuration problem.

    In my secnario, I have configured 3 routers in the below manner with serial interfaces.

    Below are the configs:

    R1 Configuration:

    interface Serial2/0
     ip address 192.168.1.1 255.255.255.252
     serial restart-delay 0
     clock rate 64000
     service-policy output Network_Policy
    end

    R1#sh class-map
     Class Map match-any class-default (id 0)
       Match any

     Class Map match-any Network_Ctrl (id 1)
      Description: Network_Control_Protocol
       Match protocol icmp
       Match protocol telnet
    R1#sh policy-map
      Policy Map Network_Policy
        Class Network_Ctrl
          set dscp cs6

    R1#sh runn | s ip route
    ip route 172.16.1.0 255.255.255.252 Serial2/0

    ---------------------------------------------------------

    R2 Configuration:

    R2#sh run int ser 2/0
    interface Serial2/0
     ip address 192.168.1.2 255.255.255.252
     ip access-group 100 in
     auto discovery qos
     serial restart-delay 0
     clock rate 64000
     service-policy input Test_Input

    R2#sh run int ser 2/1
    interface Serial2/1
     ip address 172.16.1.1 255.255.255.252
     serial restart-delay 0
     clock rate 64000

    R2#sh class-map
     Class Map match-any class-default (id 0)
       Match any

     Class Map match-all Network_Ctrl (id 1)
       Match   dscp cs6 (48)

    R2#sh policy-map
      Policy Map Test_Input
        Class Network_Ctrl
          set mpls experimental imposition dscp

    R2#sh access-lists 100
    Extended IP access list 100
        10 permit icmp any any dscp cs6 log

    ip route 172.16.1.0 255.255.255.252 Serial2/1
    ip route 192.168.1.0 255.255.255.252 Serial2/0

    ----------------------------------------------------

    R3 Configuration:

    ---------------------

    interface Serial1/0
     ip address 172.16.1.2 255.255.255.252
     serial restart-delay 0
     clock rate 64000

    ip route 192.168.1.0 255.255.255.252 172.16.1.1

    and Finally I have got this output from debug ip packet

    IP: s=192.168.1.1 (Serial1/0), d=172.16.1.2, len 100, input feature
        ICMP type=8, code=0, MCI Check(64), rtype 0, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
    FIBipv4-packet-proc: route packet from Serial1/0 src 192.168.1.1 dst 172.16.1.2
    FIBfwd-proc: Default:172.16.1.2/32 receive entry
    FIBipv4-packet-proc: packet routing failed
    IP: tableid=0, s=192.168.1.1 (Serial1/0), d=172.16.1.2 (Serial1/0), routed via RIB
    IP: s=192.168.1.1 (Serial1/0), d=172.16.1.2 (Serial1/0), len 100, rcvd 3
        ICMP type=8, code=0
    IP: s=192.168.1.1 (Serial1/0), d=172.16.1.2, len 100, stop process pak for forus packet
        ICMP type=8, code=0
    FIBipv4-packet-proc: route packet from (local) src 172.16.1.2 dst 192.168.1.1
    FIBipv4-packet-proc: packet routing succeeded
    IP: s=172.16.1.2 (local), d=192.168.1.1 (Serial1/0), len 100, sending
        ICMP type=0, code=0
    IP: s=172.16.1.2 (local), d=192.168.1.1 (Serial1/0), len 100, sending full packet
        ICMP type=0, code=0

    Reply with your inputs




    INE - The Industry Leader in CCIE Preparation

    http://www.INE.com



    Subscription information may be found at:

    http://www.ieoc.com/forums/ForumSubscriptions.aspx
Sign In or Register to comment.