Vol II Lab 6 Task 3.3

Hi Guys,

    For the above subject I have seen a lot of people in the forum asking questions about this lab but no one answers?? so I really wonder why??

for me this is the second time to carry on this lab and face the same problem with the above task,

First, I do not understand why the command "distance 19 ip" is needed under the isis process on R9?

Second, I can figure out that we need to set the next hop through route-maps as shown on R2 and this is to assign labels corresponds to those next-hops and thus maintain an LSP path throught the ATM cloud?? am I right??

Third, After i copy the same config from the workbook to the devices "although i do not fully understand it just for sake of the trying" routers within AS200 are not able to reach R9 loopbacks "Data plane speaking" but for the updates "control plane" everything is fine.

 

so please any help?

 

Comments

  • I am planning to do this lab shortly (maybe even today/tomorrow), so I will share my thoughts and findings...

    Cheers,

    Seba

  • Ohh yes please cause I got my CCIE lab after a week :)

    thanks a lot for the help

     

  • Very briefly because it is very late (2AM) and I just finished some lab session; I am in the middle of Lab 6 (very interesting MPLS VPN section).

    - distance 19 ip - it is required to "force" R9 to use routing to R2 Lo0 via ISIS (IGP) not BGP. As we have eBGP the AD is 20. That is why we need to use 19 or less as a distance value. If you don't do that your LSP will be broken, because LDP/TDP will assign a label only to the prefix which is known from IGP

    - next-hop, etc - yes, you need to do that to have LSP path up&running; if you don't change next-hops, the  PHP process will occur too soon and LSP will be broken.

    - it worked in my case, I mean my configuration which is very similar to the presented solution worked well

    Cheers,

    Seba

  • Did you see my last post to this in the lab section of the forum?

     

    http://ieoc.com/forums/t/4651.aspx

     

     

  • Yes, I did. But the problem is that your solution didn't work for me (at least yesterday ;) )

    Anyway I am still in the middle of this lab, so I am going to test other options later today...

     

    Just add-on to my previous post - as I can see I mixed a few things in the single answer about distance 19 ip; so just ignore it ;)

    I'll post something in this subject after extra tests.

    Cheers,

    Seba

  • Hi Seba,

       Thank uo so much for the prompt reply, I will be waiting starving for your next clarification about this bloody task :) and it will be great if you can post a sample of your config....

    thanks a lot

     

  • Just a quick update, after extra testing phase, both solutions (WB + proposed by awilkins) worked fine.

    As I mentioned before I tried non-wb solution before and it just didn't work, so I started to look for another solution... Probably dynamips issue.

    Anyway, this lab is a very good candidate for re-doing again shortly ;) It is described as difficulty level 8, but I find it far more difficult than other 8 level labs. Actually lab 10, diff. lvl 9, in my opinion was easier ;)

    Cheers,

    Seba

  • I agree it is not difficulty level 8 by any means...

     

  • So I have similar problems, in fact my configuration is EXACTLY as it is in the solutions guide and it still doesn't work.  I did however narrow the problem down to the label that gets generated by R9 for the aggregate address.  In my case, the label that gets generated is invalid according to this debug:

    BGP: adding MPLS label to 217.1.0.0/22
    BGP: check on 217.1.0.0/22 in LDP - failed
    BGP-IPv4: Send prefix 217.1.0.0/22, label unrecognized tag type

    The BGP label table on R2 also shows the invalid label:

    SPRack1R2#sh ip bgp labels
       Network          Next Hop      In label/Out label
       20.1.1.1/32      20.1.12.1       20(from LDP)/nolabel
       20.1.2.2/32      0.0.0.0         imp-null(from LDP)/nolabel
       20.1.3.3/32      20.1.23.3       16(from LDP)/nolabel
       20.1.4.4/32      20.1.26.6       22/nolabel
       20.1.5.5/32      20.1.23.3       19(from LDP)/nolabel
       20.1.6.6/32      20.1.26.6       21/nolabel
       217.1.0.0/22     150.1.9.9       36/242616

    If I remove the aggregate, the loopback networks themselves work fine and I can ping them from anywhere within AS200... however using only the aggregate still doesn't work.  I am still trying to figure out why...

  • Hi Guys,


    I am not sure is it too late or not , but i could find work around with create static route for aggregate route in R9 to NUll0 , it will fix the issue and R9 will  imp-null to aggreagte route as well.

     

    Ali

  • alivip - static routes are prohibited in the lab...

  • Hi ,

     

    The solution guide is not quiet correct , if you move  next hop ip set route-map for AS 9 prefixes from R2 to R9 it will work.

     

    Ali

     

Sign In or Register to comment.