4.9-Redistribution

Tag is not working for me. Any help will be great. All the routes still from R1.

 

R5#sh ip route | inc 212.18
O E2 212.18.1.0/24 [110/1] via 136.1.15.1, 2d18h, Serial0/0.15
O E2 212.18.0.0/24 [110/1] via 136.1.15.1, 2d18h, Serial0/0.15
O E2 212.18.3.0/24 [110/1] via 136.1.15.1, 2d18h, Serial0/0.15
O E2 212.18.2.0/24 [110/1] via 136.1.15.1, 2d18h, Serial0/0.15
R5#sh ip route | inc 31.3 
O E2    31.3.0.0 [110/1] via 136.1.15.1, 2d18h, Serial0/0.15
R5#sh ip route | inc 31.2
O E2    31.2.0.0 [110/1] via 136.1.15.1, 2d18h, Serial0/0.15
R5#sh ip route | inc 31.1
O E2    31.1.0.0 [110/1] via 136.1.15.1, 2d18h, Serial0/0.15
R5#sh ip route | inc 30.2
O E2    30.2.0.0 [110/1] via 136.1.15.1, 2d18h, Serial0/0.15
R5#sh ip route | inc 30.3
O E2    30.3.0.0 [110/1] via 136.1.15.1, 2d18h, Serial0/0.15
R5#sh ip route | inc 30.0
     30.0.0.0/16 is subnetted, 4 subnets
O E2    30.0.0.0 [110/1] via 136.1.15.1, 2d18h, Serial0/0.15
R5#sh ip route | inc 30.1
O E2    30.1.0.0 [110/1] via 136.1.15.1, 2d18h, Serial0/0.15
R5#

Comments

  • Please show us the route-map you are using to filter the routes and the relevant redistribute statements.

  • Thanks Darrell,

    The Ethernet interfaces in all the routers is FastEthernet.

    R1:

    router eigrp 100
     redistribute ospf 1 metric 10000 1000 100 1 1500
     network 136.1.136.1 0.0.0.0
     no auto-summary
     eigrp router-id 150.1.1.1
    !
    router ospf 1
     router-id 150.1.1.1
     log-adjacency-changes
     auto-cost reference-bandwidth 20000
     area 0 authentication message-digest
     redistribute eigrp 100 subnets route-map EIGRP2OSPF
     network 136.1.15.1 0.0.0.0 area 0
     network 150.1.1.1 0.0.0.0 area 0
     distance ospf external 171

    route-map EIGRP2OSPF permit 10
     match tag 1
     set metric 1
    !
    route-map EIGRP2OSPF permit 1000

    R2

    route-map EIGRP2OSPF permit 10
     match tag 3
     set metric 1
    !
    route-map EIGRP2OSPF permit 1000

    router ospf 1
     router-id 150.1.2.2
     log-adjacency-changes
     auto-cost reference-bandwidth 20000
     area 0 authentication message-digest
     redistribute eigrp 100 subnets route-map EIGRP2OSPF
     network 136.1.245.2 0.0.0.0 area 0
     network 150.1.2.2 0.0.0.0 area 0
     distance ospf external 171

    router eigrp 100
     redistribute ospf 1 metric 10000 1000 100 1 1500
     network 136.1.23.2 0.0.0.0
     no auto-summary
     eigrp router-id 150.1.2.2

    R5:

    router ospf 1
     log-adjacency-changes
     auto-cost reference-bandwidth 20000
     area 0 authentication message-digest
     area 45 virtual-link 150.1.4.4 message-digest-key 1 md5 CISCO
     redistribute rip subnets
     network 136.1.15.5 0.0.0.0 area 0
     network 136.1.45.5 0.0.0.0 area 45
     network 136.1.245.5 0.0.0.0 area 0
     network 150.1.5.5 0.0.0.0 area 0
    !
    router rip
     version 2
     redistribute ospf 1 metric 1
     passive-interface default
     no passive-interface FastEthernet0/0
     no passive-interface FastEthernet0/1
     network 136.1.0.0
     network 192.10.1.0
     distance 109
     no auto-summary

    R6:

    ip prefix-list RIP_FROM_BB1 seq 5 permit 212.18.0.0/22 ge 24 le 24
    !
    ip prefix-list RIP_FROM_BB3 seq 5 permit 30.0.0.0/14 ge 16 le 16
    ip prefix-list RIP_FROM_BB3 seq 10 permit 31.0.0.0/14 ge 16 le 16
    !
    route-map RIP2EIGRP permit 10
     match ip address RIP_FROM_BB1
     set tag 1
    !
    route-map RIP2EIGRP permit 20
     match ip address RIP_FROM_BB3
     set tag 3
    !
    route-map RIP2EIGRP permit 30
    !

    !
    router eigrp 100
     redistribute rip metric 10000 1000 100 1 1500 route-map RIP2EIGRP
     network 136.1.136.6 0.0.0.0
     network 150.1.6.6 0.0.0.0
     no auto-summary
     eigrp router-id 150.1.6.6
    !
    router rip
     version 2
     redistribute eigrp 100 metric 1
     network 54.0.0.0
     network 204.12.1.0
     no auto-summary

     

  • It took a little looking -

    When you are matching a prefix-list, you need to "match ip address prefix-list <prefix-list-name>"

    Your route-maps are looking for access-lists named RIP_FROM_BB1 and RIP_FROM_BB3. Insert "prefix-list" in your 2 "match" lines and it should work.

  • Darell,

    I really appreciate your help on this. I should me more detail. All good now.

    R5#sh ip route | inc 31.3
    O E2    31.3.0.0 [110/1] via 136.1.245.2, 00:01:01, Serial0/0.245
    R5#sh ip route | inc 31.2
    O E2    31.2.0.0 [110/1] via 136.1.245.2, 00:01:07, Serial0/0.245
    R5#sh ip route | inc 31.1
    O E2    31.1.0.0 [110/1] via 136.1.245.2, 00:01:11, Serial0/0.245
    R5#sh ip route | inc 30.0
         30.0.0.0/16 is subnetted, 4 subnets
    O E2    30.0.0.0 [110/1] via 136.1.245.2, 00:01:20, Serial0/0.245
    R5#sh ip route | inc 30.1
    O E2    30.1.0.0 [110/1] via 136.1.245.2, 00:01:23, Serial0/0.245

     

     

  • Glad to help - I certainly did not learn without help!

  • hi guys

    i wish some one can helps in this

    first of all i was thinking to solve this cas in diffrent way

    wihtout any taging

    on R5 i creat ACL or prelists match each traffic lets say traffic from BB! and lets say R1 IP is 10.1.1.1

    i wanted to let R5 prefer that path as asked in the question through R1 for all traffci match in ACL 10

    this is thriough chnaging the distance od traffic match in that ACL from R1

    as we know OSPF use in distance command the router ID

    ket sy router 1 IP is also 10.1.1.1

    i used the following command but i surprized it did not work

    distance 100 10.1.1.1 0.0.0.0 10

    where 10 is the ACL

    the problem is it apply it to both neighbors in our case like in the lab 3

    both R1 and R2 will be seen with AD as 100

    while i put only R1

    why id dose not work with spicific host the distance command ?

    and the way i was looking to do will be ok or not ?

     

     

     

    ANOTHER way

    as we taged the traffic in R6 lets say we have tag 10 need it to be prefered through R1

    i created the following route map

    route-map map1 permit 20

    match tag 10

    match ip route-source 1

    set metric 1

    route-map map1 permit 30

     

    where ACL 1 should match R1 IP address

     

    then under OSPF

    distribute-list route-map map1 in

    BUT this one did not work

    why ? and is this one should be another to solve this task ??

    Thank you

Sign In or Register to comment.