BB2 & ipv6 ospf 1 area 0 Issue

Hi there

I am setting up my BB routers and my FRS today in my home lab and when I past in the config for int Fa0/0 on BB2 I get the following after the ipv6 ospf 1 area 0.  I am running a 3620 with 12.3-26 IP Plus.  Can anyone help please?

Router(config-router)#interface Fa0/0
Router(config-if)# description FastEthernet to SW2 Fa0/24
Router(config-if)# ip address 192.10.1.254 255.255.255.0
Router(config-if)# ip rip authentication mode md5
Router(config-if)# ip rip authentication key-chain RIP
Router(config-if)# ipv6 address 2001:192:10:1::254/64
Router(config-if)# ipv6 rip RIPng enable
Router(config-if)# ipv6 ospf 1 area 0
                        ^
% Invalid input detected at '^' marker.

Router(config-if)# no shutdown

Thanks

Kev

 

Comments

  • 12.3 probably does not support the ip ospf x area y command under the interface.

    Use the network command under the ospf router process to do the same thing.

    Edit: Sorry - I just saw that this is IPv6 - the IOS version may not support IPv6 ospf.

  • Thanks DarrellEscola.  I guessed as much.  It is strange that Internetwork Expert use IP PLUS 12.2(15)T17 for BB2 and have the IPV6 OSPF command under the interface in the config file when this is not supported.  I will try with a 2620XM running the latest code.

     

    EDIT: The ios level Internetwork Expert's use for BB2 does support IPV6 OSPF under the interface.  It is my own fault for not using the same level of code. :-)

  • Today I have learned how valuable the Cisco Feature Navigator is. [:D]

    Now can anyone tell me how I recover a 2620XM with not enough memory for the code I am running to boot up fully???? [:'(]

  • If you can get into rommon mode you can download a new ios via tftp from rommon mode. 

    http://www.cisco.com/en/US/products/hw/routers/ps259/products_tech_note09186a008015bf9e.shtml

    Another method that is a little scary but much quicker that i have used in the past:

    If you have another 2620 you can actually swap the flash dimm while the router is powered on.  I have done it many times and haven't ruined one yet.  Just take the flash out of the router that has a valid ios and use that flash to power up your router with the bad ios.  then once it is up swap the flash dimms and then write a new ios to the flash dimm with the bad ios.  (I would suggest using a grounding strap.)

  • izack, many thanks.  I like the second method, I have wondered in the past if that would work.  I'll check out the 1st method too.












  • AFAIK the 3620 routers won't support OSPFv3.  At least they
    never did back when I had some in my lab!

     

    Scott

     

     

    From: [email protected]
    [mailto:[email protected]] On Behalf Of EdinburghKev

    Sent: Saturday, January 17, 2009 9:57 AM

    To: [email protected]

    Subject: [CCIE R&S General] BB2 & ipv6 ospf 1 area 0 Issue

     

    Hi there

    I am setting up my BB routers and my FRS today in my home lab and when I
    past in the config for int Fa0/0 on BB2 I get the following after the ipv6
    ospf 1 area 0
    .  I am running a 3620 with 12.3-26 IP Plus.  Can
    anyone help please?

    Router(config-router)#interface Fa0/0

    Router(config-if)# description FastEthernet to SW2 Fa0/24

    Router(config-if)# ip address 192.10.1.254 255.255.255.0

    Router(config-if)# ip rip authentication mode md5

    Router(config-if)# ip rip authentication key-chain RIP

    Router(config-if)# ipv6 address 2001:192:10:1::254/64

    Router(config-if)# ipv6 rip RIPng enable

    Router(config-if)# ipv6 ospf 1 area 0

                           
    ^

    % Invalid input detected at '^' marker.



    Router(config-if)# no shutdown

    Thanks

    Kev

     







    Internetwork Expert - The Industry Leader in CCIE Preparation

    http://www.internetworkexpert.com



    Subscription information may be found at:

    http://www.ieoc.com/forums/ForumSubscriptions.aspx
















  • For IPv6 (OSPFv3) there is no "network" command.

     

    Scott

     

    From:
    [email protected] [mailto:[email protected]] On Behalf Of DarrellEscola

    Sent: Saturday, January 17, 2009 10:52 AM

    To: [email protected]

    Subject: Re: [CCIE R&S General] BB2 & ipv6 ospf 1 area 0 Issue

     

    12.3 probably does not support the ip ospf x area y command under the
    interface.

    Use the network command under the ospf router process to do the same thing.







    Internetwork Expert - The Industry Leader in CCIE Preparation

    http://www.internetworkexpert.com



    Subscription information may be found at:

    http://www.ieoc.com/forums/ForumSubscriptions.aspx





  • I noticed this was IPv6 right after I posted the response - updated the response soon after...

  • I ended up running a 3640 with c3640-i-mz.124-23.bin (IP Plus) for my BB2 router and it has taken all the commands from the BB2 initial config file.   I will probably have to revisit my configs as I get in to the labs when I start to find out that some of the features I need are not supported.  [:S]

  • Need to use 3640 as a BB?

    I am just starting and the three 3640s are my best routers in my home lab.  I was planning to use the 2511 terminal and 2523 frame switch as the BBs.  How many questions will I lost if I can't afford 3640s as the BBs?

  • hi sypl, I believe InternetworkExpert use a 2501 running 12.2(15)T17 IP Plus for the BB2 router.  I do not have any 2500s so I started off with a 3620 with 12.3-26 IP Plus but after help from the forum found that the IPV6 OSPF commands used in the config were not supported.  In the end I used a spare 3640 running IP Plus 12.3-26 and it took all the commands okay.

    12.2(15)T17 IP Plus is recommended for BB1, 2, 3 & the FRS. [;)]

  • Good!  I verified that by uploading 12.2(15)T17 IS-L image to my Terminal and Frame Switch.   The 2511 with the Ethernet interface can be the BB3 and the 2523 frame switch (no Ethernet) should become the BB1.  Hopefully, a 1721 can take up the role of BB2.

    The remining problems for me are now at the 2610XMs (R1, R2) and the 3825 (R6).   That is not in the scope of this thread.

  • sypl, good work with BB1, 2 & 3.  The only reason R6 is a 3825 is that is has a pair of 1GB ethernet NICs and the IExpert guide has those 1Bg NICs connecting back to a 100Mb switchport.  Forget about the 3825 and use an XM if you can find one cheaply or use a 2691 for R1, 2 & 6.  The 2691 can run 256Mb ram and 64Mb flash meaning you can run the latest AdvancedEnterpriseServices IOS on them and pick them up cheaper than the XM routers.

    Feel free to post in here about your home lab.  I set mine up a week ago and I have not started a hands on lab yet.

  • Thank you for your advice. [:)]

    The cheapest way to complete the lab now should be using Dynamips.  

    I invested a huge amount of money for the current equipments 2 years ago.  Unfortunately, due to a job change, I couldn't find the time and motivation to start my study, until now. [:(]   My 1721s should not be suitable for the lab as it lacks some important features.  There are some modified models of the XMs which support 256D/48F, of course the price is higher.  I will consider them, if I still want a "physical" lab.

     

  • It works in 3660!

     

    Sorry, 3660.

    I thought you are a big elephant in my room.

Sign In or Register to comment.