Vol II Lab 3 Task 6 Multicast

Hi all,

   For the Multicast Task in the above lab, my config are alright according to the workbook solution, but when I try to test the ping from R7 to R6 I got the following error on R1 after I issued the command "debug ip mpacket" and "debug ip pim"

SPRack1R1#debug ip pim vrf 100
PIM debugging is on
SPRack1R1#
IP(1): s=10.1.17.7 (FastEthernet1/0) d=224.7.7.7 id=608, ttl=254, prot=1, len=114(100), RPF lookup failed for source or RP
IP(0): s=150.1.3.3 (Tunnel0) d=224.0.1.40 (ATM3/0.1) id=6490, ttl=13, prot=17, len=48(48), mforward
SPRack1R1#
IP(1): s=10.1.17.7 (FastEthernet1/0) d=224.7.7.7 id=609, ttl=254, prot=1, len=114(100), RPF lookup failed for source or RP
PIM(1): Building Periodic Join/Prune message for 224.0.1.40
SPRack1R1#
IP(1): s=10.1.17.7 (FastEthernet1/0) d=224.7.7.7 id=610, ttl=254, prot=1, len=114(100), RPF lookup failed for source or RP
SPRack1R1#
IP(1): s=10.1.17.7 (FastEthernet1/0) d=224.7.7.7 id=611, ttl=254, prot=1, len=114(100), RPF lookup failed for source or RP
SPRack1R1#

 

It looks like an RPF failure, so any help??

 

Comments

  • Hi,

    I haven't look at this task myself but I have a few suggetions. Check and make sure u have the static RP configured correctly where it should be (unless ur doing auto-RP). Also, run the sh ip rpf x.x.x.x command, then compare this to the output of the same command but add a static mroute before you run the command again and see how things look before and after.

    Cheers,

    Joe.

  • Hi,

       Below are the output of some troubleshooting commands, the rp-address is 172.30.101.3 "which is a route inside vrf 100"

    SPRack1R1#sh ip rpf vrf 100 172.30.101.3
    RPF information for ? (172.30.101.3) failed, no route exists

    after doing sh ip route vrf 100

    SPRack1R1#sh ip route vrf 100

    Routing Table: 100
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
           ia - IS-IS inter area, * - candidate default, U - per-user static route
           o - ODR, P - periodic downloaded static route

    Gateway of last resort is not set

    B    200.0.0.0/24 [200/1] via 150.1.3.3, 00:18:11
         54.0.0.0/24 is subnetted, 1 subnets
    B       54.1.1.0 [200/1] via 150.1.3.3, 00:18:11
    B    200.0.1.0/24 [200/1] via 150.1.3.3, 00:18:11
    B    200.0.2.0/24 [200/1] via 150.1.3.3, 00:18:11
         172.30.0.0/24 is subnetted, 1 subnets
    B       172.30.101.0 [200/0] via 150.1.3.3, 00:21:41
    B    200.0.3.0/24 [200/1] via 150.1.3.3, 00:18:11
         10.0.0.0/24 is subnetted, 2 subnets
    D       10.1.7.0 [90/156160] via 10.1.17.7, 00:22:59, FastEthernet1/0
    C       10.1.17.0 is directly connected, FastEthernet1/0
    B    192.168.1.0/24 [200/0] via 150.1.9.9, 00:21:28

    I can see the subnet, I know that the problem is with the RPF check within the VRF, I added a global static mroute as per the workbook but this does not work for the VRF multicast traffic

    so any help...

     

  • Please post your configurations and i'll take a look at the task! Do you have full connectivity in your lab up to this task? i.e., is everything else working routing wise?

  • Yes man everything is working fine control plane and data plane, and here are my R1, R2, R3, R5 and R6 config:

    SPRack1R1#sh run
    Building configuration...

    Current configuration : 2738 bytes
    !
    ! Last configuration change at 07:50:12 UTC Tue Jan 13 2009
    ! NVRAM config last updated at 06:18:55 UTC Tue Jan 13 2009
    !
    version 12.2
    no service timestamps debug uptime
    no service timestamps log uptime
    no service password-encryption
    !
    hostname SPRack1R1
    !
    boot-start-marker
    boot-end-marker
    !
    !
    ip subnet-zero
    ip cef
    !
    !
    no ip domain-lookup
    !
    ip vrf 100
     rd 12349:100
     route-target export 12349:100
     route-target import 12349:100
     route-target import 12349:9
     mdt default 239.100.100.100

    !
    ip multicast-routing
    ip multicast-routing vrf 100
    no mpls traffic-eng auto-bw timers frequency 0
    !
    key chain 1
     key 1
      key-string CISCO
    call rsvp-sync
    !
    !
    !
    !
    !
    !
    !
    !        
    interface Tunnel0
     ip unnumbered Loopback0
     ip pim sparse-dense-mode
     tunnel source Loopback0
     tunnel destination 150.1.2.2
     no clns route-cache
    !
    interface Loopback0
     ip address 150.1.1.1 255.255.255.255
     ip router isis
    !
    interface FastEthernet1/0
     ip vrf forwarding 100
     ip address 10.1.17.1 255.255.255.0
     ip authentication mode eigrp 10 md5
     ip authentication key-chain eigrp 10 1
     ip pim sparse-mode
     duplex half
     no clns route-cache
    !
    interface Serial2/0
     no ip address
     shutdown
    !
    interface Serial2/1
     no ip address
     shutdown
     serial restart-delay 0
     no clns route-cache
    !
    interface Serial2/2
     no ip address
     shutdown
     serial restart-delay 0
     no clns route-cache
    !
    interface Serial2/3
     no ip address
     shutdown
     serial restart-delay 0
     no clns route-cache
    !
    interface ATM3/0
     description r1:ATM3/0
     no ip address
     no atm enable-ilmi-trap
    !
    interface ATM3/0.1 mpls
     ip address 150.1.101.1 255.255.255.0
     ip pim sparse-dense-mode
     ip router isis
     no atm enable-ilmi-trap
     mpls atm control-vc 1 64
     mpls label protocol tdp
     mpls ip
     isis circuit-type level-2-only
    !
    router eigrp 1
     auto-summary
     !
     address-family ipv4 vrf 100
     redistribute bgp 12349 metric 1 1 1 1 1
     network 10.1.17.0 0.0.0.255
     no auto-summary
     autonomous-system 10
     exit-address-family
    !
    router isis
     net 49.0001.0000.0000.0001.00
    !
    router bgp 12349
     no bgp default ipv4-unicast
     bgp log-neighbor-changes
     neighbor 150.1.3.3 remote-as 12349
     neighbor 150.1.3.3 update-source Loopback0
     !
     address-family vpnv4
     neighbor 150.1.3.3 activate
     neighbor 150.1.3.3 next-hop-self
     neighbor 150.1.3.3 send-community both
     exit-address-family
     !
     address-family ipv4 vrf 100
     redistribute eigrp 10
     no auto-summary
     no synchronization
     exit-address-family
    !
    ip classless
    !
    no ip http server
    !        
    ip pim vrf 100 rp-address 172.30.101.3
    ip mroute 0.0.0.0 0.0.0.0 Tunnel0
    ip mroute vrf 100 0.0.0.0 0.0.0.0 172.30.101.3
    !
    !
    !
    !
    !
    control-plane
    !
    !
    dial-peer cor custom
    !
    !
    !
    !
    line con 0
     exec-timeout 0 0
     logging synchronous
     stopbits 1
    line aux 0
     stopbits 1
    line vty 0 4
     privilege level 15
     no login
    !
    !
    end
    =================================================================
    SPRack1R2#sh run
    Building configuration...

    Current configuration : 2191 bytes
    !
    ! Last configuration change at 07:54:47 UTC Tue Jan 13 2009
    ! NVRAM config last updated at 06:18:57 UTC Tue Jan 13 2009
    !
    version 12.2
    no service timestamps debug uptime
    no service timestamps log uptime
    no service password-encryption
    !
    hostname SPRack1R2
    !
    boot-start-marker
    boot-end-marker
    !
    !
    ip subnet-zero
    ip cef
    !
    !
    no ip domain-lookup
    !
    ip multicast-routing
    no mpls traffic-eng auto-bw timers frequency 0
    !
    key chain 1
     key 1
      key-string CISCO
    call rsvp-sync
    !
    !
    !
    !
    !
    !
    !
    !
    interface Tunnel0
     ip unnumbered Loopback0
     ip pim sparse-dense-mode
     tunnel source Loopback0
     tunnel destination 150.1.1.1
     no clns route-cache
    !
    interface Loopback0
     ip address 150.1.2.2 255.255.255.255
     ip router isis
    !
    interface FastEthernet1/0
     ip address 150.1.23.2 255.255.255.0
     ip pim sparse-dense-mode
     ip router isis
     duplex half
     mpls label protocol tdp
     mpls ip
     isis circuit-type level-2-only
     isis authentication mode md5 level-2
     isis authentication key-chain 1
    !
    interface Serial2/0
     ip address 150.1.24.2 255.255.255.0
     ip pim sparse-dense-mode
     ip router isis
     encapsulation frame-relay
     mpls label protocol tdp
     mpls ip
     frame-relay map clns 204 broadcast
     frame-relay map ip 150.1.24.4 204 broadcast
     no frame-relay inverse-arp
     isis circuit-type level-2-only
     isis authentication mode md5 level-2
     isis authentication key-chain 1
    !
    interface Serial2/1
     no ip address
     shutdown
     serial restart-delay 0
     no clns route-cache
    !
    interface Serial2/2
     no ip address
     shutdown
     serial restart-delay 0
     no clns route-cache
    !
    interface Serial2/3
     no ip address
     shutdown
     serial restart-delay 0
     no clns route-cache
    !
    interface ATM3/0
     description r2:ATM3/0
     no ip address
     no atm enable-ilmi-trap
    !
    interface ATM3/0.1 mpls
     ip address 150.1.102.2 255.255.255.0
     ip router isis
     no atm enable-ilmi-trap
     mpls label protocol tdp
     mpls ip
     isis circuit-type level-2-only
    !
    router isis
     net 49.0001.0000.0000.0002.00
    !
    ip classless
    !
    no ip http server
    !
    ip mroute 150.1.1.1 255.255.255.255 Tunnel0
    !
    !
    !        
    !
    !
    control-plane
    !
    !
    dial-peer cor custom
    !
    !
    !
    !
    line con 0
     exec-timeout 0 0
     logging synchronous
     stopbits 1
    line aux 0
     stopbits 1
    line vty 0 4
     privilege level 15
     no login
    !
    !
    end
    ===========================================================================
    SPRack1R3#sh run
    Building configuration...

    Current configuration : 3644 bytes
    !
    ! Last configuration change at 07:51:09 UTC Tue Jan 13 2009
    ! NVRAM config last updated at 06:30:25 UTC Tue Jan 13 2009
    !
    version 12.4
    no service timestamps debug uptime
    no service timestamps log uptime
    no service password-encryption
    !
    hostname SPRack1R3
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    memory-size iomem 10
    !
    !
    ip cef
    no ip domain lookup
    !        
    !
    ip vrf 100
     rd 12349:100
     route-target export 12349:100
     route-target import 12349:100
     mdt default 239.100.100.100
    !
    ip vrf 200
     rd 12349:200
     route-target export 12349:200
     route-target import 12349:200
    !
    ip vrf CENTRAL_SERVICES
     rd 12349:9
     route-target import 12349:9
    !
    ip multicast-routing
    ip multicast-routing vrf 100
    !
    !
    !
    key chain 1
     key 1   
      key-string CISCO
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    interface Loopback0
     ip address 150.1.3.3 255.255.255.255
     ip router isis
     ip pim sparse-dense-mode
    !
    interface Ethernet0/0
     ip address 150.1.23.3 255.255.255.0
     ip router isis
     ip pim sparse-dense-mode
     half-duplex
     mpls label protocol tdp
     mpls ip
     isis circuit-type level-2-only
     isis authentication mode md5 level-2
     isis authentication key-chain 1
    !
    interface Ethernet0/1
     no ip address
     half-duplex
    !
    interface Ethernet0/1.1000
     encapsulation dot1Q 1000
     ip vrf forwarding 100
     ip address 172.30.101.3 255.255.255.0
     ip pim dense-mode
    !        
    interface Ethernet0/1.2000
     encapsulation dot1Q 2000
     ip vrf forwarding 200
     ip address 172.30.102.3 255.255.255.0
    !
    interface Ethernet0/1.3000
     encapsulation dot1Q 3000
     ip vrf forwarding CENTRAL_SERVICES
     ip address 172.30.103.3 255.255.255.0
    !
    interface Serial1/0
     no ip address
     shutdown
    !
    interface Serial1/1
     no ip address
     shutdown
    !
    interface Serial1/2
     no ip address
     shutdown
    !
    interface Serial1/3
     no ip address
     shutdown
    !
    router isis
     net 49.0001.0000.0000.0003.00
    !
    router rip
     version 2
     !
     address-family ipv4 vrf CENTRAL_SERVICES
     redistribute bgp 12349 metric 1
     network 172.30.0.0
     no auto-summary
     exit-address-family
     !
     address-family ipv4 vrf 200
     redistribute bgp 12349 metric 1
     network 172.30.0.0
     no auto-summary
     exit-address-family
     !
     address-family ipv4 vrf 100
     redistribute bgp 12349 metric 1
     network 172.30.0.0
     no auto-summary
     exit-address-family
    !
    router bgp 12349
     no bgp default ipv4-unicast
     bgp log-neighbor-changes
     neighbor 150.1.1.1 remote-as 12349
     neighbor 150.1.1.1 update-source Loopback0
     neighbor 150.1.4.4 remote-as 12349
     neighbor 150.1.4.4 update-source Loopback0
     neighbor 150.1.9.9 remote-as 12349
     neighbor 150.1.9.9 update-source Loopback0
     !
     address-family ipv4
     neighbor 150.1.1.1 activate
     neighbor 150.1.4.4 activate
     neighbor 150.1.9.9 activate
     no auto-summary
     no synchronization
     exit-address-family
     !
     address-family vpnv4
     neighbor 150.1.1.1 activate
     neighbor 150.1.1.1 send-community both
     neighbor 150.1.1.1 route-reflector-client
     neighbor 150.1.4.4 activate
     neighbor 150.1.4.4 send-community both
     neighbor 150.1.4.4 route-reflector-client
     neighbor 150.1.9.9 activate
     neighbor 150.1.9.9 send-community both
     neighbor 150.1.9.9 route-reflector-client
     exit-address-family
     !
     address-family ipv4 vrf CENTRAL_SERVICES
     redistribute rip
     no synchronization
     exit-address-family
     !
     address-family ipv4 vrf 200
     redistribute rip
     no synchronization
     exit-address-family
     !
     address-family ipv4 vrf 100
     redistribute rip
     no synchronization
     exit-address-family
    !
    ip http server
    no ip http secure-server
    !
    !
    ip pim send-rp-discovery Loopback0 scope 16
    ip pim vrf 100 rp-address 172.30.101.3
    !
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    !        
    !
    line con 0
     exec-timeout 0 0
     logging synchronous
    line aux 0
    line vty 0 4
     privilege level 15
     no login
    !
    !
    end
    ================================================================================

    SPRack1R5#sh run
    Building configuration...

    Current configuration : 2901 bytes
    !
    ! Last configuration change at 07:51:36 UTC Tue Jan 13 2009
    ! NVRAM config last updated at 06:19:05 UTC Tue Jan 13 2009
    !
    version 12.4
    no service timestamps debug uptime
    no service timestamps log uptime
    no service password-encryption
    !
    hostname SPRack1R5
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    memory-size iomem 10
    !
    !
    ip cef
    no ip domain lookup
    !        
    !
    ip vrf 100
     rd 100:100
     route-target export 100:100
     route-target import 100:100
     mdt default 239.100.100.100
    !
    ip vrf 54
     rd 100:54
     route-target export 100:54
     route-target import 100:54
    !
    ip vrf CENTRAL_SERVICES
     rd 12349:9
     route-target export 12349:9
    !
    ip multicast-routing
    ip multicast-routing vrf 100
    !
    !
    !
    !
    !        
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    interface Loopback0
     ip address 160.1.5.5 255.255.255.255
     ip pim sparse-mode
    !
    interface Ethernet0/0
     no ip address
     half-duplex
    !
    interface Ethernet0/0.1000
     encapsulation dot1Q 1000
     ip vrf forwarding 100
     ip address 172.30.101.5 255.255.255.0
     ip pim dense-mode
    !
    interface Ethernet0/0.2000
     encapsulation dot1Q 2000
     ip vrf forwarding 54
     ip address 172.30.102.5 255.255.255.0
    !
    interface Ethernet0/0.3000
     encapsulation dot1Q 3000
     ip vrf forwarding CENTRAL_SERVICES
     ip address 172.30.103.5 255.255.255.0
    !
    interface Serial0/0
     no ip address
     shutdown
     half-duplex
    !
    interface Ethernet0/1
     ip address 160.1.56.5 255.255.255.0
     ip pim sparse-mode
     ip ospf authentication message-digest
     ip ospf message-digest-key 1 md5 CISCO
     ip ospf network point-to-point
     half-duplex
     mpls label protocol ldp
     mpls ip
    !
    interface Serial0/1
     no ip address
     shutdown
    !
    router ospf 1
     log-adjacency-changes
     network 160.1.5.5 0.0.0.0 area 0
     network 160.1.56.5 0.0.0.0 area 0
    !
    router rip
     version 2
     !
     address-family ipv4 vrf CENTRAL_SERVICES
     redistribute bgp 100 metric 1
     network 172.30.0.0
     no auto-summary
     exit-address-family
     !
     address-family ipv4 vrf 54
     redistribute bgp 100 metric 1
     network 172.30.0.0
     no auto-summary
     exit-address-family
     !
     address-family ipv4 vrf 100
     redistribute bgp 100 metric 1
     network 172.30.0.0
     no auto-summary
     exit-address-family
    !
    router bgp 100
     no bgp default ipv4-unicast
     bgp log-neighbor-changes
     neighbor 160.1.6.6 remote-as 100
     neighbor 160.1.6.6 update-source Loopback0
     !
     address-family vpnv4
     neighbor 160.1.6.6 activate
     neighbor 160.1.6.6 send-community both
     neighbor 160.1.6.6 next-hop-self
     exit-address-family
     !
     address-family ipv4 vrf CENTRAL_SERVICES
     redistribute rip
     no synchronization
     exit-address-family
     !
     address-family ipv4 vrf 54
     redistribute rip
     no synchronization
     exit-address-family
     !
     address-family ipv4 vrf 100
     redistribute rip
     no synchronization
     exit-address-family
    !
    ip http server
    no ip http secure-server
    !        
    !
    ip pim rp-address 160.1.5.5
    !
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    line con 0
     exec-timeout 0 0
     logging synchronous
    line aux 0
    line vty 0 4
     privilege level 15
     no login
    !
    !
    end
    ===============================================================
    SPRack1R6#sh run
    Building configuration...

    Current configuration : 2560 bytes
    !
    ! Last configuration change at 07:51:56 UTC Tue Jan 13 2009
    ! NVRAM config last updated at 07:16:11 UTC Tue Jan 13 2009
    !
    version 12.4
    no service timestamps debug uptime
    no service timestamps log uptime
    no service password-encryption
    !
    hostname SPRack1R6
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    memory-size iomem 25
    !
    !
    ip cef
    no ip domain lookup
    !        
    !
    ip vrf 100
     rd 100:100
     route-target export 100:100
     route-target import 100:100
     route-target import 12349:9
     mdt default 239.100.100.100
    !
    ip vrf 54
     rd 100:54
     route-target export 100:54
     route-target import 100:54
     route-target import 12349:9
    !
    ip multicast-routing
    ip multicast-routing vrf 100
    !
    !
    !
    key chain 1
     key 1
      key-string CISCO
    !        
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    interface Loopback0
     ip address 160.1.6.6 255.255.255.255
    !
    interface Ethernet0/0
     ip address 160.1.56.6 255.255.255.0
     ip pim sparse-mode
     ip ospf authentication message-digest
     ip ospf message-digest-key 1 md5 CISCO
     ip ospf network point-to-point
     half-duplex
     mpls ip
    !
    interface Serial0/0
     no ip address
     encapsulation frame-relay
    !
    interface Serial0/0.1 point-to-point
     ip vrf forwarding 100
     ip address 54.1.1.6 255.255.255.0
     ip authentication mode eigrp 10 md5
     ip authentication key-chain eigrp 10 1
     ip pim dense-mode
     ip igmp join-group 224.7.7.7
     frame-relay interface-dlci 101  
    !
    interface Ethernet0/1
     ip vrf forwarding 54
     ip address 204.12.1.6 255.255.255.0
     half-duplex
    !
    router eigrp 1
     redistribute bgp 100 metric 1 1 1 1 1
     auto-summary
     !
     address-family ipv4 vrf 100
     network 54.1.1.0 0.0.0.255
     no auto-summary
     autonomous-system 10
     exit-address-family
    !
    router ospf 1
     log-adjacency-changes
     network 160.1.6.6 0.0.0.0 area 0
     network 160.1.56.6 0.0.0.0 area 0
    !
    router bgp 100
     no bgp default ipv4-unicast
     bgp log-neighbor-changes
     neighbor 160.1.5.5 remote-as 100
     neighbor 160.1.5.5 update-source Loopback0
     !       
     address-family vpnv4
     neighbor 160.1.5.5 activate
     neighbor 160.1.5.5 send-community both
     neighbor 160.1.5.5 next-hop-self
     exit-address-family
     !
     address-family ipv4 vrf 54
     neighbor 204.12.1.254 remote-as 54
     neighbor 204.12.1.254 activate
     no synchronization
     exit-address-family
     !
     address-family ipv4 vrf 100
     redistribute connected
     redistribute eigrp 10
     no synchronization
     exit-address-family
    !
    ip http server
    no ip http secure-server
    !
    !
    ip pim rp-address 160.1.5.5
    !
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    line con 0
     exec-timeout 0 0
     logging synchronous
    line aux 0
    line vty 0 4
     privilege level 15
     no login
    !        
    scheduler allocate 20000 1000
    !
    end
    ======================================================================

     

     

  • Hello BassemMagdy,

    You didn't configure pim on R1 loopback.

    interface Loopback0
     ip address 150.1.1.1 255.255.255.255
     ip router isis
    !

    Please let me know how is going after that, :)

     

  • good point buddy, but what if i was sourcing the traffic from the serial interface??

    it still do not wanna work...

     

  • Guys,

    Can you please post on the correct forum so everyone working the labs can provide input as needed.

    If you keep using the tech forum then you might find you are asking Qs for labs that have been answered already.

  • what if i was sourcing the traffic from the serial interface??

    Hi dude, what do u mean sourcing traffic from serial interface? do you mean ping from R6 and igmp join at R7 site  ?

    In this case MDT is running across MPLS so edge router R1 and R3 they have to peer with MPBGP and peering address must have PIM Typically loopback of R1 and R3.

    Sorry for posting at wrong session, Please help to move to correct place.

  • As you can see my friend in the output the source which is validated against the RPF is the Ethernet interface of R7 "sorry it is not serial" and according to the out of the sh ip rpf as you can see there is no route inside the VRF for the RP although I can see its subnet in the routing table of the VRF

    Can anyone move this post to the correct forum?

     

Sign In or Register to comment.