multicast auto-rp problem

I was trying to duplicate the scenario from the Class On Demand cd from day 5 part 1 multicast where you have routers R3 -->connected to R1--> connected to R2. So, in the COD Brian configures auto-rp on R2 by configuring:

!
ip pim send-rp-announce Loopback0 scope 255
ip pim send-rp-discovery Loopback0 scope 255
!
He then goes through the routers and does a show ip pim rp mappings on all the routers R2 then R1 then R3 to show us how the mapping info  is passed down through the routers from R2 which is the rp-canidate and the Mapping agent.

However, In my lab, the RP mapping info never shows up on my R3. Show ip pim rp mapping shows nothing.

 

Also, Debugs of mpacket on R1 show the following:


R1#
00:48:03: IP(0): s=150.1.2.2 (FastEthernet0/0) d=224.0.1.40 id=3217, ttl=254, prot=17, len=62(48), mroute olist null
00:48:17: IP(0): s=150.1.2.2 (FastEthernet0/0) d=224.0.1.39 id=3230, ttl=254, prot=17, len=62(48), mroute olist null
00:49:03: IP(0): s=150.1.2.2 (FastEthernet0/0) d=224.0.1.40 id=3263, ttl=254, prot=17, len=62(48), mroute olist null

 

Here are my configs from R2,R1,R3

 

R2:

R2#sh run
Building configuration...

Current configuration : 3015 bytes
!
version 12.2
!
hostname R2
!
enable password cisco
!
ip subnet-zero
ip cef
!
!
no ip domain-lookup
!
ip multicast-routing
no mpls traffic-eng auto-bw timers frequency 0
call rsvp-sync
!
interface Loopback0
 ip address 150.1.2.2 255.255.255.255
 ip pim sparse-mode
 ip router isis
!
interface FastEthernet0/0
 description r1
 ip address 150.1.12.2 255.255.255.0
 ip pim sparse-mode
 ip router isis
 no ip mroute-cache
 load-interval 30
 duplex half
 mpls ip
!        
!
interface Ethernet5/0
 description r4
 ip address 150.1.24.2 255.255.255.0
 ip router isis
 no ip mroute-cache
 duplex half
 mpls ip
!
!
!
!
router isis
 net 49.0000.0000.0002.00
 is-type level-2-only
!
ip classless
!
ip pim send-rp-announce Loopback0 scope 255
ip pim send-rp-discovery Loopback0 scope 255
!
!
!
end

R2#    

R2#     show ip pim ne
PIM Neighbor Table
Neighbor          Interface                Uptime/Expires    Ver   DR
Address                                                            Prio/Mode
150.1.12.1        FastEthernet0/0          01:24:07/00:01:15 v2    1 / S
R2#
R2#ping 150.1.3.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 150.1.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/36/56 ms
R2#traceroute 150.1.3.3

Type escape sequence to abort.
Tracing the route to 150.1.3.3

  1 150.1.12.1 [MPLS: Label 18 Exp 0] 12 msec 24 msec 32 msec
  2 150.1.13.3 40 msec *  32 msec
R2#

 

-------------------------------------------------------------------

R1#sh run
Building configuration...

Current configuration : 2478 bytes
!
version 12.2
!
hostname R1
!
enable password cisco
!
ip subnet-zero
ip cef
!
!
no ip domain-lookup
!
ip multicast-routing
no mpls traffic-eng auto-bw timers frequency 0
mpls label protocol ldp
call rsvp-sync
!
!        
interface Loopback0
 ip address 150.1.1.1 255.255.255.255
 ip router isis
!
interface FastEthernet0/0
 description r2
 ip address 150.1.12.1 255.255.255.0
 ip pim sparse-mode
 ip router isis
 no ip mroute-cache
 duplex half
 mpls ip
!
interface Ethernet5/0
 description r3
 ip address 150.1.13.1 255.255.255.0
 ip pim sparse-mode
 ip router isis
 service-policy output TRAFFIC_OUT
 no ip mroute-cache
 duplex half
 mpls ip
!
router isis
 net 49.0000.0000.0001.00
 is-type level-2-only
!
ip classless
!
end

R1#
PIM Neighbor Table
Neighbor          Interface                Uptime/Expires    Ver   DR
Address                                                            Prio/Mode
150.1.12.2        FastEthernet0/0          01:27:34/00:01:21 v2    1 / DR S
150.1.13.3        Ethernet5/0              00:57:01/00:01:23 v2    1 / DR S
R1#sh ip pim rp mapping
PIM Group-to-RP Mappings

Group(s) 224.0.0.0/4
  RP 150.1.2.2 (?), v2v1
    Info source: 150.1.2.2 (?), elected via Auto-RP
         Uptime: 00:08:34, expires: 00:02:21
R1#
R1#sh ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report, Z - Multicast Tunnel
       Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.0.1.39), 00:09:00/stopped, RP 0.0.0.0, flags: DP
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list: Null

(150.1.2.2, 224.0.1.39), 00:01:00/00:01:59, flags: PT
  Incoming interface: FastEthernet0/0, RPF nbr 150.1.12.2
  Outgoing interface list: Null

(*, 224.0.1.40), 01:28:37/stopped, RP 0.0.0.0, flags: DPL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list: Null

(150.1.2.2, 224.0.1.40), 00:08:59/00:02:56, flags: PLT
  Incoming interface: FastEthernet0/0, RPF nbr 150.1.12.2
  Outgoing interface list: Null

R1#
R1#debug ip mpacket
IP multicast packets debugging is on
R1#debug ip pim
PIM debugging is on
R1#debug ip igmp
IGMP debugging is on
R1#
01:30:17: IGMP(0): Send v2 general Query on FastEthernet0/0
01:30:17: IGMP(0): Set report delay time to 3.6 seconds for 224.0.1.40 on FastEthernet0/0
01:30:18: IGMP(0): Send v2 general Query on Ethernet5/0
01:30:21: IGMP(0): Send v2 Report for 224.0.1.40 on FastEthernet0/0
01:30:21: IGMP(0): Received v2 Report on FastEthernet0/0 from 150.1.12.1 for 224.0.1.40
01:30:21: IGMP(0): Received Group record for group 224.0.1.40, mode 2 from 150.1.12.1 for 0 sources
01:30:21: IGMP(0): Updating EXCLUDE group timer for 224.0.1.40
01:30:21: IGMP(0): MRT Add/Update FastEthernet0/0 for (*,224.0.1.40) by 0
01:30:23: IGMP(0): Received v2 Report on FastEthernet0/0 from 150.1.12.2 for 224.0.1.39
01:30:23: IGMP(0): Received Group record for group 224.0.1.39, mode 2 from 150.1.12.2 for 0 sources
01:30:23: IGMP(0): Updating EXCLUDE group timer for 224.0.1.39
01:30:23: IGMP(0): MRT Add/Update FastEthernet0/0 for (*,224.0.1.39) by 0
01:30:37: IP(0): s=150.1.2.2 (FastEthernet0/0) d=224.0.1.40 id=5648, ttl=254, prot=17, len=62(48), mroute olist null
01:30:41: IP(0): s=150.1.2.2 (FastEthernet0/0) d=224.0.1.39 id=5654, ttl=254, prot=17, len=62(48), mroute olist null
01:31:17: IGMP(0): Send v2 general Query on FastEthernet0/0
01:31:17: IGMP(0): Set report delay time to 6.4 seconds for 224.0.1.40 on FastEthernet0/0
01:31:18: IGMP(0): Send v2 general Query on Ethernet5/0
01:31:21: IGMP(0): Received v2 Report on FastEthernet0/0 from 150.1.12.2 for 224.0.1.39
01:31:21: IGMP(0): Received Group record for group 224.0.1.39, mode 2 from 150.1.12.2 for 0 sources
01:31:21: IGMP(0): Updating EXCLUDE group timer for 224.0.1.39
01:31:21: IGMP(0): MRT Add/Update FastEthernet0/0 for (*,224.0.1.39) by 0
01:31:24: IGMP(0): Send v2 Report for 224.0.1.40 on FastEthernet0/0
01:31:24: IGMP(0): Received v2 Report on FastEthernet0/0 from 150.1.12.1 for 224.0.1.40
01:31:24: IGMP(0): Received Group record for group 224.0.1.40, mode 2 from 150.1.12.1 for 0 sources
01:31:24: IGMP(0): Updating EXCLUDE group timer for 224.0.1.40
01:31:24: IGMP(0): MRT Add/Update FastEthernet0/0 for (*,224.0.1.40) by 0
01:31:37: IP(0): s=150.1.2.2 (FastEthernet0/0) d=224.0.1.40 id=5698, ttl=254, prot=17, len=62(48), mroute olist null
01:31:41: PIM(0): Insert (150.1.2.2,224.0.1.39) prune in nbr 150.1.12.2's queue
01:31:41: IP(0): s=150.1.2.2 (FastEthernet0/0) d=224.0.1.39 id=5704, ttl=254, prot=17, len=62(48), mroute olist null
01:31:41: PIM(0): Building Join/Prune packet for nbr 150.1.12.2
01:31:41: PIM(0): Adding v2 (150.1.2.2/32, 224.0.1.39) Prune
01:31:41: PIM(0): Send v2 join/prune to 150.1.12.2 (FastEthernet0/0)
01:32:17: IGMP(0): Send v2 general Query on FastEthernet0/0
01:32:17: IGMP(0): Set report delay time to 3.2 seconds for 224.0.1.40 on FastEthernet0/0
01:32:18: IGMP(0): Send v2 general Query on Ethernet5/0
01:32:21: IGMP(0): Received v2 Report on FastEthernet0/0 from 150.1.12.2 for 224.0.1.39
01:32:21: IGMP(0): Received Group record for group 224.0.1.39, mode 2 from 150.1.12.2 for 0 sources
01:32:21: IGMP(0): Updating EXCLUDE group timer for 224.0.1.39
01:32:21: IGMP(0): MRT Add/Update FastEthernet0/0 for (*,224.0.1.39) by 0
01:32:21: IGMP(0): Send v2 Report for 224.0.1.40 on FastEthernet0/0
01:32:21: IGMP(0): Received v2 Report on FastEthernet0/0 from 150.1.12.1 for 224.0.1.40
01:32:21: IGMP(0): Received Group record for group 224.0.1.40, mode 2 from 150.1.12.1 for 0 sources
01:32:21: IGMP(0): Updating EXCLUDE group timer for 224.0.1.40
01:32:21: IGMP(0): MRT Add/Update FastEthernet0/0 for (*,224.0.1.40) by 0
01:32:37: IP(0): s=150.1.2.2 (FastEthernet0/0) d=224.0.1.40 id=5745, ttl=254, prot=17, len=62(48), mroute olist null
01:32:41: IP(0): s=150.1.2.2 (FastEthernet0/0) d=224.0.1.39 id=5752, ttl=254, prot=17, len=62(48), mroute olist null
01:33:18: IGMP(0): Send v2 general Query on FastEthernet0/0
01:33:18: IGMP(0): Set report delay time to 2.7 seconds for 224.0.1.40 on FastEthernet0/0
01:33:19: IGMP(0): Send v2 general Query on Ethernet5/0
01:33:21: IGMP(0): Send v2 Report for 224.0.1.40 on FastEthernet0/0
01:33:21: IGMP(0): Received v2 Report on FastEthernet0/0 from 150.1.12.1 for 224.0.1.40
01:33:21: IGMP(0): Received Group record for group 224.0.1.40, mode 2 from 150.1.12.1 for 0 sources
01:33:21: IGMP(0): Updating EXCLUDE group timer for 224.0.1.40
01:33:21: IGMP(0): MRT Add/Update FastEthernet0/0 for (*,224.0.1.40) by 0
01:33:22: IGMP(0): Received v2 Report on FastEthernet0/0 from 150.1.12.2 for 224.0.1.39
01:33:22: IGMP(0): Received Group record for group 224.0.1.39, mode 2 from 150.1.12.2 for 0 sources
01:33:22: IGMP(0): Updating EXCLUDE group timer for 224.0.1.39
01:33:22: IGMP(0): MRT Add/Update FastEthernet0/0 for (*,224.0.1.39) by 0
01:33:37: IP(0): s=150.1.2.2 (FastEthernet0/0) d=224.0.1.40 id=5793, ttl=254, prot=17, len=62(48), mroute olist null
01:33:40: IP(0): s=150.1.2.2 (FastEthernet0/0) d=224.0.1.39 id=5801, ttl=254, prot=17, len=62(48), mroute olist null
01:34:18: IGMP(0): Send v2 general Query on FastEthernet0/0
01:34:18: IGMP(0): Set report delay time to 9.9 seconds for 224.0.1.40 on FastEthernet0/0
01:34:19: IGMP(0): Send v2 general Query on Ethernet5/0
01:34:22: IGMP(0): Received v2 Report on FastEthernet0/0 from 150.1.12.2 for 224.0.1.39
01:34:22: IGMP(0): Received Group record for group 224.0.1.39, mode 2 from 150.1.12.2 for 0 sources
01:34:22: IGMP(0): Updating EXCLUDE group timer for 224.0.1.39
01:34:22: IGMP(0): MRT Add/Update FastEthernet0/0 for (*,224.0.1.39) by 0
01:34:28: IGMP(0): Send v2 Report for 224.0.1.40 on FastEthernet0/0
01:34:28: IGMP(0): Received v2 Report on FastEthernet0/0 from 150.1.12.1 for 224.0.1.40
01:34:28: IGMP(0): Received Group record for group 224.0.1.40, mode 2 from 150.1.12.1 for 0 sources
01:34:28: IGMP(0): Updating EXCLUDE group timer for 224.0.1.40
01:34:28: IGMP(0): MRT Add/Update FastEthernet0/0 for (*,224.0.1.40) by 0
01:34:36: IP(0): s=150.1.2.2 (FastEthernet0/0) d=224.0.1.40 id=5842, ttl=254, prot=17, len=62(48), mroute olist null
01:34:41: IP(0): s=150.1.2.2 (FastEthernet0/0) d=224.0.1.39 id=5848, ttl=254, prot=17, len=62(48), mroute olist null
R1#
R1#un all
All possible debugging has been turned off
R1#

 

----------------------------------------------------------------------------------------------------------------------------------

 

R3#sh run
Building configuration...

Current configuration : 3399 bytes
!
version 12.4
hostname R3
!
enable password cisco
!
!
ip cef
no ip domain lookup
!
!
ip multicast-routing
!
!
vtp file nvram:vlan.dat
!
!
!
interface Loopback0
 ip address 150.1.3.3 255.255.255.255
 ip router isis
!
interface Ethernet0/0
 description R7
 ip address 10.1.37.3 255.255.255.0
 ip router isis
 ip pim sparse-mode
 no ip mroute-cache
 half-duplex
!
!
interface Ethernet0/3
 description R1
 ip address 150.1.13.3 255.255.255.0
 ip router isis
 ip pim sparse-mode
 no ip mroute-cache
 half-duplex
 mpls ip
!
!
!
router isis
 net 49.0000.0000.0003.00
!
ip http server
ip forward-protocol nd
!
!
end

R3#   
R3#
R3#debug ip pim
PIM debugging is on
R3#debug ip igmp
IGMP debugging is on
R3#debug ip mpacket
IP multicast packets debugging is on
R3#
R3#
R3#term mon
R3#
*Mar  1 01:40:44.743: IGMP(0): Received v2 Query on Ethernet0/3 from 150.1.13.1
*Mar  1 01:41:05.251: IGMP(0): Send v2 general Query on Ethernet0/0
*Mar  1 01:41:05.255: IGMP(0): Set report delay time to 7.7 seconds for 224.0.1.40 on Ethernet0/0
*Mar  1 01:41:13.255: IGMP(0): Send v2 Report for 224.0.1.40 on Ethernet0/0
*Mar  1 01:41:13.255: IGMP(0): Received v2 Report on Ethernet0/0 from 10.1.37.3 for 224.0.1.40
*Mar  1 01:41:13.255: IGMP(0): Received Group record for group 224.0.1.40, mode 2 from 10.1.37.3 for 0 sources
*Mar  1 01:41:13.255: IGMP(0): Updating EXCLUDE group timer for 224.0.1.40
*Mar  1 01:41:13.255: IGMP(0): MRT Add/Update Ethernet0/0 for (*,224.0.1.40) by 0
*Mar  1 01:41:44.903: IGMP(0): Received v2 Query on Ethernet0/3 from 150.1.13.1
*Mar  1 01:42:05.295: IGMP(0): Send v2 general Query on Ethernet0/0
*Mar  1 01:42:05.299: IGMP(0): Set report delay time to 0.5 seconds for 224.0.1.40 on Ethernet0/0
*Mar  1 01:42:06.303: IGMP(0): Send v2 Report for 224.0.1.40 on Ethernet0/0
*Mar  1 01:42:06.303: IGMP(0): Received v2 Report on Ethernet0/0 from 10.1.37.3 for 224.0.1.40
*Mar  1 01:42:06.303: IGMP(0): Received Group record for group 224.0.1.40, mode 2 from 10.1.37.3 for 0 sources
*Mar  1 01:42:06.303: IGMP(0): Updating EXCLUDE group timer for 224.0.1.40
*Mar  1 01:42:06.303: IGMP(0): MRT Add/Update Ethernet0/0 for (*,224.0.1.40) by 0
*Mar  1 01:42:45.031: IGMP(0): Received v2 Query on Ethernet0/3 from 150.1.13.1
*Mar  1 01:43:05.339: IGMP(0): Send v2 general Query on Ethernet0/0
*Mar  1 01:43:05.343: IGMP(0): Set report delay time to 0.1 seconds for 224.0.1.40 on Ethernet0/0
*Mar  1 01:43:06.355: IGMP(0): Send v2 Report for 224.0.1.40 on Ethernet0/0
*Mar  1 01:43:06.355: IGMP(0): Received v2 Report on Ethernet0/0 from 10.1.37.3 for 224.0.1.40
*Mar  1 01:43:06.355: IGMP(0): Received Group record for group 224.0.1.40, mode 2 from 10.1.37.3 for 0 sources
*Mar  1 01:43:06.355: IGMP(0): Updating EXCLUDE group timer for 224.0.1.40
*Mar  1 01:43:06.355: IGMP(0): MRT Add/Update Ethernet0/0 for (*,224.0.1.40) by 0
*Mar  1 01:43:45.251: IGMP(0): Received v2 Query on Ethernet0/3 from 150.1.13.1
*Mar  1 01:44:05.387: IGMP(0): Send v2 general Query on Ethernet0/0
*Mar  1 01:44:05.391: IGMP(0): Set report delay time to 6.0 seconds for 224.0.1.40 on Ethernet0/0
*Mar  1 01:44:11.431: IGMP(0): Send v2 Report for 224.0.1.40 on Ethernet0/0
*Mar  1 01:44:11.431: IGMP(0): Received v2 Report on Ethernet0/0 from 10.1.37.3 for 224.0.1.40
*Mar  1 01:44:11.431: IGMP(0): Received Group record for group 224.0.1.40, mode 2 from 10.1.37.3 for 0 sources
*Mar  1 01:44:11.431: IGMP(0): Updating EXCLUDE group timer for 224.0.1.40
*Mar  1 01:44:11.431: IGMP(0): MRT Add/Update Ethernet0/0 for (*,224.0.1.40) by 0
*Mar  1 01:44:45.359: IGMP(0): Received v2 Query on Ethernet0/3 from 150.1.13.1
*Mar  1 01:45:05.455: IGMP(0): Send v2 general Query on Ethernet0/0
*Mar  1 01:45:05.459: IGMP(0): Set report delay time to 2.3 seconds for 224.0.1.40 on Ethernet0/0
*Mar  1 01:45:08.483: IGMP(0): Send v2 Report for 224.0.1.40 on Ethernet0/0
*Mar  1 01:45:08.483: IGMP(0): Received v2 Report on Ethernet0/0 from 10.1.37.3 for 224.0.1.40
*Mar  1 01:45:08.483: IGMP(0): Received Group record for group 224.0.1.40, mode 2 from 10.1.37.3 for 0 sources
*Mar  1 01:45:08.483: IGMP(0): Updating EXCLUDE group timer for 224.0.1.40
*Mar  1 01:45:08.483: IGMP(0): MRT Add/Update Ethernet0/0 for (*,224.0.1.40) by 0
*Mar  1 01:45:45.583: IGMP(0): Received v2 Query on Ethernet0/3 from 150.1.13.1
*Mar  1 01:46:05.519: IGMP(0): Send v2 general Query on Ethernet0/0
*Mar  1 01:46:05.523: IGMP(0): Set report delay time to 2.7 seconds for 224.0.1.40 on Ethernet0/0
*Mar  1 01:46:08.543: IGMP(0): Send v2 Report for 224.0.1.40 on Ethernet0/0
*Mar  1 01:46:08.543: IGMP(0): Received v2 Report on Ethernet0/0 from 10.1.37.3 for 224.0.1.40
*Mar  1 01:46:08.543: IGMP(0): Received Group record for group 224.0.1.40, mode 2 from 10.1.37.3 for 0 sources
*Mar  1 01:46:08.543: IGMP(0): Updating EXCLUDE group timer for 224.0.1.40
*Mar  1 01:46:08.543: IGMP(0): MRT Add/Update Ethernet0/0 for (*,224.0.1.40) by 0
*Mar  1 01:46:45.751: IGMP(0): Received v2 Query on Ethernet0/3 from 150.1.13.1
*Mar  1 01:47:05.555: IGMP(0): Send v2 general Query on Ethernet0/0
*Mar  1 01:47:05.559: IGMP(0): Set report delay time to 7.2 seconds for 224.0.1.40 on Ethernet0/0
*Mar  1 01:47:13.579: IGMP(0): Send v2 Report for 224.0.1.40 on Ethernet0/0
*Mar  1 01:47:13.579: IGMP(0): Received v2 Report on Ethernet0/0 from 10.1.37.3 for 224.0.1.40
*Mar  1 01:47:13.579: IGMP(0): Received Group record for group 224.0.1.40, mode 2 from 10.1.37.3 for 0 sources
*Mar  1 01:47:13.579: IGMP(0): Updating EXCLUDE group timer for 224.0.1.40
*Mar  1 01:47:13.579: IGMP(0): MRT Add/Update Ethernet0/0 for (*,224.0.1.40) by 0
*Mar  1 01:47:45.967: IGMP(0): Received v2 Query on Ethernet0/3 from 150.1.13.1
*Mar  1 01:48:05.603: IGMP(0): Send v2 general Query on Ethernet0/0
*Mar  1 01:48:05.603: IGMP(0): Set report delay time to 7.2 seconds for 224.0.1.40 on Ethernet0/0
*Mar  1 01:48:13.619: IGMP(0): Send v2 Report for 224.0.1.40 on Ethernet0/0
*Mar  1 01:48:13.619: IGMP(0): Received v2 Report on Ethernet0/0 from 10.1.37.3 for 224.0.1.40
*Mar  1 01:48:13.619: IGMP(0): Received Group record for group 224.0.1.40, mode 2 from 10.1.37.3 for 0 sources
*Mar  1 01:48:13.619: IGMP(0): Updating EXCLUDE group timer for 224.0.1.40
*Mar  1 01:48:13.619: IGMP(0): MRT Add/Update Ethernet0/0 for (*,224.0.1.40) by 0
*Mar  1 01:48:46.187: IGMP(0): Received v2 Query on Ethernet0/3 from 150.1.13.1
*Mar  1 01:49:05.659: IGMP(0): Send v2 general Query on Ethernet0/0
*Mar  1 01:49:05.663: IGMP(0): Set report delay time to 5.2 seconds for 224.0.1.40 on Ethernet0/0
*Mar  1 01:49:11.699: IGMP(0): Send v2 Report for 224.0.1.40 on Ethernet0/0
*Mar  1 01:49:11.703: IGMP(0): Received v2 Report on Ethernet0/0 from 10.1.37.3 for 224.0.1.40
*Mar  1 01:49:11.703: IGMP(0): Received Group record for group 224.0.1.40, mode 2 from 10.1.37.3 for 0 sources
*Mar  1 01:49:11.703: IGMP(0): Updating EXCLUDE group timer for 224.0.1.40
*Mar  1 01:49:11.703: IGMP(0): MRT Add/Update Ethernet0/0 for (*,224.0.1.40) by 0
*Mar  1 01:49:46.355: IGMP(0): Received v2 Query on Ethernet0/3 from 150.1.13.1
*Mar  1 01:50:05.683: IGMP(0): Send v2 general Query on Ethernet0/0
*Mar  1 01:50:05.687: IGMP(0): Set report delay time to 7.1 seconds for 224.0.1.40 on Ethernet0/0

 

 

Comments

  • <!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">






    If you're running PIM in sparse-mode only you'll need to add "ip pim
    auto-rp listener" to force the routers to treat 224.0.1.39 and
    224.0.1.40 as dense mode groups.  The other option would be to run
    sparse-dense mode.





    HTH,



    Brian McGahan, CCIE #8593 (R&S/SP/Security)

    [email protected]

     

    Internetwork Expert, Inc.

    http://www.InternetworkExpert.com

    Toll Free: 877-224-8987 x 705

    Outside US: 775-826-4344 x 705

    Online Community: http://www.IEOC.com

    CCIE Blog: http://blog.internetworkexpert.com






    rockriver wrote:

    I was trying to duplicate the scenario from the Class On Demand cd
    from day 5 part 1 multicast where you have routers R3 -->connected
    to R1--> connected to R2. So, in the COD Brian configures auto-rp on
    R2 by configuring:

    !

    ip pim send-rp-announce Loopback0 scope 255

    ip pim send-rp-discovery Loopback0 scope 255

    !

    He then goes through the routers and does a show ip pim rp mappings on
    all the routers R2 then R1 then R3 to show us how the mapping info  is
    passed down through the routers from R2 which is the rp-canidate and
    the Mapping agent.

    However, In my lab, the RP mapping info never shows up on my R3.
    Show ip pim rp mapping shows nothing.

     

    Also, Debugs of mpacket on R1 show the following:



    R1#

    00:48:03: IP(0): s=150.1.2.2 (FastEthernet0/0) d=224.0.1.40 id=3217,
    ttl=254, prot=17, len=62(48), mroute olist null

    00:48:17: IP(0): s=150.1.2.2 (FastEthernet0/0) d=224.0.1.39 id=3230,
    ttl=254, prot=17, len=62(48), mroute olist null

    00:49:03: IP(0): s=150.1.2.2 (FastEthernet0/0) d=224.0.1.40 id=3263,
    ttl=254, prot=17, len=62(48), mroute olist null

     

    Here are my configs from R2,R1,R3

     

    R2:

    R2#sh run

    Building configuration...



    Current configuration : 3015 bytes

    !

    version 12.2

    !

    hostname R2

    !

    enable password cisco

    !

    ip subnet-zero

    ip cef

    !

    !

    no ip domain-lookup

    !

    ip multicast-routing

    no mpls traffic-eng auto-bw timers frequency 0

    call rsvp-sync

    !

    interface Loopback0

     ip address 150.1.2.2 255.255.255.255

     ip pim sparse-mode

     ip router isis

    !

    interface FastEthernet0/0

     description r1

     ip address 150.1.12.2 255.255.255.0

     ip pim sparse-mode

     ip router isis

     no ip mroute-cache

     load-interval 30

     duplex half

     mpls ip

    !        

    !

    interface Ethernet5/0

     description r4

     ip address 150.1.24.2 255.255.255.0

     ip router isis

     no ip mroute-cache

     duplex half

     mpls ip

    !

    !

    !

    !

    router isis

     net 49.0000.0000.0002.00

     is-type level-2-only

    !

    ip classless

    !

    ip pim send-rp-announce Loopback0 scope 255

    ip pim send-rp-discovery Loopback0 scope 255

    !

    !

    !

    end



    R2#    



    R2#     show ip pim ne

    PIM Neighbor Table

    Neighbor          Interface                Uptime/Expires    Ver   DR

    Address                                                           
    Prio/Mode

    150.1.12.1        FastEthernet0/0          01:24:07/00:01:15 v2    1 / S

    R2#

    R2#ping 150.1.3.3



    Type escape sequence to abort.

    Sending 5, 100-byte ICMP Echos to 150.1.3.3, timeout is 2 seconds:

    !!!!!

    Success rate is 100 percent (5/5), round-trip min/avg/max = 16/36/56 ms

    R2#traceroute 150.1.3.3



    Type escape sequence to abort.

    Tracing the route to 150.1.3.3



      1 150.1.12.1 [MPLS: Label 18 Exp 0] 12 msec 24 msec 32 msec

      2 150.1.13.3 40 msec *  32 msec

    R2#

     

    -------------------------------------------------------------------

    R1#sh run

    Building configuration...



    Current configuration : 2478 bytes

    !

    version 12.2

    !

    hostname R1

    !

    enable password cisco

    !

    ip subnet-zero

    ip cef

    !

    !

    no ip domain-lookup

    !

    ip multicast-routing

    no mpls traffic-eng auto-bw timers frequency 0

    mpls label protocol ldp

    call rsvp-sync

    !

    !        

    interface Loopback0

     ip address 150.1.1.1 255.255.255.255

     ip router isis

    !

    interface FastEthernet0/0

     description r2

     ip address 150.1.12.1 255.255.255.0

     ip pim sparse-mode

     ip router isis

     no ip mroute-cache

     duplex half

     mpls ip

    !

    interface Ethernet5/0

     description r3

     ip address 150.1.13.1 255.255.255.0

     ip pim sparse-mode

     ip router isis

     service-policy output TRAFFIC_OUT

     no ip mroute-cache

     duplex half

     mpls ip

    !

    router isis

     net 49.0000.0000.0001.00

     is-type level-2-only

    !

    ip classless

    !

    end



    R1#

    PIM Neighbor Table

    Neighbor          Interface                Uptime/Expires    Ver   DR

    Address                                                           
    Prio/Mode

    150.1.12.2        FastEthernet0/0          01:27:34/00:01:21 v2    1 /
    DR S

    150.1.13.3        Ethernet5/0              00:57:01/00:01:23 v2    1 /
    DR S

    R1#sh ip pim rp mapping

    PIM Group-to-RP Mappings



    Group(s) 224.0.0.0/4

      RP 150.1.2.2 (?), v2v1

        Info source: 150.1.2.2 (?), elected via Auto-RP

             Uptime: 00:08:34, expires: 00:02:21

    R1#

    R1#sh ip mroute

    IP Multicast Routing Table

    Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C -
    Connected,

           L - Local, P - Pruned, R - RP-bit set, F - Register flag,

           T - SPT-bit set, J - Join SPT, M - MSDP created entry,

           X - Proxy Join Timer Running, A - Candidate for MSDP
    Advertisement,

           U - URD, I - Received Source Specific Host Report, Z - Multicast
    Tunnel

           Y - Joined MDT-data group, y - Sending to MDT-data group

    Outgoing interface flags: H - Hardware switched, A - Assert winner

     Timers: Uptime/Expires

     Interface state: Interface, Next-Hop or VCD, State/Mode



    (*, 224.0.1.39), 00:09:00/stopped, RP 0.0.0.0, flags: DP

      Incoming interface: Null, RPF nbr 0.0.0.0

      Outgoing interface list: Null



    (150.1.2.2, 224.0.1.39), 00:01:00/00:01:59, flags: PT

      Incoming interface: FastEthernet0/0, RPF nbr 150.1.12.2

      Outgoing interface list: Null



    (*, 224.0.1.40), 01:28:37/stopped, RP 0.0.0.0, flags: DPL

      Incoming interface: Null, RPF nbr 0.0.0.0

      Outgoing interface list: Null



    (150.1.2.2, 224.0.1.40), 00:08:59/00:02:56, flags: PLT

      Incoming interface: FastEthernet0/0, RPF nbr 150.1.12.2

      Outgoing interface list: Null



    R1#

    R1#debug ip mpacket

    IP multicast packets debugging is on

    R1#debug ip pim

    PIM debugging is on

    R1#debug ip igmp

    IGMP debugging is on

    R1#

    01:30:17: IGMP(0): Send v2 general Query on FastEthernet0/0

    01:30:17: IGMP(0): Set report delay time to 3.6 seconds for 224.0.1.40
    on FastEthernet0/0

    01:30:18: IGMP(0): Send v2 general Query on Ethernet5/0

    01:30:21: IGMP(0): Send v2 Report for 224.0.1.40 on FastEthernet0/0

    01:30:21: IGMP(0): Received v2 Report on FastEthernet0/0 from
    150.1.12.1 for 224.0.1.40

    01:30:21: IGMP(0): Received Group record for group 224.0.1.40, mode 2
    from 150.1.12.1 for 0 sources

    01:30:21: IGMP(0): Updating EXCLUDE group timer for 224.0.1.40

    01:30:21: IGMP(0): MRT Add/Update FastEthernet0/0 for (*,224.0.1.40) by
    0

    01:30:23: IGMP(0): Received v2 Report on FastEthernet0/0 from
    150.1.12.2 for 224.0.1.39

    01:30:23: IGMP(0): Received Group record for group 224.0.1.39, mode 2
    from 150.1.12.2 for 0 sources

    01:30:23: IGMP(0): Updating EXCLUDE group timer for 224.0.1.39

    01:30:23: IGMP(0): MRT Add/Update FastEthernet0/0 for (*,224.0.1.39) by
    0

    01:30:37: IP(0): s=150.1.2.2 (FastEthernet0/0) d=224.0.1.40 id=5648,
    ttl=254, prot=17, len=62(48), mroute olist null

    01:30:41: IP(0): s=150.1.2.2 (FastEthernet0/0) d=224.0.1.39 id=5654,
    ttl=254, prot=17, len=62(48), mroute olist null

    01:31:17: IGMP(0): Send v2 general Query on FastEthernet0/0

    01:31:17: IGMP(0): Set report delay time to 6.4 seconds for 224.0.1.40
    on FastEthernet0/0

    01:31:18: IGMP(0): Send v2 general Query on Ethernet5/0

    01:31:21: IGMP(0): Received v2 Report on FastEthernet0/0 from
    150.1.12.2 for 224.0.1.39

    01:31:21: IGMP(0): Received Group record for group 224.0.1.39, mode 2
    from 150.1.12.2 for 0 sources

    01:31:21: IGMP(0): Updating EXCLUDE group timer for 224.0.1.39

    01:31:21: IGMP(0): MRT Add/Update FastEthernet0/0 for (*,224.0.1.39) by
    0

    01:31:24: IGMP(0): Send v2 Report for 224.0.1.40 on FastEthernet0/0

    01:31:24: IGMP(0): Received v2 Report on FastEthernet0/0 from
    150.1.12.1 for 224.0.1.40

    01:31:24: IGMP(0): Received Group record for group 224.0.1.40, mode 2
    from 150.1.12.1 for 0 sources

    01:31:24: IGMP(0): Updating EXCLUDE group timer for 224.0.1.40

    01:31:24: IGMP(0): MRT Add/Update FastEthernet0/0 for (*,224.0.1.40) by
    0

    01:31:37: IP(0): s=150.1.2.2 (FastEthernet0/0) d=224.0.1.40 id=5698,
    ttl=254, prot=17, len=62(48), mroute olist null

    01:31:41: PIM(0): Insert (150.1.2.2,224.0.1.39) prune in nbr
    150.1.12.2's queue

    01:31:41: IP(0): s=150.1.2.2 (FastEthernet0/0) d=224.0.1.39 id=5704,
    ttl=254, prot=17, len=62(48), mroute olist null

    01:31:41: PIM(0): Building Join/Prune packet for nbr 150.1.12.2

    01:31:41: PIM(0): Adding v2 (150.1.2.2/32, 224.0.1.39) Prune

    01:31:41: PIM(0): Send v2 join/prune to 150.1.12.2 (FastEthernet0/0)

    01:32:17: IGMP(0): Send v2 general Query on FastEthernet0/0

    01:32:17: IGMP(0): Set report delay time to 3.2 seconds for 224.0.1.40
    on FastEthernet0/0

    01:32:18: IGMP(0): Send v2 general Query on Ethernet5/0

    01:32:21: IGMP(0): Received v2 Report on FastEthernet0/0 from
    150.1.12.2 for 224.0.1.39

    01:32:21: IGMP(0): Received Group record for group 224.0.1.39, mode 2
    from 150.1.12.2 for 0 sources

    01:32:21: IGMP(0): Updating EXCLUDE group timer for 224.0.1.39

    01:32:21: IGMP(0): MRT Add/Update FastEthernet0/0 for (*,224.0.1.39) by
    0

    01:32:21: IGMP(0): Send v2 Report for 224.0.1.40 on FastEthernet0/0

    01:32:21: IGMP(0): Received v2 Report on FastEthernet0/0 from
    150.1.12.1 for 224.0.1.40

    01:32:21: IGMP(0): Received Group record for group 224.0.1.40, mode 2
    from 150.1.12.1 for 0 sources

    01:32:21: IGMP(0): Updating EXCLUDE group timer for 224.0.1.40

    01:32:21: IGMP(0): MRT Add/Update FastEthernet0/0 for (*,224.0.1.40) by
    0

    01:32:37: IP(0): s=150.1.2.2 (FastEthernet0/0) d=224.0.1.40 id=5745,
    ttl=254, prot=17, len=62(48), mroute olist null

    01:32:41: IP(0): s=150.1.2.2 (FastEthernet0/0) d=224.0.1.39 id=5752,
    ttl=254, prot=17, len=62(48), mroute olist null

    01:33:18: IGMP(0): Send v2 general Query on FastEthernet0/0

    01:33:18: IGMP(0): Set report delay time to 2.7 seconds for 224.0.1.40
    on FastEthernet0/0

    01:33:19: IGMP(0): Send v2 general Query on Ethernet5/0

    01:33:21: IGMP(0): Send v2 Report for 224.0.1.40 on FastEthernet0/0

    01:33:21: IGMP(0): Received v2 Report on FastEthernet0/0 from
    150.1.12.1 for 224.0.1.40

    01:33:21: IGMP(0): Received Group record for group 224.0.1.40, mode 2
    from 150.1.12.1 for 0 sources

    01:33:21: IGMP(0): Updating EXCLUDE group timer for 224.0.1.40

    01:33:21: IGMP(0): MRT Add/Update FastEthernet0/0 for (*,224.0.1.40) by
    0

    01:33:22: IGMP(0): Received v2 Report on FastEthernet0/0 from
    150.1.12.2 for 224.0.1.39

    01:33:22: IGMP(0): Received Group record for group 224.0.1.39, mode 2
    from 150.1.12.2 for 0 sources

    01:33:22: IGMP(0): Updating EXCLUDE group timer for 224.0.1.39

    01:33:22: IGMP(0): MRT Add/Update FastEthernet0/0 for (*,224.0.1.39) by
    0

    01:33:37: IP(0): s=150.1.2.2 (FastEthernet0/0) d=224.0.1.40 id=5793,
    ttl=254, prot=17, len=62(48), mroute olist null

    01:33:40: IP(0): s=150.1.2.2 (FastEthernet0/0) d=224.0.1.39 id=5801,
    ttl=254, prot=17, len=62(48), mroute olist null

    01:34:18: IGMP(0): Send v2 general Query on FastEthernet0/0

    01:34:18: IGMP(0): Set report delay time to 9.9 seconds for 224.0.1.40
    on FastEthernet0/0

    01:34:19: IGMP(0): Send v2 general Query on Ethernet5/0

    01:34:22: IGMP(0): Received v2 Report on FastEthernet0/0 from
    150.1.12.2 for 224.0.1.39

    01:34:22: IGMP(0): Received Group record for group 224.0.1.39, mode 2
    from 150.1.12.2 for 0 sources

    01:34:22: IGMP(0): Updating EXCLUDE group timer for 224.0.1.39

    01:34:22: IGMP(0): MRT Add/Update FastEthernet0/0 for (*,224.0.1.39) by
    0

    01:34:28: IGMP(0): Send v2 Report for 224.0.1.40 on FastEthernet0/0

    01:34:28: IGMP(0): Received v2 Report on FastEthernet0/0 from
    150.1.12.1 for 224.0.1.40

    01:34:28: IGMP(0): Received Group record for group 224.0.1.40, mode 2
    from 150.1.12.1 for 0 sources

    01:34:28: IGMP(0): Updating EXCLUDE group timer for 224.0.1.40

    01:34:28: IGMP(0): MRT Add/Update FastEthernet0/0 for (*,224.0.1.40) by
    0

    01:34:36: IP(0): s=150.1.2.2 (FastEthernet0/0) d=224.0.1.40 id=5842,
    ttl=254, prot=17, len=62(48), mroute olist null

    01:34:41: IP(0): s=150.1.2.2 (FastEthernet0/0) d=224.0.1.39 id=5848,
    ttl=254, prot=17, len=62(48), mroute olist null

    R1#

    R1#un all

    All possible debugging has been turned off

    R1#

     

    ----------------------------------------------------------------------------------------------------------------------------------

     

    R3#sh run

    Building configuration...



    Current configuration : 3399 bytes

    !

    version 12.4

    hostname R3

    !

    enable password cisco

    !

    !

    ip cef

    no ip domain lookup

    !

    !

    ip multicast-routing

    !

    !

    vtp file nvram:vlan.dat

    !

    !

    !

    interface Loopback0

     ip address 150.1.3.3 255.255.255.255

     ip router isis

    !

    interface Ethernet0/0

     description R7

     ip address 10.1.37.3 255.255.255.0

     ip router isis

     ip pim sparse-mode

     no ip mroute-cache

     half-duplex

    !

    !

    interface Ethernet0/3

     description R1

     ip address 150.1.13.3 255.255.255.0

     ip router isis

     ip pim sparse-mode

     no ip mroute-cache

     half-duplex

     mpls ip

    !

    !

    !

    router isis

     net 49.0000.0000.0003.00

    !

    ip http server

    ip forward-protocol nd

    !

    !

    end



    R3#   

    R3#

    R3#debug ip pim

    PIM debugging is on

    R3#debug ip igmp

    IGMP debugging is on

    R3#debug ip mpacket

    IP multicast packets debugging is on

    R3#

    R3#

    R3#term mon

    R3#

    *Mar  1 01:40:44.743: IGMP(0): Received v2 Query on Ethernet0/3 from
    150.1.13.1

    *Mar  1 01:41:05.251: IGMP(0): Send v2 general Query on Ethernet0/0

    *Mar  1 01:41:05.255: IGMP(0): Set report delay time to 7.7 seconds for
    224.0.1.40 on Ethernet0/0

    *Mar  1 01:41:13.255: IGMP(0): Send v2 Report for 224.0.1.40 on
    Ethernet0/0

    *Mar  1 01:41:13.255: IGMP(0): Received v2 Report on Ethernet0/0 from
    10.1.37.3 for 224.0.1.40

    *Mar  1 01:41:13.255: IGMP(0): Received Group record for group
    224.0.1.40, mode 2 from 10.1.37.3 for 0 sources

    *Mar  1 01:41:13.255: IGMP(0): Updating EXCLUDE group timer for
    224.0.1.40

    *Mar  1 01:41:13.255: IGMP(0): MRT Add/Update Ethernet0/0 for
    (*,224.0.1.40) by 0

    *Mar  1 01:41:44.903: IGMP(0): Received v2 Query on Ethernet0/3 from
    150.1.13.1

    *Mar  1 01:42:05.295: IGMP(0): Send v2 general Query on Ethernet0/0

    *Mar  1 01:42:05.299: IGMP(0): Set report delay time to 0.5 seconds for
    224.0.1.40 on Ethernet0/0

    *Mar  1 01:42:06.303: IGMP(0): Send v2 Report for 224.0.1.40 on
    Ethernet0/0

    *Mar  1 01:42:06.303: IGMP(0): Received v2 Report on Ethernet0/0 from
    10.1.37.3 for 224.0.1.40

    *Mar  1 01:42:06.303: IGMP(0): Received Group record for group
    224.0.1.40, mode 2 from 10.1.37.3 for 0 sources

    *Mar  1 01:42:06.303: IGMP(0): Updating EXCLUDE group timer for
    224.0.1.40

    *Mar  1 01:42:06.303: IGMP(0): MRT Add/Update Ethernet0/0 for
    (*,224.0.1.40) by 0

    *Mar  1 01:42:45.031: IGMP(0): Received v2 Query on Ethernet0/3 from
    150.1.13.1

    *Mar  1 01:43:05.339: IGMP(0): Send v2 general Query on Ethernet0/0

    *Mar  1 01:43:05.343: IGMP(0): Set report delay time to 0.1 seconds for
    224.0.1.40 on Ethernet0/0

    *Mar  1 01:43:06.355: IGMP(0): Send v2 Report for 224.0.1.40 on
    Ethernet0/0

    *Mar  1 01:43:06.355: IGMP(0): Received v2 Report on Ethernet0/0 from
    10.1.37.3 for 224.0.1.40

    *Mar  1 01:43:06.355: IGMP(0): Received Group record for group
    224.0.1.40, mode 2 from 10.1.37.3 for 0 sources

    *Mar  1 01:43:06.355: IGMP(0): Updating EXCLUDE group timer for
    224.0.1.40

    *Mar  1 01:43:06.355: IGMP(0): MRT Add/Update Ethernet0/0 for
    (*,224.0.1.40) by 0

    *Mar  1 01:43:45.251: IGMP(0): Received v2 Query on Ethernet0/3 from
    150.1.13.1

    *Mar  1 01:44:05.387: IGMP(0): Send v2 general Query on Ethernet0/0

    *Mar  1 01:44:05.391: IGMP(0): Set report delay time to 6.0 seconds for
    224.0.1.40 on Ethernet0/0

    *Mar  1 01:44:11.431: IGMP(0): Send v2 Report for 224.0.1.40 on
    Ethernet0/0

    *Mar  1 01:44:11.431: IGMP(0): Received v2 Report on Ethernet0/0 from
    10.1.37.3 for 224.0.1.40

    *Mar  1 01:44:11.431: IGMP(0): Received Group record for group
    224.0.1.40, mode 2 from 10.1.37.3 for 0 sources

    *Mar  1 01:44:11.431: IGMP(0): Updating EXCLUDE group timer for
    224.0.1.40

    *Mar  1 01:44:11.431: IGMP(0): MRT Add/Update Ethernet0/0 for
    (*,224.0.1.40) by 0

    *Mar  1 01:44:45.359: IGMP(0): Received v2 Query on Ethernet0/3 from
    150.1.13.1

    *Mar  1 01:45:05.455: IGMP(0): Send v2 general Query on Ethernet0/0

    *Mar  1 01:45:05.459: IGMP(0): Set report delay time to 2.3 seconds for
    224.0.1.40 on Ethernet0/0

    *Mar  1 01:45:08.483: IGMP(0): Send v2 Report for 224.0.1.40 on
    Ethernet0/0

    *Mar  1 01:45:08.483: IGMP(0): Received v2 Report on Ethernet0/0 from
    10.1.37.3 for 224.0.1.40

    *Mar  1 01:45:08.483: IGMP(0): Received Group record for group
    224.0.1.40, mode 2 from 10.1.37.3 for 0 sources

    *Mar  1 01:45:08.483: IGMP(0): Updating EXCLUDE group timer for
    224.0.1.40

    *Mar  1 01:45:08.483: IGMP(0): MRT Add/Update Ethernet0/0 for
    (*,224.0.1.40) by 0

    *Mar  1 01:45:45.583: IGMP(0): Received v2 Query on Ethernet0/3 from
    150.1.13.1

    *Mar  1 01:46:05.519: IGMP(0): Send v2 general Query on Ethernet0/0

    *Mar  1 01:46:05.523: IGMP(0): Set report delay time to 2.7 seconds for
    224.0.1.40 on Ethernet0/0

    *Mar  1 01:46:08.543: IGMP(0): Send v2 Report for 224.0.1.40 on
    Ethernet0/0

    *Mar  1 01:46:08.543: IGMP(0): Received v2 Report on Ethernet0/0 from
    10.1.37.3 for 224.0.1.40

    *Mar  1 01:46:08.543: IGMP(0): Received Group record for group
    224.0.1.40, mode 2 from 10.1.37.3 for 0 sources

    *Mar  1 01:46:08.543: IGMP(0): Updating EXCLUDE group timer for
    224.0.1.40

    *Mar  1 01:46:08.543: IGMP(0): MRT Add/Update Ethernet0/0 for
    (*,224.0.1.40) by 0

    *Mar  1 01:46:45.751: IGMP(0): Received v2 Query on Ethernet0/3 from
    150.1.13.1

    *Mar  1 01:47:05.555: IGMP(0): Send v2 general Query on Ethernet0/0

    *Mar  1 01:47:05.559: IGMP(0): Set report delay time to 7.2 seconds for
    224.0.1.40 on Ethernet0/0

    *Mar  1 01:47:13.579: IGMP(0): Send v2 Report for 224.0.1.40 on
    Ethernet0/0

    *Mar  1 01:47:13.579: IGMP(0): Received v2 Report on Ethernet0/0 from
    10.1.37.3 for 224.0.1.40

    *Mar  1 01:47:13.579: IGMP(0): Received Group record for group
    224.0.1.40, mode 2 from 10.1.37.3 for 0 sources

    *Mar  1 01:47:13.579: IGMP(0): Updating EXCLUDE group timer for
    224.0.1.40

    *Mar  1 01:47:13.579: IGMP(0): MRT Add/Update Ethernet0/0 for
    (*,224.0.1.40) by 0

    *Mar  1 01:47:45.967: IGMP(0): Received v2 Query on Ethernet0/3 from
    150.1.13.1

    *Mar  1 01:48:05.603: IGMP(0): Send v2 general Query on Ethernet0/0

    *Mar  1 01:48:05.603: IGMP(0): Set report delay time to 7.2 seconds for
    224.0.1.40 on Ethernet0/0

    *Mar  1 01:48:13.619: IGMP(0): Send v2 Report for 224.0.1.40 on
    Ethernet0/0

    *Mar  1 01:48:13.619: IGMP(0): Received v2 Report on Ethernet0/0 from
    10.1.37.3 for 224.0.1.40

    *Mar  1 01:48:13.619: IGMP(0): Received Group record for group
    224.0.1.40, mode 2 from 10.1.37.3 for 0 sources

    *Mar  1 01:48:13.619: IGMP(0): Updating EXCLUDE group timer for
    224.0.1.40

    *Mar  1 01:48:13.619: IGMP(0): MRT Add/Update Ethernet0/0 for
    (*,224.0.1.40) by 0

    *Mar  1 01:48:46.187: IGMP(0): Received v2 Query on Ethernet0/3 from
    150.1.13.1

    *Mar  1 01:49:05.659: IGMP(0): Send v2 general Query on Ethernet0/0

    *Mar  1 01:49:05.663: IGMP(0): Set report delay time to 5.2 seconds for
    224.0.1.40 on Ethernet0/0

    *Mar  1 01:49:11.699: IGMP(0): Send v2 Report for 224.0.1.40 on
    Ethernet0/0

    *Mar  1 01:49:11.703: IGMP(0): Received v2 Report on Ethernet0/0 from
    10.1.37.3 for 224.0.1.40

    *Mar  1 01:49:11.703: IGMP(0): Received Group record for group
    224.0.1.40, mode 2 from 10.1.37.3 for 0 sources

    *Mar  1 01:49:11.703: IGMP(0): Updating EXCLUDE group timer for
    224.0.1.40

    *Mar  1 01:49:11.703: IGMP(0): MRT Add/Update Ethernet0/0 for
    (*,224.0.1.40) by 0

    *Mar  1 01:49:46.355: IGMP(0): Received v2 Query on Ethernet0/3 from
    150.1.13.1

    *Mar  1 01:50:05.683: IGMP(0): Send v2 general Query on Ethernet0/0

    *Mar  1 01:50:05.687: IGMP(0): Set report delay time to 7.1 seconds for
    224.0.1.40 on Ethernet0/0

     

     







    Internetwork Expert - The Industry Leader in CCIE Preparation

    http://www.internetworkexpert.com



    Subscription information may be found at:

    http://www.ieoc.com/forums/ForumSubscriptions.aspx

  • That make sense . That is what I was thinking as well but on the COD cd on day 5 part 1 multicast and if you fast forward to time 36:35 (36 minutes and 35 seconds) it talks about how since R2 is configured as RP and Mapping agent , its canidate-rp messages don't need to go anywhere ,and as long as we can get the canidate rp message to the mapping agent then there is no requirement to run pim-sparse-dense mode or auto-rp-listener.

    Also, I never actually see where auto-rp-listener is configured on R1 , but when show ip pim rp mappings is done on R3, it has the mapping info. I basically just followed along and configed just like the COD but could not get the RP mapping output on R3,

     

    note***- Previous to time 36:35 in the  COD , it talked about BSR. I was able to get the BSR config between R4,R5, and R6 to work fine. Functionally, it seems that BSR is the way to go for Mcast implementation.

     

    thanks,

    shane

  • I guess my point is that the COD explanation seems misleading/wrong since the explanation in the COD says you don't need pim-sparse-dense mode or rp-listener if you configure R2 as both rp-canidate and mapping agent. Maybe I misunderstood the COD but Ive watched it multiple times and thats what it says.

  • <!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">





    If all devices are directly connected to R2 then that explanation is
    correct.  The router will automatically listen for 224.0.1.40 as soon
    as PIM is enabled.



    Brian McGahan, CCIE #8593 (R&S/SP/Security)

    [email protected]

     

    Internetwork Expert, Inc.

    http://www.InternetworkExpert.com

    Toll Free: 877-224-8987 x 705

    Outside US: 775-826-4344 x 705

    Online Community: http://www.IEOC.com

    CCIE Blog: http://blog.internetworkexpert.com






    rockriver wrote:

    I guess my point is that the COD explanation seems
    misleading/wrong since the explanation in the COD says you don't need
    pim-sparse-dense mode or rp-listener if you configure R2 as both
    rp-canidate and mapping agent. Maybe I misunderstood the COD but Ive
    watched it multiple times and thats what it says.







    Internetwork Expert - The Industry Leader in CCIE Preparation

    http://www.internetworkexpert.com



    Subscription information may be found at:

    http://www.ieoc.com/forums/ForumSubscriptions.aspx

  • Thats the thing, R1 is the only router directly connected to R2. R1 sits between R3 and R2.

    R3 is connected to R1. When you get a chance, please check out the COD and you will see what I mean. MInute 20 (approximatly) on the COD shows the router topology.

    Thanks for your time with this,

    shane

Sign In or Register to comment.