Task 11.1. NAT

Hello Experts,

I am confused with this task.

Configure a new Loopback interface on R3 using the IP address 145.X.133.3/24.

Do not advertise this Loopback with any routing protocol.

...

SG:
R3:
router rip
 version 2
 no auto-summary
 network 145.1.0.0
 passive-interface default
 no passive-interface Ethernet0/0

ip telnet source-interface Loopback1
!
interface Loopback1
  ip address 145.1.133.3 255.255.255.0
  ip nat inside
!
interface Ethernet0/0
  ip nat outside
!
interface Ethernet0/1
  ip nat outside
!
interface Serial1/2.13
  ip nat outside
!
interface Serial1/3.23
  ip nat outside                              
!
ip nat inside source list 150 interface Loopback0 overload
!
access-list 150 permit tcp host 145.1.133.3 any eq telnet
------------------------------------------------------------------------

My solution was:
router rip
 version 2
 redistribute ospf 1 route-map OSPF->RIP
 passive-interface default
 no passive-interface FastEthernet0/0
 network 145.7.0.0
 no auto-summary

ip telnet source-interface Loopback133

interface Loopback133
  ip address 145.7.133.3 255.255.255.0
  ip nat inside
!
interface Ethernet0/0
  ip nat outside
!
interface Ethernet0/1
  ip nat outside
!
interface Serial1/2.13
  ip nat outside
!
interface Serial1/3.23
  ip nat outside                              
!
ip nat inside source list NAT interface Loopback0 overload
!
ip access-list extended NAT
 permit tcp host 145.7.133.3 any eq telnet

How can I not advertise the New Loopback in to the RIP, if it is directly connected to R3 and RIP is running on R3..?
Am I missing something here...?

Thank you for your response.

Regards

L.

Sign In or Register to comment.