4.4 EIGRP - Neighbor not on common Subnet

Hello everybody,

 

I keep receiving the following Error-Message on Router R6:


03:48:57.607: IP-EIGRP(Default-IP-Routing-Table:10): Neighbor 54.6.10.254 not on common subnet for Serial0/0
03:49:08.136: IP-EIGRP(Default-IP-Routing-Table:10): Neighbor 54.6.3.254 not on common subnet for Serial0/0
03:49:19.739: IP-EIGRP(Default-IP-Routing-Table:10): Neighbor 54.6.10.254 not on common subnet for Serial0/0
03:49:31.278: IP-EIGRP(Default-IP-Routing-Table:10): Neighbor 54.6.3.254 not on common subnet for Serial0/0
03:49:43.145: IP-EIGRP(Default-IP-Routing-Table:10): Neighbor 54.6.10.254 not on common subnet for Serial0/0
03:49:55.141: IP-EIGRP(Default-IP-Routing-Table:10): Neighbor 54.6.3.254 not on common subnet for Serial0/0
03:50:06.323: IP-EIGRP(Default-IP-Routing-Table:10): Neighbor 54.6.10.254 not on common subnet for Serial0/0
03:50:18.503: IP-EIGRP(Default-IP-Routing-Table:10): Neighbor 54.6.3.254 not on common subnet for Serial0/0
03:50:29.261: IP-EIGRP(Default-IP-Routing-Table:10): Neighbor 54.6.10.254 not on common subnet for Serial0/0
03:50:41.577: IP-EIGRP(Default-IP-Routing-Table:10): Neighbor 54.6.3.254 not on common subnet for Serial0/0

 

The Config from Router R6 (only The S0/0-Interface and the EIGRP-Config):

!
interface Serial0/0
 ip address 54.6.2.6 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 54.6.2.254 100 broadcast
 no frame-relay inverse-arp
end
!
!
!
!
!
router eigrp 10
 network 54.6.2.6 0.0.0.0
 network 150.6.6.6 0.0.0.0
 no auto-summary
 eigrp router-id 150.6.6.6
!

This is EXACTLY the config recommended in the LAB-Workbook. Is that part of the

troubleshooting? If so, how could I change this behaviour? In my Opinion, there is some

misconfiguration on the BB1-Router. Since I only use the correct DLCI, the correct IP-addresses

and even the neighbouring between R6 and BB1 does work, I guess that htere are some additional

IP-Addresses on BB! mapped to the same DLCI on the FR-Switch that is sent to the R6 router...

 

Any Clue? Did you see the same behaviour?

 

Thanks for any suggestions!

 

Cheers!

 

Abraxas

 

 

 

Comments

  • These are indeed the other addresses that are configured on BB1. Check if you have some dynamic mappings in your 'show frame-relay map' for these addresses and/or reload the router.

    Rick Mur

    CCIE #21946 (R&S)


    CCNP, CCIP, JNCIA-ER, MCSE

    [email protected]

    On 9 Dec 2008 04:04:19 -0800

    Abraxas <[email protected]> wrote:

    Hello everybody,

    I keep receiving the following Error-Message on Router R6:

    03:48:57.607: IP-EIGRP(Default-IP-Routing-Table:10): Neighbor

    54.6.10.254 not on common subnet for Serial0/0


    03:49:08.136: IP-EIGRP(Default-IP-Routing-Table:10): Neighbor

    54.6.3.254 not on common subnet for Serial0/0

    03:49:19.739: IP-EIGRP(Default-IP-Routing-Table:10): Neighbor

    54.6.10.254 not on common subnet for Serial0/0

    03:49:31.278: IP-EIGRP(Default-IP-Routing-Table:10): Neighbor


    54.6.3.254 not on common subnet for Serial0/0

    03:49:43.145: IP-EIGRP(Default-IP-Routing-Table:10): Neighbor

    54.6.10.254 not on common subnet for Serial0/0

    03:49:55.141: IP-EIGRP(Default-IP-Routing-Table:10): Neighbor

    54.6.3.254 not on common subnet for Serial0/0

    03:50:06.323: IP-EIGRP(Default-IP-Routing-Table:10): Neighbor

    54.6.10.254 not on common subnet for Serial0/0

    03:50:18.503: IP-EIGRP(Default-IP-Routing-Table:10): Neighbor

    54.6.3.254 not on common subnet for Serial0/0

    03:50:29.261: IP-EIGRP(Default-IP-Routing-Table:10): Neighbor

    54.6.10.254 not on common subnet for Serial0/0

    03:50:41.577: IP-EIGRP(Default-IP-Routing-Table:10): Neighbor

    54.6.3.254 not on common subnet for Serial0/0

    The Config from Router R6 (only The S0/0-Interface and the

    EIGRP-Config):


    !

    interface Serial0/0

    ip address 54.6.2.6 255.255.255.0

    encapsulation frame-relay

    frame-relay map ip 54.6.2.254 100 broadcast

    no frame-relay inverse-arp


    end

    !

    !

    !

    !

    !

    router eigrp 10


    network 54.6.2.6 0.0.0.0

    network 150.6.6.6 0.0.0.0

    no auto-summary

    eigrp router-id 150.6.6.6

    !

    This is EXACTLY the config recommended in the LAB-Workbook. Is that

    part of the

    troubleshooting? If so, how could I change this behaviour? In my

    Opinion, there is some

    misconfiguration on the BB1-Router. Since I only use the correct

    DLCI, the correct IP-addresses


    and even the neighbouring between R6 and BB1 does work, I guess that

    htere are some additional

    IP-Addresses on BB! mapped to the same DLCI on the FR-Switch that is

    sent to the R6 router...

    Any Clue? Did you see the same behaviour?

    Thanks for any suggestions!

    Cheers!

    Abraxas


    "Internetwork Expert - The Industry Leader in CCIE Preparation

    http://www.internetworkexpert.com

    Subscription information may be found at:

    http://www.ieoc.com/forums/ForumSubscriptions.aspx

    "

  • Hi Rick,

     

    thanks for that really quick reply. I checked the Frame-Relay mappings and there seem to be only the static one that i configured. I used the no frame-relay inverse-arp command and it semms to work:

     

    Rack6R6#sh fram map
    Serial0/0 (up): ip 54.6.2.254 dlci 100(0x64,0x1840), static,
      broadcast,
      CISCO, status defined, active
    Rack6R6#

    I also did a reload of the router R6. No changes. I'm still getting the messages. This page:

     

    http://tools.cisco.com/search/display?url=http://www.cisco.com/en/US/tech/tk365/technologies_configuration_example09186a0080093f09.shtml&amp;pos=1&amp;strqueryid=4&amp;websessionid=I9aPcXEx6MKwQ9ZJyywsJ5j

     

    Suggests to use the "no eigrp log-neighbor-warnings" in a case where you don't have any access to the misconfigured Router. But the only result is that the messages will be suppressed. Not a nice solution but the only one I've found. Any other Ideas?

     

    Kind Regards

     

    Abraxas

     

  • It's because the main interface terminates all active DLCI's. So all multicast packets received from other DLCI's are also processed and EIGRP then notices that it can't find any network statement for it.

    The only true solution for this problem is to create a point-to-point subinterface to terminate DLCI 100 on the subinterface and not receive any ambiguous traffic, but this might me prohibited by the task.

    An other solution is to create subinterfaces for all other DLCI's not used and not set an IP address on those or you can choose to disable the neighbor logging, although I really don't like that work-around.

    In either case the messages are fine and are not really errors in this task, so you can choose to ignore them.

    HTH,

    Rick Mur

    CCIE #21946 (R&S)

    CCNP, CCIP, JNCIA-ER, MCSE

    [email protected]


    On 9 Dec 2008 05:14:20 -0800

    Abraxas <[email protected]> wrote:

    Hi Rick,

    thanks for that really quick reply. I checked the Frame-Relay

    mappings and there seem to be only the static one that i configured. I

    used the no frame-relay inverse-arp command and it semms to work:

    Rack6R6#sh fram map


    Serial0/0 (up): ip 54.6.2.254 dlci 100(0x64,0x1840), static,

    broadcast,

    CISCO, status defined, active

    Rack6R6#

    I also did a reload of the router R6. No changes. I'm still getting

    the messages. This page:

    http://tools.cisco.com/search/display?url=http://www.cisco.com/en/US/tech/tk365/technologies_configuration_example09186a0080093f09.shtml&amp;pos=1&amp;strqueryid=4&amp;websessionid=I9aPcXEx6MKwQ9ZJyywsJ5j

    Suggests to use the "no eigrp log-neighbor-warnings" in a case where

    you don't have any access to the misconfigured Router. But the only

    result is that the messages will be suppressed. Not a nice solution

    but the only one I've found. Any other Ideas?

    Kind Regards


    Abraxas

    "Internetwork Expert - The Industry Leader in CCIE Preparation

    http://www.internetworkexpert.com

    Subscription information may be found at:

    http://www.ieoc.com/forums/ForumSubscriptions.aspx

    "

Sign In or Register to comment.