MPLS VPNs with OSPF and Domain-ID

Hi,

When I configured the above lab, I checked all my configs and they matched IE workbook exactly.

However, the routing tables of the CE routers (SW1, SW2 ,R5 and R6) only show one O IA route (loopback of other CE). The other connection shows as E2 (see below show ip route output).

I've tried resetting BGP and OSPF processes but every time I get on Intra-Area route and one Inter-Area. I'm using dynamips so not sure if this is an IOS buy, a dynamips bug -any thoughts?

Rack1SW1#sh ip route
10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
O IA 10.1.5.5/32 [110/12] via 10.1.37.3, 00:14:18, FastEthernet0/3
C 10.1.7.0/24 is directly connected, Loopback0
O E2 10.1.45.0/24 [110/1] via 10.1.37.3, 00:14:18, FastEthernet0/3
C 10.1.37.0/24 is directly connected, FastEthernet0/3

Rack1SW2#sh ip route
10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C 10.1.8.0/24 is directly connected, Loopback0
O IA 10.1.6.6/32 [110/12] via 10.1.38.3, 00:03:43, FastEthernet0/3
O E2 10.1.46.0/24 [110/1] via 10.1.38.3, 00:03:43, FastEthernet0/3
C 10.1.38.0/24 is directly connected, FastEthernet0/3

Rack1R5#sh ip route
10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
O IA 10.1.7.7/32 [110/21] via 10.1.45.4, 00:15:03, Ethernet0/0
C 10.1.5.0/24 is directly connected, Loopback0
C 10.1.45.0/24 is directly connected, Ethernet0/0
O E2 10.1.37.0/24 [110/1] via 10.1.45.4, 00:14:58, Ethernet0/0

Rack1R6#sh ip route
10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
O IA 10.1.8.8/32 [110/21] via 10.1.46.4, 00:03:30, Ethernet0/0
C 10.1.6.0/24 is directly connected, Loopback0
C 10.1.46.0/24 is directly connected, Ethernet0/0
O E2 10.1.38.0/24 [110/1] via 10.1.46.4, 00:03:25, Ethernet0/0

Comments

  • I noticed in the VPNv4 BGP table that the domain-id is not applied to the subnets showing as OSPF External E2 on the PE routers.

    Rack1R3#sh ip bgp vpnv4 all 10.1.8.8
    BGP routing table entry for 1:8:10.1.8.8/32, version 63
    Paths: (1 available, best #1, table R6-SW2)
    Advertised to update-groups:
    1
    Local
    10.1.38.8 from 0.0.0.0 (150.1.3.3)
    Origin incomplete, metric 11, localpref 100, weight 32768, valid, sourced, best
    Extended Community: RT:1:8 OSPF DOMAIN ID:0x0005:0x000000440200
    OSPF RT:0.0.0.0:2:0 OSPF ROUTER ID:10.1.38.3:512,
    mpls labels in/out 23/nolabel

    Rack1R3#sh ip bgp vpnv4 all 10.1.37.0
    BGP routing table entry for 1:7:10.1.37.0/24, version 5
    Paths: (1 available, best #1, table R5-SW1)
    Advertised to update-groups:
    1
    Local
    0.0.0.0 from 0.0.0.0 (150.1.3.3)
    Origin incomplete, metric 0, localpref 100, weight 32768, valid, sourced, best
    Extended Community: RT:1:7 OSPF DOMAIN ID:0x0005:0x000000070200
    OSPF RT:0.0.0.0:2:0 OSPF ROUTER ID:10.1.37.3:512,
    mpls labels in/out 22/aggregate(R5-SW1)


    I guess this is due to the route being 'Connected' rather than 'OSPF' from the perspective of the PE routers, and as such the domain-id only applies to OSPF routes and not Connected routes on the PE.

    I cant see how the Brian's managed to get these routes as showing Inter Area (IA) on their outputs in the workbook (other than the output was typed from docs incorrectly rather than copied from router output).
Sign In or Register to comment.