nei send-label a must??

Hi:

I have been banging my head against the wall and pulling out all my hair - trying to get an Inter-AS scenario(option3) to work.

I have R5 in AS5 running ebgp with R4 in AS 1234

R5 is also peering vpnv4 with R3 a RR inside AS1234.

R1 and R4 are PE's peering with R3 inside AS1234.

When I enable the nei send-label option b/w R4 and R5, I am able to ping from vrf VPN_A in R5 all the way to vrf VPN_A in R1.

No problem here - same also if I use option 2a, b or c!!

But when I do NOT enable the nei send-label cmd BUT try to enable mpls b/w R4 and R5, it just does not work!!!!!

On R3, I always see untagged for 131.1.5.5/32-l0 of R5.

So I configured a static route on R4 for R5:131.1.45.5/32 and redistributed this into ISIS hoping to see a Pop tag for next-hop but nada.

What is the trick to get this option 3 working without using the bgp nei send-label cmd - if it indeed works??

Thx.

r3#sh mpls forwarding-table 131.1.5.5
Local Outgoing Prefix Bytes tag Outgoing Next Hop
tag tag or VC or Tunnel Id switched interface
18 Untagged 131.1.5.5/32 520 Se0/0.34 point2point
r3#sh ip bgp vpnv4 all sum | i 131.1.5.5
131.1.5.5 4 5 96 106 3985 0 0 00:44:44 1
r3#

r1#sh ip cef vrf VPN_A 172.16.5.0 | i tags
fast tag rewrite with Se0/0.103, point2point, tags imposed: {18 18}
tag rewrite with Se0/0.103, point2point, tags imposed: {18 18}
r1#

r5#sh ip cef vrf VPN_A 172.16.1.0 | i tags
Recursive rewrite via 131.1.45.4 0x20, tags imposed {22}
Recursive rewrite via 131.1.45.4 0x20, tags imposed {22}

r5#sh mpls forwarding-table
Local Outgoing Prefix Bytes tag Outgoing Next Hop
tag tag or VC or Tunnel Id switched interface
16 Untagged 131.1.45.4/32 0 Se0/0.504 point2point
18 Aggregate 172.16.5.0/24[V] 0
r5#

r4#sh mpls forwarding-table 131.1.45.5
Local Outgoing Prefix Bytes tag Outgoing Next Hop
tag tag or VC or Tunnel Id switched interface
21 Untagged 131.1.45.5/32 1040 Se0/0.405 point2point
r4#

Comments

  • Hi ,

    If you dont want to do a send-label between R4-R5 , how will you generate labels for VPN Prefixes in R1 and PE Loopbacks using Opt 3 ?
    2. MPLS BGP FORWARDING is a command on R4-R5 Interfaces which installs a /32 route ( which when redistributed into IGP) shall allow a label for next hop r4-R5 interface ip.

    Please share your results after troubleshooting.
  • And that's exactly the question, ain't it?

    ;->

    ...if it indeed is possible.....!!!

    But even after enabling MPLS b/w the PE's, it still does not work!!

    BTW: mpls bgp forwarding is an old command that does not exist anymore....

    Did you get a chance to set this up?

    Need someone to setup a working option 3 scenario and then remove the nei send-label cmd and get it to work?

    Thx and Best Regards.
  • Hi Cisconuts

    Quote from MPLS and VPN archi VOL1

    "a label is assigned to every IP prefix in the IP routing table of a router acting as LSR, the only exception being routes learned through the Border Gateway Protocol (BGP). No labels are assigned to these routes and the ingress Edge-LSR uses the label assigned to the BGP next hop to label the packets forwarded toward BGP destinations"

    in your case, a label will be created at your VPNv4 router but nothing at the peering point

    So really only way to make it work, it s to have an IGP at the peering point and after redistribute. But it would not be a safe solution


    Hope this will help you

    Rgds
  • Hi Cisconuts

    After reading again your question, carefully this time i can remember that there is similar scenario on LAB7.


    When i set up same scenario than you, it is working.

    on R5


    interface Loopback0
    ip address 150.1.5.5 255.255.255.255


    interface Serial1/1
    description Link to R4
    ip address 150.1.45.5 255.255.255.0
    mpls ldp discovery transport-address interface
    tag-switching ip
    serial restart-delay 0
    no dce-terminal-timing-enable
    end



    router bgp 5
    no bgp default ipv4-unicast
    bgp log-neighbor-changes
    neighbor 150.1.3.3 remote-as 1234
    neighbor 150.1.3.3 ebgp-multihop 10
    neighbor 150.1.3.3 update-source Loopback0
    neighbor 150.1.45.4 remote-as 1234
    !
    address-family ipv4
    neighbor 150.1.45.4 activate
    no auto-summary
    no synchronization
    network 150.1.5.5 mask 255.255.255.255
    exit-address-family
    !
    address-family vpnv4
    neighbor 150.1.3.3 activate
    neighbor 150.1.3.3 send-community extended
    exit-address-family



    ip route 150.1.3.3 255.255.255.255 150.1.45.4

    Rack1R5(config-if)#do sh mpls for
    Local Outgoing Prefix Bytes tag Outgoing Next Hop
    tag tag or VC or Tunnel Id switched interface
    16 16 150.1.3.3/32 0 Se1/1 point2point




    on R4


    interface Loopback0
    ip address 150.1.4.4 255.255.255.255

    interface Serial1/1
    description Link to R5
    ip address 150.1.45.4 255.255.255.0
    mpls ldp discovery transport-address interface
    tag-switching ip
    serial restart-delay 0
    no dce-terminal-timing-enable
    end


    interface Serial1/0.34 point-to-point
    description Link to R3
    ip address 150.1.34.4 255.255.255.0
    tag-switching ip
    frame-relay interface-dlci 403
    end




    router ospf 1
    log-adjacency-changes
    redistribute connected subnets
    redistribute static subnets
    network 150.1.4.4 0.0.0.0 area 0
    network 150.1.34.4 0.0.0.0 area 0
    !
    router bgp 1234
    no synchronization
    bgp log-neighbor-changes
    network 150.1.3.3 mask 255.255.255.255
    neighbor 150.1.45.5 remote-as 5
    no auto-summary
    !

    ip route 150.1.5.5 255.255.255.255 150.1.45.5



    Rack1R4(config-subif)#do sh mpls for
    Local Outgoing Prefix Bytes tag Outgoing Next Hop
    tag tag or VC or Tunnel Id switched interface
    16 Pop tag 150.1.3.3/32 1638 Se1/0.34 point2point
    17 Pop tag 150.1.5.5/32 1132 Se1/1 point2point
    Rack1R4(config-subif)#


    on R3



    interface Loopback0
    ip address 150.1.3.3 255.255.255.255



    interface Serial1/0.34 point-to-point
    description Link to R4
    ip address 150.1.34.3 255.255.255.0
    tag-switching ip
    frame-relay interface-dlci 304
    !



    router ospf 1
    log-adjacency-changes
    network 150.1.3.3 0.0.0.0 area 0
    network 150.1.34.3 0.0.0.0 area 0
    !
    router bgp 1234
    no bgp default ipv4-unicast
    bgp log-neighbor-changes
    neighbor 150.1.5.5 remote-as 5
    neighbor 150.1.5.5 ebgp-multihop 10
    neighbor 150.1.5.5 update-source Loopback0
    !
    address-family vpnv4
    neighbor 150.1.5.5 activate
    neighbor 150.1.5.5 send-community extended
    exit-address-family




    Rack1R3#sh mpls forwarding-table
    Local Outgoing Prefix Bytes tag Outgoing Next Hop
    tag tag or VC or Tunnel Id switched interface
    16 Pop tag 150.1.4.4/32 0 Se1/0.34 point2point
    17 17 150.1.5.5/32 0 Se1/0.34 point2point
    18 Pop tag 150.1.45.0/24 0 Se1/0.34 point2point
    Rack1R3#




    Let me know if it s working for you

    Rgds
  • Hi John:

    Great!!

    I will give it a shot...soon....

    BTW: were you able to ping prefixes end-to-end? can you post some stats?

    Thx.
Sign In or Register to comment.