4.11 Redistribution backup

I would love to see a working solution to this distribution problem. So far, I haven't see one.

Here's the issue: When the backup link (132.1.45/0) between R4 and R5 is down, R2 and R3 get R5's routes via EIGRP. That's the solution that most everyone solves. But activate the backup link (shut R5 S0/0). Now R2 and R3 have to get R5's routes via OSPF. Try pinging 150.1.5.5 from R2 or R3 and you'll see what I mean.

Anybody have a working solution?

Comments

  • My config works !!

    R2

    !
    router eigrp 10
     redistribute ospf 1 metric 1 1 1 1 1
     network 132.1.23.2 0.0.0.0
     network 132.1.26.2 0.0.0.0
     network 150.1.2.2 0.0.0.0
     no auto-summary
     eigrp router-id 150.1.2.2
     neighbor 132.1.26.6 FastEthernet0/1
    !
    router ospf 1
     router-id 150.1.2.2
     log-adjacency-changes
     redistribute eigrp 10 metric 20 subnets
     network 132.1.0.2 0.0.0.0 area 0
     distance 171 150.1.3.3 0.0.0.0 FILTER_EIGRP

    !

    ip access-list standard FILTER_EIGRP
     permit 132.1.5.0
     permit 132.1.6.0
     permit 192.10.1.0
    !

     

     

    R3

    !
    router eigrp 10
     redistribute ospf 1 metric 1 1 1 1 1
     network 132.1.23.3 0.0.0.0
     network 132.1.35.3 0.0.0.0
     network 150.1.3.3 0.0.0.0
     no auto-summary
     eigrp router-id 150.1.3.3
    !
    router ospf 1
     router-id 150.1.3.3
     log-adjacency-changes
     redistribute eigrp 10 metric 30 subnets
     passive-interface FastEthernet0/1
     network 132.1.0.3 0.0.0.0 area 0
     network 132.1.3.3 0.0.0.0 area 3
     network 132.1.33.3 0.0.0.0 area 33
     distance 172 150.1.2.2 0.0.0.0 FILTER_EIGRP
    !

    ip access-list standard FILTER_EIGRP
     permit 132.1.5.0
     permit 132.1.6.0
     permit 192.10.1.0
    !

     

  • i had some what of a hard time putting in my own solution, but yours was much cleaner and simpler than what was in the SG. thanks!

  • Unfortunately it's not work too. If you reboot all routers you will find routes from RIP between R2 & R3 and if you shut down frame-relay dlci between R5 & R3 and return its link back you will find routes like 132.1.45.4/32 in this loop. I think it can be additional point to solution in SG, but may be the following lines in configs will be easier for this purpose:

    on R2 & R3

    router ospf 1
      distance 110 150.1.4.4 0.0.0.0

     

  • So far i havent found that this doesnt work  … tried rebooting all devices, failing frame link back and forth, resetting OSPF process and all neighbor relationships and clearing route table … and still get successful results … R2

    router eigrp 10
     redistribute ospf 1 metric 1544 10 255 1 1500 route-map OSPF->EIGRP
     network 132.1.23.2 0.0.0.0
     network 132.1.26.2 0.0.0.0
     network 150.1.2.2 0.0.0.0
     no auto-summary
     eigrp router-id 150.1.2.2
     neighbor 132.1.26.6 FastEthernet0/0
    !
    router ospf 1
     router-id 150.1.2.2
     log-adjacency-changes
     redistribute eigrp 10 metric 1 subnets tag 290
     network 132.1.0.2 0.0.0.0 area 0
     distance 171 150.1.3.3 0.0.0.0 2
    !
    access-list 2 permit 132.1.5.0
    access-list 2 permit 132.1.6.0
    access-list 2 permit 192.10.1.0
    !
    route-map OSPF->EIGRP deny 5
     match tag 390
    !
    route-map OSPF->EIGRP permit 10
     set tag 2110
    !
     


     

    R3

    router eigrp 10
     redistribute ospf 1 metric 1544 10 255 1 1500 route-map OSPF->EIGRP
     network 132.1.23.3 0.0.0.0
     network 132.1.35.3 0.0.0.0
     network 150.1.3.3 0.0.0.0
     no auto-summary
     eigrp router-id 150.1.3.3
    !
    router ospf 1
     router-id 150.1.3.3
     log-adjacency-changes
     redistribute eigrp 10 metric 100 subnets tag 390
     passive-interface FastEthernet0/0
     passive-interface FastEthernet0/1
     network 132.1.0.3 0.0.0.0 area 0
     network 132.1.3.3 0.0.0.0 area 3
     network 132.1.33.3 0.0.0.0 area 33
     distance 171 150.1.2.2 0.0.0.0 2
    !
    access-list 2 permit 132.1.5.0
    access-list 2 permit 132.1.6.0
    access-list 2 permit 192.10.1.0
    !
    route-map OSPF->EIGRP deny 5
     match tag 290
    !
    route-map OSPF->EIGRP permit 10
     set tag 3110
    !
     




    R4

    router eigrp 10
     redistribute ospf 1 metric 1544 10 255 1 1500
     network 132.1.45.4 0.0.0.0
     no auto-summary
     eigrp router-id 150.1.4.4
    !
    router ospf 1
     router-id 150.1.4.4
     log-adjacency-changes
     redistribute eigrp 10 metric 1 subnets tag 490
     network 132.1.0.4 0.0.0.0 area 0
     network 132.1.255.4 0.0.0.0 area 255
     network 150.1.4.4 0.0.0.0 area 0
    !

  • Am I missing something here? I used simple route tags and route-maps applied to the redistribution points on R4 and R3 -

    R3

    router eigrp 10
     redistribute ospf 1 metric 1 1 1 1 1 route-map OSPF-to-EIGRP
     network 132.1.23.0 0.0.0.255
     network 132.1.35.0 0.0.0.255
     network 150.1.3.3 0.0.0.0
     no auto-summary
     eigrp router-id 150.1.3.3
    !
    router ospf 1
     router-id 150.1.3.3
     log-adjacency-changes
     redistribute eigrp 10 metric 1 subnets route-map EIGRP-to-OSPF
     passive-interface Ethernet0/0
     passive-interface Ethernet0/1
     network 132.1.0.3 0.0.0.0 area 0
     network 132.1.3.3 0.0.0.0 area 3
     network 132.1.33.3 0.0.0.0 area 33
    !
    ip http server
    ip classless
    !
    !
    !
    route-map EIGRP-to-OSPF permit 10
     match interface Serial1/1.1
     set tag 3170
    !
    route-map OSPF-to-EIGRP deny 5
     match tag 4170
    !
    route-map OSPF-to-EIGRP permit 10

     

    R4

    router eigrp 10
     redistribute ospf 1 metric 1 1 1 1 1 route-map OSPF-to-EIGRP
     network 132.1.45.0 0.0.0.255
     no auto-summary
     eigrp router-id 150.1.4.4
    !
    router ospf 1
     router-id 150.1.4.4
     log-adjacency-changes
     redistribute eigrp 10 metric 1 subnets route-map EIGRP-to-OSPF
     network 132.1.0.4 0.0.0.0 area 0
     network 132.1.255.4 0.0.0.0 area 255
     network 150.1.4.4 0.0.0.0 area 0
    !
    !
    !
    ip http server
    no ip http secure-server
    !
    !
    route-map EIGRP-to-OSPF permit 10
     set tag 4170
    !
    route-map OSPF-to-EIGRP deny 10
     match tag 3170
    !
    route-map OSPF-to-EIGRP permit 20

     

    My ping tcl script seems to work fine with the R3<=>R5 circuit either up or down.

    I have full reachability in either situation. I am the feeling I am missing something here based on the complexity of the problem?

     

  • I would try clearing all routing tables and resetting neighbors (in my case i even rebooted routers).  Problem should appear between routers 2 and 3 where External EIGRP routes preferred via OSPF hence creating a loop between R2 and R3 .... R2 learnes this routes from R3 (R3 redistributes them into OSPF) and same case with R3 learning from R2. 

     

    Problem routes:

    132.1.6.0

    132.1.5.0

    192.10.1.0

     

    Also, try pining this networks with longer pings from R1, R5 and R6, using/not using backup link.  Check sh ip route on R2 and R3 for this routes and refresh few times  to make sure route is not flapping between OSPF and EIGRP.

  • I was able to create problem after clearing ip routes on all routers. Filtered the routes in question with the ospf distance 171 command applied to acl on routers R2 and R6 as suggested. Everything looks stable now in either situation.

Sign In or Register to comment.