Section 8.1,8.2,8.3

Having a weird problem with the tagging or its not working the way I would have thought. I did not see the 666 community, the no-export community or next hop of 169.254.255.255 on R3.

Rack1R3#sh ip bgp vpnv4 all 10.6.6.6
BGP routing table entry for 12349:100:10.6.6.6/32, version 54
Paths: (1 available, best #1, table 100)
Flag: 0x820
  Advertised to update-groups:
     1        
  Local, (Received from a RR-client)
    150.1.1.1 (metric 40) from 150.1.1.1 (150.1.1.1)
      Origin incomplete, metric 2560002816, localpref 100, valid, internal, best
      Extended Community: RT:12349:100 0x8800:0:0 0x8801:10:2816
        0x8802:257:2560000000 0x8803:257:1 0x8804:0:167839495 0x8805:3:0,
      mpls labels in/out nolabel/27

So some troubleshooting shows that since I am not recieving the route from R7 with the TAG of 666, it cannot match it and set the communities and next hop. This is on R1. Should the 666 tag be present here or is stripped off and not able to be seen?

Rack1R1#sh ip route vrf 100 10.6.6.6   
Routing entry for 10.6.6.6/32
  Known via "eigrp 1", distance 170, metric 2560002816, type external
  Redistributing via eigrp 1, bgp 12349
  Advertised by bgp 12349 route-map EIGRP_TO_BGP
  Last update from 10.1.17.7 on FastEthernet1/0, 01:36:01 ago
  Routing Descriptor Blocks:
  * 10.1.17.7, from 10.1.17.7, 01:36:01 ago, via FastEthernet1/0
      Route metric is 2560002816, traffic share count is 1
      Total delay is 110 microseconds, minimum bandwidth is 1 Kbit
      Reliability 1/255, minimum MTU 1 bytes
      Loading 1/255, Hops 1

And finally on R7 we see that the route is indeed being sent with the tag of 666

Rack1R7#sh ip route 10.6.6.6
Routing entry for 10.6.6.6/32
  Known via "static", distance 1, metric 0 (connected)
  Tag 666
  Redistributing via eigrp 10
  Advertised by eigrp 10 metric 1 1 1 1 1
  Routing Descriptor Blocks:
  * directly connected, via Null0
      Route metric is 0, traffic share count is 1
      Route tag 666

No clue what would be wrong here its pretty straightforward.

Comments

  • Odd.  Here are my show commands from this section:

     

    R3#sh ip bgp vpnv4 all 10.6.6.6
    BGP routing table entry for 12349:9:10.6.6.0/24, version 112
    Paths: (1 available, best #1, table CENTRAL_SERVICES)
      Advertised to update-groups:
         1        
      Local
        172.30.103.5 from 0.0.0.0 (150.1.3.3)
          Origin incomplete, metric 1, localpref 100, weight 32768, valid, sourced, best
          Extended Community: RT:1:1
    BGP routing table entry for 12349:100:10.6.6.0/24, version 179
    Paths: (2 available, best #1, table 100, not advertised to EBGP peer, RIB-failure(17))
      Advertised to update-groups:
         1        
      Local, (Received from a RR-client)
        169.254.255.255 from 150.1.1.1 (150.1.1.1)
          Origin incomplete, metric 2560002816, localpref 100, valid, internal, best
          Community: 666 no-export
          Extended Community: RT:12349:100 0x8800:0:666 0x8801:10:2816
            0x8802:257:2560000000 0x8803:257:1 0x8804:0:168166913 0x8805:11:0
      Local
        172.30.101.5 from 0.0.0.0 (150.1.3.3)
          Origin incomplete, metric 1, localpref 90, valid, sourced
          Extended Community: RT:12349:100




    R1#sh ip route vrf 100 10.6.6.6 
    Routing entry for 10.6.6.0/24
      Known via "eigrp 10", distance 170, metric 2560002816
      Tag 666, type external
      Redistributing via eigrp 10, bgp 12349
      Advertised by bgp 12349 route-map EIGRP_TO_BGP
      Last update from 10.1.17.7 on FastEthernet0/0, 00:31:19 ago
      Routing Descriptor Blocks:
      * 10.1.17.7, from 10.1.17.7, 00:31:19 ago, via FastEthernet0/0
          Route metric is 2560002816, traffic share count is 1
          Total delay is 110 microseconds, minimum bandwidth is 1 Kbit
          Reliability 1/255, minimum MTU 1 bytes
          Loading 1/255, Hops 1
          Route tag 666


    I used a bit different config on R7 which should still meet the requirements:

    interface Loopback100
     ip address 10.6.6.1 255.255.255.0
    !
    router eigrp 10
     redistribute connected route-map SET_TAG_666
     network 10.1.7.7 0.0.0.0
     network 10.1.17.0 0.0.0.255
     no auto-summary
    !
    route-map SET_TAG_666 permit 10
     match interface Loopback100
     set metric 1 1 1 1 1
     set tag 666




    R7#sh ip route 10.6.6.6
    Routing entry for 10.6.6.0/24
      Known via "connected", distance 0, metric 0 (connected, via interface)
      Redistributing via eigrp 10
      Advertised by eigrp 10 route-map SET_TAG_666
      Routing Descriptor Blocks:
      * directly connected, via Loopback100
          Route metric is 0, traffic share count is 1


    And, to show that the TAG 666 is there, here is the EIGRP topology table entry for 10.6.6.0/24:

    R7#sh ip eigrp top 10.6.6.0/24
    IP-EIGRP (AS 10): Topology entry for 10.6.6.0/24
      State is Passive, Query origin flag is 1, 1 Successor(s), FD is 2560000256
      Routing Descriptor Blocks:
      0.0.0.0, from Rconnected, Send flag is 0x0
          Composite metric is (2560000256/0), Route is External
          Vector metric:
            Minimum bandwidth is 1 Kbit
            Total delay is 10 microseconds
            Reliability is 1/255
            Load is 1/255
            Minimum MTU is 1
            Hop count is 0
          External data:
            Originating router is 10.6.6.1 (this system)
            AS number of route is 0
            External protocol is Connected, external metric is 0
            Administrator tag is 666 (0x0000029A)



    I hope this helps you....






     

  • hi Miwitte,

     I was having the same issue with not able to see the 10.6.6.6 route with the tagged 666 value on R1.  R7 is indeed showing that it is setting the tag.

    Any other route like a 7.7.7.7 or 8.8.8.8 is no problem (introduced via static or connected).     I do not have too much time to dig this. attributing to a dynamips and / or IOS issue.

     

    R7 configs

     

    interface Loopback6
     ip address 7.7.7.7 255.255.255.0       >>>>Sending this via connected
    end

    router eigrp 10
     redistribute connected route-map toeigrp
     redistribute static metric 1 1 1 1 1
     network 10.0.0.0
     no auto-summary
    !

    ip route 8.8.8.8 255.255.255.255 Null0 tag 666      >>sending these via static
    ip route 10.6.6.6 255.255.255.255 Null0 tag 666
    !
    !
    !
    route-map toeigrp permit 10
     match interface Loopback6
     set tag 666
    !

     

    and R1 show commands

    ---------------------------

    route-map eigrptobgp permit 10
     match tag 666
     set community 666
    !        
    route-map eigrptobgp permit 20
    !        
    route-map rtbh permit 10
     match community dos
     set ip next-hop 169.254.255.255
     set local-preference 200
     set origin igp
     set community 666 no-export
    !        
    route-map rtbh permit 20
    !        
    !        
    !        

     


    SPRack1R1#sh ip rou vrf 100 10.6.6.6
    Routing entry for 10.6.6.6/32
      Known via "eigrp 12349", distance 90, metric 2560002816, type internal
      Redistributing via eigrp 12349, bgp 12349
      Advertised by bgp 12349 route-map eigrptobgp
      Last update from 10.1.17.7 on FastEthernet0/0, 00:00:21 ago
      Routing Descriptor Blocks:
      * 10.1.17.7, from 10.1.17.7, 00:00:21 ago, via FastEthernet0/0
          Route metric is 2560002816, traffic share count is 1
          Total delay is 110 microseconds, minimum bandwidth is 1 Kbit
          Reliability 1/255, minimum MTU 1 bytes
          Loading 1/255, Hops 1                >>>>>>>>>>>>>>>>>No tag for this guy



    SPRack1R1#sh ip rou vrf 100 8.8.8.8
    Routing entry for 8.8.8.8/32
      Known via "eigrp 12349", distance 170, metric 2560002816
      Tag 666, type external
      Redistributing via eigrp 12349, bgp 12349
      Advertised by bgp 12349 route-map eigrptobgp
      Last update from 10.1.17.7 on FastEthernet0/0, 00:00:14 ago
      Routing Descriptor Blocks:
      * 10.1.17.7, from 10.1.17.7, 00:00:14 ago, via FastEthernet0/0
          Route metric is 2560002816, traffic share count is 1
          Total delay is 110 microseconds, minimum bandwidth is 1 Kbit
          Reliability 1/255, minimum MTU 1 bytes
          Loading 1/255, Hops 1
          Route tag 666    >>>>>>>>>>>>See this has it.

     

     

  • Actually R1 is not setting the EIGRP tag for the 10.6.6.6 route even the command is same as 8.8.8.8

    SPRack1R7#sh ip eigrp topo 10.6.6.6/32
    IP-EIGRP (AS 10): Topology entry for 10.6.6.6/32
      State is Passive, Query origin flag is 1, 1 Successor(s), FD is 2560000256
      Routing Descriptor Blocks:
      0.0.0.0, from Rstatic, Send flag is 0x0
          Composite metric is (2560000256/0), Route is Internal
          Vector metric:
            Minimum bandwidth is 1 Kbit
            Total delay is 10 microseconds
            Reliability is 1/255
            Load is 1/255
            Minimum MTU is 1
            Hop count is 0
    SPRack1R7#sh ip eigrp topo 8.8.8.8/32
    IP-EIGRP (AS 10): Topology entry for 8.8.8.8/32
      State is Passive, Query origin flag is 1, 1 Successor(s), FD is 2560000256
      Routing Descriptor Blocks:
      0.0.0.0, from Rstatic, Send flag is 0x0
          Composite metric is (2560000256/0), Route is External
          Vector metric:
            Minimum bandwidth is 1 Kbit
            Total delay is 10 microseconds
            Reliability is 1/255
            Load is 1/255
            Minimum MTU is 1
            Hop count is 0
          External data:
            Originating router is 10.1.7.7 (this system)
            AS number of route is 0
            External protocol is Static, external metric is 0
            Administrator tag is 666 (0x0000029A)
    SPRack1R7#
    SPRack1R7#
    SPRack1R7#sh run | i ip route
    ip route 8.8.8.8 255.255.255.255 Null0 tag 666
    ip route 10.6.6.6 255.255.255.255 Null0 tag 666

  • Hi

    it seems that the troubles come from R7 EIGRP config

    router eigrp 10

    network 10.0.0.0

    With this configuration you get the redistribution of static route that are subnets of 10.0.0.0 even without the "redistribute static" command.

    If you modify the config in

    router eigrp 10

    network 10.1.7.0 0.0.0.255

    network 10.1.17.0 0.0.0.255

    the redistirbute static is required to redistribute

    ip route 10.6.6.6 255.255.255.255 Null0 tag 666

    into EIGRP and the tag is correctly transported.

    I have no explanation for this behavour.

     

  • Nice find!

    This was sending me crazy - nice to know there is a solution [:)]

  • This is my second time through these labs and I ran into it again. Must be something on R1 IOS version. This should just work.

    on R7:

    router eigrp 10
     network 10.1.7.7 0.0.0.0
     network 10.1.17.7 0.0.0.0
     no auto-summary
     redistribute static metric 1 1 1 1 1

    ip route 10.6.6.6 255.255.255.255 Null0 tag 666

    Rack1R7#sh ip route 10.6.6.6
    Routing entry for 10.6.6.6/32
      Known via "static", distance 1, metric 0 (connected)
      Tag 666
      Redistributing via eigrp 10
      Advertised by eigrp 10 metric 1 1 1 1 1
      Routing Descriptor Blocks:
      * directly connected, via Null0, permanent
          Route metric is 0, traffic share count is 1
          Route tag 666

    On r1router eigrp 1
     auto-summary
     !
     address-family ipv4 vrf 100
     redistribute bgp 12349 metric 1 1 1 1 1
     network 10.1.17.1 0.0.0.0
     no auto-summary
     autonomous-system 10
     exit-address-family

    Rack1R1#sh ip route vrf 100 10.6.6.6
    Routing entry for 10.6.6.6/32
      Known via "eigrp 1", distance 170, metric 2560002816, type external
      Redistributing via eigrp 1
      Last update from 10.1.17.7 on FastEthernet1/0, 00:36:04 ago
      Routing Descriptor Blocks:
      * 10.1.17.7, from 10.1.17.7, 00:36:04 ago, via FastEthernet1/0
          Route metric is 2560002816, traffic share count is 1
          Total delay is 110 microseconds, minimum bandwidth is 1 Kbit
          Reliability 1/255, minimum MTU 1 bytes
          Loading 1/255, Hops 1

     

     

     

     

  • Gentlemen,

    Shouldn't we find the route (to 10.6.6.0) inside the VRF table on R3 pointing to the blackhole?

    This is what I see on R3, though I'm not convinced that this is enough.

    ==

    Rack1R3#sho ip route v VRF_100 10.6.6.0
    Routing entry for 10.6.6.0/24
      Known via "rip", distance 120, metric 3
      Redistributing via rip
      Advertised by bgp 12349
      Last update from 172.30.101.5 on Ethernet0/1.100, 00:00:18 ago
      Routing Descriptor Blocks:
      * 172.30.101.5, from 172.30.101.5, 00:00:18 ago, via Ethernet0/1.100
          Route metric is 3, traffic share count is 1

    Rack1R3#

    ==

    Cause what is the use of the RTBH while R3 is not yet dropping the back traffic.

     

    Cheers,

    Peter

Sign In or Register to comment.