Vol II | Lab 1 | Section 5.7 | Cell mode MPLS issue?

I'm running into a very weird issue in this section.  R6 and R4 both have the route to 10.1.9.9 in VPN_A that exists on R9.  R9, in turn, has routes to VPN_A routes on R6 and R4.  From R7, I'm doing a continuous ping to 10.1.9.9 on R9.  I've checked everything in the path with a 'debug mpls packet'.  Both tx and rx traffic is being switched via MPLS.  When I ping from R9 to R7, for example, R7 sees the ICMP traffic and properly reponds.  However, when pinging from R7 to R9, R9 does not see any ICMP traffic.  However, when doing a 'debug mpls packet' on R9, I am seeing the traffic hit it, but it never makes it to the loopback interface of 10.1.9.9 on R9 for some reason.

Here is the MPLS traffic coming into R9 from a continuous ping from R7:

R9#
00:04:38: MPLS turbo: AT3/0.1: rx: Len 112 Stack {0 0 251} {25 0 254} - ipv4 data
R9#
00:04:40: MPLS turbo: AT3/0.1: rx: Len 112 Stack {0 0 251} {25 0 254} - ipv4 data
R9#
00:04:42: MPLS turbo: AT3/0.1: rx: Len 112 Stack {0 0 251} {25 0 254} - ipv4 data
R9#

 

Here is my MPLS forwarding table on R9:

R9#sh mpls forwarding-table
Local  Outgoing      Prefix            Bytes Label   Outgoing   Next Hop   
Label  Label or VC   or Tunnel Id      Switched      interface             
16     1/33          131.1.1.1/32      0             AT3/0.1    point2point
17     1/46          131.1.2.2/32      0             AT3/0.1    point2point
18     1/42          131.1.12.0/29     0             AT3/0.1    point2point
19     1/43          131.1.13.0/29     0             AT3/0.1    point2point
20     1/45          131.1.23.0/29     0             AT3/0.1    point2point
21     1/44          131.1.26.0/24     0             AT3/0.1    point2point
22     1/39          150.1.101.0/24    0             AT3/0.1    point2point
23     1/40          150.1.102.0/24    0             AT3/0.1    point2point
24     1/41          150.100.100.254/32  
                                       0             AT3/0.1    point2point
25     Pop Label     10.1.9.9/32[V]    0             aggregate/VPN_A            
26     1/47          131.1.6.6/32      0             AT3/0.1    point2point
27     1/48          131.1.3.3/32      0             AT3/0.1    point2point
28     1/49          131.1.4.4/32      0             AT3/0.1    point2point
29     1/50          131.1.5.5/32      0             AT3/0.1    point2point
30     1/51          131.1.34.0/29     0             AT3/0.1    point2point
31     1/52          131.1.35.0/29     0             AT3/0.1    point2point

 

MPLS neighbor status:

R9#sh mpls ldp disc
 Local LDP Identifier:
    131.1.9.9:0
    Discovery Sources:
    Interfaces:
        ATM3/0.1 (tdp): xmit/recv
            TDP Id: 150.100.100.254:3; IP addr: 150.1.109.254; no host route

R9#sh mpls ldp neigh
    Peer TDP Ident: 150.100.100.254:3; Local TDP Ident 131.1.9.9:1
        TCP connection: 150.1.109.254.47581 - 150.1.109.9.711
        State: Oper; PIEs sent/rcvd: 0/44; Downstream on demand
        Up time: 00:15:06
        TDP discovery sources:
          ATM3/0.1, Src IP addr: 150.1.109.254

Here is R9's config:

R9#sh run
Building configuration...

Current configuration : 1842 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R9
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
no aaa new-model
ip subnet-zero
ip cef
!
!
no ip domain lookup
!
!
ip vrf VPN_A
 rd 100:9
 route-target export 100:9
 route-target import 100:42
 route-target import 100:67
!
!
!
call rsvp-sync
!
!
!
!
!
!
!
no file verify auto
!
!
!
interface Loopback0
 ip address 131.1.9.9 255.255.255.255
!
interface Loopback1
 no ip address
!
interface Loopback9
 ip vrf forwarding VPN_A
 ip address 10.1.9.9 255.255.255.255
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex half
!
interface ATM3/0
 description Put Cell Mode MPLS Configs Here
 no ip address
 no atm enable-ilmi-trap
!
interface ATM3/0.1 mpls
 ip address 150.1.109.9 255.255.255.0
 no atm enable-ilmi-trap
 mpls label protocol tdp
 mpls ip
!
interface ATM4/0
 description Put ATM PVC Configs Here
 no ip address
 shutdown
 no atm enable-ilmi-trap
!
router ospf 1
 log-adjacency-changes
 network 131.1.9.9 0.0.0.0 area 0
 network 150.1.109.9 0.0.0.0 area 0
!
router bgp 100
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 131.1.1.1 remote-as 100
 !
 address-family ipv4
  neighbor 131.1.1.1 activate
  no auto-summary
  no synchronization
 exit-address-family
 !
 address-family vpnv4
  neighbor 131.1.1.1 activate
  neighbor 131.1.1.1 send-community both
 exit-address-family
 !
 address-family ipv4 vrf VPN_A
  redistribute connected
  no auto-summary
  no synchronization
 exit-address-family
!
ip classless
!
no ip http server
!
!
!
!
!
control-plane
!
!
!
dial-peer cor custom
!        
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 stopbits 1
line vty 0 4
 password cisco
 login
!
end

 

Here is R1's 'debug mpls packet' with R7 doing a continuous ping to R9:

R1#
00:17:58: MPLS turbo: Se2/0.12: rx: Len 112 Stack {22 0 253} {25 0 254} - ipv4 data
00:17:58: MPLS turbo: AT3/0.1: tx: Len 112 Stack {0 0 252} {25 0 254} - ipv4 data
R1#
00:18:00: MPLS turbo: Se2/0.12: rx: Len 112 Stack {22 0 253} {25 0 254} - ipv4 data
00:18:00: MPLS turbo: AT3/0.1: tx: Len 112 Stack {0 0 252} {25 0 254} - ipv4 data

Here is the CellMode ATM router's 'debug mpls packet' and 'show mpls forwarding table' while R7 is doing the continuous ping to R9:

CellModeATM#
00:20:00: MPLS turbo: AT1/0.1: rx: Len 112 Stack {0 0 252} {25 0 254} - ipv4 data
00:20:00: MPLS turbo: AT3/0.1: tx: Len 112 Stack {0 0 251} {25 0 254} - ipv4 data
00:20:02: MPLS turbo: AT1/0.1: rx: Len 112 Stack {0 0 252} {25 0 254} - ipv4 data
00:20:02: MPLS turbo: AT3/0.1: tx: Len 112 Stack {0 0 251} {25 0 254} - ipv4 data
00:20:04: MPLS turbo: AT1/0.1: rx: Len 112 Stack {0 0 252} {25 0 254} - ipv4 data
00:20:04: MPLS turbo: AT3/0.1: tx: Len 112 Stack {0 0 251} {25 0 254} - ipv4 data

 

CellModeATM#sh mpls forwarding-table
Local  Outgoing      Prefix            Bytes Label   Outgoing   Next Hop   
Label  Label or VC   or Tunnel Id      Switched      interface             
16     1/33          131.1.1.1/32      3031          AT1/0.1    point2point
17     1/43          131.1.2.2/32      0             AT1/0.1    point2point
18     1/39          131.1.12.0/29     0             AT1/0.1    point2point
19     1/40          131.1.13.0/29     0             AT1/0.1    point2point
20     1/42          131.1.23.0/29     0             AT1/0.1    point2point
21     1/41          131.1.26.0/24     0             AT1/0.1    point2point
22     1/33          131.1.9.9/32      58452         AT3/0.1    point2point
23     1/44          131.1.6.6/32      0             AT1/0.1    point2point
24     1/45          131.1.3.3/32      0             AT1/0.1    point2point
25     1/46          131.1.4.4/32      0             AT1/0.1    point2point
26     1/47          131.1.5.5/32      0             AT1/0.1    point2point
27     1/48          131.1.34.0/29     0             AT1/0.1    point2point
28     1/49          131.1.35.0/29     0             AT1/0.1    point2point

The bytes label switched for 131.1.9.9 continously increments while R7 is sending ICMP traffic to 10.1.9.9.

I hope this is an obvious problem with my config or something.....

Thanks in advance....

 

Comments

  • Check to see if it is not "popping" on the router before the final destination. That is what I am thinking so it is not reaching the final destination. Also check yout mpls atm control-vc & VPI settings match if not using the default 0 32


    Couple of commands to try.

    show mpls forwarding-table
    sh mpls ldp bindings
    sh ip bgp vpnv4 all labels

    Hope that helps

    James


    ________________________________________
    From: [email protected] [[email protected]] On Behalf Of awilkins [[email protected]]
    Sent: Tuesday, October 28, 2008 7:58 AM
    To: James Yeo
    Subject: [CCIE SP] Vol II | Lab 1 | Section 5.7 | Cell mode MPLS issue?

    I'm running into a very weird issue in this section. R6 and R4 both have the route to 10.1.9.9 in VPN_A that exists on R9. R9, in turn, has routes to VPN_A routes on R6 and R4. From R7, I'm doing a continuous ping to 10.1.9.9 on R9. I've checked everything in the path with a 'debug mpls packet'. Both tx and rx traffic is being switched via MPLS. When I ping from R9 to R7, for example, R7 sees the ICMP traffic and properly reponds. However, when pinging from R7 to R9, R9 does not see any ICMP traffic. However, when doing a 'debug mpls packet' on R9, I am seeing the traffic hit it, but it never makes it to the loopback interface of 10.1.9.9 on R9 for some reason.

    Here is the MPLS traffic coming into R9 from a continuous ping from R7:

    R9#
    00:04:38: MPLS turbo: AT3/0.1: rx: Len 112 Stack {0 0 251} {25 0 254} - ipv4 data
    R9#
    00:04:40: MPLS turbo: AT3/0.1: rx: Len 112 Stack {0 0 251} {25 0 254} - ipv4 data
    R9#
    00:04:42: MPLS turbo: AT3/0.1: rx: Len 112 Stack {0 0 251} {25 0 254} - ipv4 data
    R9#



    Here is my MPLS forwarding table on R9:

    R9#sh mpls forwarding-table
    Local Outgoing Prefix Bytes Label Outgoing Next Hop
    Label Label or VC or Tunnel Id Switched interface
    16 1/33 131.1.1.1/32 0 AT3/0.1 point2point
    17 1/46 131.1.2.2/32 0 AT3/0.1 point2point
    18 1/42 131.1.12.0/29 0 AT3/0.1 point2point
    19 1/43 131.1.13.0/29 0 AT3/0.1 point2point
    20 1/45 131.1.23.0/29 0 AT3/0.1 point2point
    21 1/44 131.1.26.0/24 0 AT3/0.1 point2point
    22 1/39 150.1.101.0/24 0 AT3/0.1 point2point
    23 1/40 150.1.102.0/24 0 AT3/0.1 point2point
    24 1/41 150.100.100.254/32
    0 AT3/0.1 point2point
    25 Pop Label 10.1.9.9/32[V] 0 aggregate/VPN_A
    26 1/47 131.1.6.6/32 0 AT3/0.1 point2point
    27 1/48 131.1.3.3/32 0 AT3/0.1 point2point
    28 1/49 131.1.4.4/32 0 AT3/0.1 point2point
    29 1/50 131.1.5.5/32 0 AT3/0.1 point2point
    30 1/51 131.1.34.0/29 0 AT3/0.1 point2point
    31 1/52 131.1.35.0/29 0 AT3/0.1 point2point



    MPLS neighbor status:

    R9#sh mpls ldp disc
    Local LDP Identifier:
    131.1.9.9:0
    Discovery Sources:
    Interfaces:
    ATM3/0.1 (tdp): xmit/recv
    TDP Id: 150.100.100.254:3; IP addr: 150.1.109.254; no host route

    R9#sh mpls ldp neigh
    Peer TDP Ident: 150.100.100.254:3; Local TDP Ident 131.1.9.9:1
    TCP connection: 150.1.109.254.47581 - 150.1.109.9.711
    State: Oper; PIEs sent/rcvd: 0/44; Downstream on demand
    Up time: 00:15:06
    TDP discovery sources:
    ATM3/0.1, Src IP addr: 150.1.109.254

    Here is R9's config:

    R9#sh run
    Building configuration...

    Current configuration : 1842 bytes
    !
    version 12.2
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname R9
    !
    boot-start-marker
    boot-end-marker
    !
    enable password cisco
    !
    no aaa new-model
    ip subnet-zero
    ip cef
    !
    !
    no ip domain lookup
    !
    !
    ip vrf VPN_A
    rd 100:9
    route-target export 100:9
    route-target import 100:42
    route-target import 100:67
    !
    !
    !
    call rsvp-sync
    !
    !
    !
    !
    !
    !
    !
    no file verify auto
    !
    !
    !
    interface Loopback0
    ip address 131.1.9.9 255.255.255.255
    !
    interface Loopback1
    no ip address
    !
    interface Loopback9
    ip vrf forwarding VPN_A
    ip address 10.1.9.9 255.255.255.255
    !
    interface FastEthernet0/0
    no ip address
    shutdown
    duplex half
    !
    interface ATM3/0
    description Put Cell Mode MPLS Configs Here
    no ip address
    no atm enable-ilmi-trap
    !
    interface ATM3/0.1 mpls
    ip address 150.1.109.9 255.255.255.0
    no atm enable-ilmi-trap
    mpls label protocol tdp
    mpls ip
    !
    interface ATM4/0
    description Put ATM PVC Configs Here
    no ip address
    shutdown
    no atm enable-ilmi-trap
    !
    router ospf 1
    log-adjacency-changes
    network 131.1.9.9 0.0.0.0 area 0
    network 150.1.109.9 0.0.0.0 area 0
    !
    router bgp 100
    no bgp default ipv4-unicast
    bgp log-neighbor-changes
    neighbor 131.1.1.1 remote-as 100
    !
    address-family ipv4
    neighbor 131.1.1.1 activate
    no auto-summary
    no synchronization
    exit-address-family
    !
    address-family vpnv4
    neighbor 131.1.1.1 activate
    neighbor 131.1.1.1 send-community both
    exit-address-family
    !
    address-family ipv4 vrf VPN_A
    redistribute connected
    no auto-summary
    no synchronization
    exit-address-family
    !
    ip classless
    !
    no ip http server
    !
    !
    !
    !
    !
    control-plane
    !
    !
    !
    dial-peer cor custom
    !
    !
    !
    !
    line con 0
    exec-timeout 0 0
    privilege level 15
    logging synchronous
    stopbits 1
    line aux 0
    exec-timeout 0 0
    privilege level 15
    stopbits 1
    line vty 0 4
    password cisco
    login
    !
    end



    Here is R1's 'debug mpls packet' with R7 doing a continuous ping to R9:

    R1#
    00:17:58: MPLS turbo: Se2/0.12: rx: Len 112 Stack {22 0 253} {25 0 254} - ipv4 data
    00:17:58: MPLS turbo: AT3/0.1: tx: Len 112 Stack {0 0 252} {25 0 254} - ipv4 data
    R1#
    00:18:00: MPLS turbo: Se2/0.12: rx: Len 112 Stack {22 0 253} {25 0 254} - ipv4 data
    00:18:00: MPLS turbo: AT3/0.1: tx: Len 112 Stack {0 0 252} {25 0 254} - ipv4 data

    Here is the CellMode ATM router's 'debug mpls packet' and 'show mpls forwarding table' while R7 is doing the continuous ping to R9:

    CellModeATM#
    00:20:00: MPLS turbo: AT1/0.1: rx: Len 112 Stack {0 0 252} {25 0 254} - ipv4 data
    00:20:00: MPLS turbo: AT3/0.1: tx: Len 112 Stack {0 0 251} {25 0 254} - ipv4 data
    00:20:02: MPLS turbo: AT1/0.1: rx: Len 112 Stack {0 0 252} {25 0 254} - ipv4 data
    00:20:02: MPLS turbo: AT3/0.1: tx: Len 112 Stack {0 0 251} {25 0 254} - ipv4 data
    00:20:04: MPLS turbo: AT1/0.1: rx: Len 112 Stack {0 0 252} {25 0 254} - ipv4 data
    00:20:04: MPLS turbo: AT3/0.1: tx: Len 112 Stack {0 0 251} {25 0 254} - ipv4 data



    CellModeATM#sh mpls forwarding-table
    Local Outgoing Prefix Bytes Label Outgoing Next Hop
    Label Label or VC or Tunnel Id Switched interface
    16 1/33 131.1.1.1/32 3031 AT1/0.1 point2point
    17 1/43 131.1.2.2/32 0 AT1/0.1 point2point
    18 1/39 131.1.12.0/29 0 AT1/0.1 point2point
    19 1/40 131.1.13.0/29 0 AT1/0.1 point2point
    20 1/42 131.1.23.0/29 0 AT1/0.1 point2point
    21 1/41 131.1.26.0/24 0 AT1/0.1 point2point
    22 1/33 131.1.9.9/32 58452 AT3/0.1 point2point
    23 1/44 131.1.6.6/32 0 AT1/0.1 point2point
    24 1/45 131.1.3.3/32 0 AT1/0.1 point2point
    25 1/46 131.1.4.4/32 0 AT1/0.1 point2point
    26 1/47 131.1.5.5/32 0 AT1/0.1 point2point
    27 1/48 131.1.34.0/29 0 AT1/0.1 point2point
    28 1/49 131.1.35.0/29 0 AT1/0.1 point2point

    The bytes label switched for 131.1.9.9 continously increments while R7 is sending ICMP traffic to 10.1.9.9.

    I hope this is an obvious problem with my config or something.....

    Thanks in advance....





    Internetwork Expert - The Industry Leader in CCIE Preparation
    http://www.internetworkexpert.com

    Subscription information may be found at:
    http://www.ieoc.com/forums/ForumSubscriptions.aspx

    DISCLAIMER:
    Everything in this email and its attachments relating to the official business of arivia.kom is proprietary to arivia.kom. It is confidential, legally privileged and protected by law. The person addressed in the email is the sole authorised recipient. Any unauthorized dissemination or copying of this e-mail (or any attachment to this e-mail) or the wrongful disclosure of the information herein contained is prohibited.
  • Changed IOS and the issue was resolved.  

  • Hi,

     

    Which IOS you are using after that?

     

    Thanks

    Mahir

Sign In or Register to comment.