Routing table dissimilarities

AnoobiAnoobi
edited December 2019 in Home Lab

Hi gentelmen,

Maybe this is a bit of a beginner level but it is a delimma for me!

I have this network set up:

Router 1 connected to Router 2 on Gig 0/0 and Router 2 connected to Router 3 on Gig 2/0

Router 1 config as below:
!
interface GigabitEthernet0/0
ip address 172.16.3.198 255.255.255.252

!
interface Loopback0
ip address 172.17.1.65 255.255.255.192

!
router eigrp 10
network 172.16.0.0
network 172.17.0.0
auto-summary

Router 2 Config as below:

!
interface GigabitEthernet0/0
ip address 172.16.3.197 255.255.255.252
!
interface GigabitEthernet2/0
ip address 172.16.3.205 255.255.255.252
!
router eigrp 10
network 172.16.0.0
!

Router 3 config as below:
!
interface GigabitEthernet2/0
ip address 172.16.3.206 255.255.255.252
!
router eigrp 10
network 172.16.0.0
!


My Question is when I check eigrp route on Router 2 for network 172.17.0.0 I see a different format than Router 3!

On R2
Gateway of last resort is not set

D 172.17.0.0/16 [90/130816] via 172.16.3.198, 00:16:33, GigabitEthernet0/0
R2#
Notice that it is on on line ouput and does not show that it is subnetted as below!

On R3
172.17.0.0/16 is subnetted, 1 subnets
D 172.17.0.0 [90/131072] via 172.16.3.205, 00:17:10, GigabitEthernet2/0

Also I noticed this difference too

On R2
R2#show ip route 172.17.0.0
Routing entry for 172.17.0.0/16
Known via "eigrp 10", distance 90, metric 130816, type internal
Redistributing via eigrp 10
Last update from 172.16.3.198 on GigabitEthernet0/0, 00:18:08 ago
Routing Descriptor Blocks:
* 172.16.3.198, from 172.16.3.198, 00:18:08 ago, via GigabitEthernet0/0
Route metric is 130816, traffic share count is 1
Total delay is 5010 microseconds, minimum bandwidth is 1000000 Kbit
Reliability 255/255, minimum MTU 1500 bytes
Loading 1/255, Hops 1

While or R3
R3#show ip route 172.17.0.0
Routing entry for 172.17.0.0/16, 1 known subnets
Redistributing via eigrp 10
D 172.17.0.0 [90/131072] via 172.16.3.205, 00:18:42, GigabitEthernet2/0

BUT
When I distable Auto summary (no auto-summary) under the EIGRP process 10 on Router 1 the above results between R2 and R3 looks consistant!

Gateway of last resort is not set

  172.17.0.0/26 is subnetted, 1 subnets

D 172.17.1.64
[90/130816] via 172.16.3.198, 00:01:00, GigabitEthernet0/0
R2#

and

R2#show ip route 172.17.0.0
Routing entry for 172.17.0.0/26, 1 known subnets
Redistributing via eigrp 10
D 172.17.1.64
[90/130816] via 172.16.3.198, 00:02:57, GigabitEthernet0/0

So my question is why it is behaving in this way? Why on the first scenario before auto summary was turned off the show ip route 172.17.0.0 command showed more details than the next scenario after disable auto summary? and why the show ip route output when the auto summary was on did not show that the eigrp route was subnetted? I hope the question makes sense!

FYI: I did a file caputre to see EIGRP updates sent from R1 to R2 and from R2 to R3 and they were identical as pic below!

Many thanks
Anoobi

Sign In or Register to comment.