MPLS Traffic Engineering over nonbroadcast OSPF links

I'm doing Vol II lab 1 right now (section 4.4).  I cannot get R6 or R2 to show the LAN segment between them in the traffic-eng topology.  Neither will list the LAN interface in the "show ip ospf mpls traffic-eng link' output unless I take the 'ip ospf network nonbroadcast' off the interface.  The nonbroadcast was a prior step in the lab.  MPLS and routing are working fine on this connection.


Is there a trick with MPLS Traffic engineering and nonbroadcast OSPF network types?

 

R6#sh ip ospf neigh

Neighbor ID     Pri   State           Dead Time   Address         Interface
131.1.2.2         1   FULL/BDR        00:01:37    131.1.26.2      Ethernet0/0
R6#
R6#sh mpls ldp disc
 Local LDP Identifier:
    131.1.6.6:0
    Discovery Sources:
    Interfaces:
        Ethernet0/0 (ldp): xmit/recv
            LDP Id: 131.1.2.2:0
R6#
R6#sh ip ospf mpls traffic-eng link

            OSPF Router with ID (131.1.6.6) (Process ID 1)

  Area 0 has 0 MPLS TE links. Area instance is 1.
R6#

 

R6#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

B    119.0.0.0/8 [20/0] via 54.1.2.254, 00:09:40
B    118.0.0.0/8 [20/0] via 54.1.2.254, 00:09:40
B    117.0.0.0/8 [20/0] via 54.1.2.254, 00:09:40
B    116.0.0.0/8 [20/0] via 54.1.2.254, 00:09:40
B    115.0.0.0/8 [20/0] via 54.1.2.254, 00:09:40
B    114.0.0.0/8 [20/0] via 54.1.2.254, 00:09:40
     54.0.0.0/24 is subnetted, 1 subnets
C       54.1.2.0 is directly connected, Serial1/0
B    113.0.0.0/8 [20/0] via 54.1.2.254, 00:09:40
B    112.0.0.0/8 [20/0] via 54.1.2.254, 00:09:40
     131.1.0.0/16 is variably subnetted, 14 subnets, 3 masks
O       131.1.9.9/32 [110/6] via 131.1.26.2, 00:09:52, Ethernet0/0
B       131.1.8.8/32 [200/0] via 131.1.5.5, 00:09:29
C       131.1.6.6/32 is directly connected, Loopback0
O       131.1.5.5/32 [110/68] via 131.1.26.2, 00:09:53, Ethernet0/0
O       131.1.4.4/32 [110/6] via 131.1.26.2, 00:09:53, Ethernet0/0
O       131.1.3.3/32 [110/4] via 131.1.26.2, 00:09:53, Ethernet0/0
O       131.1.2.2/32 [110/2] via 131.1.26.2, 00:09:53, Ethernet0/0
O       131.1.1.1/32 [110/4] via 131.1.26.2, 00:09:53, Ethernet0/0
O       131.1.12.0/29 [110/3] via 131.1.26.2, 00:09:53, Ethernet0/0
O       131.1.13.0/29 [110/5] via 131.1.26.2, 00:09:53, Ethernet0/0
O       131.1.23.0/29 [110/3] via 131.1.26.2, 00:09:53, Ethernet0/0
C       131.1.26.0/24 is directly connected, Ethernet0/0
O       131.1.34.0/29 [110/5] via 131.1.26.2, 00:09:53, Ethernet0/0
O       131.1.35.0/29 [110/67] via 131.1.26.2, 00:09:53, Ethernet0/0
     28.0.0.0/24 is subnetted, 2 subnets
B       28.119.17.0 [20/0] via 54.1.2.254, 00:09:40
B       28.119.16.0 [20/0] via 54.1.2.254, 00:09:40
     150.100.0.0/32 is subnetted, 1 subnets
O       150.100.100.254 [110/5] via 131.1.26.2, 00:09:53, Ethernet0/0
     150.1.0.0/24 is subnetted, 3 subnets
O       150.1.102.0 [110/5] via 131.1.26.2, 00:09:53, Ethernet0/0
O       150.1.101.0 [110/4] via 131.1.26.2, 00:09:53, Ethernet0/0
O       150.1.109.0 [110/5] via 131.1.26.2, 00:09:53, Ethernet0/0
R6#


R6#sh mpls forwarding-table
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop   
tag    tag or VC   or Tunnel Id      switched   interface             
16     Pop tag     131.1.23.0/29     0          Et0/0      131.1.26.2  
17     17          131.1.13.0/29     0          Et0/0      131.1.26.2  
18     16          131.1.1.1/32      0          Et0/0      131.1.26.2  
19     Pop tag     131.1.2.2/32      0          Et0/0      131.1.26.2  
20     23          131.1.3.3/32      0          Et0/0      131.1.26.2  
21     24          131.1.4.4/32      0          Et0/0      131.1.26.2  
22     25          131.1.5.5/32      0          Et0/0      131.1.26.2  
23     22          131.1.9.9/32      0          Et0/0      131.1.26.2  
24     Pop tag     131.1.12.0/29     0          Et0/0      131.1.26.2  
25     26          131.1.34.0/29     0          Et0/0      131.1.26.2  
26     27          131.1.35.0/29     0          Et0/0      131.1.26.2  
27     18          150.1.101.0/24    0          Et0/0      131.1.26.2  
28     19          150.1.102.0/24    0          Et0/0      131.1.26.2  
29     20          150.1.109.0/24    0          Et0/0      131.1.26.2  
30     21          150.100.100.254/32  
                                     0          Et0/0      131.1.26.2  
R6# 

 

R6#sh run
Building configuration...

Current configuration : 2462 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R6
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
memory-size iomem 5
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup
!
!
ip cef   
ip ips po max-events 100
mpls label protocol ldp
mpls ldp neighbor 131.1.2.2 password 7 062526126F61
mpls traffic-eng tunnels
no ftp-server write-enable
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!        
!
!
interface Loopback0
 ip address 131.1.6.6 255.255.255.255
!
interface Ethernet0/0
 bandwidth 100000
 ip address 131.1.26.6 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 CISCO
 ip ospf network non-broadcast
 full-duplex
 mpls traffic-eng tunnels
 tag-switching ip
 ip rsvp bandwidth
!
interface Ethernet0/1
 no ip address
 shutdown
 half-duplex
!
interface Ethernet0/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet0/3
 no ip address
 shutdown
 half-duplex
!
interface Serial1/0
 ip address 54.1.2.6 255.255.255.0
 encapsulation frame-relay
 serial restart-delay 0
 no arp frame-relay
 frame-relay map ip 54.1.2.254 100 broadcast
 no frame-relay inverse-arp
 frame-relay lmi-type ansi
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 1
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng area 0
 mpls traffic-eng interface Ethernet0/0 area 0
 log-adjacency-changes
 network 131.1.6.6 0.0.0.0 area 0
 network 131.1.26.6 0.0.0.0 area 0
 neighbor 131.1.26.2 priority 1
!
router bgp 100
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 54.1.2.254 remote-as 54
 neighbor 131.1.1.1 remote-as 100
 !
 address-family ipv4
 neighbor 54.1.2.254 activate
 neighbor 54.1.2.254 route-map AS100_COMMUNITY in
 neighbor 131.1.1.1 activate
 neighbor 131.1.1.1 next-hop-self
 neighbor 131.1.1.1 send-community both
 no auto-summary
 no synchronization
 exit-address-family
!
ip http server
no ip http secure-server
ip classless
!
ip bgp-community new-format
!
!
!
route-map AS100_COMMUNITY permit 100
 set local-preference 120
 set community 100:54
!        
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
line vty 0 4
 password cisco
 login
!        
!
end

 

 

 

Comments

Sign In or Register to comment.