4.4

hello...

Am facing some problem with section 4.4. Supposedly simple, but my virtual link via area 45 is not coming up.

Say "Virtual Link OSPF_VL0 to router 150.1.4.4 is down".


Did anyone else face the same issue..? if so wats the problem and the solution..?


Regards

Comments

  • Hi,

    First step to trouble shoot this problem is to check whether you are able to reach the router ids.In order to make the Virtual Link UP you have to take sure that you are able to reach the router ids from both routers. (ie 150.1.4.4 from R5 and 150.1.5.5 from R4).

    Router ids will be reachable if you are able to bring the OSPF neighborship either through FR ckt or through the PPP link between R5 and R4.

    I assume that you are using below commands under ospf process.

    R4

    router ospf 4

    router-id 150.1.4.4

    network 136.1.45.4 0.0.0.0 area 45  -------> In order to establish OSPF neighborship through PPP link between R4 & R5

     area 45 virtual-link 150.1.5.5

    R5

    router ospf 5

    router-id 150.1.5.5

    network 136.1.45.5 0.0.0.0 area 45 -------> In order to establish OSPF neighborship through PPP link between R4 & R5

    area 45 virtual-link 150.1.4.4

     

  • Greetings!

     

    My question would be; when did you check to note that the virtual link was not coming up?  I'm curious whether it was after you configured 4.5 to authenticate all the links in area 0, since the virtual link is an extension of area 0 and also needs to be authenticated.

     

    Does your area 45 adjacency come up?  If so, then maybe you've just got a typo on your config on R4?

     

    Can you post your configurations?

     

    Thanks!

     

    --JB

Sign In or Register to comment.