PPPoe Configuration is Failing

Hi,
I have a problem with "Providing Protocol Support for Broadband Access Aggregation of PPPoE Sessions". I have included below configs for booth server (r1) and client (r3) as well as output for the debug ppp authentication on the server.

The configs are pretty basic and simple. Please help me find out what is the problem.

Server Config & Debug Output

R1#show run
Building configuration...

version 15.4
platform console serial
!
hostname R1
!
license boot level ax

!
username r3 password 0 cisco

!
!
bba-group pppoe global
virtual-template 1
!
!
interface GigabitEthernet1
no ip address
negotiation auto
pppoe enable group global
cdp enable
!
!
interface Virtual-Template1
ip address 192.168.0.1 255.255.255.0
ppp authentication chap
!
!
!
line con 0
logging synchronous
stopbits 1
line vty 0 4
no login
line vty 5 10
privilege level 15
logging synchronous
no login
rotary 1
!
!
end

R1#
R1#debug ppp authentication
PPP authentication debugging is on
R1#
*Sep 2 23:14:00.285: ppp101 PPP: Using vpn set call direction
*Sep 2 23:14:00.285: ppp101 PPP: Treating connection as a callin
*Sep 2 23:14:00.285: ppp101 PPP: Session handle[57000065] Session id[101]
*Sep 2 23:14:00.327: ppp101 CHAP: O CHALLENGE id 1 len 23 from "R1"
*Sep 2 23:14:00.327: ppp101 CHAP: I CHALLENGE id 1 len 23 from "R3"
*Sep 2 23:14:00.327: ppp101 CHAP: Waiting for Peer to authenticate first
*Sep 2 23:14:00.329: ppp101 CHAP: I RESPONSE id 1 len 23 from "R3"
*Sep 2 23:14:00.3
R1#29: ppp101 PPP: Sent CHAP LOGIN Request
*Sep 2 23:14:00.330: ppp101 PPP: Received LOGIN Response PASS
*Sep 2 23:14:00.339: Vi1.1 PPP: Sent CHAP SENDAUTH Request
*Sep 2 23:14:00.339: Vi1.1 CHAP: O SUCCESS id 1 len 4
*Sep 2 23:14:00.339: Vi1.1 PPP: Received SENDAUTH Response PASS
*Sep 2 23:14:00.339: Vi1.1 CHAP: Using hostname from configured hostname
*Sep 2 23:14:00.339: Vi1.1 CHAP: Using password from AAA
*Sep 2 23:14:00.339: Vi1.1 CHAP: O RESPONSE id 1 len 23 from "R1"
*Sep 2 23:14:00.341:
R1# Vi1.1 CHAP: I FAILURE id 1 len 25 msg is "Authentication failed"
R1#u all
All possible debugging has been turned off
R1#

Client Config & Console Logging Messages

R3#show run
Building configuration...

version 15.4
platform console serial
!
hostname R3
!
!
license boot level ax

!
interface GigabitEthernet1
no ip address
negotiation auto
pppoe enable
pppoe-client dial-pool-number 1
cdp enable
!

interface Dialer1
ip address 192.168.0.3 255.255.255.0
encapsulation ppp
dialer pool 1
ppp authentication chap
ppp chap password 0 cisco
!
!
!
line con 0
logging synchronous
stopbits 1
line vty 0 4
no login
line vty 5 10
privilege level 15
logging synchronous
no login
rotary 1
!
!
end

R3#
*Sep 2 23:11:24.477: %DIALER-6-BIND: Interface Vi1 bound to profile Di1
*Sep 2 23:11:24.480: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
*Sep 2 23:11:24.508: %DIALER-6-UNBIND: Interface Vi1 unbound from profile Di1
*Sep 2 23:11:24.513: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to down
*Sep 2 23:11:46.764: %DIALER-6-BIND: Interface Vi1 bound to profile Di1
*Sep 2 23:11:46.767: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
*Sep 2 23:11:46.810: %DIALER-6-UNBIND: Interface Vi1 unbound from profile Di1
11:46.814: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to down
R3#
*Sep 2 23:12:09.049: %DIALER-6-BIND: Interface Vi1 bound to profile Di1
*Sep 2 23:12:09.052: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
*Sep 2 23:12:09.085: %DIALER-6-UNBIND: Interface Vi1 unbound from profile Di1
R3#s
*Sep 2 23:12:09.090: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to down

Comments

  • Here is the show ip interface both r1 and r3

    R1#show ip interface brie
    Interface IP-Address OK? Method Status Protocol
    GigabitEthernet1 unassigned YES manual up up
    GigabitEthernet2 unassigned YES manual up up
    Virtual-Access1 unassigned YES unset up up
    Virtual-Access2 unassigned YES unset down down
    Virtual-Template1 192.168.0.1 YES manual down down
    R1#

    R3#show ip interface brief
    Interface IP-Address OK? Method Status Protocol
    GigabitEthernet1 unassigned YES manual up up
    GigabitEthernet2 unassigned YES manual up up
    Dialer1 192.168.0.3 YES manual up up
    Virtual-Access1 unassigned YES unset down down
    R3#

  • You are trying to authenticate bi-directionally Sep 2 23:14:00.327: ppp101 CHAP: Waiting for Peer to authenticate first

    you can fix this by either adding "username R1 password 0 cisco" to r3 or add the ppp authentication chap callin to R3

    interface Dialer1
    mtu 1492
    ip address negotiated
    encapsulation ppp
    dialer pool 1
    ppp authentication chap callin
    ppp chap password 0 cisco

    R1(config-if)#
    *Sep 3 16:24:06.465: ppp142 PPP: Using vpn set call direction
    *Sep 3 16:24:06.465: ppp142 PPP: Treating connection as a callin
    *Sep 3 16:24:06.465: ppp142 PPP: Session handle[1A000076] Session id[142]
    *Sep 3 16:24:06.488: ppp142 CHAP: O CHALLENGE id 1 len 27 from "R1"
    *Sep 3 16:24:06.489: ppp142 CHAP: I RESPONSE id 1 len 23 from "r3"
    *Sep 3 16:24:06.490: ppp142 PPP: Sent CHAP LOGIN Request
    *Sep 3 16:24:06.490: ppp142 PPP: Received LOGIN Response PASS

Sign In or Register to comment.