EIGRP auto-summary configurations

Hi everyone

as you can see into this topology
enabled auto-summary into R1 and R2
but theres something i dont understand
R2#show ip route eigrp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
+ - replicated route, % - next hop override

Gateway of last resort is not set

  2.0.0.0/8 is variably subnetted, 6 subnets, 4 masks

D 2.0.0.0/8 is a summary, 00:21:48, Null0
10.0.0.0/8 is variably subnetted, 11 subnets, 5 masks
D 10.0.0.0/8 is a summary, 00:21:48, Null0
R2#
R2#show ip protocols
*** IP Routing is NSF aware ***

Routing Protocol is "eigrp 1"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Default networks flagged in outgoing updates
Default networks accepted from incoming updates
EIGRP-IPv4 Protocol for AS(1)
Metric weight K1=1, K2=0, K3=1, K4=0, K5=0
NSF-aware route hold timer is 240
Router-ID: 2.4.3.1
Topology : 0 (base)
Active Timer: 3 min
Distance: internal 90 external 170
Maximum path: 4
Maximum hopcount 100
Maximum metric variance 1

Automatic Summarization: enabled
10.0.0.0/8 for Lo0, Lo1, Lo2
Summarizing 5 components with metric 128256
2.0.0.0/8 for Et0/1, Et0/0, Lo3
Lo4, Lo5
Summarizing 3 components with metric 128256
Maximum path: 4
Routing for Networks:
0.0.0.0
Routing Information Sources:
Gateway Distance Last Update
10.1.12.1 90 00:04:21
Distance: internal 90 external 170

R2#show ip eigrp topology all-links
EIGRP-IPv4 Topology Table for AS(1)/ID(2.4.3.1)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status

P 2.4.3.1/32, 1 successors, FD is 128256, serno 35
via Connected, Loopback2
P 10.1.12.0/24, 1 successors, FD is 281600, serno 31
via Connected, Ethernet0/0
P 2.2.0.0/16, 1 successors, FD is 128256, serno 33
via Connected, Loopback0
P 2.0.0.0/8, 1 successors, FD is 128256, serno 39
via Summary (128256/0), Null0
P 10.1.0.0/24, 1 successors, FD is 128256, serno 37
via Connected, Loopback4
P 10.1.23.0/24, 1 successors, FD is 281600, serno 32
via Connected, Ethernet0/1
P 10.0.0.0/8, 1 successors, FD is 128256, serno 40
via Summary (128256/0), Null0
P 10.0.0.0/16, 1 successors, FD is 128256, serno 36
via Connected, Loopback3
P 2.3.3.0/24, 1 successors, FD is 128256, serno 34
via Connected, Loopback1
P 10.1.1.0/27, 1 successors, FD is 128256, serno 38
via Connected, Loopback5

R2#

R1#show ip route eigrp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
+ - replicated route, % - next hop override

Gateway of last resort is not set

D 2.0.0.0/8 [90/409600] via 10.1.12.2, 00:23:11, Ethernet0/0
10.0.0.0/8 is variably subnetted, 6 subnets, 4 masks
D 10.0.0.0/16 [90/409600] via 10.1.12.2, 00:23:11, Ethernet0/0
D 10.1.0.0/24 [90/409600] via 10.1.12.2, 00:23:11, Ethernet0/0
D 10.1.1.0/27 [90/409600] via 10.1.12.2, 00:23:11, Ethernet0/0
D 10.1.23.0/24 [90/307200] via 10.1.12.2, 00:23:11, Ethernet0/0

R1#show ip eigrp topology all-links
EIGRP-IPv4 Topology Table for AS(1)/ID(1.1.1.5)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status

P 10.1.12.0/24, 1 successors, FD is 281600, serno 1
via Connected, Ethernet0/0
P 2.0.0.0/8, 1 successors, FD is 409600, serno 24
via 10.1.12.2 (409600/128256), Ethernet0/0
P 10.1.0.0/24, 1 successors, FD is 409600, serno 22
via 10.1.12.2 (409600/128256), Ethernet0/0
P 10.1.23.0/24, 1 successors, FD is 307200, serno 20
via 10.1.12.2 (307200/281600), Ethernet0/0
P 10.0.0.0/16, 1 successors, FD is 409600, serno 21
via 10.1.12.2 (409600/128256), Ethernet0/0
P 10.1.1.0/27, 1 successors, FD is 409600, serno 23
via 10.1.12.2 (409600/128256), Ethernet0/0

R1#

now why R1 rcv 2.0.0.0/8 as result of auto-summary configuration , but dont rcv 10.0.0.0/8 as summary route R2 put 10.0.0.0/8 inside his local topology tbl and inside his local RT as null0 outgoing interface , but why dont send it to R1?
look again at show ip protocols into R2, 10.0.0.0/8 for Lo0, Lo1, Lo2 means R2 know this will be eligible to be summarized

Comments

  • alexpfalexpf ✭✭

    Can you give me the show run | s eigrp from bot routers?

  • R2#show running-config | section router
    router eigrp 1
    network 0.0.0.0
    auto-summary
    R2#

    R1#show running-config | section router
    router eigrp 1
    network 0.0.0.0
    auto-summary
    R1#
    R2#show ip route eigrp

    Gateway of last resort is not set

    D 1.0.0.0/8 [90/409600] via 10.1.12.1, 00:00:58, Ethernet0/0
    2.0.0.0/8 is variably subnetted, 6 subnets, 4 masks
    D 2.0.0.0/8 is a summary, 00:02:22, Null0
    10.0.0.0/8 is variably subnetted, 11 subnets, 5 masks
    D 10.0.0.0/8 is a summary, 00:02:22, Null0
    R2#
    R1#show ip route eigrp

      1.0.0.0/8 is variably subnetted, 7 subnets, 2 masks
    

    D 1.0.0.0/8 is a summary, 00:00:25, Null0
    D 2.0.0.0/8 [90/409600] via 10.1.12.2, 00:00:25, Ethernet0/0
    10.0.0.0/8 is variably subnetted, 7 subnets, 5 masks
    D 10.0.0.0/8 is a summary, 00:00:25, Null0
    D 10.0.0.0/16 [90/409600] via 10.1.12.2, 00:00:25, Ethernet0/0
    D 10.1.0.0/24 [90/409600] via 10.1.12.2, 00:00:25, Ethernet0/0
    D 10.1.1.0/27 [90/409600] via 10.1.12.2, 00:00:25, Ethernet0/0
    D 10.1.23.0/24 [90/307200] via 10.1.12.2, 00:00:25, Ethernet0/0
    R1#

  • alexpfalexpf ✭✭

    Here is my response. The interface auto-summary command would work, but the auto-summary won't work because the two routers are connected on that subnet. I believe that the auto-summary command can't summarize to a directly connected interface on the same subnet. You can easily test that. Please let me know if that doesn't fix it because I can lab it up pretty easy, too.

    Thanks,

    Alex

  • if the network wanted to adv is different than outgoing int , it will be summarized
    if the network wanted to adv is into the same classful network like outgoing interface ,then we have 2-conditions:-
    1-if the subnetmask is lower than the subnetmask for outgoing interface , then it will be summarized
    1-if the wubnetmask is qual to or higher than the subnet mask for outgoing interface , that network will NEVER be summarized and will adv as it`s into local device

    based on this lecture and based on this topology
    1.jpg

    R1#show running-config | section router
    router eigrp 1
    network 0.0.0.0
    auto-summary
    R2#show running-config | section router
    router eigrp 1
    network 0.0.0.0
    auto-summary
    R3#show running-config | section router
    router eigrp 1
    network 10.1.0.0 0.0.255.255
    network 100.1.1.0 0.0.0.0
    redistribute connected
    R1#show ip route

      1.0.0.0/8 is variably subnetted, 7 subnets, 2 masks
    

    D 1.0.0.0/8 is a summary, 00:14:54, Null0
    C 1.1.1.0/32 is directly connected, Loopback0
    C 1.1.1.1/32 is directly connected, Loopback1
    C 1.1.1.2/32 is directly connected, Loopback2
    C 1.1.1.3/32 is directly connected, Loopback3
    C 1.1.1.4/32 is directly connected, Loopback4
    C 1.1.1.5/32 is directly connected, Loopback5
    D 2.0.0.0/8 [90/409600] via 10.1.12.2, 00:02:08, Ethernet0/0
    10.0.0.0/8 is variably subnetted, 11 subnets, 6 masks
    D 10.0.0.0/8 is a summary, 00:01:02, Null0
    D 10.0.0.0/16 [90/409600] via 10.1.12.2, 00:09:44, Ethernet0/0
    D 10.1.0.0/24 [90/409600] via 10.1.12.2, 00:09:44, Ethernet0/0
    D 10.1.1.0/27 [90/409600] via 10.1.12.2, 00:09:44, Ethernet0/0
    C 10.1.12.0/24 is directly connected, Ethernet0/0
    L 10.1.12.1/32 is directly connected, Ethernet0/0
    D 10.1.14.0/24 [90/435200] via 10.1.12.2, 00:14:50, Ethernet0/0
    D 10.1.23.0/24 [90/307200] via 10.1.12.2, 00:14:50, Ethernet0/0
    D EX 10.2.0.0/16 [170/435200] via 10.1.12.2, 00:14:50, Ethernet0/0
    C 10.128.0.0/9 is directly connected, Loopback7
    L 10.128.8.1/32 is directly connected, Loopback7
    100.0.0.0/32 is subnetted, 4 subnets
    D 100.1.1.0 [90/435200] via 10.1.12.2, 00:14:50, Ethernet0/0
    D EX 100.1.1.1 [170/435200] via 10.1.12.2, 00:14:50, Ethernet0/0
    D EX 100.1.1.2 [170/435200] via 10.1.12.2, 00:14:50, Ethernet0/0
    D EX 100.1.1.3 [170/435200] via 10.1.12.2, 00:14:50, Ethernet0/0
    R2#show ip route
    R3#show ip route

    D 1.0.0.0/8 [90/435200] via 10.1.23.2, 00:15:23, Ethernet0/0
    D 2.0.0.0/8 [90/409600] via 10.1.23.2, 00:02:41, Ethernet0/0
    10.0.0.0/8 is variably subnetted, 11 subnets, 5 masks
    D 10.0.0.0/16 [90/409600] via 10.1.23.2, 00:10:17, Ethernet0/0
    D 10.1.0.0/24 [90/409600] via 10.1.23.2, 00:10:17, Ethernet0/0
    D 10.1.1.0/27 [90/409600] via 10.1.23.2, 00:10:17, Ethernet0/0
    D 10.1.12.0/24 [90/307200] via 10.1.23.2, 00:15:23, Ethernet0/0
    C 10.1.14.0/24 is directly connected, Loopback4
    L 10.1.14.3/32 is directly connected, Loopback4
    C 10.1.23.0/24 is directly connected, Ethernet0/0
    L 10.1.23.3/32 is directly connected, Ethernet0/0
    C 10.2.0.0/16 is directly connected, Loopback5
    L 10.2.15.3/32 is directly connected, Loopback5
    D 10.128.0.0/9 [90/435200] via 10.1.23.2, 00:01:34, Ethernet0/0
    100.0.0.0/32 is subnetted, 4 subnets
    C 100.1.1.0 is directly connected, Loopback1
    C 100.1.1.1 is directly connected, Loopback0
    C 100.1.1.2 is directly connected, Loopback2
    C 100.1.1.3 is directly connected, Loopback3
    R3#
    D 1.0.0.0/8 [90/409600] via 10.1.12.1, 00:15:07, Ethernet0/0
    2.0.0.0/8 is variably subnetted, 6 subnets, 4 masks
    D 2.0.0.0/8 is a summary, 00:02:25, Null0
    C 2.2.0.0/16 is directly connected, Loopback0
    L 2.2.2.5/32 is directly connected, Loopback0
    C 2.3.3.0/24 is directly connected, Loopback1
    L 2.3.3.1/32 is directly connected, Loopback1
    C 2.4.3.1/32 is directly connected, Loopback2
    10.0.0.0/8 is variably subnetted, 14 subnets, 6 masks
    D 10.0.0.0/8 is a summary, 00:02:25, Null0
    C 10.0.0.0/16 is directly connected, Loopback3
    L 10.0.0.1/32 is directly connected, Loopback3
    C 10.1.0.0/24 is directly connected, Loopback4
    L 10.1.0.1/32 is directly connected, Loopback4
    C 10.1.1.0/27 is directly connected, Loopback5
    L 10.1.1.1/32 is directly connected, Loopback5
    C 10.1.12.0/24 is directly connected, Ethernet0/0
    L 10.1.12.2/32 is directly connected, Ethernet0/0
    D 10.1.14.0/24 [90/409600] via 10.1.23.3, 00:15:07, Ethernet0/1
    C 10.1.23.0/24 is directly connected, Ethernet0/1
    L 10.1.23.2/32 is directly connected, Ethernet0/1
    D EX 10.2.0.0/16 [170/409600] via 10.1.23.3, 00:15:07, Ethernet0/1
    D 10.128.0.0/9 [90/409600] via 10.1.12.1, 00:01:19, Ethernet0/0
    100.0.0.0/32 is subnetted, 4 subnets
    D 100.1.1.0 [90/409600] via 10.1.23.3, 00:15:07, Ethernet0/1
    D EX 100.1.1.1 [170/409600] via 10.1.23.3, 00:15:07, Ethernet0/1
    D EX 100.1.1.2 [170/409600] via 10.1.23.3, 00:15:07, Ethernet0/1
    D EX 100.1.1.3 [170/409600] via 10.1.23.3, 00:15:07, Ethernet0/1
    R2#
    R3#show ip route

    D 1.0.0.0/8 [90/435200] via 10.1.23.2, 00:15:23, Ethernet0/0
    D 2.0.0.0/8 [90/409600] via 10.1.23.2, 00:02:41, Ethernet0/0
    10.0.0.0/8 is variably subnetted, 11 subnets, 5 masks
    D 10.0.0.0/16 [90/409600] via 10.1.23.2, 00:10:17, Ethernet0/0
    D 10.1.0.0/24 [90/409600] via 10.1.23.2, 00:10:17, Ethernet0/0
    D 10.1.1.0/27 [90/409600] via 10.1.23.2, 00:10:17, Ethernet0/0
    D 10.1.12.0/24 [90/307200] via 10.1.23.2, 00:15:23, Ethernet0/0
    C 10.1.14.0/24 is directly connected, Loopback4
    L 10.1.14.3/32 is directly connected, Loopback4
    C 10.1.23.0/24 is directly connected, Ethernet0/0
    L 10.1.23.3/32 is directly connected, Ethernet0/0
    C 10.2.0.0/16 is directly connected, Loopback5
    L 10.2.15.3/32 is directly connected, Loopback5
    D 10.128.0.0/9 [90/435200] via 10.1.23.2, 00:01:34, Ethernet0/0
    100.0.0.0/32 is subnetted, 4 subnets
    C 100.1.1.0 is directly connected, Loopback1
    C 100.1.1.1 is directly connected, Loopback0
    C 100.1.1.2 is directly connected, Loopback2
    C 100.1.1.3 is directly connected, Loopback3
    R3#
    now why R2 rcv 10.128.0.0/9 without any summarization?
    does anyone know the reason please??????????????????????????????????????????????

  • alexpfalexpf ✭✭

    The diagram is not loading for me.

Sign In or Register to comment.