PVLAN with vDS and Catalyst switch

alyusufalyusuf ✭✭

we are implementing PVALN in the following infrastructure:

Cisco UCS -> Cisco FI -> Catalyst 3750 IOS v12.2 and we are using vDS

the promiscuous port attached to the Catalyst switch, another promiscuous VM (i.e. interface) attached to vDS, and all isolated interfaces attached to vDS

all communication works fine as follow:
primary vlan to primary vlan are working fine
primary vlan to isolated vlan are working fine however isolated VM has to initiate the first communication after that two way communication works fine until mac address is aging out.

below is the configuration of the catalyst switch for your reference:

vlan 849
private-vlan primary
private-vlan association 850
!
vlan 850
private-vlan isolated

//Attached to the server
interface GigabitEthernet1/0/11
switchport private-vlan mapping 849 850
switchport mode private-vlan promiscuous
spanning-tree portfast

interface GigabitEthernet1/0/13
switchport private-vlan mapping 849 850
switchport mode private-vlan promiscuous
spanning-tree portfast

//attached to the FI
interface GigabitEthernet1/0/25
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 849,850
switchport mode trunk

interface GigabitEthernet1/0/26
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 849,850
switchport mode trunk
end

FI configuration
interface Ethernet1/24
description U: Uplink
pinning border
switchport mode trunk
switchport trunk allowed vlan 1,100-105,151,155-158,160-169,171-174,178,181,187,191,200,210,230,840,842-847,849-850
speed 1000
udld disable
no shutdown

Regards
Husain Al Yusuf

Sign In or Register to comment.