Multicast over MPLS VPN-PIM neighbors keep bouncing

When doing Vol I - Multicast over MPLS VPN lab, the PIM neighbor b/w R3 & R6 keep bouncing up & down. Here is the output

Rack1R3#
*Mar  1 02:28:31.027: %PIM-5-NBRCHG: VRF AS100: neighbor 150.1.6.6 DOWN on interface Tunnel0 DR
*Mar  1 02:28:31.031: %PIM-5-DRCHG: VRF AS100: DR change from neighbor 150.1.6.6 to 150.1.3.3 on interface Tunnel0
Rack1R3#
*Mar  1 02:30:42.859: %PIM-5-NBRCHG: VRF AS100: neighbor 150.1.6.6 UP on interface Tunnel0
*Mar  1 02:30:42.903: %PIM-5-DRCHG: VRF AS100: DR change from neighbor 150.1.3.3 to 150.1.6.6 on interface Tunnel0
Rack1R3#
*Mar  1 02:35:26.095: %PIM-5-NBRCHG: VRF AS100: neighbor 150.1.6.6 DOWN on interface Tunnel0 DR
*Mar  1 02:35:26.099: %PIM-5-DRCHG: VRF AS100: DR change from neighbor 150.1.6.6 to 150.1.3.3 on interface Tunnel0
Rack1R3#
*Mar  1 02:37:37.603: %PIM-5-NBRCHG: VRF AS100: neighbor 150.1.6.6 UP on interface Tunnel0
*Mar  1 02:37:37.675: %PIM-5-DRCHG: VRF AS100: DR change from neighbor 150.1.3.3 to 150.1.6.6 on interface Tunnel0

Here the debug information

Rack1R3#
*Mar  1 04:08:41.654: PIM(0): Insert (150.1.6.6,232.0.0.1) join in nbr 150.1.13.1's queue
*Mar  1 04:08:41.658: PIM(0): Building Join/Prune packet for nbr 150.1.13.1
*Mar  1 04:08:41.662: PIM(0): Adding v2 (150.1.6.6/32, 232.0.0.1), S-bit Join
*Mar  1 04:08:41.666: PIM(0): Send v2 join/prune to 150.1.13.1 (Serial1/2)
Rack1R3#
*Mar  1 04:08:46.358: PIM(1): Building Periodic (*,G) Join / (S,G,RP-bit) Prune message for 224.0.1.40
*Mar  1 04:08:46.362: PIM(1): Insert (*,224.0.1.40) join in nbr 10.1.37.7's queue
*Mar  1 04:08:46.366: PIM(1): Building Join/Prune packet for nbr 10.1.37.7
*Mar  1 04:08:46.370: PIM(1): Adding v2 (10.1.37.7/32, 224.0.1.40), WC-bit, RPT-bit, S-bit Join
*Mar  1 04:08:46.374: PIM(1): Send v2 join/prune to 10.1.37.7 (Ethernet0/0)
Rack1R3#
*Mar  1 04:09:13.230: PIM(1): Received v2 Join/Prune on Tunnel0 from 150.1.6.6, to us
*Mar  1 04:09:13.234: PIM(1): Join-list: (*, 224.0.1.40), RPT-bit set, WC-bit set, S-bit set
*Mar  1 04:09:13.238: PIM(1): Update Tunnel0/150.1.6.6 to (*, 224.0.1.40), Forward state, by PIM *G Join
*Mar  1 04:09:14.130: PIM(0): Received v2 Join/Prune on Serial1/2 from 150.1.13.1, to us
*Mar  1 04:09:14.134: PIM(0): Prune-list: (150.1.3.3/32, 232.0.0.1)
*Mar  1 04:09:14.138: PIM(0): Prune Serial1/2/224.0.0.2 from (150.1.3.3/32, 232.0.0.1) - deleted

And here is my brief configuration on R3 & R6

Rack1R3#sho run
Building configuration...

Current configuration : 2335 bytes
..................
!
ip vrf AS100
 rd 100:1
 route-target export 100:1
 route-target import 100:1
 mdt default 232.0.0.1
!
ip multicast-routing
ip multicast-routing vrf AS100
!
interface Loopback0
 ip address 150.1.3.3 255.255.255.255
 ip router isis
 ip pim sparse-mode
!
interface Ethernet0/0
 ip vrf forwarding AS100
 ip address 10.1.37.3 255.255.255.0
 ip pim sparse-mode
 full-duplex
!
interface Serial1/2
 ip address 150.1.13.3 255.255.255.0
 ip router isis
 ip pim sparse-mode
 mpls ip
 serial restart-delay 0

!
router isis
 net 00.0000.0000.0003.00
 is-type level-2-only
!
router rip
 version 2
 no auto-summary
 !
 address-family ipv4 vrf AS100
  redistribute bgp 100 metric 1
  network 10.0.0.0
  no auto-summary
 exit-address-family
!
router bgp 100
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 150.1.6.6 remote-as 100
 neighbor 150.1.6.6 update-source Loopback0
 !
 address-family vpnv4
  neighbor 150.1.6.6 activate
  neighbor 150.1.6.6 send-community both
 exit-address-family
 !
 address-family ipv4 vrf AS100
  redistribute rip
  no synchronization
 exit-address-family
!
no ip http server
no ip http secure-server
!
!
ip pim ssm range SSM_RANGE
ip pim vrf AS100 rp-address 10.1.37.7
!
!
ip access-list standard SSM_RANGE
 permit 232.0.0.0 0.255.255.255

------------------------------------------------------------

Rack1R6#sho run
Building configuration...

Current configuration : 2335 bytes
...........
!
ip vrf AS100
 rd 100:1
 route-target export 100:1
 route-target import 100:1
 mdt default 232.0.0.1
!
ip multicast-routing
ip multicast-routing vrf AS100
!
interface Loopback0
 ip address 150.1.6.6 255.255.255.255
 ip router isis
 ip pim sparse-mode
!
interface Ethernet0/0
 ip address 150.1.56.6 255.255.255.0
 ip router isis
 ip pim sparse-mode
 full-duplex
 mpls ip
!
interface Ethernet0/1
 ip vrf forwarding AS100
 ip address 10.1.68.6 255.255.255.0
 ip pim sparse-mode
 full-duplex
!
router isis
 net 00.0000.0000.0006.00
 is-type level-2-only
!
router rip
 version 2
 no auto-summary
 !
 address-family ipv4 vrf AS100
  redistribute bgp 100 metric 1
  network 10.0.0.0
  no auto-summary
 exit-address-family
!
router bgp 100
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 150.1.3.3 remote-as 100
 neighbor 150.1.3.3 update-source Loopback0
 !
 address-family vpnv4
  neighbor 150.1.3.3 activate
  neighbor 150.1.3.3 send-community both
 exit-address-family
 !
 address-family ipv4 vrf AS100
  redistribute rip
  no synchronization
 exit-address-family
!
no ip http server
no ip http secure-server
!
!
ip pim ssm range SSM_RANGE
ip pim vrf AS100 rp-address 10.1.37.7
!
!
ip access-list standard SSM_RANGE
 permit 232.0.0.0 0.255.255.255

Can anyone help me to clear out this problem? Thank you.


 

Comments












  • Please remove your ssm command from global both sides. I am
    assuming that once that command is enabled you need to force your interfaces to
    IGMP V3.

     

    Hope that helps

     

    James

     

    From: [email protected]
    [mailto:[email protected]] On Behalf Of rin1008

    Sent: Thursday, October 09, 2008 9:21 AM

    To: [email protected]

    Subject: [CCIE SP] Multicast over MPLS VPN-PIM neighbors keep bouncing

     

    When doing Vol I - Multicast over MPLS VPN lab, the PIM neighbor b/w R3
    & R6 keep bouncing up & down. Here is the output

    Rack1R3#

    *Mar  1 02:28:31.027: %PIM-5-NBRCHG: VRF AS100: neighbor 150.1.6.6 DOWN on
    interface Tunnel0 DR

    *Mar  1 02:28:31.031: %PIM-5-DRCHG: VRF AS100: DR change from neighbor
    150.1.6.6 to 150.1.3.3 on interface Tunnel0

    Rack1R3#

    *Mar  1 02:30:42.859: %PIM-5-NBRCHG: VRF AS100: neighbor 150.1.6.6 UP on
    interface Tunnel0

    *Mar  1 02:30:42.903: %PIM-5-DRCHG: VRF AS100: DR change from neighbor
    150.1.3.3 to 150.1.6.6 on interface Tunnel0

    Rack1R3#

    *Mar  1 02:35:26.095: %PIM-5-NBRCHG: VRF AS100: neighbor 150.1.6.6 DOWN on
    interface Tunnel0 DR

    *Mar  1 02:35:26.099: %PIM-5-DRCHG: VRF AS100: DR change from neighbor
    150.1.6.6 to 150.1.3.3 on interface Tunnel0

    Rack1R3#

    *Mar  1 02:37:37.603: %PIM-5-NBRCHG: VRF AS100: neighbor 150.1.6.6 UP on
    interface Tunnel0

    *Mar  1 02:37:37.675: %PIM-5-DRCHG: VRF AS100: DR change from neighbor
    150.1.3.3 to 150.1.6.6 on interface Tunnel0

    Here the debug information

    Rack1R3#

    *Mar  1 04:08:41.654: PIM(0): Insert (150.1.6.6,232.0.0.1) join in nbr
    150.1.13.1's queue

    *Mar  1 04:08:41.658: PIM(0): Building Join/Prune packet for nbr
    150.1.13.1

    *Mar  1 04:08:41.662: PIM(0): Adding v2 (150.1.6.6/32, 232.0.0.1), S-bit
    Join

    *Mar  1 04:08:41.666: PIM(0): Send v2 join/prune to 150.1.13.1 (Serial1/2)

    Rack1R3#

    *Mar  1 04:08:46.358: PIM(1): Building Periodic (*,G) Join / (S,G,RP-bit)
    Prune message for 224.0.1.40

    *Mar  1 04:08:46.362: PIM(1): Insert (*,224.0.1.40) join in nbr
    10.1.37.7's queue

    *Mar  1 04:08:46.366: PIM(1): Building Join/Prune packet for nbr 10.1.37.7

    *Mar  1 04:08:46.370: PIM(1): Adding v2 (10.1.37.7/32, 224.0.1.40),
    WC-bit, RPT-bit, S-bit Join

    *Mar  1 04:08:46.374: PIM(1): Send v2 join/prune to 10.1.37.7
    (Ethernet0/0)

    Rack1R3#

    *Mar  1 04:09:13.230: PIM(1): Received v2 Join/Prune on Tunnel0 from
    150.1.6.6, to us

    *Mar  1 04:09:13.234: PIM(1): Join-list: (*, 224.0.1.40), RPT-bit set,
    WC-bit set, S-bit set

    *Mar  1 04:09:13.238: PIM(1): Update Tunnel0/150.1.6.6 to (*, 224.0.1.40),
    Forward state, by PIM *G Join

    *Mar  1 04:09:14.130: PIM(0): Received v2 Join/Prune on Serial1/2 from
    150.1.13.1, to us

    *Mar  1 04:09:14.134: PIM(0): Prune-list: (150.1.3.3/32, 232.0.0.1)

    *Mar  1 04:09:14.138: PIM(0): Prune Serial1/2/224.0.0.2 from
    (150.1.3.3/32, 232.0.0.1) - deleted

    And here is my brief configuration on R3 & R6

    Rack1R3#sho run

    Building configuration...



    Current configuration : 2335 bytes

    ..................

    !

    ip vrf AS100

     rd 100:1

     route-target export 100:1

     route-target import 100:1

     mdt default 232.0.0.1

    !

    ip multicast-routing

    ip multicast-routing vrf AS100

    !

    interface Loopback0

     ip address 150.1.3.3 255.255.255.255

     ip router isis

     ip pim sparse-mode

    !

    interface Ethernet0/0

     ip vrf forwarding AS100

     ip address 10.1.37.3 255.255.255.0

     ip pim sparse-mode

     full-duplex

    !

    interface Serial1/2

     ip address 150.1.13.3 255.255.255.0

     ip router isis

     ip pim sparse-mode

     mpls ip

     serial restart-delay 0



    !

    router isis

     net 00.0000.0000.0003.00

     is-type level-2-only

    !

    router rip

     version 2

     no auto-summary

     !

     address-family ipv4 vrf AS100

      redistribute bgp 100 metric 1

      network 10.0.0.0

      no auto-summary

     exit-address-family

    !

    router bgp 100

     no bgp default ipv4-unicast

     bgp log-neighbor-changes

     neighbor 150.1.6.6 remote-as 100

     neighbor 150.1.6.6 update-source Loopback0

     !

     address-family vpnv4

      neighbor 150.1.6.6 activate

      neighbor 150.1.6.6 send-community both

     exit-address-family

     !

     address-family ipv4 vrf AS100

      redistribute rip

      no synchronization

     exit-address-family

    !

    no ip http server

    no ip http secure-server

    !

    !

    ip pim ssm range SSM_RANGE

    ip pim vrf AS100 rp-address 10.1.37.7

    !

    !

    ip access-list standard SSM_RANGE

     permit 232.0.0.0 0.255.255.255

    ------------------------------------------------------------

    Rack1R6#sho run

    Building configuration...



    Current configuration : 2335 bytes

    ...........

    !

    ip vrf AS100

     rd 100:1

     route-target export 100:1

     route-target import 100:1

     mdt default 232.0.0.1

    !

    ip multicast-routing

    ip multicast-routing vrf AS100

    !

    interface Loopback0

     ip address 150.1.6.6 255.255.255.255

     ip router isis

     ip pim sparse-mode

    !

    interface Ethernet0/0

     ip address 150.1.56.6 255.255.255.0

     ip router isis

     ip pim sparse-mode

     full-duplex

     mpls ip

    !

    interface Ethernet0/1

     ip vrf forwarding AS100

     ip address 10.1.68.6 255.255.255.0

     ip pim sparse-mode

     full-duplex

    !

    router isis

     net 00.0000.0000.0006.00

     is-type level-2-only

    !

    router rip

     version 2

     no auto-summary

     !

     address-family ipv4 vrf AS100

      redistribute bgp 100 metric 1

      network 10.0.0.0

      no auto-summary

     exit-address-family

    !

    router bgp 100

     no bgp default ipv4-unicast

     bgp log-neighbor-changes

     neighbor 150.1.3.3 remote-as 100

     neighbor 150.1.3.3 update-source Loopback0

     !

     address-family vpnv4

      neighbor 150.1.3.3 activate

      neighbor 150.1.3.3 send-community both

     exit-address-family

     !

     address-family ipv4 vrf AS100

      redistribute rip

      no synchronization

     exit-address-family

    !

    no ip http server

    no ip http secure-server

    !

    !

    ip pim ssm range SSM_RANGE

    ip pim vrf AS100 rp-address 10.1.37.7

    !

    !

    ip access-list standard SSM_RANGE

     permit 232.0.0.0 0.255.255.255

    Can anyone help me to clear out this problem? Thank you.

     







    Internetwork Expert - The Industry Leader in CCIE Preparation

    http://www.internetworkexpert.com



    Subscription information may be found at:

    http://www.ieoc.com/forums/ForumSubscriptions.aspx





  • Thanks for your reply. Actually i'm trying to use PIM-SSM in the Core here. The Cisco DOC says IGMP v3 is required when using SSM, but it's just only used between Router and Host only. In this case I consider R3 & R6 are two routers so IGMP has no meaning.

    Please correct me if i'm wrong.

  • Are you using dynamips?  I've had some issues with certain IOS images.  Upgrade IOS if you can and try that.

    I did this lab just the other night.  Here are my configs for R3 and R6.  I had to do 'ip pim ssm default' on all the transit routers as well - even though Cisco's docs indicated otherwise.

     

    R3 Config:


    version 12.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname R3
    !
    boot-start-marker
    boot-end-marker
    !
    enable password cisco
    !
    memory-size iomem 5
    no aaa new-model
    ip subnet-zero
    !
    !
    no ip domain lookup
    !
    !
    ip vrf SW1-SW2
     rd 100:1
     route-target export 100:1
     route-target import 100:1
     mdt default 232.0.0.1
    !
    ip multicast-routing
    ip multicast-routing vrf SW1-SW2
    ip cef
    ip ips po max-events 100
    mpls label protocol ldp
    no ftp-server write-enable
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    interface Loopback0
     ip address 150.1.3.3 255.255.255.255
     ip router isis
     ip pim sparse-mode
    !
    interface Ethernet0/0
     ip vrf forwarding SW1-SW2
     ip address 10.1.37.3 255.255.255.0
     ip pim sparse-mode
     full-duplex
    !
    interface Ethernet0/1
     ip address 192.10.1.3 255.255.255.0
     full-duplex
    !
    interface Ethernet0/2
     no ip address
     shutdown
     half-duplex
    !
    interface Ethernet0/3
     no ip address
     shutdown
     half-duplex
    !
    interface Serial1/0
     no ip address
     shutdown
     serial restart-delay 0
    !
    interface Serial1/1
     no ip address
     shutdown
     serial restart-delay 0
    !
    interface Serial1/2
     ip address 150.1.13.3 255.255.255.0
     ip router isis
     ip pim sparse-mode
     tag-switching ip
     serial restart-delay 0
    !
    interface Serial1/3
     no ip address
     shutdown
     serial restart-delay 0
    !
    router isis
     net 00.0000.0000.0000.0300
     is-type level-2-only
    !
    router rip
     !
     address-family ipv4 vrf SW1-SW2
     redistribute bgp 1 metric 1
     network 10.0.0.0
     no auto-summary
     version 2
     exit-address-family
    !
    router bgp 1
     no bgp default ipv4-unicast
     bgp log-neighbor-changes
     neighbor 150.1.6.6 remote-as 1
     neighbor 150.1.6.6 update-source Loopback0
     !
     address-family vpnv4
     neighbor 150.1.6.6 activate
     neighbor 150.1.6.6 send-community extended
     exit-address-family
     !
     address-family ipv4 vrf SW1-SW2
     redistribute rip
     no auto-summary
     no synchronization
     exit-address-family
    !
    no ip http server
    no ip http secure-server
    ip classless
    !
    ip pim ssm default
    ip pim vrf SW1-SW2 rp-address 10.1.7.7
    !
    !
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    !
    line con 0
     exec-timeout 0 0
     privilege level 15
     logging synchronous
    line aux 0
     exec-timeout 0 0
     privilege level 15
    line vty 0 4
     password cisco
     login
    !
    !
    end

     

    R6 Config:

    version 12.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname R6
    !
    boot-start-marker
    boot-end-marker
    !
    enable password cisco
    !
    memory-size iomem 5
    no aaa new-model
    ip subnet-zero
    !
    !
    no ip domain lookup
    !
    !
    ip vrf SW1-SW2
     rd 100:1
     route-target export 100:1
     route-target import 100:1
     mdt default 232.0.0.1
    !
    ip multicast-routing
    ip multicast-routing vrf SW1-SW2
    ip cef
    ip ips po max-events 100
    mpls label protocol ldp
    no ftp-server write-enable
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    interface Loopback0
     ip address 150.1.6.6 255.255.255.255
     ip router isis
     ip pim sparse-mode
    !
    interface Ethernet0/0
     ip address 150.1.56.6 255.255.255.0
     ip router isis
     ip pim sparse-mode
     no ip mroute-cache
     full-duplex
     tag-switching ip
    !
    interface Ethernet0/1
     ip vrf forwarding SW1-SW2
     ip address 10.1.68.6 255.255.255.0
     ip pim sparse-mode
     full-duplex
    !
    interface Ethernet0/2
     no ip address
     shutdown
     half-duplex
    !
    interface Ethernet0/3
     no ip address
     shutdown
     half-duplex
    !
    interface Serial1/0
     no ip address
     encapsulation frame-relay
     serial restart-delay 0
    !
    interface Serial1/0.1 point-to-point
     ip address 54.1.1.6 255.255.255.0
     frame-relay interface-dlci 101  
    !
    interface Serial1/1
     no ip address
     shutdown
     serial restart-delay 0
    !
    interface Serial1/2
     no ip address
     shutdown
     serial restart-delay 0
    !
    interface Serial1/3
     no ip address
     shutdown
     serial restart-delay 0
    !
    router isis
     net 00.0000.0000.0000.0600
     is-type level-2-only
    !
    router rip
     !
     address-family ipv4 vrf SW1-SW2
     redistribute bgp 1 metric 1
     network 10.0.0.0
     no auto-summary
     version 2
     exit-address-family
    !
    router bgp 1
     no bgp default ipv4-unicast
     bgp log-neighbor-changes
     neighbor 150.1.3.3 remote-as 1
     neighbor 150.1.3.3 update-source Loopback0
     !
     address-family vpnv4
     neighbor 150.1.3.3 activate
     neighbor 150.1.3.3 send-community extended
     exit-address-family
     !
     address-family ipv4 vrf SW1-SW2
     redistribute rip
     no auto-summary
     no synchronization
     exit-address-family
    !
    no ip http server
    no ip http secure-server
    ip classless
    !
    ip pim ssm default
    ip pim vrf SW1-SW2 rp-address 10.1.7.7
    !
    !
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    !
    line con 0
     exec-timeout 0 0
     privilege level 15
     logging synchronous
    line aux 0
     exec-timeout 0 0
     privilege level 15
    line vty 0 4
     password cisco
     login
    !
    !
    end

     

     

     

     

     

     

  • hi

     

    Actually you can enable ssm in the core for vrf specific you donot need to run IGMPv3. There is no relation with core and customers. Becasue for cutomers you are using auto rp or BSR and for COre you are using SSM which is actually require for your default adn data mdt. SO you can use SSM without IGMPv3.

     

     

    regards

    shivlu

  • Yes, I agree with shivlu that IGMPv3 is not necessary inside the Core.

    The problem seems to be solved after I follow awilkins advice by enabling SSM on other transit routers. The tunnel is not bouncing anymore. However, I still wonder if the Tunnel 0 is related to SSM on transit router so it causes the problem.

    Thank you.

Sign In or Register to comment.