Layer 2 Dynamic Switchports

Hi,


 [ sw1 ](gig0/33)----(gig0/33)[ sw2 ]
(gig0/37)
    |
    |
    |
    |
(gig0/37)
 [ sw4 ]


On sw1 two ports I set:

"switchport mode dynamic desireble"


On sw2 (gig0/33) and sw4 (gig0/37) I set:

"switchport mode dynamic auto"


The effect of above settings is:


SW1#sh int gig0/37 switchport
Name: Gi0/37
Switchport: Enabled
Administrative Mode: dynamic desirable
Operational Mode: trunk
Administrative Trunking Encapsulation: negotiate
Operational Trunking Encapsulation: isl
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk associations: none
Administrative private-vlan trunk mappings: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL

Protected: false
Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Appliance trust: none
SW1#



and


SW1#sh int gig0/33 switchport
Name: Gi0/33
Switchport: Enabled
Administrative Mode: dynamic desirable
Operational Mode: static access
Administrative Trunking Encapsulation: negotiate
Operational Trunking Encapsulation: native
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk associations: none
Administrative private-vlan trunk mappings: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL

Protected: false
Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Appliance trust: none
SW1#


What settings (defautl?) can influence on operational mode 'static access' vs 'trunk'?

Thanks

Comments

  • JoeMJoeM ✭✭✭

     

    [ sw1 ](gig0/33)----(gig0/33)[ sw2 ]
    (gig0/37)
        |
        |
        |
        |
    (gig0/37)
     [ sw4 ]


    On sw1 two ports I set:

    "switchport mode dynamic desireble"


    On sw2 (gig0/33) and sw4 (gig0/37) I set:

    "switchport mode dynamic auto"

    SW1#sh int gig0/33 switchport
    Name: Gi0/33
    Switchport: Enabled
    Administrative Mode: dynamic desirable  <--this side good
    Operational Mode: static access  <--other side?

     Hi Hubert,

    I think you may want to double-check your settings on SW2 gi0/33.  

    My guess is that it is set to switchport mode access .

  • DTP only works if the VTP domain names match

    So i assume they match between SW1 and SW4 and differ between SW1 and SW2

    If DTP fails it falls back to "access" mode

  • JoeMJoeM ✭✭✭

    I agree with Johannes.   Nice call.  This would be a perfect exam question.

     

  • JoeMJoeM ✭✭✭

    But not sure about what Hubert is doing...because in my lab...there is a clear log error on both sides. If he does not see this, then I go back to my original answer. ;-)

     %DTP-5-DOMAINMISMATCH: Unable to perform trunk negotiation on port Gi0/0 because of VTP domain mismatch.

  • Hi,

     

    yes, VTP domain is the problem

     

    Thanks

  • JoeMJoeM ✭✭✭

    Thanks Hubert for updating us.   Nice little puzzle. 

Sign In or Register to comment.