Issues with EIGRP query scooping

Hi,

 

Goals: reduce eigrp query domain by using summarisation and feasible successors.

 

Topology:

https://s32.postimg.org/xoala47th/eigrp_fs.png

 

Routers have FS: R1, R2, R3, R4, R6 to R5's loopback0 and to 0.0.0.0.

R7 does not have FS and I could not make it. When I tweaked delays, R7 had FS but at the same time R6 lost it's FS.

Why is that?

 

R1:

P 0.0.0.0/0, 1 successors, FD is 8519680

        via 155.1.146.4 (8519680/7864320), GigabitEthernet1.146, serno 133

        via 155.1.0.5 (11141120/7208960), Tunnel0

R2:

P 0.0.0.0/0, 1 successors, FD is 9830400

        via 155.1.23.3 (9830400/9175040), GigabitEthernet1.23, serno 348

        via 155.1.0.5 (11141120/7208960), Tunnel0

R3:

P 0.0.0.0/0, 1 successors, FD is 9175040

        via 155.1.13.1 (9175040/8519680), GigabitEthernet1.13, serno 469

        via 155.1.0.5 (11141120/7208960), Tunnel0

R4:

P 0.0.0.0/0, 1 successors, FD is 7864320

        via 155.1.45.5 (7864320/7208960), GigabitEthernet1.45

        via 155.1.0.5 (8519680/7208960), Tunnel0

R6:

P 0.0.0.0/0, 1 successors, FD is 10485760

        via 155.1.146.4 (10485760/7864320), GigabitEthernet1.146

        via 155.1.67.7 (11141120/9830400), GigabitEthernet1.67, serno 964

R7:

P 0.0.0.0/0, 1 successors, FD is 9830400

        via 155.1.37.3 (9830400/9175040), GigabitEthernet1.37, serno 825

 

If I shut the link down between R4 and R5, I will receive the following query debug messages or R4:

 

The first part of the query debug is clear for me. R5 sends a query message for the lost link between R4-R5.

 

EIGRP: Received QUERY on Tu0 - paklen 44 nbr 155.1.0.5

  AS 1, Flags 0x0:(NULL), Seq 677/0 interfaceQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/0

  {type = 602, length = 44}

  {vector = {afi = 1, tid = 0}

            {routerid = 150.1.5.5

            {offset = 0, priority = 0, reliability = 220, load = 0,

             mtu = {0:[00, 00, 00]), hopcount = 255, 

             delay = 281474976710655, bw = 4294967295,

             reserved = 00, opaque_flags = 04}

            {nh:00000000}

            {189B012D}

  } route: 155.1.45.0/24

EIGRP METRIC: Non OTP LISP metric calculation

 

 

This one shows incoming query from R1, but the router ID is R5's router ID. Moreover, R5's loopback and the default route is queried.

Why is that?

 

EIGRP: Received QUERY on Gi1.146 - paklen 87 nbr 155.1.146.1

  AS 1, Flags 0x0:(NULL), Seq 522/0 interfaceQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/0

  {type = 602, length = 42}

  {vector = {afi = 1, tid = 0}

            {routerid = 150.1.5.5

            {offset = 0, priority = 0, reliability = 255, load = 1,

             mtu = {1400:[00, 05, 78]), hopcount = 2, 

             delay = 281474976710655, bw = 100000,

             reserved = 00, opaque_flags = 06}

            {nh:00000000}

            {0000}

  }

  {type = 602, length = 45}

  {vector = {afi = 1, tid = 0}

            {routerid = 150.1.5.5

            {offset = 0, priority = 0, reliability = 255, load = 1,

             mtu = {1400:[00, 05, 78]), hopcount = 2, 

             delay = 281474976710655, bw = 1000000,

             reserved = 00, opaque_flags = 04}

            {nh:00000000}

            {20960105 05}

  } route: 0.0.0.0/0 route: 150.1.5.5/32 route: 0.0.0.0/0 route: 150.1.5.5/32

EIGRP METRIC: Non OTP LISP metric calculation route: 0.0.0.0/0 route: 150.1.5.5/32

 

Thanks for the help!

 

Br,

István

Sign In or Register to comment.