Help with my Cisco 1921 DSL config

all i am currently debating switching from cable internet to century-link DSL, i have a cisco 1921 and EHWIC-VA-DSL.

 

here is my current config, does anyone with experience in century-link or DSL know if this works or if there is something missing from my config. i am going to test this weekend before i jump the gun and purchase DSL

 

hostname Home_LAN

!

boot-start-marker

boot-end-marker

!

aaa new-model

!

ip dhcp excluded-address 192.168.0.1

!

ip dhcp pool LAN

import all

network 192.168.0.0 255.255.255.0

default-router 192.168.0.1 

dns-server 192.168.0.1 

!

ip domain name crankshaws.com

ip name-server 205.171.3.66

ip name-server 205.171.202.166

ip cef

no ipv6 cef

!

license udi pid CISCO1921/K9 sn FJC1934E0J0

!

username admin privilege 15 secret 5 $1$ql9b$RxCn2WwhtA7KzLvP0GJUS1

username cisco privilege 15 secret 5 $1$9IP1$58H8Iqjnwz2g8YNGYRQPx1

username jrc privilege 15 secret 5 $1$E0CD$4Cwa8UCCOrlz4uBHNraBc0

username joe privilege 15 secret 5 $1$iRsz$XZNEFhnL9gyx6eIW39CAW0

!

controller VDSL 0/1/0

!

interface loopback0

ip address 1.1.1.1 255.255.255.255

!

interface Gig0/0

no ip address

ip nat inside

no ip route-cache cef

duplex auto

speed auto

cdp enable

!

interface Gig0/0.1

encapsulation dot1q 1

ip address 192.168.0.1 255.255.255.0

!

interface Gig0/0.725

encapsulation dot1q 725

ip address 10.0.0.1 255.255.255.0

!

interface ATM0/1/0

no ip address

no atm ilmi-keepalive

no ip redirects

no ip unreachables

no ip proxy-arp

bundle-enable

ip flow ingress

ip nat outside

ip nat enable

ip virtual-reassembly

logging event atm pvc state

logging event subif-link-status

load-interval 30

no snmp trap link-status

dsl operating-mode auto

hold-queue 224 in

pvc 8/35

  encapsulation aal5snap

  pppoe-client dial-pool-number 1

!

interface Dialer0

ip address negotiated

ip mtu 1492

ip nat outside

encapsulation ppp

ip tcp adjust-mss 1452

dialer pool 1

dialer-group 1

ppp chap refuse

ppp pap sent-username password 0

!

ip route 0.0.0.0 0.0.0.0 Dialer0

no ip http server

!

ip nat inside source list 1 interface Dialer0 overload

!

banner login ^CC

*************************************************************

*                                                           *

* THIS IS A PRIVATE ROUTER.  ANY UNAUTHORIZED ACCESS IS     *

* PROHIBITED.  ANY UNAUTHORIZED USER WILL BE SUBJECT TO     *

* CRIMINAL PROSECUTION UNDER THE FULL EXTENT OF THE LAW.    *

*                                                           *

*************************************************************^C

!

line con 0

exec-timeout 0 0

privilege level 15

logging synchronous

line aux 0

line 2

no activation-character

no exec

transport preferred none

transport output pad telnet rlogin lapb-ta mop udptn v120 ssh

stopbits 1

line vty 0 4

exec-timeout 0 0

privilege level 15

password 7 094F471A1A0A

login local

transport input all

Comments

  • I see you've posted this in both INE's forum and Cisco's Learning Network.

    Its probably not the best location to ask for help with such a thing, as these forums are dedicated to persons working towards their CCIE Service Provider certification.

    I have replied to your post with a few suggestions on Cisco's Learning Network. However I would recommend in the future requesting this assistance in a more accurate location.

Sign In or Register to comment.