Full Scale Lab 3 - EIGRP Site Routing. No FS for load balancing.

Hi,

I have the required details and FC in the EIGRP topology table with the modification of the metric to suit.  Note I'm doing this in GNS3 so the interswitch L3 link is g0/0.12.

I can't work out why the routing table only has a single route to 150.1.21.21/32 but doesn't for 150.1.19.19/32.

Details below.

SW2#sh ip ei top
EIGRP-IPv4 VR(INE) Topology Table for AS(5000)/ID(150.1.22.22)
 <snip>

P 150.1.21.21/32, 1 successors, FD is 2048000
        via 119.3.223.3 (2048000/1392640), GigabitEthernet0/0.322
        via 119.3.12.1 (8519680/81920), GigabitEthernet0/0.12
P 150.1.19.19/32, 2 successors, FD is 1392640
        via 119.3.12.1 (4014080/737280), GigabitEthernet0/0.12
        via 119.3.223.3 (1392640/737280), GigabitEthernet0/0.322

SW2#sh ip route
 <snip>

D        150.1.19.19
           [90/10880] via 119.3.223.3, 00:08:21, GigabitEthernet0/0.322
           [90/31360] via 119.3.12.1, 00:08:21, GigabitEthernet0/0.12
D        150.1.21.21
           [90/16000] via 119.3.223.3, 00:08:21, GigabitEthernet0/0.322
C        150.1.22.22 is directly connected, Loopback0

SW2#sh run | s route-map

route-map EIGRP_R3 permit 10
 match ip address prefix-list L21
 set metric 3358720 +13 255 1 1500
route-map EIGRP_R3 permit 20

SW2#sh run | s r eig
router eigrp INE
 !
 address-family ipv4 unicast autonomous-system 5000
  !
  af-interface default
   authentication mode hmac-sha-256 !EIGRP_!
  exit-af-interface
  !
  topology base
   variance 4
   distribute-list route-map EIGRP_R3 in GigabitEthernet0/0.12
  exit-af-topology
  network 0.0.0.0
  metric weights 0 0 0 1 0 0 0
  eigrp router-id 150.1.22.22
 exit-address-family

 

Thanks.

Comments

  • Split horizon rule on R3

  • Thanks man.  Can you elaborate your thoughts for me as I can't see it please?

    I see the route being advertised by R3 and SW1 to SW2 so there's no issue with them having a route so how does R3 signal this route can't be used because of a split-horizon rule?

  • R3 should have ECMP towards 150.1.21.21 and is learning the route from S2 and R19 so it wont advertise it back to S2. Try disabling split horizon on R3's link to S2 and see if now you see the route coming from R3.

  • Hi, no. R3 only has the route via R19 and is advertising it out to SW2.

    SW2 meets the FC for the route but is not shown as a FS or appears in the RIB. Upon checking the ''sh ei add ipv4 events | I .21.21 " I see the route is marked as metric (infinity).

    354 21:35:40.267 Metric set: 150.1.21.21/32 metric(Infinity)

    Still not sure why and how to solve this. Any further ideas?

  • Just checked this on rack rentals with the same topology and I get the same result. This means either my configuration is wrong which is unlikely as it's not complicated or complex or I'm missing something fundamental about how named mode EIGRP works.

    Has anyone else gone through Full Scale Lab 3's EIGRP section and looked at this?

  • Solved this one myself. A very silly mistake.

    The route to be LBed with needs to meet the condition of it's final metric on the router has to be the same or less than the successor's route x the variance:

    Route Metric < FD * Variance

    If it is over by a single unit it will fail.

    Solutions to this are:

    1 - Up your variance to ensure the Route Metric meets the condition
    2 - Calculate the value exactly which may be difficult especially on-the-fly

Sign In or Register to comment.