Cannot connect Jabber clients to Presence server

Hi;


I'm a newbie at Collaboration and to learn basics have setup a small lab including CUCM 11, Presence 11 and two Cisco 7821 Phones. I have configured CUCM and Presence and setup a SIP trunk between them according to the documents. I tried to setup Jabber client on Windows but was unsuccessful. first of all, I have created some local users on CUCM and have some LDAP users that have been synchronized with a test AD in which both of the Presence and CUCM are members of that domain. I have configured one of CUCM local users for Jabber Client and finished configuring steps to configure Jabber Clients according to the documents. 

my first question is the format of the username that need to be used with Jabber. the Jabber client says that we must use "[email protected]" format, but I saw the videos on the Internet using just normal username and password. regarding to the fact that I've configured one of CUCM local users for the Jabber, I entered it in the form of "username" but Jabber said that the format need to be like "[email protected]".

the second issue is that even after writing the username in that format, the Jabber said that "Cannot Communicate With the Server". I can ping both of the CUCM and Presence Server both using their ip addresses and hostnames through my PC on which the Jabber is installed. also I wrote the serves IP address on the Jabber client while trying to connect the Jabber instead of their hostnames. is there any requirement regarding being member of a unique domain?

I tried Jabber for iPad to connect to the Presence but was unsuccessful too. is there any knows issue or tricks regarding this? otherwise, I can briefly explain the steps that I went through them to configure the Presence and CUCM for Jabber clients. 


regards;

Comments

  • Hi Timaz,

     

    Setting up IMP can be quite tricky the first times! ^^

    First of all, CUCM users (whether they are local or LDAP sync'ed) are part of a domain that you must have provided when installing the IMP node. In CUCM, system > server, you added the IMP mode before launching the installation. In this same section, CUCM asked for a domain. According to what you entered (e.g. cisco.com), your IMP users have now the following format: [email protected]

    You need to enter this information the first time you connect. Once connected, Jabber client remembers your login and just prompts you for the password the next times.

    Regarding the message "Cannot communicate with server", it could be for several reasons. Probably DNS? Did you setup the SRV record so that Jabber clients discover the CUCM addresses automatically or do you try to connect manually by providing the information required?

     

    Rémi

    Rémi
    CCIE Collaboration #57461

  • timaztimaz ✭✭

    Regarding the message "Cannot communicate with server", it could be for several reasons. Probably DNS? Did you setup the SRV record so that Jabber clients discover the CUCM addresses automatically or do you try to connect manually by providing the information required?

     

    Hi; 

    after reading some docs, I created the SRV records, but the steps contain generating *.xml file for Jabber clients. I found a web-based tool named "jabber client config file generator" but it has hundereds of options that I don't know them. is there any sample (and very basic) xml file that contains just critical parts like IP addresses of the servers on the Internet? I just need to know and test the necessary steps. 

Sign In or Register to comment.