PSTN CME Config

Hi,

Can anyone provide me with a PSTN Config where the PSTN is CME instead of UCM?  For the purpose of the INE labs.  Or any other lab.  I can just redo the numbers.

Comments

  • Here is the config of a PSTN router that I used during my voice preparation. There some additional configs for Gatekeeper and ospf routing.

    Hope this helps.

    -------------------------------------------------------------------------------------------

    clock timezone EST -5

    clock summer-time EDT recurring

    ntp master 4

    ntp update-calendar

    !

    network-clock-participate wic 0 

    network-clock-participate wic 1 

    network-clock-participate wic 2 

    network-clock-participate wic 3 

    dot11 syslog

    !

    !

    ip cef

    !

    !

    no ip domain lookup

    !

    multilink bundle-name authenticated

    frame-relay switching

    !

    isdn switch-type primary-ni

    !

    voice-card 0

     no dspfarm

    !

    !

    !

    voice service voip 

     allow-connections h323 to h323

     allow-connections h323 to sip

     allow-connections sip to h323

     allow-connections sip to sip

     sip

    !

    !

    !

    voice class codec 1

     codec preference 1 g729r8

     codec preference 2 g711ulaw

    !

    !

    !

    !

    !

    !

    !

    !

    !

    !

    !

    !

    voice translation-rule 1

     rule 1 /^911$/ // type any unknown plan any unknown

     rule 2 /^(2123942123)$/ /1/ type any subscriber plan any isdn

     rule 3 /^6178632683$/ // type any national plan any isdn

     rule 4 /^32141891$/ /34/ type any international plan any isdn

     rule 5 /^6745738932$/ /91/ type any international plan any isdn

     rule 6 /^9004522138$/ // type any national plan any isdn

    !

    voice translation-rule 2

     rule 1 /^911$/ // type any unknown plan any unknown

     rule 2 /^2123942123$/ // type any national plan any isdn

     rule 3 /^617(8632683)$/ /1/ type any subscriber plan any isdn

     rule 4 /^32141891$/ /34/ type any international plan any isdn

     rule 5 /^6745738932$/ /91/ type any international plan any isdn

     rule 6 /^9004522138$/ // type any national plan any isdn

    !

    voice translation-rule 3

     rule 1 /^911$/ /999/ type any unknown plan any unknown

     rule 2 /^2123942123$/ /1/ type any international plan any isdn

     rule 3 /^6178632683$/ /1/ type any international plan any isdn

     rule 4 /^32141891$/ // type any national plan any isdn

     rule 5 /^6745738932$/ /91/ type any international plan any isdn

     rule 6 /^9004522138$/ /1/ type any international plan any isdn

    !         

    voice translation-rule 34

     rule 1 /^011/ /1234/

     rule 2 /^911$/ /1234/

     rule 3 /^1617/ /1234/

     rule 4 /^1212/ /1234/

     rule 5 /^212/ /1234/

     rule 6 /^394/ /1234/

     rule 7 /^617/ /1234/

     rule 8 /^863/ /1234/

    !

    voice translation-rule 212

     rule 1 /^1212/ /1234/

     rule 2 /^1/ //

     rule 3 /^394/ //

     rule 4 /^011/ //

     rule 5 /^212/ //

     rule 6 /^911$/ //

     rule 9 /./ /1234/

    !

    voice translation-rule 617

     rule 1 /^1617/ /1234/

     rule 2 /^1/ //

     rule 3 /^863/ //

     rule 4 /^011/ //

     rule 5 /^617/ //

     rule 6 /^911$/ //

     rule 9 /./ /1234/

    !

    !

    voice translation-profile block-call-into-BR1

     translate called 617

    !

    voice translation-profile block-call-into-BR2

     translate called 34

    !

    voice translation-profile block-call-into-HQ

     translate called 212

    !

    voice translation-profile display-proper-ani-into-BR1

     translate calling 2

    !

    voice translation-profile display-proper-ani-into-BR2

     translate calling 3

    !

    voice translation-profile display-proper-ani-into-HQ

     translate calling 1

    !

    !

    !

    !

    !

    !

    archive

     log config

      hidekeys

    !

    !

    !

    controller T1 0/0/0

     framing esf

     clock source internal

     linecode b8zs

     channel-group 0 timeslots 1-24

     description ** SERIAL DATA CONNECTION TO BR1-RTR **

    !

    controller T1 0/0/1

     framing esf

     clock source internal

     linecode b8zs

     channel-group 0 timeslots 1-24

     description ** SERIAL DATA CONNECTION TO BR2-RTR **

    !

    controller T1 0/1/0

     framing esf

     clock source internal

     linecode b8zs

     channel-group 0 timeslots 1-24

     description ** SERIAL DATA CONNECTION TO HQ-RTR **

    !

    controller T1 0/1/1

     framing esf

     linecode b8zs

    !

    controller E1 0/2/0

     clock source internal

     pri-group timeslots 1-3,16

     description ** E1 VOICE CONNECTION TO BR2-RTR **

    !

    controller E1 0/2/1

    !

    controller T1 0/3/0

     framing esf

     clock source internal

     linecode b8zs

     pri-group timeslots 1-3,23-24

     description ** T1 VOICE CONNECTION TO HQ-RTR **

    !

    controller T1 0/3/1

     framing esf

     clock source internal

     linecode b8zs

     pri-group timeslots 1-3,23-24

     description ** T1 VOICE CONNECTION TO BR1-RTR **

    !

    !

    !

    !

    !

    interface FastEthernet0/0

     ip address 10.10.100.2 255.255.255.0

     ip ospf network broadcast

     ip ospf priority 0

     duplex full

     speed 100

     h323-gateway voip interface

     h323-gateway voip id PSTN-WAN ipaddr 10.10.100.2 1719

     h323-gateway voip h323-id pstn-gw

     h323-gateway voip tech-prefix 1#

     h323-gateway voip bind srcaddr 10.10.100.2

    !

    interface FastEthernet0/1

     no ip address

     shutdown

     duplex auto

     speed auto

    !

    interface Serial0/0/0:0

     description ** T1 DATA CONNECTION TO BR1-RTR **

     no ip address

     encapsulation frame-relay IETF

     frame-relay lmi-type ansi

     frame-relay intf-type dce

     frame-relay route 101 interface Serial0/1/0:0 201

    !

    interface Serial0/0/1:0

     description ** T1 DATA CONNECTION TO BR2-RTR **

     no ip address

     encapsulation frame-relay IETF

     frame-relay lmi-type ansi

     frame-relay intf-type dce

     frame-relay route 102 interface Serial0/1/0:0 202

    !

    interface Serial0/1/0:0

     description ** T1 DATA CONNECTION TO HQ-RTR **

     no ip address

     encapsulation frame-relay IETF

     frame-relay lmi-type ansi

     frame-relay intf-type dce

     frame-relay route 201 interface Serial0/0/0:0 101

     frame-relay route 202 interface Serial0/0/1:0 102

    !

    interface Serial0/2/0:15

     description ** E1 PRI D-CHANNEL TO BR2-RTR **

     no ip address

     encapsulation hdlc

     isdn switch-type primary-net5

     isdn protocol-emulate network

     isdn incoming-voice voice

     no cdp enable

    !

    interface Serial0/3/0:23

     description ** T1 PRI D-CHANNEL TO HQ-RTR **

     no ip address

     encapsulation hdlc

     isdn switch-type primary-ni

     isdn protocol-emulate network

     isdn incoming-voice voice

     isdn outgoing display-ie

     no cdp enable

    !

    interface Serial0/3/1:23

     description ** T1 PRI D-CHANNEL TO BR1-RTR **

     no ip address

     encapsulation hdlc

     isdn switch-type primary-ni

     isdn protocol-emulate network

     isdn incoming-voice voice

     no cdp enable

    !

    router ospf 1

     router-id 10.10.100.2

     log-adjacency-changes

     network 10.0.0.0 0.255.255.255 area 0

    !         

    ip forward-protocol nd

    !

    !

    ip http server

    no ip http secure-server

    !

    !

    !

    !

    !

    !

    !

    !

    control-plane

    !

    !

    !

    voice-port 0/2/0:15

     translation-profile incoming block-call-into-BR2

     translation-profile outgoing display-proper-ani-into-BR2

     description ** PRI VOICE TRUNK TO BR2-RTR **

    !

    voice-port 0/3/0:23

     translation-profile incoming block-call-into-HQ

     translation-profile outgoing display-proper-ani-into-HQ

     description ** PRI VOICE TRUNK TO HQ-RTR **

    !

    voice-port 0/3/1:23

     translation-profile incoming block-call-into-BR1

     translation-profile outgoing display-proper-ani-into-BR1

     description ** PRI VOICE TRUNK TO BR1-RTR **

    !

    !

    !

    !

    !

    dial-peer voice 100 pots

     incoming called-number .

     direct-inward-dial

    !

    dial-peer voice 101 pots

     destination-pattern 2123945...

     port 0/3/0:23

     forward-digits 10

    !

    dial-peer voice 102 pots

     destination-pattern 6178631...

     port 0/3/1:23

     forward-digits 10

    !

    dial-peer voice 103 pots

     destination-pattern 32143...

     port 0/2/0:15

     forward-digits 8

    !

    dial-peer voice 104 pots

     destination-pattern 32143...

     no digit-strip

     port 0/2/0:15

     prefix +34

    !

    dial-peer voice 201 voip

     voice-class codec 1

     incoming called-number .

     dtmf-relay h245-alphanumeric

     no vad

    !

    !

    num-exp 1#343214.... 3214....

    num-exp 1#916745738932 6745738932

    num-exp 999 911

    num-exp 394.... 212394....

    num-exp 1212394.... 212394....

    num-exp 001212394.... 212394....

    num-exp 863.... 617863....

    num-exp 1617863.... 617863....

    num-exp 001617863.... 617863....

    num-exp 03214.... 3214....

    num-exp 011343214.... 3214....

    num-exp 00343214.... 3214....

    num-exp 343214.... 3214....

    num-exp 011916745738932 6745738932

    num-exp 00916745738932 6745738932

    num-exp 916745738932 6745738932

    num-exp 1900452.... 900452....

    gateway 

     timer receive-rtp 1200

    !         

    !

    !

    gatekeeper

     zone local PSTN-WAN ine.com 10.10.100.2

     zone remote HQ-RTR ine.com 10.10.200.3 1719

     zone remote US ine.com 10.10.110.1 1719

     zone prefix PSTN-WAN 34*

     zone prefix PSTN-WAN 91*

     gw-type-prefix 1#* default-technology

     no shutdown

    !

    !

    telephony-service

     no auto-reg-ephone

     load 7960-7940 P00308000500

     max-ephones 42

     max-dn 144

     ip source-address 10.10.100.2 port 2000

     caller-id block code *67

     system message ine PSTN Phone

     max-conferences 8 gain -6

     transfer-system full-consult

     create cnf-files

    !

    !

    ephone-dn  1

     number 911

     label Emergency  911/999

     description PSTN Phone

     name Emergency Services

    !

    !

    ephone-dn  2

     number 2123942123 no-reg primary

     label HQ-NYC  +1-212-394-2123

     call-forward noan 9004522138 timeout 16

    !

    !

    ephone-dn  3

     number 6178632683 no-reg primary

     label BR1-Boston  +1-617-863-2683

    !

    !

    ephone-dn  4

     number 32141891 no-reg primary

     label BR2-Spain  +34-3214-1891

    !

    !

    ephone-dn  5

     number 6745738932 no-reg primary

     label India  +91-67-4573-8932

    !

    !

    ephone-dn  6

     number 9004522138 no-reg primary

     label Restricted  +1-900-452-2138

    !

    !

    ephone  1

     device-security-mode none

     mac-address 0200.4C4F.4F50

     type 7960

     button  1:1 2:2 3:3 4:4

     button  5:5 6:6

    !

    !

    !

    ephone  2

     device-security-mode none

     mac-address 0017.5989.A569

     type 7960

     button  1:1 2:2 3:3 4:4

     button  5:5 6:6

    !

    !

    alias exec c conf t

    alias exec sd show dial-peer voice summary

    privilege configure level 15 interface

    privilege exec all level 1 configure

    privilege exec level 15 undebug voip dialpeer

    privilege exec level 15 undebug voip vtsp all

    privilege exec level 15 undebug voip vtsp

    privilege exec level 15 undebug voip

    privilege exec level 15 undebug ras

    privilege exec level 15 undebug h225 asn1

    privilege exec level 15 undebug h225

    privilege exec level 15 undebug isdn q931

    privilege exec level 15 undebug isdn

    privilege exec level 15 undebug all

    privilege exec all level 1 undebug

    privilege exec level 1 terminal monitor

    privilege exec level 1 terminal

    privilege exec level 15 show dial-peer voice summary

    privilege exec level 0 show dial-peer voice

    privilege exec level 0 show dial-peer

    privilege exec level 1 show isdn status

    privilege exec level 1 show isdn

    privilege exec all level 1 show

    privilege exec level 15 debug voip dialpeer

    privilege exec level 15 debug voip vtsp all

    privilege exec level 15 debug voip vtsp

    privilege exec level 15 debug voip

    privilege exec level 15 debug ras

    privilege exec level 15 debug h225 asn1

    privilege exec level 15 debug h225

    privilege exec level 15 debug isdn q931

    privilege exec level 15 debug isdn

    privilege exec level 15 debug all

    privilege exec all level 1 debug

    !

    line con 0

     exec-timeout 0 0

     logging synchronous

    line aux 0

    line vty 0 4

     exec-timeout 0 0

     logging synchronous

     no login

     transport input telnet

    line vty 5 14

     exec-timeout 0 0

     logging synchronous

     no login

     transport input telnet

    line vty 15

     exec-timeout 0 0

     privilege level 15

     logging synchronous

     login

     rotary 15

     transport input telnet

    !

    scheduler allocate 20000 1000

    !

    end

  • Viki,

    Thanks.  I'll modify it for the 9971 and use voice register global.  

    Does anyone know if the 2811 will support video calls with the 9971/9951 from the PSTN?  AFTER I get 9971 registerd to CME, to get video to work to the HQ or Br2, I believe all I would have to do is add camera and video to voice register global and voice register pool.  Then create a voice class codec with video h264 and whatever codecs I need and then add the voice class codec to the voice register pool.  I'll test it but let me know if I Am missing anything?  Thanks.

  • Hi,

    I got the following content from someone else.

    "You are going to need 3 gateways plus a backbone gateway that will act as the PSTN/WAN. Clearly the optimum solution is to use 4 x 2911, but on a budget I would say  you are going to need (as an absolute minimum) 1 x 2911 for R1 and go with a 2811 at R2/R3, as well the Backbone gateway, all of which are equipped with the cheaper PVDM2 modules".

    Hope this helps.

     

     

Sign In or Register to comment.