OSPF over DMVPN- Advanced Technology Labs

Hi Experts, 

Need help to understand the OSPF over DMVPN. I started with OSPF and added the initial configs. But OSPF neighbhor not working. Any help will be great. Here are the configs. 

 

R5:

R5#sh dmvpn 

Legend: Attrb --> S - Static, D - Dynamic, I - Incomplete

        N - NATed, L - Local, X - No Socket

        # Ent --> Number of NHRP entries with same NBMA peer

        NHS Status: E --> Expecting Replies, R --> Responding, W --> Waiting

        UpDn Time --> Up or Down Time for a Tunnel

==========================================================================

 

Interface: Tunnel0, IPv6 NHRP Details 

Type:Hub, Total NBMA Peers (v4/v6): 4

    1.Peer NBMA Address: 169.254.100.1

        Tunnel IPv6 Address: 2001:155:1:1234::1

        IPv6 Target Network: 2001:155:1:1234::1/128

        # Ent: 1, Status: UP, UpDn Time: 00:20:33, Cache Attrib: D

    2.Peer NBMA Address: 169.254.100.2

        Tunnel IPv6 Address: 2001:155:1:1234::2

        IPv6 Target Network: 2001:155:1:1234::2/128

        # Ent: 1, Status: UP, UpDn Time: 00:20:33, Cache Attrib: D

    3.Peer NBMA Address: 169.254.100.3

        Tunnel IPv6 Address: 2001:155:1:1234::3

        IPv6 Target Network: 2001:155:1:1234::3/128

        # Ent: 1, Status: UP, UpDn Time: 00:20:33, Cache Attrib: D

    4.Peer NBMA Address: 169.254.100.4

        Tunnel IPv6 Address: 2001:155:1:1234::4

        IPv6 Target Network: 2001:155:1:1234::4/128

        # Ent: 1, Status: UP, UpDn Time: 00:20:33, Cache Attrib: D

 

R5#ping 169.254.100.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 169.254.100.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 12/31/72 ms

R5#ping 169.254.100.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 169.254.100.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 20/26/32 ms

R5#ping 169.254.100.3

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 169.254.100.3, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 24/29/40 ms

R5#ping 169.254.100.4

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 169.254.100.4, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 24/29/40 ms

R5#sh ip int b

Interface              IP-Address      OK? Method Status                Protocol

Ethernet0/0            unassigned      YES unset  administratively down down    

GigabitEthernet0/0     unassigned      YES unset  administratively down down    

GigabitEthernet1/0     unassigned      YES unset  up                    up      

GigabitEthernet1/0.5   155.1.5.5       YES manual up                    up      

GigabitEthernet1/0.45  155.1.45.5      YES manual up                    up      

GigabitEthernet1/0.58  155.1.58.5      YES manual up                    up      

GigabitEthernet1/0.100 169.254.100.5   YES manual up                    up      

FastEthernet2/0        unassigned      YES unset  administratively down down    

FastEthernet2/1        unassigned      YES unset  administratively down down    

Loopback0              150.1.5.5       YES manual up                    up      

Tunnel0                155.1.0.5       YES manual up                    up      

R5#

R5#sh run 

Building configuration...

 

Current configuration : 2773 bytes

!

! Last configuration change at 00:14:09 UTC Sat Sep 12 2015

!

version 15.2

no service timestamps debug uptime

no service timestamps log uptime

!

hostname R5

!

boot-start-marker

boot-end-marker

!

!

!

no aaa new-model

no ip icmp rate-limit unreachable

ip cef

!

!

!

!

!         

!

no ip domain lookup

ipv6 unicast-routing

ipv6 cef

!

!

multilink bundle-name authenticated

!

!

!

!

!

!

!

!

!

ip tcp synwait-time 5

!

!

!

!

crypto isakmp policy 10

 encr aes

 hash md5

 authentication pre-share

 group 5

crypto isakmp key cisco address 0.0.0.0        

crypto isakmp key cisco address ipv6 ::/0

!

!

crypto ipsec transform-set ESP_AES_SHA esp-aes esp-sha-hmac 

 mode tunnel

!

crypto ipsec profile DMVPN_PROFILE

 set transform-set ESP_AES_SHA 

!

!

!

!

!

!

!

interface Loopback0

 ip address 150.1.5.5 255.255.255.255

 ipv6 address 2001:150:5:5::5/128

!

interface Tunnel0

 ip address 155.1.0.5 255.255.255.0

 no ip redirects

 ip ospf network non-broadcast

 ipv6 address FE80::5 link-local

 ipv6 address 2001:155:1:1234::5/64

 ipv6 mtu 1416

 ipv6 nhrp authentication cisco

 ipv6 nhrp map multicast dynamic

 ipv6 nhrp network-id 10

 ipv6 nhrp holdtime 600

 ipv6 nhrp redirect

 tunnel source GigabitEthernet1/0.100

 tunnel mode gre multipoint

 tunnel key 10

 tunnel protection ipsec profile DMVPN_PROFILE

!

interface Ethernet0/0

 no ip address

 shutdown

 duplex auto

!         

interface GigabitEthernet0/0

 no ip address

 shutdown

 media-type gbic

 speed 1000

 duplex full

 negotiation auto

!

interface GigabitEthernet1/0

 no ip address

 negotiation auto

!

interface GigabitEthernet1/0.5

 encapsulation dot1Q 5

 ip address 155.1.5.5 255.255.255.0

 ipv6 address 2001:155:1:5::5/64

!

interface GigabitEthernet1/0.45

 encapsulation dot1Q 45

 ip address 155.1.45.5 255.255.255.0

 ipv6 address 2001:155:1:45::5/64

!

interface GigabitEthernet1/0.58

 encapsulation dot1Q 58

 ip address 155.1.58.5 255.255.255.0

 ipv6 address 2001:155:1:58::5/64

!

interface GigabitEthernet1/0.100

 encapsulation dot1Q 100

 ip address 169.254.100.5 255.255.255.0

 ipv6 address 2001:169:254:100::5/64

!

interface FastEthernet2/0

 no ip address

 shutdown

 speed auto

 duplex auto

!

interface FastEthernet2/1

 no ip address

 shutdown

 speed auto

 duplex auto

!

router ospf 1

 network 0.0.0.0 255.255.255.255 area 0

 neighbor 155.1.0.4

 neighbor 155.1.0.3

 neighbor 155.1.0.2

 neighbor 155.1.0.1

!

router rip

 version 2

 network 150.1.0.0

 network 155.1.0.0

 no auto-summary

!

ip forward-protocol nd

!

!

no ip http server

no ip http secure-server

!

ipv6 router rip RIPNG

 no split-horizon

!

!

!

!         

control-plane

!

!

line con 0

 exec-timeout 0 0

 privilege level 15

 logging synchronous

 stopbits 1

line aux 0

 exec-timeout 0 0

 privilege level 15

 logging synchronous

 stopbits 1

line vty 0 4

 privilege level 15

 no login

!

!

end

 

R5#

 

 

R1:

R1#sh run int tunnel 0

Building configuration...

 

Current configuration : 584 bytes

!

interface Tunnel0

 ip address 155.1.0.1 255.255.255.0

 no ip redirects

 ip ospf network non-broadcast

 ip ospf priority 0

 ip ospf 1 area 0

 ipv6 address FE80::1 link-local

 ipv6 address 2001:155:1:1234::1/64

 ipv6 mtu 1416

 ipv6 nhrp authentication cisco

 ipv6 nhrp map 2001:155:1:1234::5/64 169.254.100.5

 ipv6 nhrp map multicast 169.254.100.5

 ipv6 nhrp network-id 10

 ipv6 nhrp holdtime 600

 ipv6 nhrp nhs 2001:155:1:1234::5

 ipv6 nhrp shortcut

 tunnel source GigabitEthernet1/0.100

 tunnel mode gre multipoint

 tunnel key 10

 tunnel protection ipsec profile DMVPN_PROFILE

end       

 

R1#sh run int loop 0

Building configuration...

 

Current configuration : 117 bytes

!

interface Loopback0

 ip address 150.1.1.1 255.255.255.255

 ip ospf 1 area 0

 ipv6 address 2001:150:1:1::1/128

end

 

R1#sh ip ospf int b

Interface    PID   Area            IP Address/Mask    Cost  State Nbrs F/C

Lo0          1     0               150.1.1.1/32       1     LOOP  0/0

Tu0          1     0               155.1.0.1/24       1000  DROTH 0/0

R1#

R1#

 

 

 

Comments

Sign In or Register to comment.