Rip Neighbor Forming Issue

Hello,

I'm using GNS3 simulating 2 Cisco7206XVR  Version 15.2(4)S5 routers and an L2 IOU (I86BI_LINUXL2-ADVENTERPRISEK9-M), Experimental Version 15.1(20130726:213425).

I have a simple rip configuration and am successful when forming neighbors with the links directly connected.

R1:

interface GigabitEthernet0/0.13

 encapsulation dot1Q 13

 ip address 155.1.13.1 255.255.255.0

 ipv6 address 2001:155:1:13::1/64

!


router rip

 version 2

 network 150.1.0.0

 network 155.1.0.0

 no auto-summary

!



R3:



interface GigabitEthernet0/0.13

 encapsulation dot1Q 13

 ip address 155.1.13.3 255.255.255.0

 ipv6 address 2001:155:1:13::3/64

!


router rip

 version 2

 network 150.1.0.0

 network 155.1.0.0

 no auto-summary

!



IOU1:



interface Ethernet0/1

 description to R1

 switchport trunk encapsulation dot1q

 switchport trunk allowed vlan 13,100,146

 switchport mode trunk

 duplex auto

!



interface Ethernet0/3

 description to R3

 switchport trunk encapsulation dot1q

 switchport trunk allowed vlan 13,23,37,100

 switchport mode trunk

 duplex auto

!



When the two routers are directly connected the neighborship works fine.



R1#show ip protocols

*** IP Routing is NSF aware ***


Routing Protocol is "rip"

  Outgoing update filter list for all interfaces is not set

  Incoming update filter list for all interfaces is not set

  Sending updates every 30 seconds, next due in 24 seconds

  Invalid after 180 seconds, hold down 180, flushed after 240

  Redistributing: rip

  Default version control: send version 2, receive version 2

    Interface             Send  Recv  Triggered RIP  Key-chain

    GigabitEthernet0/0.13 2     2

    GigabitEthernet0/0.14 2     2

    Loopback0             2     2

    Tunnel0               2     2

  Automatic network summarization is not in effect

  Maximum path: 4

  Routing for Networks:

    150.1.0.0

    155.1.0.0

  Routing Information Sources:

    Gateway         Distance      Last Update

    155.1.13.3           120      00:00:24

  Distance: (default is 120)





R3#show ip protocols

*** IP Routing is NSF aware ***


Routing Protocol is "rip"

  Outgoing update filter list for all interfaces is not set

  Incoming update filter list for all interfaces is not set

  Sending updates every 30 seconds, next due in 24 seconds

  Invalid after 180 seconds, hold down 180, flushed after 240

  Redistributing: rip

  Default version control: send version 2, receive version 2

    Interface             Send  Recv  Triggered RIP  Key-chain

    GigabitEthernet0/0.13 2     2

    GigabitEthernet0/0.23 2     2

    GigabitEthernet0/0.37 2     2

    Loopback0             2     2

    Tunnel0               2     2

  Automatic network summarization is not in effect

  Maximum path: 4

  Routing for Networks:

    150.1.0.0

    155.1.0.0

  Routing Information Sources:

    Gateway         Distance      Last Update

    155.1.13.1           120      00:00:07

  Distance: (default is 120)



When I connect them through an IOU switch, they lose neighborship but I'm still able to ping the RIP multicast address.



R1#ping 224.0.0.9

Type escape sequence to abort.

Sending 1, 100-byte ICMP Echos to 224.0.0.9, timeout is 2 seconds:


Reply to request 0 from 150.1.1.1, 16 ms

Reply to request 0 from 155.1.13.3, 60 ms



The neighborship is rectified however if I issue the command ip rip v2-broadcast on the interfaces of R1 and R3.


It doesn't look like it's an issue with reachability, or the rip process. It's as though the switch isn't forwarding rip multicast messages for some reason. I can't wrap my head around it.



IOU1(config-if)#do show run

Building configuration...


Current configuration : 3131 bytes

!

version 15.1

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

service compress-config

!

hostname IOU1

!

boot-start-marker

boot-end-marker

!

!

logging discriminator EXCESS severity drops 6 msg-body drops EXCESSCOLL

logging buffered 50000

no logging console

!

no aaa new-model

clock timezone EST -5 0

no ip icmp rate-limit unreachable

!

ip cef

!

!

no ip domain-lookup

no ipv6 cef

ipv6 multicast rpf use-bgp

!

!

!

!

!

!

!

spanning-tree mode pvst

spanning-tree extend system-id

!

!

!

!

vlan internal allocation policy ascending

!

ip tcp synwait-time 5

!

!

!

!

!

!

!

!

!

interface Ethernet0/0

 duplex auto

!

interface Ethernet0/1

 description to R1

 switchport trunk encapsulation dot1q

 switchport trunk allowed vlan 13,100,146

 switchport mode trunk

 duplex auto

!

interface Ethernet0/3

 description to R3

 switchport trunk encapsulation dot1q

 switchport trunk allowed vlan 13,23,37,100

 switchport mode trunk

 duplex auto

!

interface Vlan1

 no ip address

 shutdown

!

!

no ip http server

!

!

no cdp run

!

!

!

control-plane

!

!

line con 0

 exec-timeout 0 0

 privilege level 15

 logging synchronous

line aux 0

 exec-timeout 0 0

 privilege level 15

 logging synchronous

line vty 0 4

 login

!

end



Sign In or Register to comment.