OSPF over DMVPN

Hi Guys,

 

I am having the trouble with the advanced lab OSPF over DMVPN,  i have been through and configured it as i would expect it to be, and i have then checked my config against the expected config which is the same.

The problem I am seeing is that R5 the hub router is suppose to be the DR router due to it having the highest loop back address but every time i bring the neighbors online every other router other than R5 is elected the DR.  Test this I set up the tu0 interface on R5 to have a priority of 255 to try and ensure that it is the DR,  this made no difference, R3 was Elected DR and R5 was elected BDR,  so on R3 i shutdown the tu0 interface thinkning R5 would take over,  to my shock it didnt the DR moved to R2.

Please could someone assist with some advice as I am not sure if this is just the rack or i am doing something wrong.  given my checks against the INE content it should work.

Thanks

Neil

Comments

  • so with some further tinkering.....

    I shutdown the link back to the hub router one by one on all the spoke routers until R5 became the DR,  I then went back round and enabled the spoke router links and this seemed to fix the issue. 

    Would appreciate confirmation as to whether this is expected behaviour,  i am assuming this issue was being caused by me not clearing the OSPF process on all routers and only on R5...

    look forward to comments

    Thanks

     

    Neil

  • HI,

       What is the exact name of the lab you're trying to do? If you run OSPF with DR network types, the hub(s) need to be DR and BDR, to make sure of this you configure priority of ZERO on all spokes; configuring a priority of 255 on hub does NOT guarantee that the hub will be elected as DR, becuase of how DR election works.

    Regards,
    Cristian. 

     

  • Hi Christian,

     

    I am doing the OSPF Advanced Labs and it is called OSPF over DMVPN.  I did not think to set the spokes to priority 0 but the configs that INE have provided as the correct ones dont have this.

    cheers

     

    Neil

  • Hi,

      I have fixed the configuration/solution.

    Thanks for this.

    Cristian.

  • Hi Cristian,

    Your welcome.

    Thank you for the feedback.

    cheers

    Neil

Sign In or Register to comment.